Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Urxvt] Problema con las fuentes. [Solucionado]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
lince_0011
n00b
n00b


Joined: 09 Aug 2011
Posts: 68

PostPosted: Fri Aug 12, 2011 3:13 pm    Post subject: [Urxvt] Problema con las fuentes. [Solucionado] Reply with quote

Bueno esta es la primera vez que instalo y utilizo gentoo, pero valla que me ha gustado :)

Bueno ya tengo el sistema funcionando como quiero, salvo por unos problemas mínimos.
Siempre he utilizado rxvt-unicode por lo que decidi instalar esta terminal en gentoo, despues procedir a crear el archivo .xdefaults y pues ya saben, ahi especifique el fondo de la terminal, los colores,fuente,etc.

Pero tengo problemas con la fuente, comparto mi .xdefaults:
Code:
!-----------
!Scroll bar
!-----------
urxvt*scrollBar: false

!------
!Fuente
!------
urxvt*font: xft: Terminus: pixelsize=7
!------------------
!Cursosr del promt
!------------------
urxvt*cursorBlink: true
!--------------
!Transparensia #
!--------------
!urxvt*transparent: true
!urxvt*shading: 5
!-------
!Colores
!-------
! vim: set filetype=xdefaults :
*foreground: #D7D0C7
*background: #151515

!black
 *color0:  #252525
 *color8:  #505050
!red
 *color1:  #D4A7E2
 *color9:  #F99286
!green
 *color2:  #8DD78D
 *color10: #C3F786
!yellow
 *color3:  #EBEABD
 *color11: #FCFBCC
!blue
 *color4:  #41B4A3
 *color12: #B6DEFB
!magenta
 *color5:  #8E6794
 *color13: #AD7FA8
!cyan
 *color6:  #C8C9EB
 *color14: #D7D9FC
!white
 *color7:  #FCFEFD
 *color15: #E2E2E2


Al intentar lanzar urxvt desde otra terminal como xterm me aparece:
Code:
urxvt: unable to load base fontset, please specify a valid one using -fn, aborting.


Y pues simplemente no puedo lanzar esa consola, busque sobre ese menaje que lanza urxvt, pero igual no encuentro nada que me ayude.

Saludos y gracias por sus respuestas..


Last edited by lince_0011 on Thu Feb 23, 2012 4:02 pm; edited 3 times in total
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9810
Location: Córdoba (Spain)

PostPosted: Sun Aug 14, 2011 2:38 pm    Post subject: Reply with quote

Suponiendo que la especificación de la fuente sea correcta y que dicha fuente esté instalada, comprueba que rxvt-univode está compilado con USE=truetype. O, si no quieres usar fuentes true type, entonces quita la especificación tipo xft:..... y usa una especificación de fuente de X11.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 811

PostPosted: Sun Aug 14, 2011 5:59 pm    Post subject: Reply with quote

¿Tienes instalado el paquete terminus-font? ¿Lo tienes con el valor X incluido en la variable USE?
Back to top
View user's profile Send private message
lince_0011
n00b
n00b


Joined: 09 Aug 2011
Posts: 68

PostPosted: Mon Aug 15, 2011 1:18 am    Post subject: Reply with quote

Gracias por responder.
Si si tengo instalada esa fuente, y claro si tengo X en la variable USE.

Saludos
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9810
Location: Córdoba (Spain)

PostPosted: Mon Aug 15, 2011 1:51 pm    Post subject: Reply with quote

Qué ocurre si ejecutas esto desde un terminal?

Code:
urxvt -fn "xft:Terminus"

_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
lince_0011
n00b
n00b


Joined: 09 Aug 2011
Posts: 68

PostPosted: Mon Aug 15, 2011 3:59 pm    Post subject: Reply with quote

i92guboj wrote:
Qué ocurre si ejecutas esto desde un terminal?

Code:
urxvt -fn "xft:Terminus"


Sucede lo mismo:
Code:
urxvt: unable to load base fontset, please specify a valid one using -fn, aborting.


Probare lo que mencionas arriba, agregar esa variable la USE, luego comento haber que tal.

EDITO: Agregue truetype a la variable USE, recompile e instale rxvt-unicode y ahora ya medio funciona.

Gracias por sus respuestas :wink:

Saludos
Back to top
View user's profile Send private message
lince_0011
n00b
n00b


Joined: 09 Aug 2011
Posts: 68

PostPosted: Mon Aug 15, 2011 11:52 pm    Post subject: Reply with quote

Hola de nuevo, siento reabrir el post pero creo que es mejor en vez de crear uno nuevo con el mismo problema.

Bueno ya logre colocarle una fuente a urxvt, y digo "una" por que solo una puedo poner.

Es decir de todas las demas fuentes que tengo instaladas ninguna otra funciona, actualmente tengo la fuente Clean pero otras no me funcionan.

Por ejemplo la fuente Neep,Terminus u otras al colocar cualquiera de ellas en el .Xdefaults la terminal se ve enorme y claro la fuente ni hablar.
No me toma esa fuente que le estoy especificando, como menciono mas arriba esto solo ocurre con las demas fuentes, con la fuente Clean no tengo problemas.

EDITO: Una imagen dice mas que mil palabras:
Con font Clean

[img]http://ompldr.org/tOXd5eg[/img]

Con otras:
[img]http://ompldr.org/tOXd6MQ[/img]

Saludos
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9810
Location: Córdoba (Spain)

PostPosted: Tue Aug 16, 2011 9:29 am    Post subject: Reply with quote

Quizás estás intentando usar una fuente que no sea monotipo. Las fuentes monotipo están diseñadas de forma que todos los caracteres encajan en celdas del mismo tamaño. Los emuladores de terminal requieren fuentes monotipo. Si intentas usar una fuente no monotipo, la mayoría de emuladores de terminal cuadrarán la parrilla de caracteres para que la fuente encaje, pero a costa de desperdiciar mucho espacio. Si tu fuente no tiene la cadena "mono" en algún lugar del nombre entonces seguramente no sea monotipo (a no ser que sea una fuente específicamente diseñada este propósito).
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
lince_0011
n00b
n00b


Joined: 09 Aug 2011
Posts: 68

PostPosted: Tue Aug 16, 2011 2:47 pm    Post subject: Reply with quote

No es que ni la fuente que tengo ahora Clean tiene la cadena "mono".
La declaro así tal cual:
Code:
URxvt*font: xft:Clean: pixelsize=7


Y se me hace raro que no logre utilizar de forma correcta otra fuente. 8O
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 811

PostPosted: Tue Aug 16, 2011 7:12 pm    Post subject: Reply with quote

¿Tienes la ruta a los archivos de la fuente "terminus" incluida entre las rutas de fuentes del servidor X?
Code:
grep /font /var/log/Xorg.0.log
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9810
Location: Córdoba (Spain)

PostPosted: Tue Aug 16, 2011 10:30 pm    Post subject: Reply with quote

Usa otras fuentes monotipo. Si también falla ya miramos más cosas, pero primero lo primero. Si no sabes cual probar, puedes usar Bitstream Vera Sans Mono o DejaVu Sans Mono.

En cuanto a los FontPath de X, no tienen nada que ver con esto. Las aplicaciones que usan XFT acceden a las fuentes de otra forma. Puedes incluso simplemente copiar el archivo ttf en ~/.fonts/ y automáticamente deberías poder usarlo sin ninguna configuración adicional.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
lince_0011
n00b
n00b


Joined: 09 Aug 2011
Posts: 68

PostPosted: Tue Aug 16, 2011 11:48 pm    Post subject: Reply with quote

Gracias de nuevo por responder.

Si de hecho algunas de las fuentes que tengo las copie directamente, y si puedo utilizarlas en el sistema a excepción de la terminal.

Las fuentes Bitstream Vera Sans Mono ya las habia instalado, intente colocarla en el .Xdefaults pero el problema es el mismo.
La terminal se ve mas grande y la fuente no cambia en nada.

No lo puedo creer, la instalación de gentoo no fue nada difícil y ahora estoy batallando con las fuentes en la consola :oops:
Back to top
View user's profile Send private message
ramonoid
n00b
n00b


Joined: 25 Jan 2011
Posts: 16
Location: Tijuana, Méjico

PostPosted: Wed Aug 17, 2011 12:10 am    Post subject: Reply with quote

Qué tal si prescindes de Xft y especificas la fuente a la clásica del tipo:

Code:
xlsfonts | grep fuente


De preferencia aquellas que cumplan el estandar iso8859.


Solo para combrobar si las fuentes pueden especificarse de otra manera y para ir delimitando.
_________________
gentoo::scrotwm::vim::zsh::urxvtd|blog::dotfiles::last.fm
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 811

PostPosted: Wed Aug 17, 2011 12:52 am    Post subject: Reply with quote

Mira si fontconfig lista la fuente que quieres.
Code:
fc-list "Terminus"
Back to top
View user's profile Send private message
lince_0011
n00b
n00b


Joined: 09 Aug 2011
Posts: 68

PostPosted: Wed Aug 17, 2011 12:57 am    Post subject: Reply with quote

Gracias por responder.
Si así si se puede colocar la fuente también, lo malo es que no me muestra la fuentes que quiero.
Por ejemplo Neep yo mismo me baje la fuente, lo moví a /usr/share/fonts y si me aparece y la puedo utilizar en el sistema.

Pero al buscarla con xlsfonts no me muestra nada, y así con varias fuentes.

quilosaq wrote:
Mira si fontconfig lista la fuente que quieres.
Code:
fc-list "Terminus"


Si si me la muestra:
Code:
Terminus:style=Bold
Terminus:style=Regular


Saludos
Back to top
View user's profile Send private message
ramonoid
n00b
n00b


Joined: 25 Jan 2011
Posts: 16
Location: Tijuana, Méjico

PostPosted: Wed Aug 17, 2011 1:19 am    Post subject: Reply with quote

Recuerda agregar a tu $HOME/.xinitrc

Code:
xset +fp /ruta/a/donde/tengas/las/fuentes/que/quieres/

_________________
gentoo::scrotwm::vim::zsh::urxvtd|blog::dotfiles::last.fm
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 811

PostPosted: Wed Aug 17, 2011 6:22 am    Post subject: Reply with quote

Resumiendo:
Si xfontconfig te lista la fuente
Code:
fc-list "Terminus"
y rxvt-unicode lo tienes compilado con el valor truetype
Code:
equery uses rxvt-unicode
y
Code:
urxvt -fn "xft:Terminus"
te sigue sin funcionar yo miraría la configuración de python. ¿Qué versión tienes seleccionada?
Code:
eselect python list
¿Has ejecutado
Code:
# python-updater
?
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9810
Location: Córdoba (Spain)

PostPosted: Wed Aug 17, 2011 6:53 am    Post subject: Reply with quote

Si vas a utilizar fuentes a la antigua, varias cosas:

  • tendrás que añadir fontpaths a to xorg.conf, o bien user el comando que te dan arriba
  • También tendrás que hacer xset fp rehash para que salgan en los listados si no quieres tener que reiniciar X.
  • muchas fuentes tienen un use flag X que sirva precisamente para instalar la versión correspondiente de la fuente. Sin dicho flag probablemente la fuente no sea listada porque simplemente no está instalada en la versión correcta.


Puedes pegar la salida de "emerge -pv rxvt-unicode"?
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
lince_0011
n00b
n00b


Joined: 09 Aug 2011
Posts: 68

PostPosted: Wed Aug 17, 2011 2:34 pm    Post subject: Reply with quote

Aquí la salida de
Code:
emerge -pv rxvt-unicode
:

Code:
[ebuild   R    ] x11-terms/rxvt-unicode-9.10  USE="256-color font-styles perl truetype vanilla -afterimage -blink -fading-colors -force-hints -iso14755 -pixbuf -unicode3 -wcwidth"


@quilosaq, me aparece la versión 2.7, ahora mismo estoy actualizando python. Luego comento como me fue.


Saludos :wink:
Back to top
View user's profile Send private message
lince_0011
n00b
n00b


Joined: 09 Aug 2011
Posts: 68

PostPosted: Thu Feb 23, 2012 3:46 am    Post subject: Reply with quote

Despues de mis andadas en Gentoo de nuevo tengo el problemita de las fuentes en urxvt.
Hasta el dia de hoy todo estaba bien, pero ahora sigo teniendo el mismo problema con las fuentes en consola.

:cry:
Back to top
View user's profile Send private message
lince_0011
n00b
n00b


Joined: 09 Aug 2011
Posts: 68

PostPosted: Thu Feb 23, 2012 4:02 pm    Post subject: Reply with quote

La solucion era tan sencilla, habia que agregar xft a las use flags en el make.conf, luego recompilar urxvt y listo.

Saludos
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum