Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge of phonon and changing profile[SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
edrozim
n00b
n00b


Joined: 12 Mar 2009
Posts: 18
Location: Ukraine

PostPosted: Thu Aug 11, 2011 11:29 am    Post subject: emerge of phonon and changing profile[SOLVED] Reply with quote

Hello people !
Problem appears after I realized that for a long time after installation I still using default "default/linux/x86/10.0" profile :
1. So I switch to "default/linux/x86/10.0/desktop/kde" (because I am using kde) with command :
Code:
eselect profile set 4

2. Of course after such major change need to update system :
Code:
EMERGE_DEFAULT_OPTS="--ask --verbose --with-bdeps=y --deep --autounmask=n"  emerge -Nu world

==> and this raise the problem :
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "media-libs/phonon[aqua=,gstreamer]".
!!! One of the following packages is required to complete your request:
- media-libs/phonon-4.5.0 (Change USE: +gstreamer)
(dependency required by "x11-libs/qt-qt3support-4.7.2" [installed])
(dependency required by "x11-libs/qt-gui-4.7.2[qt3support]" [installed])
(dependency required by "app-text/poppler-0.16.7[qt4]" [installed])
(dependency required by "net-print/cups-1.4.6-r2" [installed])
(dependency required by "app-text/ghostscript-gpl-8.71-r6[cups]" [installed])



Need to mention here that in package.use file I had such line :
Code:
media-libs/phonon -gstreamer vlc


I did this because I read in several places that kde devs select vlc backend as main backend.

Important NOTE : to all people who want direct me to Google or Gentoo Handbook please keep calm :) I am not n00b and can handle resolving dependencies my self , my question more complicated

I review files that come to play after changing profile :
Code:
/usr/portage/profiles/targets/desktop/kde/*
/usr/portage/profiles/default/linux/x86/10.0/desktop/kde/*


And find no word about forcing gstreamer backend for phonon .
So two questions torment me :
1. In which way portage get this unresolved dependency if only thing that I did is change profile from default to kde ?
2. If KDE devs select vlc as preferable backend (http://kde.org/announcements/4.7/platform.php ) than why kde profile force gstreamer ?


Last edited by edrozim on Thu Aug 11, 2011 12:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9844
Location: Córdoba (Spain)

PostPosted: Thu Aug 11, 2011 11:59 am    Post subject: Reply with quote

You need qt-gui, which needs qt-qt3support because of the qt3support USE flag. You probably can't disable that since there's still a lot of legacy code around in kde. So, I guess your best bet is to disable the phonon use flag for qt-qt3support. You can do that by adding this line into /etc/portage/package.use

Code:
x11-libs/qt-qt3support -phonon


Then try again.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
edrozim
n00b
n00b


Joined: 12 Mar 2009
Posts: 18
Location: Ukraine

PostPosted: Thu Aug 11, 2011 12:35 pm    Post subject: Reply with quote

Thanks man this helps . Also I found place in ebuild file what cause my problem :
(from /usr/portage/x11-libs/qt-qt3support/qt-qt3support-4.7.2.ebuild )

Code:
DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=,qt3support]
        ~x11-libs/qt-gui-${PV}[accessibility=,aqua=,debug=,qt3support]
        ~x11-libs/qt-sql-${PV}[aqua=,debug=,qt3support]
        phonon? (
                !kde? ( || ( ~x11-libs/qt-phonon-${PV}[aqua=,debug=]
                        media-libs/phonon[aqua=,gstreamer] ) )
                kde? ( media-libs/phonon[aqua=,gstreamer] ) )"


They should port qt-qt3support to phonon vlc backend if they declare such direction .
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9844
Location: Córdoba (Spain)

PostPosted: Thu Aug 11, 2011 3:08 pm    Post subject: Reply with quote

edrozim wrote:
Thanks man this helps . Also I found place in ebuild file what cause my problem :
(from /usr/portage/x11-libs/qt-qt3support/qt-qt3support-4.7.2.ebuild )

Code:
DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=,qt3support]
        ~x11-libs/qt-gui-${PV}[accessibility=,aqua=,debug=,qt3support]
        ~x11-libs/qt-sql-${PV}[aqua=,debug=,qt3support]
        phonon? (
                !kde? ( || ( ~x11-libs/qt-phonon-${PV}[aqua=,debug=]
                        media-libs/phonon[aqua=,gstreamer] ) )
                kde? ( media-libs/phonon[aqua=,gstreamer] ) )"


They should port qt-qt3support to phonon vlc backend if they declare such direction .


The support for VLC is a relatively recent addition. The ebuild is probably from the times when gstreamer was THE backend, and so is qt-qt3support itself. I have no idea if someone took the time to backport the VLC stuff into that compatibility layer. Maybe not. In any case, I just set -phonon for this ebuild, and I don't really miss anything.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum