Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
module ABI major version doesn't match server's ver [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
helio
Apprentice
Apprentice


Joined: 08 Apr 2006
Posts: 158

PostPosted: Tue Jul 26, 2011 3:46 am    Post subject: module ABI major version doesn't match server's ver [Solved] Reply with quote

After a recent emerge update, the X (kdm and startx) stopped working. Here are the error messages from startx

Current version of pixman: 0.22.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul 25 22:31:16 2011
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) module ABI major version (8) doesn't match the server's version (10)
(EE) Failed to load module "nouveau" (module requirement mismatch, 0)
(EE) module ABI major version (8) doesn't match the server's version (10)
(EE) Failed to load module "vesa" (module requirement mismatch, 0)
(EE) open /dev/fb0: No such file or directory
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

I followed the tread http://forums.gentoo.org/viewtopic-t-885090-highlight-module+abi+major.html

and re-emerged both xorg-server and x11-drivers. But I am still getting the same error messages. Do I need to recompile the modules?

Thanks.


Last edited by helio on Tue Jul 26, 2011 6:19 pm; edited 2 times in total
Back to top
View user's profile Send private message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1028
Location: Romania

PostPosted: Tue Jul 26, 2011 4:00 am    Post subject: Reply with quote

Yes, re-merge X11 drivers:
Code:
qlist -I x11-drivers
ls /var/db/pkg/x11-drivers

_________________
My Smooth Computer
MB: VIA 82C598MVP on DFI P5BV3+/Rev. B+
CPU: AMD K6-II 333 MHz | RAM: 256 MB SDRAM
Video: Asus MB19TU on nVidia GeForce MX4000 64 MB
Sound: CM8738 | Net: RTL-8139
PATA HDD WD 80 GB & DVD-RW LG 16x
Back to top
View user's profile Send private message
s_bernstein
Apprentice
Apprentice


Joined: 11 Mar 2006
Posts: 172
Location: Bremen, Germany

PostPosted: Tue Jul 26, 2011 5:11 am    Post subject: Reply with quote

or you try
Code:
emerge -1 $(qlist -IC x11-drivers)


which will rebuild all installed x11 drivers without futher interaction
Back to top
View user's profile Send private message
helio
Apprentice
Apprentice


Joined: 08 Apr 2006
Posts: 158

PostPosted: Tue Jul 26, 2011 6:18 pm    Post subject: Reply with quote

Thanks a lot, sebaro and s_bernstein. "emerge -1" solved the problem. The problem I had was that the command I used was "emerge x11-base/xorg-drivers", which didn't actually force the rebuilding of those x11-drivers.
Back to top
View user's profile Send private message
blietaer
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2006
Posts: 103

PostPosted: Tue Aug 30, 2011 12:32 pm    Post subject: Reply with quote

I feel the need to report that this topic saved my day too.
Back to top
View user's profile Send private message
apyh
n00b
n00b


Joined: 17 Mar 2003
Posts: 61
Location: Texas

PostPosted: Sat Sep 17, 2011 4:40 pm    Post subject: Reply with quote

same here, tho, i haven't used x in a while (pre-august)
Back to top
View user's profile Send private message
frankfmb
n00b
n00b


Joined: 30 Oct 2011
Posts: 1
Location: Tjensvoll, Stavanger

PostPosted: Sun Oct 30, 2011 2:19 pm    Post subject: Reply with quote

Had almost given up, Many thanks
Back to top
View user's profile Send private message
ironBelt
n00b
n00b


Joined: 14 Nov 2011
Posts: 2
Location: Sunnyvale CA

PostPosted: Mon Nov 21, 2011 1:48 am    Post subject: Reply with quote

blietaer wrote:
I feel the need to report that this topic saved my day too.
+1

When X was trying to load the keyboard driver it got an ABI version mismatch (or whatever) between 13 and 14.

Re-emerging xf86-input-evdev, xf86-input-keyboard, and xf86-input-mouse solved the problem
Back to top
View user's profile Send private message
jlpoole
Apprentice
Apprentice


Joined: 01 Nov 2005
Posts: 232
Location: Napa, CA

PostPosted: Fri Jan 20, 2012 5:43 am    Post subject: Reply with quote

Another thumbs up.

After a session of updating by emerge, my XFCE would start and my mouse and keyboard would not work (Dell Inspiron Laptop); I had to hard reboot. The most helpful advice offered in this topic:
Code:
emerge x11-drivers/xf86-input-evdev
emerge x11-drivers/xf86-input-keyboard
emerge x11-drivers/xf86-input-mouse

restored my mouse and keyboard.

An aside: I found a way to test that without having to resort to the harmful and risky power-off button. I would start my laptop, then SSH into it from another machine and then "startx" within the SSH shell which would cause the XFCE session on the laptop to start. The advantage of this remote activation was that I could kill the XFCE session (Ctrl-C) from the remote shell and not subject my laptop to the really bad push the power-off button maneuver. Doing it this way is really compelling for performing emerge updates where there is a risk you might be frozen out of your machine. I guess one should having sshd auto start when rebooting after an emerge that affects X windows, XFCE or the likes.
Back to top
View user's profile Send private message
solamour
Guru
Guru


Joined: 21 Dec 2004
Posts: 505
Location: San Diego, CA

PostPosted: Fri Jan 20, 2012 7:18 am    Post subject: Reply with quote

Worked. Thanks. I should pay more attention to the emerge logs.
__
sol
Back to top
View user's profile Send private message
chtof
n00b
n00b


Joined: 29 Aug 2003
Posts: 61
Location: France

PostPosted: Mon Apr 30, 2012 6:07 pm    Post subject: Reply with quote

s_bernstein wrote:
or you try
Code:
emerge -1 $(qlist -IC x11-drivers)


which will rebuild all installed x11 drivers without futher interaction


+1 :D

Great ! Thanks for your post, it has solved also my problem after an upgrade of nvidia-drivers. It could be nice if this tip was added in the post-install of the nvidia-drivers for those who have a problem of this kind.

Code:

(...)
[   309.849] (II) LoadModule: "synaptics"
[   309.849] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[   309.860] (II) Module synaptics: vendor="X.Org Foundation"
[   309.860]    compiled for 1.10.2, module version = 1.4.0
[   309.860]    Module class: X.Org XInput Driver
[   309.860]    ABI class: X.Org XInput driver, version 12.2
[   309.860] (EE) module ABI major version (12) doesn't match the server's version (13)
[   309.860] (II) UnloadModule: "synaptics"
[   309.860] (II) Unloading synaptics
[   309.860] (EE) Failed to load module "synaptics" (module requirement mismatch, 0)
[   309.860] (EE) No input driver matching `synaptics'
[   309.861] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[   309.861] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
(...)
Back to top
View user's profile Send private message
ArneBab
Guru
Guru


Joined: 24 Jan 2006
Posts: 376
Location: Graben-Neudorf, Germany

PostPosted: Mon Jul 30, 2012 5:49 pm    Post subject: Reply with quote

s_bernstein wrote:
or you try
Code:
emerge -1 $(qlist -IC x11-drivers)


which will rebuild all installed x11 drivers without futher interaction


Many thanks from me, too!

(I know this does not add information to this thread, but since it already has all needed information, the thank you should not hurt :) )
_________________
Being unpolitical means being political without realizing it. - Arne Babenhauserheide ( http://draketo.de )

pkgcore: So fast that it feels unreal - by doing only what is needed.
Back to top
View user's profile Send private message
proteusx
n00b
n00b


Joined: 21 Jan 2008
Posts: 47

PostPosted: Fri Aug 03, 2012 12:15 pm    Post subject: Reply with quote

Code:
emerge -1a @x11-module-rebuild
Back to top
View user's profile Send private message
xp-vit
n00b
n00b


Joined: 22 Sep 2012
Posts: 36

PostPosted: Sun Sep 23, 2012 1:22 pm    Post subject: Reply with quote

s_bernstein wrote:
or you try
Code:
emerge -1 $(qlist -IC x11-drivers)


which will rebuild all installed x11 drivers without futher interaction


this worked perfect. Thanks a lot! You saved my day.
Back to top
View user's profile Send private message
shin938
n00b
n00b


Joined: 10 Feb 2012
Posts: 20

PostPosted: Wed Dec 05, 2012 6:46 pm    Post subject: Reply with quote

Thank you for this thread, saved my day too!
Back to top
View user's profile Send private message
MidnightCheese
n00b
n00b


Joined: 14 Jun 2004
Posts: 10
Location: Music City

PostPosted: Mon Nov 11, 2013 7:20 pm    Post subject: Reply with quote

Fixed my issue as well. Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum