Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Słuchawki bluetooth nie chcą działać
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Polish OTW
View previous topic :: View next topic  
Author Message
KoKA
n00b
n00b


Joined: 25 Feb 2011
Posts: 21

PostPosted: Wed Jul 20, 2011 8:17 pm    Post subject: Słuchawki bluetooth nie chcą działać Reply with quote

Witam, mój problem polega na tym iż nie mogę odtworzyć dźwięku na słuchawkach bluetooth.
Jako aplikacji bluetooth używam net-wireless/blueman (inne funkcje bluetooth działają normalnie), system dźwięku to ALSA, wyjście wybieram przez PulseAudio.
Wszystko się ładnie ustawia, słuchawki sygnalizują połączenie się, ale jak puszczam dźwięk (Firefox, Totem, Exaile) to nic nie słychać. Nie pomaga też łączenie się przez gnome-bluetooth. Na Windows 7 działają bez problemu.
Pliki:
/etc/asound.conf
Code:

pcm.pulse {
    type pulse
}
ctl.pulse {
    type pulse
}
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}
pcm.bluetooth {
   type plug
   slave {
      pcm "bluetooth_hw"
   }
}

pcm.bluetooth_hw {
   type bluetooth
   device B6:38:5B:6B:06:0D
   profile "auto"
}

/etc/pulse/default.pa
Code:

.nofail
.fail
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
.ifexists module-udev-detect.so
load-module module-udev-detect
.else
load-module module-detect
.endif
.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
.endif
.ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
.endif
load-module module-native-protocol-unix
.ifexists module-gconf.so
.nofail
load-module module-gconf
.fail
.endif
load-module module-default-device-restore
load-module module-rescue-streams
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-position-event-sounds
load-module module-cork-music-on-phone
load-module module-alsa-sink device=bluetooth
load-module module-alsa-source device=bluetooth


Dodam jeszcze że gdy ustawiam dźwięk na maksymalną wartość to w słuchawkach przez krótka chwilę słychać pisk. Oprócz tego blueman w ogóle nie wyświetla Menedżera Urządzeń (menu Devices), ale nie jest to szczególnie uciążliwe.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Polish OTW All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum