Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
fstab - czy jest potrzebny
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
dudycz.damian
n00b
n00b


Joined: 27 Feb 2011
Posts: 11

PostPosted: Sat Jun 25, 2011 10:01 pm    Post subject: fstab - czy jest potrzebny Reply with quote

Zauwazylem ostatnio, ze gentoo montuje mi glowny system plikow w troche niespodziewany przeze mnie sposob.
Quote:
rootfs on / type rootfs (rw)
/dev/root on / type ext2 (rw,noatime,barrier=1,data=ordered)
devtmpfs on /dev type devtmpfs (rw,relatime,size=1954896k,nr_inodes=488724,mode=755)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
rc-svcdir on /lib64/rc/init.d type tmpfs (rw,nosuid,nodev,noexec,relatime,size=1024k,mode=755)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
shm on /dev/shm type tmpfs (rw,nosuid,nodev,noexec,relatime)
/dev/sda7 on /var type ext4 (rw,noatime,commit=0)
/dev/sda8 on /tmp type ext4 (rw,noatime,commit=0)
/dev/sda10 on /home type ext4 (rw,noatime,commit=0)
usbfs on /proc/bus/usb type usbfs (rw,noexec,nosuid,devmode=0664,devgid=85)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)

Czyli zamiast /dev/sda6, ktory mam wpisany w fstab jako
/dev/sda6 / ext4 noatime 0 1
mam zamontowane /dev/root. Po usunieciu wpisu z fstab system dalej sie uruchamia z prawie identycznym rezultatem. Moze mi ktos wytlumaczyc o co z tym chodzi? Czy wpis w fstab jest mi juz niepotrzebny? I czemu system plikow jest montowany jako ext2, a nie ext4? I jeszcze zauwazylem, ze root i real_root w grub.conf tez nie sa potrzebne. Mam racje? Podejzewam, ze wszystko to za sprawa devtmpfs, moze ktos to mi troche rozjasnic? :)
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2799

PostPosted: Sat Jun 25, 2011 10:53 pm    Post subject: Reply with quote

root jest potrzebne, chyba, ze masz initramfs, wtedy mozna go olac (tutaj warto zaznaczyc, ze initramfs musi sam nam zamontowac rootfs), real_root jest to przelacznik uzywany przez genkernlowy initramfs.

/dev/root to symlink do wlasciwego rootfs (ls -l /dev/root).

ext4 montowany jako ext2 juz gdzies widzialem, nie jest to dobry objaw. Pewnie jakis zonk z 'CONFIG_EXT4_USE_FOR_EXT23' w kernelu. Mozesz wytestowac wylaczajac ta opcje.

A co do samego devtmpfs, to udev uzywa go, jednak nie do konca tak jak powinien, Bug #365227.

I tak, fstab *jest* potrzebny.
_________________
BitBucket -- better-initramfs to address many usecases and linux's limitations.
Back to top
View user's profile Send private message
dudycz.damian
n00b
n00b


Joined: 27 Feb 2011
Posts: 11

PostPosted: Sun Jun 26, 2011 7:54 pm    Post subject: Reply with quote

Wyłączenie "CONFIG_EXT4_USE_FOR_EXT23" pomogło, dzięki. Ale jeśli chodzi o resztę, to trochę dziwne to jest. Nie używam initramfs.
Co zauważyłem: Kiedy uruchamiam system bez wpisu w fstab, system włącza się normalnie. Myślałem, że bierze to z grub.conf z root (hd0,5), albo root=/dev/sda6
Ale teraz co dziwnego się dzieje. Po wyłączeniu wpisu w fstab, i uruchomieniu systemu bezpośrednio z /boot system włącza się i działa normalnie. To jest dla mnie bardzo dziwne. System uruchomiony z takiego gruba:

title Gentoo Linux
root (hd0,4)
kernel /linux-2.6-gentoo

Na /dev/sda5 mam gruba i kernela, nic więcej. Jak to możliwe, że system uruchamia się normalnie, tak jakbym włączył go z /dev/sda6? Bez żadnego root=/dev/sda6, bez root (hd0,5)? /dev/root jest tu nadal linkiem do /dev/sda6

Co do fstab jeszcze jedno pytanie - czyli mogę zamiast /dev/sda6 wpisać po prostu /dev/root? Niby mi to działa, ale jak narazie wszystko tu działa i mnie to trochę dziwi. Może kernel w jakiś sposób sam wykrywa co gdzie jest?
Back to top
View user's profile Send private message
wertjacek
n00b
n00b


Joined: 19 Jan 2007
Posts: 33

PostPosted: Tue Jul 19, 2011 10:00 pm    Post subject: Reply with quote

a nie dzieje sie to przypadkiem za pomocą pliku /etc/mtab?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum