Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
another gdm keyboard issue
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
trscookie
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2006
Posts: 145
Location: London

PostPosted: Wed Jul 06, 2011 11:32 pm    Post subject: another gdm keyboard issue Reply with quote

Hello All,

I have been sifting through quite a lot of posts on this but do not seem to have the same setup as other people so was wondering if anybody else has the answer.

The short of it is GDM will not use my QWERTY UK keyboard it defaults to the USA one which is beginning to get annoying.

I have configured X with the following:

Code:

colossus ~ # ls -ltr /etc/X11/
total 24
-rwxr-xr-x 1 root root  923 Jul  2 06:51 startDM.sh
-rwxr-xr-x 1 root root 1301 Jul  2 06:51 chooser.sh
drwxr-xr-x 3 root root  136 Jul  2 06:51 xinit
drwxr-xr-x 2 root root   96 Jul  2 06:51 Sessions
drwxr-xr-x 3 root root   72 Jul  2 07:15 dm
-rw-r--r-- 1 root root 7310 Jul  2 07:38 xorg.conf.original-0
drwxr-xr-x 7 root root  344 Jul  3 22:41 gdm
-rw-r--r-- 1 root root 7784 Jul  3 23:04 xorg.conf


Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "evdev"
   Option       "XkbdLayout" "gb"
EndSection



Changed the language on GDM its self and of course XFCE.


Configured my locale:

Code:

colossus ~ # cat /etc/locale.gen | grep -v ^#
en_GB.UTF-8 UTF-8



Set my keymaps:
Code:

colossus ~ # cat /etc/conf.d/keymaps | grep -v ^# | sed '/^$/d'
keymap="uk"
windowkeys="YES"
extended_keymaps=""
dumpkeys_charset=""
fix_euro="NO"



And set my make.conf LINGUAS but am now at a loss.

Code:

colossus ~ # cat /etc/make.conf | grep LING
LINGUAS="en en_GB"



I dont suppose anybody else has any ideas?

Many thanks,
trscookie
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1254
Location: Adelaide/Australia

PostPosted: Thu Jul 07, 2011 10:27 am    Post subject: Reply with quote

Tried changing your language at the gdm login screen?

Do you have
Code:
en_GB ISO-8859-1
en_GB.UTF-8 UTF-8
in your /etc/locale.gen file?

If you don't, re-emerge glibc after adding it.
_________________
...Lyall
Back to top
View user's profile Send private message
trscookie
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2006
Posts: 145
Location: London

PostPosted: Fri Jul 08, 2011 12:19 pm    Post subject: Reply with quote

Hello,

Thanks for the reply. I have changed the language on GDM and checked the language in locale.gen:

Code:

adrian@colossus 10 files 3.8Mb$ cat /etc/locale.gen | grep -v ^#

en_GB ISO-8859-1
en_GB.UTF-8 UTF-8
~



I have also recompiled glibc and checked the usr/locale directory for the files:

Code:

adrian@colossus 10 files 3.8Mb$ locate en_GB | grep locale | grep -v .mo
/usr/share/i18n/locales/en_GB
/usr/share/locale/en_GB
/usr/share/locale/en_GB/LC_MESSAGES



The only thing I can think of now is that it is caused by me using XDM to start GDM:

Code:

adrian@colossus 10 files 3.8Mb$ rc-status
Runlevel: default
 netmount                                                                                                                                                    [  started  ]
 xdm                                                                                                                                                         [  started  ]
 udev-postmount                                                                                                                                              [  started  ]
 local                                                                                                                                                       [  started  ]



XDM config:

Code:

colossus ~ # cat /etc/conf.d/xdm  | grep -v ^# | sed -e '/^$/d'
CHECKVT=7
DISPLAYMANAGER="gdm"



Thanks again.
Back to top
View user's profile Send private message
tclover
Apprentice
Apprentice


Joined: 10 Apr 2011
Posts: 295

PostPosted: Fri Jul 08, 2011 4:42 pm    Post subject: Don't remebember... Reply with quote

I had that same issue on having the choice of keyboard layouts... and yeah I did found nothing on the forums nor googling. It ended up on endless searchs... No luck for you.
But now, I solved that issue but I do not remember how... I did it. The only thing I can say is go right away to try editing `/etc/gdm/custom.conf'. You can easily find some hints googling. You can do many things with custom.conf, the thing is it's becoming deprecated and gnome devs team tends to remove functionalities. I don't think it can help because I made a fresh install after that and I had nothing on that file anymore so I don't know. However, that flag that you have on the bottom of gdm login manager can be used to change LANG setting and keyboard layout before login to gnome. Forget about setting the keyboard layout for gdm login manager in gnome nor in xorg.conf and related X configuration files--it simply won't work for the login! That's what I ended enabling with something I don't remember anymore. You could try clicking on it to see if... and try a few settings in custom.conf.
Back to top
View user's profile Send private message
trscookie
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2006
Posts: 145
Location: London

PostPosted: Fri Jul 08, 2011 11:04 pm    Post subject: Reply with quote

cheers I'll give it a shot and let you know
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1254
Location: Adelaide/Australia

PostPosted: Sat Jul 09, 2011 12:03 am    Post subject: Reply with quote

Don't forget to post what solves your problem, for the next person :)
_________________
...Lyall
Back to top
View user's profile Send private message
jaymz
Apprentice
Apprentice


Joined: 07 Nov 2002
Posts: 171
Location: /dev/chair

PostPosted: Sat Jul 09, 2011 7:30 pm    Post subject: Reply with quote

hey!

I had a similar issue and, actually, the solution for me was in xorg.conf
try changing
Code:
Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "evdev"
   Option       "XkbdLayout" "gb"
EndSection


into
Code:
Section "InputClass"
   Identifier  "Keyboard0"
   Driver      "evdev"
   Option       "XkbdLayout" "gb"
EndSection

_________________
Sleep my friend and you will see, dream is my reality.....
Back to top
View user's profile Send private message
trscookie
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2006
Posts: 145
Location: London

PostPosted: Sun Jul 10, 2011 12:08 pm    Post subject: Reply with quote

:S dont seem to be having much luck here I'm afraid, tried the xorg conf but it complained about the "InputClass" and I've played around with the custom.conf but that didnt seem to have any affect either. Ill have a dig about and see what else i can find (ill keep you posted if i resolve it). Cheers guys :)
Back to top
View user's profile Send private message
trscookie
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2006
Posts: 145
Location: London

PostPosted: Sun Jul 10, 2011 1:02 pm    Post subject: Reply with quote

AH found it!!!!

OK was pretty simple, I just added "setxkbmap gb" to "/etc/X11/gdm/Init/Default"

Think this might have something to do with Xorg.conf not being initialized until gdm starts the init process maybe? Basically so the gdm conf settings were overriding the settings in X?

Anyhoo its fixed! cheers for your help :D
Back to top
View user's profile Send private message
tclover
Apprentice
Apprentice


Joined: 10 Apr 2011
Posts: 295

PostPosted: Sun Jul 10, 2011 4:01 pm    Post subject: Reply with quote

Actually the xorg.conf InputClass(s) could work if you take a few things into account. First you can remove the InputDevice(s) in the xorg.conf if you get your InputClass(s) working--after getting it to work of course or you'll end up with...

Actually if you do not put a `MatchProduct' line, and you could ckeck it on your Xorg.0.log, your InputClass will be apllied to all input devices! That something you may not want, so you have to put something like this
Quote:
Section "InputClass"
Identifier "eKeyboard"
Driver "evdev"
MatchProduct "AT Translated Set 2 keyboard"
MatchIsKeyboard "on"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "es,us"
Option "XkbOptions" "grp:switch,grp:alt_shift_toggle,terminate:ctrl_alt_bksp"
EndSection

and take a little attention on your Xorg.0.log to get your MatchProduct name which might be "AT Translated Set 2 keyboard" if you have a standard laptop keyboard. And everything should be fine as I also tested it. Xorg.0.log will show a few lines of complain of missing input devices on xorg server layout, as udev take care of auto detecting your device, you should be fine if you have merged xf86-input-evdev.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum