Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Errore ati-drivers: CONFIG_PCI_MSI disabled
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano
View previous topic :: View next topic  
Author Message
devi
n00b
n00b


Joined: 05 Feb 2010
Posts: 57

PostPosted: Wed Feb 10, 2010 10:01 pm    Post subject: [RISOLTO] Errore ati-drivers: CONFIG_PCI_MSI disabled Reply with quote

Ho appena finito di installare xorg-x11 e provo ad installare ati-drivers ma si pianta ed esce questo errore:
Code:
ERROR: x11-drivers/ati-drivers-9.11 failed: CONFIG_PCI_MSI disabled
.
Per me è arabo. Come posso risolvere?


Last edited by devi on Thu Feb 11, 2010 12:03 pm; edited 2 times in total
Back to top
View user's profile Send private message
devi
n00b
n00b


Joined: 05 Feb 2010
Posts: 57

PostPosted: Thu Feb 11, 2010 8:31 am    Post subject: Reply with quote

Risolto!
Da terminale
Code:
# nano /usr/src/linux/.config
ed impostare
Code:
CONFIG_PCI_MSI=y
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2909
Location: Parma (Italy)

PostPosted: Thu Feb 11, 2010 11:38 am    Post subject: Reply with quote

per queste cose è meglio andare nella dir dei sorgenti
Code:
# cd /usr/src/linux

e utilizzare l'utility apposita
Code:
# make menuconfig


in quanto potrebbero esserci dipendenze da altre voci o conflitti di cui tener conto.
per trovare la voce basta premere / e apparirà la schermata di search
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2089
Location: イタリアのロヂで

PostPosted: Sun Jul 03, 2011 8:09 pm    Post subject: Reply with quote

piccolo problema, non esiste CONFIG_PCI_MSI
io provo a crearlo da zero. tanto è un test.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Sun Jul 03, 2011 10:27 pm    Post subject: Reply with quote

bandreabis wrote:
piccolo problema, non esiste CONFIG_PCI_MSI
io provo a crearlo da zero. tanto è un test.

Code:
amd64box ~ # grep MSI /usr/src/linux/.config
CONFIG_ARCH_SUPPORTS_MSI=y
CONFIG_PCI_MSI=y
:)
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2089
Location: イタリアのロヂで

PostPosted: Mon Jul 04, 2011 6:02 am    Post subject: Reply with quote

Ma è solo per AMD64?
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2089
Location: イタリアのロヂで

PostPosted: Tue Nov 01, 2011 12:07 am    Post subject: Reply with quote

up?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4751
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Tue Nov 01, 2011 1:30 pm    Post subject: Reply with quote

CONFIG_PCI_MSI help wrote:
Depends on: PCI [=y] && ARCH_SUPPORTS_MSI [=y]
Selected by: AMD_IOMMU [=y] && X86_64 [=y] && PCI [=y] && ACPI [=y]
A quel che ricordo vale per tutte le x86 ma non mi torna in mente quale precisa combinazione lo disabilita (local apic mi pare ma sto andando a vento) ed ora non ho voglia di andarlo a cercare. Ma inizierei dalla sezione processor type del menu.
Cerca un poco avrai disabilitato qualcosa di troppo.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum