Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installation Issues With Current Stage3 Tarballs
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5  Next  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
M
Guru
Guru


Joined: 12 Dec 2006
Posts: 427

PostPosted: Mon Jun 20, 2011 5:51 pm    Post subject: Reply with quote

NeddySeagoon,

Thank you! I had a hard disk crash on one of the servers and for the last two days I was trying to boot damn system! I have daily backups of everything important, compiled world in an hour and then for the next two days I compiled 10 different versions of kernels and what not, and then I just added "gentoo" to keywords in google and got to this page.

This is a very critical bug! And it is almost a one month old!
Back to top
View user's profile Send private message
arcfxn
n00b
n00b


Joined: 31 Jan 2011
Posts: 74
Location: NY, USA

PostPosted: Mon Jun 20, 2011 5:56 pm    Post subject: Re: Official Solution / Workaround Reply with quote

FaeLLe wrote:
You can refer to the instructions from a Gentoo Developer at,

http://dev.gentoo.org/~a3li/openrc.txt


Thanks for the link. I think these instructions are more clear, and may fix my problem.

I was chrooted while performing the steps in the OP - it makes sense that I shouldn't have /dev bind-mounted, but I didn't think of it.


edit: ----------

It worked!

Might want to consider adding a little caveat about chrooting to the OP, since so many of us are performing this fix from live-cd environments.
Back to top
View user's profile Send private message
h2sammo
Veteran
Veteran


Joined: 11 Mar 2009
Posts: 1019
Location: Davie, FL

PostPosted: Wed Jun 22, 2011 10:34 am    Post subject: Reply with quote

i am still having problems.

i did the mknod commands, then chrooted and added udev to rc-ypdate (sysinit). i did the prescribed symlinks as well. however, my boot gives me a message about "couldnt" open /dev/tty1...to tty12 then it basically hangs at starting local, with messages that c1...c6 starting too fast and it makes them wait 5 minutes... pretty much this cycle repeats forever.

i have also noticed that swap devices are not found /dev/hda3 start failed; no such file/directory.

any ideas?

my original post with machine details: http://forums.gentoo.org/viewtopic-t-883403-highlight-.html
_________________
www.claudiubucur.com
Back to top
View user's profile Send private message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1127
Location: 127.0.0.1

PostPosted: Wed Jun 22, 2011 5:28 pm    Post subject: Reply with quote

i cannot believe that this issue is still there in the stage3-amd64-20110609.tar.bz2 file i just looked at, would have thought it would have been fixed by now, i know its not an issue in the 20110421 file i used when i had to reinstall ;)
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4122
Location: Houston, Republic of Texas

PostPosted: Wed Jun 22, 2011 5:41 pm    Post subject: Reply with quote

h2sammo wrote:
i am still having problems.

i did the mknod commands, then chrooted and added udev to rc-ypdate (sysinit). i did the prescribed symlinks as well. however, my boot gives me a message about "couldnt" open /dev/tty1...to tty12 then it basically hangs at starting local, with messages that c1...c6 starting too fast and it makes them wait 5 minutes... pretty much this cycle repeats forever.


make sure you didn't bind mount /dev before you removed and recreated these device nodes. if you do bind mount /dev, you will "hide" the rogue device nodes, and therefore what you rm will not be the bad device nodes, but rather the copy created from your livecd's /dev via the bind mount.

h2sammo wrote:

i have also noticed that swap devices are not found /dev/hda3 start failed; no such file/directory.


recent udev will no longer create /dev/hd* device nodes. CONFIG_IDE is officially dead, you need to be using CONFIG_ATA drivers, which will show up as /dev/sd*
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
h2sammo
Veteran
Veteran


Joined: 11 Mar 2009
Posts: 1019
Location: Davie, FL

PostPosted: Wed Jun 22, 2011 10:54 pm    Post subject: Reply with quote

how do i check i
Quote:
didn't bind mount /dev
?

i did
Code:
# mount /dev/sda4 /mnt/gentoo


i noticed that is i do
Code:
ls /mnt/gentoo/dev
after mounting above, i see different contents than what i see inside dev while being chrooted. should i not see the same contents in that folder?
_________________
www.claudiubucur.com
Back to top
View user's profile Send private message
minaguib
n00b
n00b


Joined: 03 Nov 2003
Posts: 35
Location: Montréal

PostPosted: Thu Jun 23, 2011 3:44 am    Post subject: Reply with quote

A colleague and I have spent over a day diagnosing this issue.

Hindsight being 20/20, the challenge was finding this thread. The solution outlined here worked flawlessly.

Thank you for documenting it.

Now, gentoo devs, how about getting the minimal installer and tarballs fixed so that, you know, people can install gentoo without feeling like pulling their hair out ?
Back to top
View user's profile Send private message
kiss-o-matic
Guru
Guru


Joined: 19 Jul 2004
Posts: 423
Location: Tokyo

PostPosted: Thu Jun 23, 2011 8:25 am    Post subject: Reply with quote

I'm having issues here and leaving for the day, so can't go into too much detail, but, I enabled the devtmpfs option in the kernel and got past the init_early.sh hang, but am now hanging at :

Code:

tmpfs: No value for mount option 'nodev/nosuid'



Any love?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32452
Location: 56N 3W

PostPosted: Thu Jun 23, 2011 5:43 pm    Post subject: Reply with quote

kiss-o-matic,

Don't use devtmpfs and make the devices you need to get started as static entries in /mnt/gentoo/dev after you mount your root filesystem but before you do anything else. Thats covered in the first post of the thread.

If you have something non standard, e.g. root on raid, you may need more /dev entries ... make them the same way.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
nost4r
Apprentice
Apprentice


Joined: 08 Oct 2006
Posts: 164
Location: Bordeaux

PostPosted: Thu Jun 23, 2011 8:31 pm    Post subject: Reply with quote

I have made a fresh install today, I get "root partition in readonly" after booted.

Is it because of that ?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32452
Location: 56N 3W

PostPosted: Thu Jun 23, 2011 8:43 pm    Post subject: Reply with quote

nost4r,

If you don't fix the issues in the first post of this thread, it normally hangs very soon after the kernel loads.
Boot your CD, mount your root on /mnt/gentoo then look in /mnt/gentoo/dev

If null is a normal file, you have at least some of these issues. It may be that udev did not start because its not in the sysinit runlevel.
The first post in this thread describes how to fix that too.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
nost4r
Apprentice
Apprentice


Joined: 08 Oct 2006
Posts: 164
Location: Bordeaux

PostPosted: Thu Jun 23, 2011 9:29 pm    Post subject: Reply with quote

Hum not solved, I get before Gentoo starting : using mount -t auto -o ro /
Back to top
View user's profile Send private message
kiss-o-matic
Guru
Guru


Joined: 19 Jul 2004
Posts: 423
Location: Tokyo

PostPosted: Fri Jun 24, 2011 1:21 am    Post subject: Reply with quote

NeddySeagoon wrote:
kiss-o-matic,

Don't use devtmpfs and make the devices you need to get started as static entries in /mnt/gentoo/dev after you mount your root filesystem but before you do anything else. Thats covered in the first post of the thread.

If you have something non standard, e.g. root on raid, you may need more /dev entries ... make them the same way.


Thanks, that worked. I actually jumped in here (at the end) after reading updates on another thread, so never checked the original post. Shame on me!
Back to top
View user's profile Send private message
boaglio
n00b
n00b


Joined: 14 May 2004
Posts: 60
Location: Sao Paulo - Brazil

PostPosted: Fri Jun 24, 2011 1:39 am    Post subject: Reply with quote

WOW, thank you so much for answering this...

This took me all day , about 8 hours of trying to make it work... and I thought I was a Gentoo expert after so many years :)

First I thought I was my new ext4 partition, and then my ck-sources,an then my kernel config, and then my boot partition , and then my base-layout version... oh boy :?
Back to top
View user's profile Send private message
bugmenot
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2006
Posts: 76

PostPosted: Fri Jun 24, 2011 8:02 pm    Post subject: Reply with quote

Thank you so much for posting this, worked flawlessly!
Back to top
View user's profile Send private message
h2sammo
Veteran
Veteran


Joined: 11 Mar 2009
Posts: 1019
Location: Davie, FL

PostPosted: Sat Jun 25, 2011 1:38 pm    Post subject: Reply with quote

i rerun the install and used this process in the beginning and i can boot into gentoo on my clamshell. oh yey
_________________
www.claudiubucur.com
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1556

PostPosted: Sun Jun 26, 2011 9:46 am    Post subject: Re: Installation Issues With Current Stage3 Tarballs Reply with quote

Hello Neddy

I tried your solution. Unfortunately it didn't work. It can't umounr /dev. Says it's busy. I exited the chroot and umounted proc and boot but /mnt/gentoo/dev it isn't able to umount. So I am forced to poweroff or reboot.

NeddySeagoon wrote:
The current stage3 tarball with baselayout2 is broken. If you used an April 2011 stage3 tarball, that has baselayout1 and you may have different problems if you missed the baseylayout upgrade guide.

The content of its /dev is wrong, it contains only a normal file called null of zero length. A minimum of three character device special files are needed for udev to start and the boot process to proceed normally. Taken from a working system ...
Code:
crw------- 1 root root        5,   1 May 28 10:28 console
crw-rw-rw- 1 root root        1,   3 May 28 10:27 null
crw-rw-rw- 1 root root        1,   5 May 28 10:27 zero

Notice the leading c, that denotes the file as a character special device. These are made with mknod as follows:

Remove the useless null
Code:
cd /mnt/gentoo/dev
rm null

and make the missing devices
Code:
mknod --mode=600 console c 5 1
mknod --mode=666 null c 1 3
mknod --mode=666 zero c 1 5

This will allow udev to start to make the rest of your /dev nodes, once it gets started.
According to the baseylayout upgrade guide, OpenRC no longer starts udev by default
Its not set to start in the current stage3 either.
Code:
ls -l ../etc/runlevels/sysinit
shows only
Code:
total 0
lrwxrwxrwx 1 root root 17 May 28 15:30 devfs -> /etc/init.d/devfs
lrwxrwxrwx 1 root root 17 May 28 15:30 dmesg -> /etc/init.d/dmesg

So we must add a symlink there
Code:
cd /etc/runlevels/sysinit
ln -s /etc/init.d/udev udev


This is all from bug 368597 so hopefully my new install will boot first time.
I'll update this post with any more stage3 related details as they happen.

----- edit -----
The step
Code:
rc-update add net.eth0 default
returns
* rc-update: service `net.eth0' does not exist
because the net.eth0 symlink is missing. Add that with
Code:
cd /etc/init.d
ln -s net.lo net.eth0


Adding eth0 to the default runlevel will work now.

------- edit 2 -------

Tested on real hardware - works for me
Back to top
View user's profile Send private message
BatesIsBack
n00b
n00b


Joined: 19 Jun 2011
Posts: 3

PostPosted: Sun Jun 26, 2011 10:07 am    Post subject: Reply with quote

Allow me to add to the chorus of "thankyou" for posting this fix.

The bug page seems to indicate that CONFIG_DEVTMPFS and CONFIG_DEVTMPFS_MOUNT are now required kernel options for Gentoo.

It must be a difficult time for new Gentoo users as following the installation docs will almost certainly produce an unbootable system. Is the issue remaining unsolved so that they learn how to find solutions from forums.gentoo.org right from the beginning?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32452
Location: 56N 3W

PostPosted: Sun Jun 26, 2011 12:54 pm    Post subject: Reply with quote

BatesIsBack,

The root of the problem is that until baselayout2 was stabilised, everyone installed using baselayout1 then upgraded to baselayout2/Openrc.
The stage3 files are autogenerated from the stable tree and the auto generation had mostly JustWorked.

Unfortunately, the autogeneration of stage3 files was not tested with baselayout2 prior to it being stabilised, so we have broken stage3 files.
Normally, when stage3 gets broken, its removed from the mirrors and older stages remain. April 2011 stage3 files will still work but they will have baselayout1 in.

Now, the update from baselayout1 to baselayout2 is not something that will just work - Gentoo put a lot of publicity into baselaout2 going stable. New users are either hit by a broken stage3, if the new stages are left or by missing the publicity if they use an old stage3. Both result in unbootable systems. They are equally bad - just different.

With hindsight, its easy to say that this should have been tested - indeed drobbins commented that he hit the issue in Funtoo.

The autobuilds are in the process of being fixed. My view is that CONFIG_DEVTMPFS and CONFIG_DEVTMPFS_MOUNT is a hack and the static /dev entries needed to boot should be added to /dev. The addition of udev to the sysinit runlevel needs to be fixed, regardless of how /dev is addressed.
Incidently, baselayout1 provides a full static /dev, you just don't see it as the udev tmpfs /dev is mounted over the top of it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ccosse
Apprentice
Apprentice


Joined: 10 Mar 2004
Posts: 159
Location: New Mexico, USA

PostPosted: Mon Jun 27, 2011 4:01 am    Post subject: Reply with quote

Thanks from me too, Neddy ... There's another post out there with the correct syntax for the mknod commands, but lacking this important line:

Code:

ln -s /etc/init.d/udev udev


This made all the difference for me ... I now have Gentoo 11 on a Sony Vaio VPCF1. I previously spent about 3 days trying to quickpkg the dvd and install the liveDVD environment but finally went back to the handbook method. Anyway, this is a major landmark for me and am very happy to have Gentoo back.
Back to top
View user's profile Send private message
bdx
n00b
n00b


Joined: 04 Jan 2006
Posts: 48

PostPosted: Mon Jun 27, 2011 4:58 am    Post subject: Reply with quote

Ran into this "no-boot" problem attempting a gentoo re-install. Sounds like things are
really messed up.

Anyways, thanks for the instructions.

Anyone care to explain why this work-around is not "proper" ?

NOTICE: Some places suggest enabling CONFIG_DEVTMPFS in your kernel.
This is a workaround which will make your system boot, but is not a proper
fix.
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4971

PostPosted: Mon Jun 27, 2011 7:49 am    Post subject: Reply with quote

bdx wrote:
Ran into this "no-boot" problem attempting a gentoo re-install. Sounds like things are
really messed up.

Anyways, thanks for the instructions.

Anyone care to explain why this work-around is not "proper" ?

NOTICE: Some places suggest enabling CONFIG_DEVTMPFS in your kernel.
This is a workaround which will make your system boot, but is not a proper
fix.


check the topic at #gentoo in freenode, there is a better way to solve this.
worked for me.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32452
Location: 56N 3W

PostPosted: Mon Jun 27, 2011 5:13 pm    Post subject: Reply with quote

bdx,

devfs and udev ran side by side in the 2.6.x kernel series until devfs was removed in 2.6.13 as being a bad thing.
devfs has been added back recently under a new name, devtmpfs. Its really intended for use in an initrd, since you don't want both devtmpfs and udev trying to manage /dev at the same time.

If you use an initrd devtmpfs is a valid solution as its /dev gets thrown away at the piviot root step.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
tuber
Apprentice
Apprentice


Joined: 12 Nov 2004
Posts: 267

PostPosted: Wed Jun 29, 2011 4:38 am    Post subject: Reply with quote

Does using devtmpfs also apply to initramfs?
Back to top
View user's profile Send private message
disi
Veteran
Veteran


Joined: 28 Nov 2003
Posts: 1354
Location: Out There ...

PostPosted: Wed Jun 29, 2011 1:06 pm    Post subject: Reply with quote

NeddySeagoon wrote:
The autobuilds are in the process of being fixed. My view is that CONFIG_DEVTMPFS and CONFIG_DEVTMPFS_MOUNT is a hack and the static /dev entries needed to boot should be added to /dev. The addition of udev to the sysinit runlevel needs to be fixed, regardless of how /dev is addressed.
Incidently, baselayout1 provides a full static /dev, you just don't see it as the udev tmpfs /dev is mounted over the top of it.


There are warnings, right before udev starts about missing /dev/null if you have this kernel feature disabled. I created /dev/null on the harddrive partition, which doesn't seem to be recongnized or an empty devtmpfs is mounted when sysinit starts, it complains and then udevd kicks in?
Not sure about the order of events here :)
_________________
Gentoo on Uptime Project - Larry is a cow
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page Previous  1, 2, 3, 4, 5  Next
Page 2 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum