Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Timidity crashing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
zboj87
n00b
n00b


Joined: 17 Mar 2007
Posts: 20
Location: Poland

PostPosted: Thu Jun 16, 2011 12:34 pm    Post subject: Timidity crashing Reply with quote

Hi,

I have emerged timidity to use Midi functions however as soon as I run it, it gets crashed. I read all hints from bug: http://bugs.gentoo.org/169453 but none of them was helpful.

Additional information:

Code:
# HOME=/tmp /etc/init.d/timidity restart
 * Stopping TiMidity++ ...                                  [ ok ]
 * Starting TiMidity++ Virtual Midi Sequencer ...           [ ok ]



Code:
# /etc/init.d/timidity status
 * status: crashed


Content:
http://paste.pocoo.org/show/408784/


Code:
$ timidity -iA -Os
Can't open pcm device 'default'.
Couldn't open ALSA pcm device (`s')


Code:
$ cat /proc/asound/oss/sndstat | grep Midi
Midi devices: NOT ENABLED IN CONFIG


Sequecner support is build-in. I'd be grateful for some advices.
Back to top
View user's profile Send private message
Letharion
Veteran
Veteran


Joined: 13 Jun 2005
Posts: 1252
Location: Sweden

PostPosted: Thu Jun 16, 2011 4:01 pm    Post subject: Reply with quote

What happens if you run timidity directly from console instead?
Back to top
View user's profile Send private message
zboj87
n00b
n00b


Joined: 17 Mar 2007
Posts: 20
Location: Poland

PostPosted: Thu Jun 16, 2011 4:04 pm    Post subject: Reply with quote

If you mean just typing timidity, there's the output:
Code:
piotr@gentoo ~ $ timidity
TiMidity++ version 2.13.2 -- MIDI to WAVE converter and player
Copyright (C) 1999-2004 Masanao Izumo <iz@onicos.co.jp>
Copyright (C) 1995 Tuukka Toivonen <tt@cgs.fi>

This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

piotr@gentoo ~ $
Back to top
View user's profile Send private message
Letharion
Veteran
Veteran


Joined: 13 Jun 2005
Posts: 1252
Location: Sweden

PostPosted: Thu Jun 16, 2011 6:07 pm    Post subject: Reply with quote

Yes, that's what I meant. I was hoping it would crash so we could get some more info.

What about manually executing the command from the init script?
Back to top
View user's profile Send private message
zboj87
n00b
n00b


Joined: 17 Mar 2007
Posts: 20
Location: Poland

PostPosted: Fri Jun 17, 2011 10:39 am    Post subject: Reply with quote

Letharion wrote:
What about manually executing the command from the init script?

What do you mean by that?
Back to top
View user's profile Send private message
mathfeel
l33t
l33t


Joined: 03 Aug 2004
Posts: 697

PostPosted: Wed Aug 17, 2011 1:14 pm    Post subject: Reply with quote

Letharion wrote:
Yes, that's what I meant. I was hoping it would crash so we could get some more info.

What about manually executing the command from the init script?


I have the same problem and:
Code:
# start-stop-daemon --start --background --chdir /usr/share/timidity --user timidity --group audio --make-pidfile --pidfile /var/run/timidity.pid --exec /usr/bin/timidity -- -iA -B2,8 -Os -EFreverb=0
# pgrep -fl timi

failed, while without the --user option:
Code:
# start-stop-daemon --start --background --chdir /usr/share/timidity --group audio --make-pidfile --pidfile /var/run/timidity.pid --exec /usr/bin/timidity -- -iA -B2,8 -Os -EFreverb=0
# pgrep -fl timi
12882 /usr/bin/timidity -iA -B2,8 -Os -EFreverb=0

worked.

But it also always crash when launched from the rc script, even after I remove the --user option:
Code:
# /etc/init.d/timidity restart; sleep 1; /etc/init.d/timidity status
 * Caching service dependencies ...                                                                                                                 [ ok ]
 * Stopping TiMidity++ ...                                                                                                                          [ ok ]
 * Starting TiMidity++ Virtual Midi Sequencer ...
 * start-stop-daemon --start --background --chdir /usr/share/timidity    --group audio --make-pidfile --pidfile /var/run/timidity.pid    --exec /usr/bin/timidity -- -iA -B2,8 -Os -EFreverb=0                                                                                                                     [ ok ]
 * status: crashed

_________________
-----------------------------------------------------------
"In heaven all the interesting people are missing"
-- Friedrich Nietzsche
Back to top
View user's profile Send private message
AsciiWolf
n00b
n00b


Joined: 05 Aug 2012
Posts: 2
Location: Czech Republic

PostPosted: Sun Aug 05, 2012 6:24 pm    Post subject: Reply with quote

Any updates on this issue?

This is what appears in my log after trying to run the TiMidity daemon via init:
Code:
Aug  5 20:29:59 desktop pulseaudio[13596]: [pulseaudio] server-lookup.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NotSupported: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
Aug  5 20:29:59 desktop pulseaudio[13596]: [pulseaudio] main.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NotSupported: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
Back to top
View user's profile Send private message
AsciiWolf
n00b
n00b


Joined: 05 Aug 2012
Posts: 2
Location: Czech Republic

PostPosted: Mon Aug 06, 2012 9:37 pm    Post subject: I got it working! Reply with quote

Update: I got it working!


If you use PulseAudio, you need to run the TiMidity daemon under your user or the PulseAudio daemon won't be able to connect to it (via dbus).

First, you need to correct the /dev/snd/seq permissions:
Code:
chown root:audio /dev/snd/seq &>/dev/null
chmod 660 /dev/snd/seq &>/dev/null

Add these two lines to the /etc/local.d/baselayout1.start script, so they can be applied automatically during boot.

Next, you need to run the TiMidity daemon under your user:
Code:
/usr/bin/timidity -iA -B2,8 -Os -EFreverb=0

If you want the TiMidity daemon to be started automatically when you log on, add this line of code to your desktop environment autostart file/whatever (I used the gnome-session-properties to do this).


And that's it! ;-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum