Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] problemy z kompilacją kernela
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
electro
n00b
n00b


Joined: 28 Feb 2008
Posts: 46
Location: Poland-Zamość

PostPosted: Mon Jun 06, 2011 5:38 am    Post subject: [Solved] problemy z kompilacją kernela Reply with quote

zainstalowalem gentoo 64 bit wg instrukcji , a po uruchomieniu jego pokazuje mi sie, stoi ekran na :

http://img33.imageshack.us/img33/3263/dscn0564it.jpg

myszke i klawiature mam na usb , w kernelu niby dalem jego obsluge, ale nadal problem

Jest to chyba m.in. zwiazane z jakimś błedęm podczas recznej kompilacji jadra ,kernela - coś dodałem za mało w opcjach itp. . wlasciwie to zrobilem tak ze odrazu dalem po poleceniu emerge gentoo-sources kolejne polecenie make menuconfig zobaczelem konfiguracje dodalem z 2 nowe opcje i tyle potem tylko polecenie make && make modules_install



probowalem rowniez skompilowac kernel za pomoca genkernela , ale mam blad kompilacji . log :

Code:

(chroot) Gentoo-11 boot # genkernel --menuconfig  all
* Gentoo Linux Genkernel; Version 3.4.10.907
* Running with options: --menuconfig all

* Linux Kernel 2.6.38-gentoo-r6 for x86_64...
* kernel: >> Running mrproper...
* config: Using config from /etc/kernels/kernel-config-x86_64-2.6.38-gentoo-r6
*         Previous config backed up to .config.bak
*         >> Running oldconfig...
* kernel: >> Cleaning...
* config: >> Invoking menuconfig...
#
# configuration written to .config
#


*** End of the configuration.
*** Execute 'make' to start the build or try 'make help'.

*         >> Compiling 2.6.38-gentoo-r6 bzImage...
*         >> Compiling 2.6.38-gentoo-r6 modules...
* Copying config for successful build to /etc/kernels/kernel-config-x86_64-2.6.38-gentoo-r6
* busybox: >> Applying patches...
* busybox: >> Configuring...
* ERROR: Failed to compile the "oldconfig" target...

* -- Grepping log... --

  SHIPPED scripts/genksyms/parse.h
  SHIPPED scripts/genksyms/keywords.c
  SHIPPED scripts/genksyms/parse.c
  HOSTCC  scripts/genksyms/lex.o
scripts/genksyms/lex.c: In function 'yylex1':
scripts/genksyms/lex.l:97: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result
--
  CC      fs/gfs2/glops.o
  CC      crypto/shash.o
  CC      fs/gfs2/inode.o
  CC      crypto/algboss.o
fs/gfs2/inode.c: In function 'gfs2_lookup_by_inum':
fs/gfs2/inode.c:188: warning: 'inode' may be used uninitialized in this function
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  CC      drivers/scsi/scsi_netlink.o
  LD      fs/xfs/xfs.o
  LD      fs/xfs/built-in.o
  CC      fs/eventpoll.o
fs/eventpoll.c: In function 'ep_poll':
fs/eventpoll.c:1143: warning: 'slack' may be used uninitialized in this function
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  LD [M]  sound/pci/snd-sonicvibes.o
  LD [M]  sound/pci/snd-via82xx.o
  LD [M]  sound/pci/snd-via82xx-modem.o
  CC [M]  sound/pcmcia/pdaudiocf/pdaudiocf.o
sound/pcmcia/pdaudiocf/pdaudiocf.c: In function 'pdacf_config':
sound/pcmcia/pdaudiocf/pdaudiocf.c:226: warning: 'pcmcia_request_exclusive_irq' is deprecated (declared at include/pcmcia/ds.h:201)
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  CC [M]  drivers/gpu/drm/radeon/radeon_ring.o
  LD [M]  sound/pcmcia/pdaudiocf/snd-pdaudiocf.o
  CC [M]  sound/pcmcia/vx/vxpocket.o
  CC [M]  drivers/gpu/drm/radeon/radeon_irq_kms.o
sound/pcmcia/vx/vxpocket.c: In function 'vxpocket_config':
sound/pcmcia/vx/vxpocket.c:232: warning: 'pcmcia_request_exclusive_irq' is deprecated (declared at include/pcmcia/ds.h:201)
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  CC [M]  net/mac80211/spectmgmt.o
  CC [M]  drivers/md/dm-linear.o
  CC [M]  net/mac80211/tx.o
  CC [M]  drivers/md/dm-stripe.o
net/mac80211/tx.c: In function 'ieee80211_subif_start_xmit':
net/mac80211/tx.c:1753: warning: unused variable 'mppath'
  CC [M]  drivers/md/dm-ioctl.o
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  CC [M]  drivers/message/fusion/mptfc.o
  CC [M]  net/netfilter/nf_conntrack_ecache.o
  CC [M]  net/netfilter/nf_conntrack_h323_main.o
  CC [M]  drivers/message/fusion/mptsas.o
drivers/message/fusion/mptsas.c: In function 'mptsas_event_process':
drivers/message/fusion/mptsas.c:5012: warning: unused variable 'log_info'
  CC [M]  net/netfilter/nf_conntrack_h323_asn1.o
  CC [M]  net/netfilter/nf_conntrack_proto_gre.o
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  CC [M]  drivers/message/i2o/bus-osm.o
  CC [M]  net/netfilter/nf_conntrack_amanda.o
  CC [M]  drivers/message/i2o/config-osm.o
In file included from drivers/message/i2o/config-osm.c:39:
drivers/message/i2o/i2o_config.c: In function 'i2o_cfg_passthru':
drivers/message/i2o/i2o_config.c:881: warning: cast to pointer from integer of different size
drivers/message/i2o/i2o_config.c:936: warning: cast to pointer from integer of different size
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  CC [M]  drivers/net/pcmcia/3c574_cs.o
  CC [M]  drivers/platform/x86/thinkpad_acpi.o
  CC [M]  drivers/net/pcmcia/fmvj18x_cs.o
  CC [M]  drivers/net/pcmcia/nmclan_cs.o
drivers/net/pcmcia/nmclan_cs.c: In function 'nmclan_config':
drivers/net/pcmcia/nmclan_cs.c:628: warning: 'pcmcia_request_exclusive_irq' is deprecated (declared at include/pcmcia/ds.h:201)
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  CC [M]  drivers/net/skfp/smtdef.o
  CC [M]  drivers/net/skfp/smtinit.o
  CC [M]  drivers/net/skfp/smttimer.o
  CC [M]  drivers/scsi/advansys.o
  CC [M]  drivers/net/skfp/srf.o
drivers/scsi/advansys.c:72:2: warning: #warning this driver is still not properly converted to the DMA API
--
  CC [M]  drivers/scsi/aic7xxx/aic79xx_proc.o
  CC [M]  drivers/scsi/aic7xxx/aic79xx_osm_pci.o
  CC [M]  drivers/net/wireless/wl3501_cs.o
  CC [M]  drivers/scsi/aic7xxx/aic7xxx_core.o
drivers/net/wireless/wl3501_cs.c: In function 'wl3501_mgmt_scan_confirm':
drivers/net/wireless/wl3501_cs.c:656: warning: 'sig' is used uninitialized in this function
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  LD [M]  drivers/usb/storage/ums-sddr09.o
  LD [M]  drivers/usb/storage/ums-sddr55.o
  LD [M]  drivers/usb/storage/ums-usbat.o
  Building modules, stage 2.
  MODPOST 1060 modules
WARNING: modpost: Found 1 section mismatch(es).
--
COMMAND: make -j2 CC="gcc" LD="ld" AS="as" 
Makefile:405: *** mixed implicit and normal rules.  Stop.
* Gentoo Linux Genkernel; Version 3.4.10.907
* Running with options: --menuconfig all

* ERROR: Failed to compile the "oldconfig" target...

* -- End log... --

* Please consult /var/log/genkernel.log for more information and any
* errors that were reported above.

* Report any genkernel bugs to bugs.gentoo.org and
* assign your bug to genkernel@gentoo.org. Please include
* as much information as you can in your bug report; attaching
* /var/log/genkernel.log so that your issue can be dealt with effectively.
*
* Please do *not* report compilation failures as genkernel bugs!
*
* busybox: >> Compiling...
* ERROR: Failed to compile the "all" target...

* -- Grepping log... --

  SHIPPED scripts/genksyms/parse.h
  SHIPPED scripts/genksyms/keywords.c
  SHIPPED scripts/genksyms/parse.c
  HOSTCC  scripts/genksyms/lex.o
scripts/genksyms/lex.c: In function 'yylex1':
scripts/genksyms/lex.l:97: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result
--
  CC      fs/gfs2/glops.o
  CC      crypto/shash.o
  CC      fs/gfs2/inode.o
  CC      crypto/algboss.o
fs/gfs2/inode.c: In function 'gfs2_lookup_by_inum':
fs/gfs2/inode.c:188: warning: 'inode' may be used uninitialized in this function
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  CC      drivers/scsi/scsi_netlink.o
  LD      fs/xfs/xfs.o
  LD      fs/xfs/built-in.o
  CC      fs/eventpoll.o
fs/eventpoll.c: In function 'ep_poll':
fs/eventpoll.c:1143: warning: 'slack' may be used uninitialized in this function
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  LD [M]  sound/pci/snd-sonicvibes.o
  LD [M]  sound/pci/snd-via82xx.o
  LD [M]  sound/pci/snd-via82xx-modem.o
  CC [M]  sound/pcmcia/pdaudiocf/pdaudiocf.o
sound/pcmcia/pdaudiocf/pdaudiocf.c: In function 'pdacf_config':
sound/pcmcia/pdaudiocf/pdaudiocf.c:226: warning: 'pcmcia_request_exclusive_irq' is deprecated (declared at include/pcmcia/ds.h:201)
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  CC [M]  drivers/gpu/drm/radeon/radeon_ring.o
  LD [M]  sound/pcmcia/pdaudiocf/snd-pdaudiocf.o
  CC [M]  sound/pcmcia/vx/vxpocket.o
  CC [M]  drivers/gpu/drm/radeon/radeon_irq_kms.o
sound/pcmcia/vx/vxpocket.c: In function 'vxpocket_config':
sound/pcmcia/vx/vxpocket.c:232: warning: 'pcmcia_request_exclusive_irq' is deprecated (declared at include/pcmcia/ds.h:201)
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  CC [M]  net/mac80211/spectmgmt.o
  CC [M]  drivers/md/dm-linear.o
  CC [M]  net/mac80211/tx.o
  CC [M]  drivers/md/dm-stripe.o
net/mac80211/tx.c: In function 'ieee80211_subif_start_xmit':
net/mac80211/tx.c:1753: warning: unused variable 'mppath'
  CC [M]  drivers/md/dm-ioctl.o
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  CC [M]  drivers/message/fusion/mptfc.o
  CC [M]  net/netfilter/nf_conntrack_ecache.o
  CC [M]  net/netfilter/nf_conntrack_h323_main.o
  CC [M]  drivers/message/fusion/mptsas.o
drivers/message/fusion/mptsas.c: In function 'mptsas_event_process':
drivers/message/fusion/mptsas.c:5012: warning: unused variable 'log_info'
  CC [M]  net/netfilter/nf_conntrack_h323_asn1.o
  CC [M]  net/netfilter/nf_conntrack_proto_gre.o
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  CC [M]  drivers/message/i2o/bus-osm.o
  CC [M]  net/netfilter/nf_conntrack_amanda.o
  CC [M]  drivers/message/i2o/config-osm.o
In file included from drivers/message/i2o/config-osm.c:39:
drivers/message/i2o/i2o_config.c: In function 'i2o_cfg_passthru':
drivers/message/i2o/i2o_config.c:881: warning: cast to pointer from integer of different size
drivers/message/i2o/i2o_config.c:936: warning: cast to pointer from integer of different size
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  CC [M]  drivers/net/pcmcia/3c574_cs.o
  CC [M]  drivers/platform/x86/thinkpad_acpi.o
  CC [M]  drivers/net/pcmcia/fmvj18x_cs.o
  CC [M]  drivers/net/pcmcia/nmclan_cs.o
drivers/net/pcmcia/nmclan_cs.c: In function 'nmclan_config':
drivers/net/pcmcia/nmclan_cs.c:628: warning: 'pcmcia_request_exclusive_irq' is deprecated (declared at include/pcmcia/ds.h:201)
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  CC [M]  drivers/net/skfp/smtdef.o
  CC [M]  drivers/net/skfp/smtinit.o
  CC [M]  drivers/net/skfp/smttimer.o
  CC [M]  drivers/scsi/advansys.o
  CC [M]  drivers/net/skfp/srf.o
drivers/scsi/advansys.c:72:2: warning: #warning this driver is still not properly converted to the DMA API
--
  CC [M]  drivers/scsi/aic7xxx/aic79xx_proc.o
  CC [M]  drivers/scsi/aic7xxx/aic79xx_osm_pci.o
  CC [M]  drivers/net/wireless/wl3501_cs.o
  CC [M]  drivers/scsi/aic7xxx/aic7xxx_core.o
drivers/net/wireless/wl3501_cs.c: In function 'wl3501_mgmt_scan_confirm':
drivers/net/wireless/wl3501_cs.c:656: warning: 'sig' is used uninitialized in this function
At top level:
cc1: warning: unrecognized command line option "-Wno-unused-but-set-variable"
--
  LD [M]  drivers/usb/storage/ums-sddr09.o
  LD [M]  drivers/usb/storage/ums-sddr55.o
  LD [M]  drivers/usb/storage/ums-usbat.o
  Building modules, stage 2.
  MODPOST 1060 modules
WARNING: modpost: Found 1 section mismatch(es).
--
COMMAND: make -j2 CC="gcc" LD="ld" AS="as" 
Makefile:405: *** mixed implicit and normal rules.  Stop.
* Gentoo Linux Genkernel; Version 3.4.10.907
* Running with options: --menuconfig all

* ERROR: Failed to compile the "oldconfig" target...
--
* Report any genkernel bugs to bugs.gentoo.org and
* assign your bug to genkernel@gentoo.org. Please include
* as much information as you can in your bug report; attaching
* /var/log/genkernel.log so that your issue can be dealt with effectively.
*
* Please do *not* report compilation failures as genkernel bugs!
--
make: getcwd: No such file or directory
make: *** No rule to make target `all'.  Stop.
* Gentoo Linux Genkernel; Version 3.4.10.907
* Running with options: --menuconfig all

* ERROR: Failed to compile the "all" target...

* -- End log... --

* Please consult /var/log/genkernel.log for more information and any
* errors that were reported above.

* Report any genkernel bugs to bugs.gentoo.org and
* assign your bug to genkernel@gentoo.org. Please include
* as much information as you can in your bug report; attaching
* /var/log/genkernel.log so that your issue can be dealt with effectively.
*
* Please do *not* report compilation failures as genkernel bugs!



Last edited by electro on Wed Jun 08, 2011 4:40 am; edited 2 times in total
Back to top
View user's profile Send private message
Garrappachc
Guru
Guru


Joined: 26 Dec 2008
Posts: 352
Location: Kraków

PostPosted: Mon Jun 06, 2011 7:10 am    Post subject: Reply with quote

Proponuję zapomnieć o genkernelu i skompilować porządnie jądro. Mi też się za pierwszym razem nie udało, ale ja nie leciałem od razu z tym na forum.
_________________
De profundis clamavi ad Te, Domine

emerge --info | virtual aviation
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 624
Location: /dev/null

PostPosted: Mon Jun 06, 2011 8:17 am    Post subject: Reply with quote

Jeden temat Ci nie wystarczy?

http://forums.gentoo.org/viewtopic-p-6710375-highlight-.html

Mniej więcej o tym samym w nim mowa więc nie wiem po co zakładałeś drugi topic.
Back to top
View user's profile Send private message
electro
n00b
n00b


Joined: 28 Feb 2008
Posts: 46
Location: Poland-Zamość

PostPosted: Mon Jun 06, 2011 8:18 am    Post subject: Reply with quote

Garrappachc wrote:
Proponuję zapomnieć o genkernelu i skompilować porządnie jądro. Mi też się za pierwszym razem nie udało, ale ja nie leciałem od razu z tym na forum.
Ja instaluję juz kolejny raz gentoo. A przez ostatnie 3 dni to kernel skompilowałem moze juz z 6 razy + 2 x przez genkernel .

3 dni juz sie mecze z gentoo , podoba mi sie ten system, tylko zawsze cos ze nie moge po instalacji zobaczyc wreszczcie konsoli i podania loginu i hasla
Back to top
View user's profile Send private message
Garrappachc
Guru
Guru


Joined: 26 Dec 2008
Posts: 352
Location: Kraków

PostPosted: Mon Jun 06, 2011 9:28 am    Post subject: Reply with quote

Cieszę się, że Ci się podoba, ale bez podstawowej wiedzy o kompilacji kernela/obsłudze linuksa/obsłudze konsoli ani rusz. Poza tym, 6x skompilowany kernel to dość niewiele, a zwłaszcza - żeby wrzucać to na forum. Jeżeli na innych dystrybucjach kernel działa, to problem leży tylko i wyłącznie w jego kompilacji, a użytkownikom tego forum nie będzie się chciało przeglądać Twojego configa tylko po to, żeby stwierdzić, że nie masz skompilowanej obsługi myszki USB i tylko dlatego, że Tobie się nie chciało przejrzeć świetnej i dostępnej w internecie dokumentacji. Powiedziałeś, że zmieniłeś dwie opcje w kernelu - i myślisz, że to wystarczy? Ja mam bardzo typowy sprzęt i bez configa muszę pozmieniać z 20 opcji, żeby kernel w ogóle wstał. Jak pierwszy raz stawiałem Gentoo, 15 razy musiałem skompilować kernel, żeby wstał, a i to była konfiguracja bez obsługi karty sieciowej, dźwiękowej, graficznej i paru innych podzespołów. Do tego co i jak w kernelu się dochodzi z czasem.

Proponuję, nim zaczniesz stawiać na poważnie Gentoo, posiedzieć przynajmniej z pół roku na innych dystrybucjach (do grzebania/dłubania polecam Archa), przyjrzeć się, jak to wszystko działa, co się składa na system na desktop, jak obsługiwać system za pomocą konsoli, zapoznać się z /etc, pobawić się modułami... Takie distra są o tyle dobre, że na nich możesz zbudować swój własny kernel, a w razie pomyłki odpalić z powrotem ten dystrybucyjny i nie musisz chrootować systemu.

P.S. Żeby nie było nieporozumień - ja Cię nie odpędzam od Gentoo. Ale żeby poznać pełnię jego możliwości i czerpać z niego maksimum korzyści, trzeba co-nieco o Linuksie wiedzieć. No, może nawet więcej niż co-nieco :)

P.P.S. I proponuję nie zakładać kolejnego wątku na anglojęzycznej części tego forum http://forums.gentoo.org/viewtopic-t-881333.html, bo po pierwsze - jest on źle nazwany, po drugie - kaleczysz język angielski, a po trzecie - nikt Ci tam nie pomoże bardziej niż my tutaj.
_________________
De profundis clamavi ad Te, Domine

emerge --info | virtual aviation
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 624
Location: /dev/null

PostPosted: Mon Jun 06, 2011 10:08 am    Post subject: Reply with quote

@electro proponuję nie zakładać 150 wątków o tym samym bo Twoja przygoda z Gentoo się szybko zakończy, ale ja Cię nie będę pouczał, wpadnie mod to sam to zrobi.

Co do Twojego problemu... kolego w poprzednim identycznym temacie miałeś już podaną odpowiedź jak i linki do tematów mogących Cię czegoś nauczyć, ale jakoś konsekwentnie się wszystkiemu opierasz i nie robisz tego o co prosimy.

Install CD + lsmod zobacz jakie moduły Ci załadowało przyda Ci się przy kompilacji jądra.


A potem proste, lspci + config kernela innej rady nie ma, jak nie rozumiesz niektórych opcji to szukaj w Internecie dużo jest ładnie opisanych, ale przy większości będziesz musiał ruszyć głową i swoim angielskim inaczej się nie da i już...

Jak tego nie potrafisz to odpuść sobie na razie Gentoo bo to jest dopiero początek i powiem Ci z perspektywy czasu, że w tej chwili to jest najprostrza z możliwych czynności schody zaczynają się potem. Podszkol się na innych dystrybucjach tak jak @Garrappachc Ci doradził, a jak nie chcesz, to trochę samozaparcia i konsekwencji Ci się przyda... Wnioskuję, że nawet dogłębnie nie przejrzałeś dostępnych opcji w kernelu, skoro zaznaczyłeś tylko dwie... to w ogóle dziwne, że kernel panic nie ma od razu...
Back to top
View user's profile Send private message
electro
n00b
n00b


Joined: 28 Feb 2008
Posts: 46
Location: Poland-Zamość

PostPosted: Mon Jun 06, 2011 10:55 am    Post subject: Reply with quote

dzięki za rady, ale jak widac instalacja gentoo mimo bardzo wielu prób moze konczyć się problemami - np. przy kompilacji kernela , z jego kompilacja mialem nie duzo doczynienia bo max 20 razy, ale czowiek jak widac sie uczy na bledach i szuka pomocy gdzie sie da aby rozwiazac problem

opcje w kernelu przegladalem w miare dokladnie, ale jak mówiłemnie nie mam jeszcze duzego doswiadczenia w kompilacji kernela


z linuxem juz mialem doczynienia sporo, setki godzin przy nim spedzilem , i np. w konsoli sobie radze

gentoo jest dystrybucją zaawansowaną = ewentualnych wiecej problemow dla uzytkownika , dlatego ja wybralem , chcialem przejsc o krok dalej niz np. ubuntu, debian itp.


odnosnie kompilacji kernela, problem z obsluga usb - klawiatura i mysz zalatwilem chyba

dodałem obsluge tych urządzeń jako wkomplikowane w kernel nie jako modul , bo mialem zaznaczone wczesniej [M] , a by to zrobic musialem zaznaczyc dwie opcje oczywiście ich wbudowanie [*] i wczesniej aby aktywowac tą opcje zwiazana z ladowaniem modulów


teraz zaś mam kolejny problem bootuje sie system dalej, ale stoi na :
Code:

VFS: cannot open root device "sdb4" or unknown - block (0,0)

please append a correct "root=" boot option

kernel panic - not syncing:

VFS: unable to mount root fs on  unknown - block (0,0)



poszukam w googlu - pisze to co wyzej

pewnie cos jeszcze musze skompilowac w kernel , obsluge ext3 mam







fstab



Code:
/dev/sdb4               /               ext3            noatime         0 1


//uzywam ext3 a system mam na sdb4 bo mam dwa dyski twarde , sd4 montowalem do instalacji , formatowlem aby na nim zainstalowac gentoo
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 624
Location: /dev/null

PostPosted: Mon Jun 06, 2011 11:07 am    Post subject: Reply with quote

Obsługę dysku SATA masz?

Pokaż konfigurację Gruba.
Back to top
View user's profile Send private message
soban_
l33t
l33t


Joined: 27 Aug 2008
Posts: 677
Location: /home/soban

PostPosted: Mon Jun 06, 2011 11:07 am    Post subject: Reply with quote

@electro , malo podajesz informacji, mozesz uzyc mojego skryptu http://forums.gentoo.org/viewtopic-t-813356-start-0.html - albo samemu zapodac, jaki wpis masz w grubie, konfiguracje kernela aktualna itp - za kazdym razem jak zmiany jakies dokonujesz, to podawaj je tutaj. No i stosuj sie do tego, co inni Ci radza - @Pryka uwierz mi ze mowi to dla Twojego dobra. Z Gentoo nie rezygnuj, ale tutaj malo kiedy dostaniesz gotowca - wiec przygotuj sie na solidne googlowanie... - sam po paru latach uzywania Gentoo wiem, ze wiekszosc problemow juz jest rozwiazanych. Wystarczy odpowiednia znajomosc angielskiego, cierpliwosci i checi.
_________________
gg: 525600
Back to top
View user's profile Send private message
n0rbi666
l33t
l33t


Joined: 04 Mar 2005
Posts: 703
Location: Poland -> Krakow

PostPosted: Mon Jun 06, 2011 3:27 pm    Post subject: Reply with quote

1) włącz obsługę devtmpfs - (Device Drivers / Generic Driver Options /). Wygląda na to, że w pierwszym poście miałeś prawie wszystko ok, wg mnie tylko tego brakowało (miałem kilka dni temu ten sam problem, zatrzymywał się dokładnie w tym samym momencie.)
_________________
Trying to forget (Wasting my time)
We're falling right through
Lying to forget (Telling more lies)
We're raising our truth
Back to top
View user's profile Send private message
electro
n00b
n00b


Joined: 28 Feb 2008
Posts: 46
Location: Poland-Zamość

PostPosted: Mon Jun 06, 2011 6:30 pm    Post subject: Reply with quote

/mnt/gentoo/boot/grub/grub.conf


Code:


default 0
timeout 7



splashimage=(hd1,3)/boot/grub/splash.xpm.gz

title Gentoo


root (hd1,3)

kernel /boot/linux-2.6.38-gentoo-r6  root=/dev/sdb4 raid=noautodetect



Quote:
Obsługę dysku SATA masz?
A jak to dokladnie opcja, jak brzmi , pamiętasz ?


Quote:
włącz obsługę devtmpfs - (Device Drivers / Generic Driver Options /)

ok, dodam bo bede kompilowal raz jeszcze jądro ,


tylko muszę wiedzie w czym dokladnie problem, abym go rozwiazal , czyli co zaznaczyc
Back to top
View user's profile Send private message
soban_
l33t
l33t


Joined: 27 Aug 2008
Posts: 677
Location: /home/soban

PostPosted: Mon Jun 06, 2011 10:09 pm    Post subject: Reply with quote

http://forums.techarena.in/operating-systems/1409862.htm btw tez ten problem mialem ostatnio ale @Tytanick pomogl wygooglowac + rw musi byc w lilo, np:
Code:
localhost ~ # cat /boot/lilo.conf
lba32
boot = /dev/hda

#menu-scheme=Wb
prompt
timeout = 40
vga = normal
default=Gentoo

image = /boot/kernel-2.6.39
        root = /dev/hda1
        label = Gentoo
#       read-only # system musi byc montowany na prawach rw a nie samego odczytu
Zas w kernelu na szybko:
Code:
.config - Linux/i386 2.6.39 Kernel Configuration                                                         
 ─────────────────────────────────────────────────────────────────────────────────────────────────────────
  ┌────────────────────────────────────── Generic Driver Options ──────────────────────────────────────┐   
  │  Arrow keys navigate the menu.  <Enter> selects submenus --->.  Highlighted letters are hotkeys.   │   
  │  Pressing <Y> includes, <N> excludes, <M> modularizes features.  Press <Esc><Esc> to exit, <?> for │   
  │  Help, </> for Search.  Legend: [*] built-in  [ ] excluded  <M> module  < > module capable         │   
  │                                                                                                    │   
  │ ┌────────────────────────────────────────────────────────────────────────────────────────────────┐ │   
  │ │             (/sbin/hotplug) path to uevent helper                                              │ │   
  │ │             [*] Maintain a devtmpfs filesystem to mount at /dev                           <-tu │ │   
  │ │             [*]   Automount devtmpfs at /dev, after the kernel mounted the rootfs         <-tu │ │   
  │ │             [*] Select only drivers that don't need compile-time external firmware             │ │   
  │ │             [*] Prevent firmware from being built                                              │ │   
  │ │             -*- Userspace firmware loading support                                             │ │   
  │ │             [*]   Include in-kernel firmware blobs in kernel binary                            │ │   
  │ │             ()    External firmware blobs to build into the kernel binary                      │ │   
  │ │             [ ] Driver Core verbose debug messages                                             │ │   
  │ │             [*] Managed device resources verbose debug messages                                │ │   
  │ └────────────────────────────────────────────────────────────────────────────────────────────────┘ │   
  ├────────────────────────────────────────────────────────────────────────────────────────────────────┤   
  │                       < Zaznacz >   < Wyjdz >   < Pomoc >                              <- joke ( : │   
  └────────────────────────────────────────────────────────────────────────────────────────────────────┘
 ─────────────────────────────────────────────────────────────────────────────────────────────────────────

_________________
gg: 525600
Back to top
View user's profile Send private message
electro
n00b
n00b


Joined: 28 Feb 2008
Posts: 46
Location: Poland-Zamość

PostPosted: Tue Jun 07, 2011 4:37 am    Post subject: Reply with quote

problem juz rozwiazalem z kompilacją kernela , po 3 dniach wreszcie, nie było latwo prawidłowo to zrobic ze wszytkimi niezbednymi opcjami, aha musze tylko recznie ladowac moduł do internetu

skompilowalem ponownie kernel z dodatkowymi opcjami m.in. :

opcje jako wbudowane w kernel [*] nie jako modul [M]

- obsluga klawiatury/myszy usb i innych , bo mi nie chciala dzialac klawiatura usb
- wymusilem wczytywanie modulów
- obsluga sata ata and paralle ata drivers
- włącz obsługę devtmpfs - (Device Drivers / Generic Driver Options /)
- opcje te też dodałem :

[*] Maintain a devtmpfs filesystem to mount at /dev <-tu │ │
│ │ [*] Automount devtmpfs at /dev, after the kernel mounted the rootfs <-tu



aha musze recznie ladowac moduł do internetu (albo jakoś go na stale wstawić w kernel)
Code:

modprobe r8169


a potem ustawic - dhcp:

Code:
dhcpcd eth0


Da się dodać te dwa polecenia jako skryp przy starcie, aby nie musiał ich pisac za każdym razem ??


teraz instaluje kde 4
emerge kde //powinno chyba wystarczyć + menager logowania kde
Back to top
View user's profile Send private message
Garrappachc
Guru
Guru


Joined: 26 Dec 2008
Posts: 352
Location: Kraków

PostPosted: Tue Jun 07, 2011 4:50 am    Post subject: Reply with quote

Moduł najlepiej wkompilować na stałe, a jeśli nie, to wrzucasz do odpowiedniego pliczku, a którego i gdzie on jest, znajdziesz w how-to gentoo, który dostępny jest w internecie. Eth0 możesz sobie dorzucić do skryptów startowych.
Emerge kde w ogóle zadziała? Poczytaj lepiej dokumentację nt. instalacji kde w gentoo. Jeszcze trzeba X'y postawić m. in.
_________________
De profundis clamavi ad Te, Domine

emerge --info | virtual aviation
Back to top
View user's profile Send private message
electro
n00b
n00b


Joined: 28 Feb 2008
Posts: 46
Location: Poland-Zamość

PostPosted: Tue Jun 07, 2011 7:14 pm    Post subject: Reply with quote

Garrappachc wrote:
Moduł najlepiej wkompilować na stałe, a jeśli nie, to wrzucasz do odpowiedniego pliczku, a którego i gdzie on jest, znajdziesz w how-to gentoo, który dostępny jest w internecie. Eth0 możesz sobie dorzucić do skryptów startowych.
Emerge kde w ogóle zadziała? Poczytaj lepiej dokumentację nt. instalacji kde w gentoo. Jeszcze trzeba X'y postawić m. in.


kde juz zainstalowałem innym poleceniem

xorg zainstalowalem , nvidia-drivers

zaś teraz mam problem z x'y xorg.conf - musze stworzyć dobry , mam nvidie

startx - mi nie chce dzialac tak jak trzeba, bo nie uruchamia mi kde, mam blad z xorg x'y
Back to top
View user's profile Send private message
soban_
l33t
l33t


Joined: 27 Aug 2008
Posts: 677
Location: /home/soban

PostPosted: Tue Jun 07, 2011 7:37 pm    Post subject: Reply with quote

Ja bym zmienil temat na Twoim miejscu - na rodzaj bledu na jaki sie nadziales i stworzyl nowy - z ktorym aktualnie masz problema. Wtedy potomni moga ladnie to przegladac.
_________________
gg: 525600
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum