Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PulseAudio - No sound when second user is logged in
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
MarkMan
n00b
n00b


Joined: 01 Feb 2011
Posts: 14

PostPosted: Fri Apr 22, 2011 12:14 am    Post subject: PulseAudio - No sound when second user is logged in Reply with quote

Hello Fellas...

I'm trying to resolve an inconvenient that I have absolutely no idea why is happening.
I'm using PulseAudio as my sound system server on a Gnome DE. I have no problems playing audio with the fiirst user that logs into Gnome, but the second user is not able to access the sound server.

Here is my "emerge --info" output:


Portage 2.1.9.42 (default/linux/amd64/10.0, gcc-4.4.5, glibc-2.11.3-r0, 2.6.36-g entoo-r8 x86_64)
=================================================================
System uname: Linux-2.6.36-gentoo-r8-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9500_@_2 .60GHz-with-gentoo-1.12.14
Timestamp of tree: Wed, 06 Apr 2011 21:45:01 +0000
app-shells/bash: 4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python: 2.6.6-r1, 2.7.1-r1, 3.1.3-r1
dev-util/cmake: 2.8.4
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox: 2.4
sys-devel/autoconf: 2.13, 2.65-r1
sys-devel/automake: 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils: 2.20.1-r1
sys-devel/gcc: 4.4.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.2.10
sys-devel/make: 3.81-r2
virtual/os-headers: 2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/ fonts/fonts.conf /etc/gconf /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php 5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox .d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks fixlafiles fixpackages new s parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unme rge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.c3sl.ufpr.br/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en es"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclu de=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync1.br.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 automount berkdb bluetooth branding bzip2 caps cdda c dparanoia cdr cdrom cli consolekit cracklib crypt cups custom-cflags cxx dbus dr i dvd dvdr ffmpeg flac fortran fuse gdbm gnome gpm gstreamer gtk gvfs iconv java javascript jpeg lock mmx modules mp3 mpeg mudflap multilib nautilus ncurses nls nptl nptlonly ogg opengl openmp pam pcre perl png policykit ppds pppd pulseaudi o python readline samba session spell sse sse2 ssl ssse3 startup-notification sy sfs tcpd threads udev unicode xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atii xp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-in tel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hoo ks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_grou pfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_ lock deflate dir disk_cache env expires ext_filter file_cache filter headers inc lude info log_config logio mem_cache mime mime_magic negotiation rewrite setenvi f speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECT D_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_ PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse syn aptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lc dm001 mtxorb ncurses text" LINGUAS="en es" PHP_TARGETS="php5-3" RUBY_TARGETS="ru by18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lsca n length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq s teal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORT AGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXT RA_OPTS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
wswartzendruber
Veteran
Veteran


Joined: 23 Mar 2004
Posts: 1224
Location: Jefferson, USA

PostPosted: Wed Apr 27, 2011 4:39 am    Post subject: Reply with quote

Well each time someone logs in, the PulseAudio server is started for that user. I'm guessing the two instances are fighting for control over the ALSA device. You might want to try using the PulseAudio system daemon, although this is not recommended.
Back to top
View user's profile Send private message
MarkMan
n00b
n00b


Joined: 01 Feb 2011
Posts: 14

PostPosted: Wed Apr 27, 2011 7:12 pm    Post subject: Reply with quote

Thank you wswartzendruber for your reply!

I thought that is what was going on. I'm trying to find a way to let PulseAudio know to override alsa's server when the new user logs in, so that the second user can access alsa's server.

Does anyone know how to do so?

Best regards
Back to top
View user's profile Send private message
LukynZ
Apprentice
Apprentice


Joined: 19 Dec 2008
Posts: 225
Location: The Czech Republic

PostPosted: Fri Apr 29, 2011 7:36 pm    Post subject: Reply with quote

I have same problem. But my second user isn't able use sound card alone. So there isn't problem with another pulseaudio server. Do you have same problem MarkMan? Or second user logged alone can play sound?
Back to top
View user's profile Send private message
MarkMan
n00b
n00b


Joined: 01 Feb 2011
Posts: 14

PostPosted: Fri Apr 29, 2011 10:33 pm    Post subject: Reply with quote

That's correct LukynZ.
It seems to be that the second user is not able to access the sound server (either ALSA or PulseAudio).
Also, when I try to open up System--->Preferences--->Sound on Gnome I get the following error:

"Waiting for sound system to respond"

and nothing else happens.

Will appreciate any further help.

Best regards
Back to top
View user's profile Send private message
LukynZ
Apprentice
Apprentice


Joined: 19 Dec 2008
Posts: 225
Location: The Czech Republic

PostPosted: Thu May 26, 2011 7:25 am    Post subject: Reply with quote

check this http://forums.gentoo.org/viewtopic-p-6699825.html#6699489
Back to top
View user's profile Send private message
Naib
Advocate
Advocate


Joined: 21 May 2004
Posts: 4161
Location: Removed by Neddy

PostPosted: Tue May 31, 2011 9:31 am    Post subject: Reply with quote

could it be todo with rw permission on the /tmp file created?>
_________________
A free press is the unsleeping guardian of every other right that free men prize; it is the most dangerous foe of tyranny. Where men have the habit of liberty, the Press will continue to be the vigilant guardian of the rights of the ordinary citizen.
Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 777
Location: san leonardo del friuli

PostPosted: Tue May 31, 2011 9:54 am    Post subject: Reply with quote

Question: do you really need pulse?
Back to top
View user's profile Send private message
LukynZ
Apprentice
Apprentice


Joined: 19 Dec 2008
Posts: 225
Location: The Czech Republic

PostPosted: Thu Jun 02, 2011 8:07 am    Post subject: Reply with quote

devilheart wrote:
Question: do you really need pulse?


Gnome3 really need pulse
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum