Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[booting] error al arranque del sistemas
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
sadonfa
n00b
n00b


Joined: 24 Sep 2010
Posts: 14

PostPosted: Sun May 29, 2011 3:03 pm    Post subject: [booting] error al arranque del sistemas Reply with quote

Buenas, espero que les valla bien, nececito que me hagan el favor y me ayuden con un problema que tengo al iniciar mi nuevo sistema me sale el siguiente error:


Code:
 >>booting (initramfs) error: your real /dev is missing file required to boot (console and null)




De antemanos gracias. Soy nuevo y espero me puedan ayudar.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 899

PostPosted: Sun May 29, 2011 3:38 pm    Post subject: Reply with quote

¿Has seguido el manual correspondiente la arquitectura de tu máquina?
¿Has utilizado la configuración manual del kernel o genkernel?
Back to top
View user's profile Send private message
sadonfa
n00b
n00b


Joined: 24 Sep 2010
Posts: 14

PostPosted: Sun May 29, 2011 3:45 pm    Post subject: Reply with quote

El manual lo e llevado paso a paso, y e instalado con genekernel.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 899

PostPosted: Sun May 29, 2011 4:13 pm    Post subject: Reply with quote

¿que tienes en
    grub.conf
?
Back to top
View user's profile Send private message
lexming
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jan 2007
Posts: 121
Location: Barcelona

PostPosted: Sun May 29, 2011 4:29 pm    Post subject: Reply with quote

Quizá esté relacionado con las siguientes opciones en la configuración del kernel:
Quote:
CONFIG_DEVTMPFS=y
CONFIG_DEVTMPFS_MOUNT=y


Deberían estar activas. Hay un bug abierto al respecto con problemas similares: https://bugs.gentoo.org/show_bug.cgi?id=368597
Back to top
View user's profile Send private message
sadonfa
n00b
n00b


Joined: 24 Sep 2010
Posts: 14

PostPosted: Sun May 29, 2011 6:23 pm    Post subject: Reply with quote

mi grup es :

Code:

default 0
timeout 30
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title Gentoo Linux 2.6.37-r4
root (hd0,0)
kernel /boot/kernel-genekernel-x86-2.6.37-gentoo-r4 root=/dev/ram0 real_root=/dev/sda3
initrd /boot/initramfs-genkernel-x86-2.6.37-gentoo-r4

vim:ft=conf:


y si es este codigo:
Code:

CONFIG_DEVTMPFS=y
CONFIG_DEVTMPFS_MOUNT=y

como lo soluciono.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 899

PostPosted: Sun May 29, 2011 6:36 pm    Post subject: Reply with quote

Quote:
kernel /boot/kernel-genekernel-x86-2.6.37-gentoo-r4 root=/dev/ram0 real_root=/dev/sda3


Arranca la máquina, monta la partición sda3 y comprueba que tiene una carpeta
    /dev
con los archivos especiales
    /dev/console
y
    /dev/null
Back to top
View user's profile Send private message
sadonfa
n00b
n00b


Joined: 24 Sep 2010
Posts: 14

PostPosted: Sun May 29, 2011 6:46 pm    Post subject: Reply with quote

Pero revisando en la carpeta dev los dos archivos estan, que devo hacer?
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 899

PostPosted: Sun May 29, 2011 6:53 pm    Post subject: Reply with quote

¿Que salida produce el comando
Code:
mount
?
¿Puedes poner el contenido de tu archivo
    /etc/fstab
?
Back to top
View user's profile Send private message
sadonfa
n00b
n00b


Joined: 24 Sep 2010
Posts: 14

PostPosted: Sun May 29, 2011 7:26 pm    Post subject: Reply with quote

El comando mount imprime lo siguiente:

Code:


tmpfs on / type tmpfs (rw, relatime)
/dev/sr0 on /mnt/cdrom type squashfs (ro,relatime)
/dev/loop0 on /mnt/livecd type squashfs (ro,relatime)
proc on /proc type proc (rw, nosuid,nodev,noexec,relatime)
sysfs on /sys type  sysfs (rw,nosuid,nodev,noexec,relatime)
udev on /dev type tmpfs (rw,nosuid,relatime,size=10240k, mode=620)
devpts on /dev/pts type devpts (rw,nosuid, noexec,relatime,gid=5,mode=620)
tmpfs on /mnt/livecd/usr/firware type tmpfs (rw,relatime)
tmpfs on /mnt/livecd/usr/portege type tmpfs (rw,relatime)
usbfs on /proc/bus/usb type usbfs (rw,nosuid,noexec,realtime,devgid=85,devmode=664)
/dev/sda3 one / type ext3 (rw,relatime, errors=continue, barrier=0, data=writeback)
/dev/sda1 one /boot type ext2 (rw,relatime,error=continue)
none on /proc type proc (rw,realtime)
udev on /dev type tmpfs (rw,nosuid,relatime, size=10240k, mode=755 )
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)




y el archivo fstab

Code:


/dev/sda1        /boot              ext2    defaults,noatime           1 2
/dev/sda3        /                    ext3     noatime                       0 1
/dev/sda2        none              swap    sw                               0 0
/dev/cdrom      /mnt/cdrom    auto     noauto,user                 0 0
proc                /proc              proc     defaults                       0 0
shm                /dev/shm        tmpfs    nodev,nosuid,noexec   0 0



Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1060
Location: La Plata, Argentina

PostPosted: Sun May 29, 2011 7:58 pm    Post subject: Reply with quote

rootfs on / type rootfs (rw)

Code:
rc-config list sysinit
rc-config list boot

que te devuelven?
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 899

PostPosted: Sun May 29, 2011 9:23 pm    Post subject: Reply with quote

Entiendo que estas arrancando con el CD de gentoo y creo que el /dev que ves es el que genera el CD al ejecutarse.

Para ver lo que tienes de verdad en tu (futura) partición raiz sigue los pasos del manual hasta el final del capítulo 3. Ejecuta los comandos que te indica:
Code:
# mount /dev/sda3 /mnt/gentoo
# mkdir /mnt/gentoo/boot
# mount /dev/sda1 /mnt/gentoo/boot


y entonces mira el contenido de
    /mnt/gentoo/dev
a ver si tienes console y null
Back to top
View user's profile Send private message
cloudalmasai
n00b
n00b


Joined: 26 Apr 2011
Posts: 12

PostPosted: Fri Jun 17, 2011 3:34 am    Post subject: Reply with quote

El problema que describes me aquejo en mi reciente instalacion gentoo, se debe a que los stage3 de abril en adelante estan corruptos, para solucionar ese problema debes hacaer lo siguiente, o almenos eso hice yo para arreglarlo:

-entra en el livecd y monta como tu particon / en /mnt/gentoo, como dice el manual.
-cd /mnt/gentoo/dev
-ls mira el contenido de la carpeta
-si solo aparece un archivo null, rm null
-luego has MAKEDEV generic, esto tarda un poquito
-cd, desmonta tu particion y reinicia, ya deberia de solucionarse
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum