Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
system boot stops at init-early.sh and hangs there
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
ghutzl
Tux's lil' helper
Tux's lil' helper


Joined: 29 May 2005
Posts: 117
Location: Germany

PostPosted: Sun May 22, 2011 5:45 pm    Post subject: system boot stops at init-early.sh and hangs there Reply with quote

Hello!

I am having a problem booting my newly installed gentoo. It starts booting but then hangs at this line:

Code:
[    1.448408] init-early.sh used greatest stack depth: 3640 bytes left


I found this quite old bug:

http://bugs.gentoo.org/show_bug.cgi?id=187628

which suggests to mount root in rw mode and not in ro mode. When I do this my system boots. I changed the grub boot entry like this:

Code:
old:
        linux   /kernel-2.6.39-gentoo root=/dev/sdb2 ro 
new:
        linux   /kernel-2.6.39-gentoo root=/dev/sdb2 rw


I cannot really figure out what is wrong here. Can anybody help?

EDIT (more info)

dmesg output: http://pastebin.com/B16scHXK

emerge --info:
Code:

Portage 2.1.9.42 (default/linux/amd64/10.0, gcc-4.4.5, libc-0-r0, 2.6.39-gentoo x86_64)
=================================================================
System uname: Linux-2.6.39-gentoo-x86_64-AMD_E-350_Processor-with-gentoo-2.0.2
Timestamp of tree: Sun, 22 May 2011 19:00:01 +0000
app-shells/bash:     4.1_p9
dev-lang/python:     2.7.1-r1, 3.1.3-r1
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.2-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.65-r1
sys-devel/automake:  1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1-r1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
sys-kernel/linux-headers: 2.6.36.1
sys-libs/glibc:      2.12.2
virtual/os-headers:  0
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-mtune=generic -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-mtune=generic -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y --keep-going"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://gentoo.mirrors.tds.net/gentoo ftp://91.121.124.139/gentoo-distfiles/ ftp://91.121.125.139/gentoo-distfiles/ ftp://mirror.netcologne.de/gentoo/ rsync://mirror.netcologne.de/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl amd64 berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv ipv6 mmx modules mudflap multilib ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline session sse sse2 ssl sysfs tcpd unicode xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US de" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

_________________
Check out this RPG: http://www.daysofdawn.com/. You can preorder it on their page. Linux needs some good RPGs and this one looks very promising!
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4151

PostPosted: Sun May 22, 2011 11:14 pm    Post subject: Reply with quote

hi,
Can see your fstab & rc-update output ?
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1085

PostPosted: Sun May 22, 2011 11:32 pm    Post subject: Re: system boot stops at init-early.sh and hangs there Reply with quote

ghutzl wrote:

...
I cannot really figure out what is wrong here. Can anybody help?
...

Have you enabled devtmpfs in your kernel? After I enabled, my same problem is solved.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
ghutzl
Tux's lil' helper
Tux's lil' helper


Joined: 29 May 2005
Posts: 117
Location: Germany

PostPosted: Mon May 23, 2011 5:45 pm    Post subject: Reply with quote

Great! That was it. I enabled devtmpfs in my kernel and my system boots with no problems. What I don't understand now is why my other system boots without devtmpfs. Obviously there must be something different. Any idea?

Both systems have:

sys-apps/baselayout-2.0.2
and
sys-apps/openrc-0.8.2-r1

For completeness, here is the output of etc-update (which shows no updates are pending):

Code:
etc-update
Scanning Configuration files...
Exiting: Nothing left to do; exiting. :)


and my fstab:
Code:
# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed; notail increases performance of ReiserFS (at the expense of storage
# efficiency).  It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sdb1               /boot           ext2            noauto,noatime  1 2
/dev/sdb2               /               ext2            noatime         0 1
/dev/gentoo/usr         /usr            ext4            noatime         0 1
/dev/gentoo/portage     /usr/portage    ext4            noatime         0 1
/dev/gentoo/distfiles   /usr/portage/distfiles            ext4            noatime         0 1
/dev/gentoo/home        /home           ext4            noatime         0 1
/dev/gentoo/opt         /opt            ext4            noatime         0 1
/dev/gentoo/var         /var            ext4            noatime         0 1
/dev/gentoo/vartmp      /var/tmp        ext4            noatime         0 1
/dev/gentoo/tmp         /tmp            ext4            noatime         0 1
/dev/gentoo/swap        none            swap            sw              0 0
#/dev/cdrom             /mnt/cdrom      auto            noauto,ro       0 0
#/dev/fd0               /mnt/floppy     auto            noauto          0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#  use almost no memory if not populated with files)
shm                     /dev/shm        tmpfs           nodev,nosuid,noexec     0 0

_________________
Check out this RPG: http://www.daysofdawn.com/. You can preorder it on their page. Linux needs some good RPGs and this one looks very promising!
Back to top
View user's profile Send private message
mengzhao
n00b
n00b


Joined: 18 Mar 2004
Posts: 13

PostPosted: Tue May 24, 2011 8:05 am    Post subject: same problem here Reply with quote

I copied my gentoo system to a new disk and I got that error and hang.
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1085

PostPosted: Tue May 24, 2011 8:05 pm    Post subject: Reply with quote

ghutzl wrote:
Great! That was it. I enabled devtmpfs in my kernel and my system boots with no problems. What I don't understand now is why my other system boots without devtmpfs. Obviously there must be something different. Any idea?
...

Probably, your other system is using an older kernel than kernel-2.6.39. With new kernel-2.6.39, I think devtmpfs is required, since some kernel devs like the devtmpfs that speed up boot process. Actually, there must be a bug, because they say devtmpfs can be disabled.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1113
Location: 127.0.0.1

PostPosted: Tue May 24, 2011 8:28 pm    Post subject: Reply with quote

i compiled devtmpfs into kernel and im still getting the issue, guess i will have to drop back to 38-r6 till its fixed

edit: its not the kernel, as its doing it on .38-r6, guess a dev somewhere has messed up a package or 2
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
webbruno
n00b
n00b


Joined: 01 May 2010
Posts: 24

PostPosted: Tue May 24, 2011 10:42 pm    Post subject: Reply with quote

Hi all, I'm experiencing the very same problem, however when I mount the root filesystem (xfs) as rw everything goes fine. I wonder if there's a problem with that
Back to top
View user's profile Send private message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1113
Location: 127.0.0.1

PostPosted: Wed May 25, 2011 11:57 am    Post subject: Re: system boot stops at init-early.sh and hangs there Reply with quote

keenblade wrote:
ghutzl wrote:

...
I cannot really figure out what is wrong here. Can anybody help?
...

Have you enabled devtmpfs in your kernel? After I enabled, my same problem is solved.


You have to enable both options, just in case people are wondering, i enabled only one of them and it didn't work, you also have to set the automatically mount devtmpfs option also
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
webbruno
n00b
n00b


Joined: 01 May 2010
Posts: 24

PostPosted: Wed May 25, 2011 2:32 pm    Post subject: Reply with quote

Btw, my problem was solved by the bleeding edge vanilla-source 2.6.39 with devtmpfs, I was using the gentoo source 2.6.37-r4 before, can't understand why that happened though
Back to top
View user's profile Send private message
araxon
n00b
n00b


Joined: 25 May 2011
Posts: 15

PostPosted: Wed May 25, 2011 3:28 pm    Post subject: Reply with quote

I had the same problem today. I resolved it by using older stage3 and portage archives. And by "older" I mean like "2010". :? So I have no clue, when the error has been introduced to the current/latest archives...
Back to top
View user's profile Send private message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1113
Location: 127.0.0.1

PostPosted: Wed May 25, 2011 3:29 pm    Post subject: Reply with quote

build devtmpfs into kernel as suggested and all is fine
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
0x90h
n00b
n00b


Joined: 25 May 2011
Posts: 1

PostPosted: Wed May 25, 2011 3:45 pm    Post subject: Reply with quote

I had the same issue, solved by creating (with mknod) the /dev/console device that was missing in the amd64 stage3.
Back to top
View user's profile Send private message
pi3.14
n00b
n00b


Joined: 25 May 2011
Posts: 5

PostPosted: Wed May 25, 2011 8:21 pm    Post subject: Reply with quote

Dark Foo wrote:
build devtmpfs into kernel as suggested and all is fine

But if there is kernel without DEVTMPFS?
Back to top
View user's profile Send private message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1113
Location: 127.0.0.1

PostPosted: Wed May 25, 2011 8:24 pm    Post subject: Reply with quote

pi3.14 wrote:
Dark Foo wrote:
build devtmpfs into kernel as suggested and all is fine

But if there is kernel without DEVTMPFS?


its there in all the .38 ones i looked at and in the .39 - will find it in Device Drivers - Generic Driver Options, at the top

another thread i read said to use mknod and create /dev/console
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
araxon
n00b
n00b


Joined: 25 May 2011
Posts: 15

PostPosted: Wed May 25, 2011 8:29 pm    Post subject: Reply with quote

Dark Foo wrote:
pi3.14 wrote:
Dark Foo wrote:
build devtmpfs into kernel as suggested and all is fine

But if there is kernel without DEVTMPFS?


its there in all the .38 ones i looked at and in the .39 - will find it in Device Drivers - Generic Driver Options, at the top

another thread i read said to use mknod and create /dev/console

Well, I'm using 2.6.31 and 2.6.27 on several machines (for a reason), and the option just isn't there.
Back to top
View user's profile Send private message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1113
Location: 127.0.0.1

PostPosted: Wed May 25, 2011 8:30 pm    Post subject: Reply with quote

Well you can either upgrade to a later kernel or try the mknod option, other than that i dont know
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
pi3.14
n00b
n00b


Joined: 25 May 2011
Posts: 5

PostPosted: Wed May 25, 2011 8:39 pm    Post subject: Reply with quote

Using OpenVZ kernel and there isn't newer one than 2.6.32 (without DEVTMPFS).
It seems, that adding "rw" to grub fixed it, but couldn't this make damage to system?
Back to top
View user's profile Send private message
pi3.14
n00b
n00b


Joined: 25 May 2011
Posts: 5

PostPosted: Thu May 26, 2011 5:43 am    Post subject: Reply with quote

One more thing, with baselayout 2 and openrc df and mount shows root mount point as
rootfs on / type rootfs (rw)
/dev/root on / type ext2 (rw....)
Is it possible to set old behaviour? (/dev/sdaX on /)? //not solved :?:
And I am using ext4, on other mounted drives it show corrected ext4, but for root mount it shows ext2 //solved, my mistake
Back to top
View user's profile Send private message
silentsnake11
n00b
n00b


Joined: 23 May 2011
Posts: 9

PostPosted: Thu May 26, 2011 2:49 pm    Post subject: Reply with quote

I've got the same problem while booting via initramfs – booting directly with real root works fine. Both devtmpfs Kernel options are enabled.

My current init script looks like this:

Code:

#!/bin/busybox sh

mount -t proc none /proc
mount -t sysfs none /sys
mount -t devtmpfs none /dev

echo "Testing..."

mount -t ext4 -o ro /dev/sda3 /mnt/root

umount /proc
umount /sys
umount /dev

exec switch_root /mnt/root /sbin/init


Files within the initramfs:

Quote:
./init
./bin
./bin/busybox
./mnt
./mnt/root
./sys
./sbin
./root
./lib
./etc
./proc
./dev
./dev/sda3
./dev/tty
./dev/console
./dev/null




Mounting works fine and there are no kernel errors or anything. It is just stucking at init-early.sh.

I found the following in the migration guide:
Quote:
Previously, the initial rootfs entry was removed from /etc/mtab, and only the real root / entry was present. The duplicate rootfs item was actually added back during shutdown. In OpenRC, both entries must be present for full support of initramfs and tmpfs-on-root. This also means that less writing is required during shutdown.


But - unfortunately - I have no clue what to do now. At the moment it should just mount an unencrypted device and go on with the regular init. Later on I will use it for decrypting and mapping the device.
Back to top
View user's profile Send private message
webbruno
n00b
n00b


Joined: 01 May 2010
Posts: 24

PostPosted: Fri May 27, 2011 12:13 pm    Post subject: Reply with quote

What happens if:

Code:
mount -t ext4 -o ro /dev/sda3 /mnt/root


is changed to:

Code:
mount -t ext4 -o ro /dev/sda3 /


if that doesn't work try to mount as rw
Back to top
View user's profile Send private message
silentsnake11
n00b
n00b


Joined: 23 May 2011
Posts: 9

PostPosted: Sat May 28, 2011 1:13 pm    Post subject: Reply with quote

Thanks for your reply.

If i try to mount /dev/sda3 / i get the following error while booting:

http://img34.imageshack.us/img34/6905/bildschirmfoto20110528uq.png

Same with mounting it as R/W.
Back to top
View user's profile Send private message
alecjw
n00b
n00b


Joined: 27 Mar 2010
Posts: 41
Location: Hertfordshire, UK

PostPosted: Sat May 28, 2011 4:25 pm    Post subject: Reply with quote

I'm having the same problem here - I've tried rebuilding my kernel with devfs and putting rw in the kernel command line, but i still get init-early.sh used greatest stack depth.... I'm not using an initramfs
_________________
ACTA is a war on your digital freedom
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1085

PostPosted: Sat May 28, 2011 4:38 pm    Post subject: Reply with quote

alecjw wrote:
I'm having the same problem here - I've tried rebuilding my kernel with devfs and putting rw in the kernel command line, but i still get init-early.sh used greatest stack depth.... I'm not using an initramfs

Are you sure you enabled both option in kernel? To check that:
Code:

zgrep DEVTMP /proc/config.gz
or
grep DEVTMP /usr/src/linux/.config

these should output:
CONFIG_DEVTMPFS=y
CONFIG_DEVTMPFS_MOUNT=y

_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
alecjw
n00b
n00b


Joined: 27 Mar 2010
Posts: 41
Location: Hertfordshire, UK

PostPosted: Sat May 28, 2011 5:33 pm    Post subject: Reply with quote

I had DEVTMPFS enabled, but not DEVTMPFS_MOUNT. recompiling now.
_________________
ACTA is a war on your digital freedom
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum