Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Open Firmware and yaboot: Loading ELF... CLAIM failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
corphi
n00b
n00b


Joined: 19 May 2008
Posts: 20

PostPosted: Mon May 16, 2011 2:57 pm    Post subject: Open Firmware and yaboot: Loading ELF... CLAIM failed Reply with quote

The whole story: I wanted to do a kernel update from hardened-sources-2.6.28-r7 to hardened-sources-2.6.32-r42. Using ybin -v, I managed to render my installation unbootable, only the Open Firmware boot prompt showed up (Reason: decrementer exception). I suspect that I should have run mkofboot -v before; I vaguely remember a yaboot update a while ago that - at least I believe so - caused this.

But the Gentoo installation CD (probably 2007.0) booted fine (pressing C during boot) and its yaboot version fixed this issue. The new kernel booted, but hang shortly after. I rebooted the old kernel and a few Internet searches later, I was sure to have tracked and fixed the error in kernel configuration: Another ybin -v (yes, from hard disk). You guessed right, the boot loader is on strike, again. But this time, I cannot boot my installation CD any more. Booting now drops me into Open Firmware boot prompt, regardless of which keys I press. The reason given is
Code:
Invalid memory access at   %SRR0: 00213318   %SRR1: 00003030


Fiddling with the prompt, I managed to find the command that should start yaboot - at least, I can hear the disk and there are no complaints about not finding the file:
Code:
boot cd:,\\yaboot
By replacing the c with an h, the command instead tries to load it from hard disk. Both variants print a load-size (HD: 2e658, CD: 23834), an adler32 checksum (HD: 7b5d7d3b, CD: 32ab01b2) and this:
Code:
Loading ELF

CLAIM failed


It’s a 1,5GHz G4 Mac mini (ppc32) (Apple PowerMac 10,2 4.9.4f1 BootROM built on 07/12/05 at 14:14:17). In the process, I cleared the NVRAM and wiped the Open Firmware settings a few times without much luck.

Do you have any ideas what to try next?
Back to top
View user's profile Send private message
JoseJX
Developer
Developer


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Mon May 16, 2011 3:16 pm    Post subject: Reply with quote

Make sure that you're booting the CD using the ppc32 kernel (type ppc32 at the prompt). The CD, by default, tries to boot a 64 bit kernel.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
corphi
n00b
n00b


Joined: 19 May 2008
Posts: 20

PostPosted: Mon May 16, 2011 6:23 pm    Post subject: Reply with quote

The installation CD is an old one, it only sports a ppc32 kernel named apple. But the kernel is not my problem. I cannot start yaboot to select one.
Back to top
View user's profile Send private message
JoseJX
Developer
Developer


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Mon May 23, 2011 2:26 am    Post subject: Reply with quote

Sorry, I missed your question the first time. I've never heard of this problem. Can you try another CD? Does OSX boot (even the installer CD)?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum