Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Troubles with python[Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Grook
n00b
n00b


Joined: 23 Jun 2010
Posts: 26

PostPosted: Fri Apr 01, 2011 3:25 pm    Post subject: Troubles with python[Solved] Reply with quote

Hello. Recently i'v updated system. There were a lot of packages and one of them is python. After
Code:
emerge -uND @world; emerge --depclean; revdep-rebuild
i entered
Code:
python-updater
comand. After it my laptop unexpectly shutted down.

Now i cant use anything:

There is no output of any command of emerge
Code:
laptop grook # emerge --sync
laptop grook #


Here is output of python-updater:
Code:
laptop grook # python-updater
 * Python 2 and Python 3 not installed

But if i`ll start it manually:
Code:
laptop grook # python3       
Python 3.1.3 (r313:86834, Mar 12 2011, 02:08:08)
[GCC 4.4.5] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> 



here is output of the revdep-rebuild:
Code:
laptop grook # revdep-rebuild
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 25% ]  *   broken /usr/bin/vim (requires libpython2.6.so.1.0)
[ 46% ]  *   broken /usr/lib64/alsa-lib/smixer/smixer-python.la (requires -lpython2.6)
 *   broken /usr/lib64/alsa-lib/smixer/smixer-python.so (requires libpython2.6.so.1.0)
[ 59% ]  *   broken /usr/lib64/kde4/kpythonpluginfactory.so (requires libpython2.6.so.1.0)
[ 83% ]  *   broken /usr/lib64/python2.6/site-packages/cairo/_cairo.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/_cracklibmodule.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/Cython/Compiler/Parsing.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/Cython/Compiler/Scanning.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/Cython/Compiler/Visitor.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/Cython/Plex/Scanners.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/Cython/Runtime/refnanny.so (requires libpython2.6.so.1.0)
[ 84% ]  *   broken /usr/lib64/python2.6/site-packages/hgext/inotify/linux/_inotify.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/_lcms.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/libxsltmod.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/mercurial/base85.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/mercurial/bdiff.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/mercurial/diffhelpers.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/mercurial/mpatch.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/mercurial/osutil.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/mercurial/parsers.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/numpy/core/multiarray.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/numpy/core/multiarray_tests.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/numpy/core/scalarmath.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/numpy/core/_sort.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/numpy/core/umath.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/numpy/core/umath_tests.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/numpy/fft/fftpack_lite.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/numpy/lib/_compiled_base.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/numpy/linalg/lapack_lite.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/numpy/numarray/_capi.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/numpy/random/mtrand.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/PyKDE4/dnssd.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/PyKDE4/kdecore.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/PyKDE4/kdeui.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/PyKDE4/khtml.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/PyKDE4/kio.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/PyKDE4/knewstuff.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/PyKDE4/kparts.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/PyKDE4/ktexteditor.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/PyKDE4/kutils.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/PyKDE4/phonon.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/PyKDE4/plasma.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/PyKDE4/solid.so (requires libpython2.6.so.1.0)
[ 85% ]  *   broken /usr/lib64/python2.6/site-packages/_xmlplus/parsers/pyexpat.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/_xmlplus/parsers/sgmlop.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/_xmlplus/utils/boolean.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib64/python2.6/site-packages/yasm.so (requires libpython2.6.so.1.0)
[ 100% ]                 
 * Generated new 3_broken.rr
 * Assigning files to packages
 *   /usr/bin/vim -> app-editors/vim
 *   /usr/lib64/alsa-lib/smixer/smixer-python.la -> media-libs/alsa-lib
 *   /usr/lib64/alsa-lib/smixer/smixer-python.so -> media-libs/alsa-lib
 *   /usr/lib64/kde4/kpythonpluginfactory.so -> kde-base/pykde4
 *   /usr/lib64/python2.6/site-packages/cairo/_cairo.so -> dev-python/pycairo
 *   /usr/lib64/python2.6/site-packages/_cracklibmodule.so -> sys-libs/cracklib
 *   /usr/lib64/python2.6/site-packages/Cython/Compiler/Parsing.so -> dev-python/cython
 *   /usr/lib64/python2.6/site-packages/Cython/Compiler/Scanning.so -> dev-python/cython
 *   /usr/lib64/python2.6/site-packages/Cython/Compiler/Visitor.so -> dev-python/cython
 *   /usr/lib64/python2.6/site-packages/Cython/Plex/Scanners.so -> dev-python/cython
 *   /usr/lib64/python2.6/site-packages/Cython/Runtime/refnanny.so -> dev-python/cython
 *   /usr/lib64/python2.6/site-packages/hgext/inotify/linux/_inotify.so -> dev-vcs/mercurial
 *   /usr/lib64/python2.6/site-packages/_lcms.so -> media-libs/lcms
 *   /usr/lib64/python2.6/site-packages/libxsltmod.so -> dev-libs/libxslt
 *   /usr/lib64/python2.6/site-packages/mercurial/base85.so -> dev-vcs/mercurial
 *   /usr/lib64/python2.6/site-packages/mercurial/bdiff.so -> dev-vcs/mercurial
 *   /usr/lib64/python2.6/site-packages/mercurial/diffhelpers.so -> dev-vcs/mercurial
 *   /usr/lib64/python2.6/site-packages/mercurial/mpatch.so -> dev-vcs/mercurial
 *   /usr/lib64/python2.6/site-packages/mercurial/osutil.so -> dev-vcs/mercurial
 *   /usr/lib64/python2.6/site-packages/mercurial/parsers.so -> dev-vcs/mercurial
 *   /usr/lib64/python2.6/site-packages/numpy/core/multiarray.so -> dev-python/numpy
 *   /usr/lib64/python2.6/site-packages/numpy/core/multiarray_tests.so -> dev-python/numpy
 *   /usr/lib64/python2.6/site-packages/numpy/core/scalarmath.so -> dev-python/numpy
 *   /usr/lib64/python2.6/site-packages/numpy/core/_sort.so -> dev-python/numpy
 *   /usr/lib64/python2.6/site-packages/numpy/core/umath.so -> dev-python/numpy
 *   /usr/lib64/python2.6/site-packages/numpy/core/umath_tests.so -> dev-python/numpy
 *   /usr/lib64/python2.6/site-packages/numpy/fft/fftpack_lite.so -> dev-python/numpy
 *   /usr/lib64/python2.6/site-packages/numpy/lib/_compiled_base.so -> dev-python/numpy
 *   /usr/lib64/python2.6/site-packages/numpy/linalg/lapack_lite.so -> dev-python/numpy
 *   /usr/lib64/python2.6/site-packages/numpy/numarray/_capi.so -> dev-python/numpy
 *   /usr/lib64/python2.6/site-packages/numpy/random/mtrand.so -> dev-python/numpy
 *   /usr/lib64/python2.6/site-packages/PyKDE4/dnssd.so -> kde-base/pykde4
 *   /usr/lib64/python2.6/site-packages/PyKDE4/kdecore.so -> kde-base/pykde4
 *   /usr/lib64/python2.6/site-packages/PyKDE4/kdeui.so -> kde-base/pykde4
 *   /usr/lib64/python2.6/site-packages/PyKDE4/khtml.so -> kde-base/pykde4
 *   /usr/lib64/python2.6/site-packages/PyKDE4/kio.so -> kde-base/pykde4
 *   /usr/lib64/python2.6/site-packages/PyKDE4/knewstuff.so -> kde-base/pykde4
 *   /usr/lib64/python2.6/site-packages/PyKDE4/kparts.so -> kde-base/pykde4
 *   /usr/lib64/python2.6/site-packages/PyKDE4/ktexteditor.so -> kde-base/pykde4
 *   /usr/lib64/python2.6/site-packages/PyKDE4/kutils.so -> kde-base/pykde4
 *   /usr/lib64/python2.6/site-packages/PyKDE4/phonon.so -> kde-base/pykde4
 *   /usr/lib64/python2.6/site-packages/PyKDE4/plasma.so -> kde-base/pykde4
 *   /usr/lib64/python2.6/site-packages/PyKDE4/solid.so -> kde-base/pykde4
 *   /usr/lib64/python2.6/site-packages/_xmlplus/parsers/pyexpat.so -> dev-python/pyxml
 *   /usr/lib64/python2.6/site-packages/_xmlplus/parsers/sgmlop.so -> dev-python/pyxml
 *   /usr/lib64/python2.6/site-packages/_xmlplus/utils/boolean.so -> dev-python/pyxml
 *   /usr/lib64/python2.6/site-packages/yasm.so -> dev-lang/yasm
 * Generated new 4_raw.rr and 4_owners.rr
 * Cleaning list of packages to rebuild
 * Generated new 4_pkgs.rr
 * Assigning packages to ebuilds
 * Generated new 4_ebuilds.rr
 * Evaluating package order
 *
 * Portage could not find any version of the following packages it could build:
 * app-editors/vim:0 dev-lang/yasm:0 dev-libs/libxslt:0 dev-python/cython:0 dev-python/numpy:0 dev-python/pycairo:0 dev-python/pyxml:0 dev-vcs/mercurial:0 kde-base/pykde4:4.4 media-libs/alsa-lib:0 media-libs/lcms:0 sys-libs/cracklib:0
 *
 * (Perhaps they are masked, blocked, or removed from portage.)
 * Try to emerge them manually.
 *
 * Warning: Portage cannot rebuild any of the necessary packages.



How can i solve this problem?

Thanks in advance.[/quote]


Last edited by Grook on Fri Apr 01, 2011 5:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
Yuu
Apprentice
Apprentice


Joined: 23 Dec 2008
Posts: 220
Location: France

PostPosted: Fri Apr 01, 2011 4:37 pm    Post subject: Reply with quote

Hi,

If yes, maybe you should read the Python 2.7 upgrade? thread :

Helena wrote:
So, to summarize, the only steps needed are, to my best belief
Code:
eselect python set python2.7
python-updater
emerge --depclean
revdep-rebuild
Note: this remains true as long as we need to keep both a 2.x and a 3.x Python version active. This was already mentioned in an "eselect news" item if I remember well when python 3 first became available.

_________________
Inspiron 1720 laptop : T8300 | 200 Gb hard drive | 2Gb of ram | 8600M GT | Gentoo x86_64
Server : Celeron 220 | 250 Gb hard drive | 2Gb of ram | SiS 662 VGA | Gentoo x86_64
Back to top
View user's profile Send private message
ferreirafm
Guru
Guru


Joined: 28 Jul 2005
Posts: 449
Location: Sao Paulo, Brazil

PostPosted: Fri Apr 01, 2011 4:58 pm    Post subject: Reply with quote

Hi Grook.
This question have been discussed in several posts.
You have to eselect the python version just emerged, before running python-updater. After that, run depclean and revdep-rebuild afterwards.
Boot your laptop with the System-Rescue-CD or the Gentoo instalation CD and emerge the 2.6 python version. If you are stucked in a console download the python stuff (wget http://www.jabawok.net/gentoo/distfiles/Python-2.6.6.tar.bz2) and extract it overwriting the files you have.
After the python remedy, the code sequence should be:
Code:
> emerge -pvuDN world
> eselect list python
> eselect python set <2.7 python version>
> python -updater
> emerge --depclean
> revdep-rebuild

G'Luck
Back to top
View user's profile Send private message
Grook
n00b
n00b


Joined: 23 Jun 2010
Posts: 26

PostPosted: Fri Apr 01, 2011 5:12 pm    Post subject: Reply with quote

Oh guys, thanks a lot! I guess it helped!
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Wed Apr 20, 2011 8:50 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see Python 2.7 upgrade?
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum