Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ati-drivers slow scrolling
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
MageSlayer
Apprentice
Apprentice


Joined: 26 Jul 2007
Posts: 228
Location: Ukraine

PostPosted: Mon Apr 11, 2011 10:03 pm    Post subject: ati-drivers slow scrolling Reply with quote

Hi

Sometimes for no apparent reason, I experience an awful slow window scrolling. One can see "waves".
It happens in every window, but manifests itself in large areas much greater. Looks like it depends on a size of a scrolling area.

I am on 2.6.36.2 vanilla + BFS v.360 + ati-drivers 11.3
Any hints?

P.S. I cannot use xf86-video-ati, as it does not support OpenCL.
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2525
Location: UK

PostPosted: Tue Apr 12, 2011 12:28 am    Post subject: Reply with quote

That's the price of using fglrx. You might be able to regain some semblance of a usable desktop by disabling all compositing though.
_________________
runit-init howto | Overlay
Back to top
View user's profile Send private message
zBrain
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2006
Posts: 96

PostPosted: Tue Apr 12, 2011 12:43 am    Post subject: Reply with quote

Seriously? Theres no solution for this?
Back to top
View user's profile Send private message
MageSlayer
Apprentice
Apprentice


Joined: 26 Jul 2007
Posts: 228
Location: Ukraine

PostPosted: Tue Apr 12, 2011 6:00 am    Post subject: Reply with quote

Ant P. wrote:
That's the price of using fglrx. You might be able to regain some semblance of a usable desktop by disabling all compositing though.


Compositing is already disabled by:
Code:

Section "Extensions"
    Option "Composite" "off"
EndSection


... and does not help.
Back to top
View user's profile Send private message
norg
Tux's lil' helper
Tux's lil' helper


Joined: 23 Aug 2010
Posts: 104
Location: Augsburg (Germany)

PostPosted: Tue Apr 12, 2011 8:36 am    Post subject: Reply with quote

Can you paste the xorg.conf? You can also try a blank xorg.conf and use aticonfig --initial to create a default one.
I had the same issue after a driver update and this worked for me, so i created a new xorg.conf and checked every new option i add.
Also check if direct rendering etc. is working, a look at the xorg.log is also helpful.
Back to top
View user's profile Send private message
MageSlayer
Apprentice
Apprentice


Joined: 26 Jul 2007
Posts: 228
Location: Ukraine

PostPosted: Tue Apr 12, 2011 4:52 pm    Post subject: Reply with quote

norg wrote:
Can you paste the xorg.conf? You can also try a blank xorg.conf and use aticonfig --initial to create a default one.
I had the same issue after a driver update and this worked for me, so i created a new xorg.conf and checked every new option i add.
Also check if direct rendering etc. is working, a look at the xorg.log is also helpful.


Nothing is fancy in xorg.conf
See below. It is almost exactly initial configuration done by aticonfig.

Code:

Section "ServerLayout"
   Identifier     "aticonfig Layout"
   Screen      0  "aticonfig-Screen[0]-1" 0 0
   Screen         "aticonfig-Screen[0]-0" LeftOf "aticonfig-Screen[0]-1"
   #Option           "AIGLX" "false"
   Option           "AIGLX" "True"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)
#
#    FontPath   "/usr/lib/X11/fonts/local/"
#    FontPath   "/usr/lib/X11/fonts/misc/"
#    FontPath   "/usr/lib/X11/fonts/75dpi/:unscaled"
#    FontPath   "/usr/lib/X11/fonts/100dpi/:unscaled"
#    FontPath   "/usr/lib/X11/fonts/Type1/"
#    FontPath   "/usr/lib/X11/fonts/TrueType/"
#    FontPath   "/usr/lib/X11/fonts/freefont/"
#    FontPath   "/usr/lib/X11/fonts/75dpi/"
#    FontPath   "/usr/lib/X11/fonts/100dpi/"
# The module search path.  The default path is shown here.
#    ModulePath "/usr/lib/modules"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/OTF"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/75dpi/"
   FontPath     "/usr/share/fonts/corefonts/"
   FontPath     "/usr/share/fonts/cyrillic/"
   FontPath     "/usr/share/fonts/default/"
   FontPath     "/usr/share/fonts/terminus/"
EndSection

Section "Module"
EndSection

Section "ServerFlags"
   Option       "Xinerama" "on"
   Option       "AllowMouseOpenFail" "on"
   Option       "IgnoreABI" "on"
   Option       "AIGLX" "true"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-1"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"

   #Option       "ForceGenericCPU" "no"
   #Option       "FSAAEnable" "off"
   #Option       "FSAADisableGamma" "off"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   Option       "UseFastTLS" "off"
   Option       "OpenGLOverlay" "off"
   Option       "BlockSignalsOnLock" "off"
   #Option       "BackingStore" "on"
   Option       "BackingStore" "off"
   Option       "VideoOverlay" "off"
   #Option       "EnableTearFreeDesktop" "true"
   Option       "EnableTearFreeDesktop" "false"
   Option       "Capabilities" "0x00000800"
   Option       "RequestMSI" "false"
   #Option       "UseInternalAGPGART" "yes"
   BusID       "PCI:1:0:0"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-1"
   Driver      "fglrx"
   BusID       "PCI:1:0:0"
   Screen      1
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   #Option       "AllowGLXWithComposite" "True"
   Option       "RenderAccel" "True"
   Option       "AddARGBGLXVisuals" "True"
   Option       "backingstore" "True"
   Option       "TripleBuffer" "True"
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-1"
   Device     "aticonfig-Device[0]-1"
   Monitor    "aticonfig-Monitor[0]-1"
   DefaultDepth     24
   #Option       "AllowGLXWithComposite" "True"
   Option       "RenderAccel" "True"
   Option       "AddARGBGLXVisuals" "True"
   Option       "backingstore" "True"
   Option       "TripleBuffer" "True"
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "Extensions"
    Option "Composite" "off"
EndSection
Back to top
View user's profile Send private message
zBrain
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2006
Posts: 96

PostPosted: Tue Apr 12, 2011 6:14 pm    Post subject: Reply with quote

Try the instructions here: http://www.thinkwiki.org/wiki/Xorg_RandR_1.2

I had the same issues with xinerama/fglrx. Turns out xrandr works MUCH better, and your xorg.conf ends up cleaner.

My thread on the topic at Phoronix where I got help is: http://phoronix.com/forums/showthread.php?45842-New-to-ATI-on-Linux-need-some-help

Edit: I was able to get compositing and dual head with this method.
Back to top
View user's profile Send private message
MageSlayer
Apprentice
Apprentice


Joined: 26 Jul 2007
Posts: 228
Location: Ukraine

PostPosted: Wed Apr 13, 2011 10:41 pm    Post subject: Reply with quote

zBrain wrote:
Try the instructions here: http://www.thinkwiki.org/wiki/Xorg_RandR_1.2

I had the same issues with xinerama/fglrx. Turns out xrandr works MUCH better, and your xorg.conf ends up cleaner.

My thread on the topic at Phoronix where I got help is: http://phoronix.com/forums/showthread.php?45842-New-to-ATI-on-Linux-need-some-help

Edit: I was able to get compositing and dual head with this method.


Thanks for hint. It looks like it really works better.
But the problem that I cannot force to initialize X in Virtual/xinerama-like (dual monitor configuration) desktop mode.
I was able to start in clone mode (both monitors show the same image) using following xorg.conf.

Running ...
Code:
 xrandr --output DFP2 --right-of DFP4

... after start makes it work as expected. But I think that kind of trick should not be necessary.

Code:

Section "ServerLayout"
   Identifier     "aticonfig Layout"
   Option           "AIGLX" "True"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)
#
#    FontPath   "/usr/lib/X11/fonts/local/"
#    FontPath   "/usr/lib/X11/fonts/misc/"
#    FontPath   "/usr/lib/X11/fonts/75dpi/:unscaled"
#    FontPath   "/usr/lib/X11/fonts/100dpi/:unscaled"
#    FontPath   "/usr/lib/X11/fonts/Type1/"
#    FontPath   "/usr/lib/X11/fonts/TrueType/"
#    FontPath   "/usr/lib/X11/fonts/freefont/"
#    FontPath   "/usr/lib/X11/fonts/75dpi/"
#    FontPath   "/usr/lib/X11/fonts/100dpi/"
# The module search path.  The default path is shown here.
#    ModulePath "/usr/lib/modules"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/OTF"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/75dpi/"
   FontPath     "/usr/share/fonts/corefonts/"
   FontPath     "/usr/share/fonts/cyrillic/"
   FontPath     "/usr/share/fonts/default/"
   FontPath     "/usr/share/fonts/terminus/"
EndSection

Section "Module"
EndSection

Section "ServerFlags"
   #Option       "Xinerama" "on"
   Option       "Xinerama" "off"
   Option       "AllowMouseOpenFail" "on"
   Option       "IgnoreABI" "on"
   Option       "AIGLX" "true"
EndSection

Section "Device"

   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   Option       "UseFastTLS" "0"
   #Option       "EnableTearFreeDesktop" "true"
   Option       "EnableTearFreeDesktop" "false"
   #Option       "Capabilities" "0x00000800"

   Option "Monitor-DFP2" "monLeft"
    Option "Monitor-DFP4" "monRight"

   #Option "DesktopSetup" "horizontal" # does not work and one of the monitors is turned off!!!
   #Option "DesktopSetup" "horizontal,reverse" # does not work and one of the monitors is turned off!!!

   #Option "PairMode" "2048x1152+2048x1152" # does not work
   #Option      "MonitorLayout" "DFP2,DFP4" # does not work

   BusID       "PCI:1:0:0"
EndSection

Section "Monitor"
   Identifier "monLeft"
     Option "DPMS"

   Option "PreferredMode" "2048x1152"
EndSection

Section "Monitor"
    Identifier "monRight"

   #Option "RightOf" "DFP2" # does not work and one of the monitors is turned off!!!

    Option "DPMS"
   Option "PreferredMode" "2048x1152"
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-1"
   Device     "aticonfig-Device[0]-0"
   Monitor    "MonLeft"
   DefaultDepth     24
   SubSection "Display"
      Modes    "2048x1152" "1280x1024"
      Depth     24
      Virtual 4096 4096
                #Virtual 3328 1152
   EndSubSection
EndSection

Section "Extensions"
    Option "Composite" "off"
EndSection


Am I missing something obvious?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum