Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] configure: error: cannot run C compiled programs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
okel
n00b
n00b


Joined: 04 Nov 2004
Posts: 38

PostPosted: Fri Sep 28, 2007 10:44 am    Post subject: [solved] configure: error: cannot run C compiled programs Reply with quote

Hello,

I've setup a new gentoo on my AMD64 system with an install-amd64-minimal-2007.0.iso. It is
ds9 ~ # uname -a
Linux ds9 2.6.22-gentoo-r5 #1 SMP Wed Sep 26 00:36:53 CEST 2007 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 5000+ AuthenticAMD GNU/Linux

I have emerged a few packages but have a problem compiling the glibc, that pointed me to a compiler problem. So I tried to emerge the gcc first.
"emerge gcc". It runs for while but somewhere bails out with

Code:
Running configure in multilib subdir 32
pwd: /var/tmp/portage/sys-devel/gcc-4.1.2/work/build/x86_64-pc-linux-gnu
mkdir 32
configure: creating cache ./config.cache
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking target system type... x86_64-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for x86_64-pc-linux-gnu-gcc... /var/tmp/portage/sys-devel/gcc-4.1.2/work/build/./gcc/xgcc -B/var/tmp/portage/sys-devel/gcc-4.1.2/work/build/./gcc/ -B/usr/x86_64-pc-linux-gnu/bin/ -B/usr/x86_64-pc-linux-gnu/lib/ -isystem /usr/x86_64-pc-linux-gnu/include -isystem /usr/x86_64-pc-linux-gnu/sys-include  -m32
checking for C compiler default output file name... a.out
checking whether the C compiler works... configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.


My make.profile is /usr/portage/profiles/default-linux/amd64/2007.0/desktop.
USE="3dnow 3dnowext a52 aac alsa apache2 cpudetection dga divx dv dvb emerald bash-completion gimp glitz gtk2 mmx mmxext multilib mysql network nsplugin realmedia sdk sse unicode v4l v4l2 video_cards_radeon x264 xvid wmp -arts -fortran -gif -gnome -kde -qt -quicktime -recode"

I've found some hints to a problem like that on the net but they all are from the year 2005, no one seems to have that problem recently. What could be the problem here?

Regards

okel


Last edited by okel on Fri Sep 28, 2007 2:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7721
Location: Somewhere over Atlanta, Georgia

PostPosted: Fri Sep 28, 2007 11:01 am    Post subject: Reply with quote

See [IG7] cannot run C compiled programs (AMD64).

- John
Back to top
View user's profile Send private message
okel
n00b
n00b


Joined: 04 Nov 2004
Posts: 38

PostPosted: Fri Sep 28, 2007 11:36 am    Post subject: Reply with quote

That's what I wrote about, it's from the year 2005. I tried it and it didn't make any difference.

okel
Back to top
View user's profile Send private message
okel
n00b
n00b


Joined: 04 Nov 2004
Posts: 38

PostPosted: Fri Sep 28, 2007 11:48 am    Post subject: Reply with quote

And: The topic you mentioned refers to another topic. In that topic people wrote about a bug, but that bug was fixed a long time ago and should be no problem any longer.

okel
Back to top
View user's profile Send private message
Macrobiotus
Apprentice
Apprentice


Joined: 06 Oct 2002
Posts: 230

PostPosted: Fri Sep 28, 2007 1:27 pm    Post subject: Reply with quote

Did you check IA32 Emulation / IA32 a.out support in your kernel?
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7721
Location: Somewhere over Atlanta, Georgia

PostPosted: Fri Sep 28, 2007 1:27 pm    Post subject: Reply with quote

Okay, let's see what's really going on, then. Look in "/var/tmp/portage/sys-devel/gcc-4.1.2/work/build/x86_64-pc-linux-gnu" and find the "config.log" file and see what the exact failure is. Towards the end of the config.log will be output relevant to the failure.

- John
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Fri Sep 28, 2007 1:32 pm    Post subject: Reply with quote

And please post the output of emerge --info too.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
okel
n00b
n00b


Joined: 04 Nov 2004
Posts: 38

PostPosted: Fri Sep 28, 2007 1:38 pm    Post subject: Reply with quote

I'm currently reading and testing http://bugs.gentoo.org/show_bug.cgi?id=189764 . It might fit to my problem. I'll post results.

okel
Back to top
View user's profile Send private message
okel
n00b
n00b


Joined: 04 Nov 2004
Posts: 38

PostPosted: Fri Sep 28, 2007 2:55 pm    Post subject: Reply with quote

Ok, that did it. The flaky kernel config is a copied config from my alternative x86 gentoo installation.

Thanks to Macrobiotus and the others.

okel
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5256

PostPosted: Tue Apr 05, 2011 9:00 pm    Post subject: Reply with quote

I don't mean to open a dead thread, but I'm having this problem now. So far for sandbox and wine.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum