Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] X crashed after world update
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
prffzc
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2005
Posts: 94

PostPosted: Thu Feb 24, 2011 2:05 pm    Post subject: [Solved] X crashed after world update Reply with quote

My X has completely crashed after yet another system update. This is my second crash in 3 weeks....

Anyway, the problem now is that it boots ok, but does not enter the graphic mode. I can change the intensity of the black screen I have but nothing else.

I have recompiled almost everything I have updated. I have no problems at revdep-rebuild nor ldconf.

Here is something I saw in the ~.xsession-errors

Code:

(xfce4-panel:5639): Wnck-CRITICAL **: wnck_window_get_state: assertion `WNCK_IS_WINDOW (window)' failed

(xfce4-panel:5639): Wnck-CRITICAL **: wnck_window_get_workspace: assertion `WNCK_IS_WINDOW (window)' failed

(xfce4-panel:5639): Wnck-CRITICAL **: wnck_window_is_pinned: assertion `WNCK_IS_WINDOW (window)' failed
[87643:272] Error(scriptinterface.cc:295): Passed a non-object for onmessasge_callback
NOTE: child process received `Goodbye', closing down
Inconsistency detected by ld.so: dl-open.c: 582: _dl_open: Assertion `_dl_debug_initialize (0, args.nsid)->r_state == RT_CONSISTENT' failed!
Inconsistency detected by ld.so: dl-open.c: 582: _dl_open: Assertion `_dl_debug_initialize (0, args.nsid)->r_state == RT_CONSISTENT' failed!
Inconsistency detected by ld.so: dl-open.c: 582: _dl_open: Assertion `_dl_debug_initialize (0, args.nsid)->r_state == RT_CONSISTENT' failed!
Inconsistency detected by ld.so: dl-open.c: 582: _dl_open: Assertion `_dl_debug_initialize (0, args.nsid)->r_state == RT_CONSISTENT' failed!
** Message: xfsm-shutdown-helper.c:1470: Using ConsoleKit to Restart

(xfce4-mixer-plugin:5689): GLib-GObject-CRITICAL **: g_signal_handler_disconnect: assertion `handler_id > 0' failed
running 'pkill -INT ^gpg-agent$; rm -f /home/dbesliu/.cache/gpg-agent-info'


I'm not sure what to paste from dmesg so... I'll wait for questions or suggestions!

Thanks!


Last edited by prffzc on Tue Mar 01, 2011 8:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6535
Location: Goose Creek SC

PostPosted: Thu Feb 24, 2011 7:52 pm    Post subject: Reply with quote

Check that X is really the problem:
If
Code:
X -retro
produces a black and white stipple screen with a movable mouse; X is ok.
If you would like a second pair of eyes (or more) to look at your setup, run
Code:
emerge wgetpaste
wgetpaste /etc/make.conf
wgetpaste -s ca  /usr/src/linux/.config
rc-update show | wgetpaste
emerge -pv xorg-server $(qlist -IC x11-drivers) | wgetpaste
lspci -k | wgetpaste
wgetpaste /etc/env.d/90xsession
wgetpaste /etc/conf.d/xdm
ls -l /etc/X11/Sessions | wgetpaste
ls -l /boot | wgetpaste
wgetpaste /boot/grub/grub.conf
eselect kernel list | wgetpaste
awk '/Graphics support/,/CONFIG_SOUND/' /usr/src/linux/.config | wgetpaste

and post the url's returned
_________________
Defund the FCC.
Back to top
View user's profile Send private message
prffzc
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2005
Posts: 94

PostPosted: Sat Feb 26, 2011 1:21 pm    Post subject: Reply with quote

Almost desperate....
So, I can"t start the system without the X. If I try X -retro from livecd it sais "module ABI major version doesn't match the server's version" One of them was 6 one 9.
I can't use wgetpaste because it gives me an error that it hasn't wrote anything although it sais it connects to the server...

However, I do not have a 90xsession file or any xsession file anywhere. I have recompiled all x11-drivers from the qlist and fixed some qt updating problems (on -u wolrd they did not appear, but when -p I could see the different versions).

Still no change....
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6535
Location: Goose Creek SC

PostPosted: Sat Feb 26, 2011 3:58 pm    Post subject: Reply with quote

boot the cd, enter the chroot (use your device names instead of /dev/sda3 and /dev/sda1):
Code:
mount /dev/sda3 /mnt/gentoo
mount /dev/sda1 /mnt/gentoo/boot
mount -t proc none /mnt/gentoo/proc
mount -o bind /dev /mnt/gentoo/dev
chroot /mnt/gentoo /bin/bash
env-update
source /etc/profile
export PS1="(chroot) $PS1"
as appropriate, delete the automatic starting of the GUI, for example:
Code:
rc-update del xdm default
Then
Quote:
EITHER
Code:
emerge pastebin
pastebin /etc/make.conf
pastebin  /usr/src/linux/.config
rc-update show | pastebin
emerge -pv xorg-server $(qlist -IC x11-drivers) | pastebin
lspci -k | pastebin
pastebin /etc/env.d/90xsession
pastebin /etc/conf.d/xdm
ls -l /etc/X11/Sessions | pastebin
ls -l /boot | pastebin
pastebin /boot/grub/grub.conf
eselect kernel list | pastebin
awk '/Graphics support/,/CONFIG_SOUND/' /usr/src/linux/.config | pastebin
OR
Code:
emerge wgetpaste
wgetpaste -s dpaste /etc/make.conf
wgetpaste -s dpaste  /usr/src/linux/.config
rc-update show | wgetpaste -s dpaste
emerge -pv xorg-server $(qlist -IC x11-drivers) | wgetpaste -s dpaste
lspci -k | wgetpaste -s dpaste
wgetpaste -s dpaste /etc/env.d/90xsession
wgetpaste -s dpaste /etc/conf.d/xdm
ls -l /etc/X11/Sessions | wgetpaste -s dpaste
ls -l /boot | wgetpaste -s dpaste
wgetpaste -s dpaste /boot/grub/grub.conf
eselect kernel list | wgetpaste -s dpaste
awk '/Graphics support/,/CONFIG_SOUND/' /usr/src/linux/.config | wgetpaste -s dpaste

and post the url's returned.
Code:
exit
reboot
If the reboot does not produce a CLI, there are problems greater than X.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
prffzc
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2005
Posts: 94

PostPosted: Sat Feb 26, 2011 6:44 pm    Post subject: Reply with quote

I didn't had xdm at boot, manage to remove from runlevels. X -retro produces the same black dead screen.

Links:
http://pastebin.com/wvnE647M
http://pastebin.com/yMTnJfBh
http://pastebin.com/ncR3VmCC
http://pastebin.com/nFX3u3jC
http://pastebin.com/uk8jtPn0
http://pastebin.com/1udwxBcP
http://pastebin.com/sjWxwg2N
http://pastebin.com/yPag68Kb
http://pastebin.com/FPZ9NG2J
http://pastebin.com/NywfZBMC

Thank goodness for livecd that's how I worked in this last week.... Having your computer broken is .... not good.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6535
Location: Goose Creek SC

PostPosted: Sat Feb 26, 2011 7:45 pm    Post subject: Reply with quote

I assume you are able to boot to a CLI, however will use cd/chroot just in case
back into the chroot:
Code:
mount /dev/sda5 /mnt/gentoo
mount /dev/sda1 /mnt/gentoo/boot #your value if not sda1
mount -t proc none /mnt/gentoo/proc
mount -o bind /dev /mnt/gentoo/dev
chroot /mnt/gentoo /bin/bash
env-update
source /etc/profile
export PS1="(chroot) $PS1"
cd /usr/src/linux
make menuconfig

edit menuconfig to:
Quote:
Device Drivers --->
Generic Driver Options --->
[ ] Include in-kernel firmware blobs in kernel binary
() External firmware blobs to build into the kernel binary
Graphics support --->
<*> /dev/agpgart (AGP Support) --->
--- /dev/agpgart (AGP Support)
<M> AMD Opteron/Athlon64 on-CPU GART support
*- VGA Arbitration
(2) Maximum number of GPUs
<*> Lowlevel video output switch controls
<*> Support for frame buffer devices --->
--- Support for frame buffer devices
[*] Enable firmware EDID
[*] Enable Video Mode Handling Helpers
[*] Enable Tile Blitting Support
[*] Backlight & LCD device support --->
-- Backlight & LCD device support
<*> Lowlevel LCD controls
<*> Lowlevel Backlight controls
Display device support --->
Console display driver support --->
-*- VGA text console
[*] Enable Scrollback Buffer in System RAM
(256) Scrollback Buffer Size (in KB)
<*> Framebuffer Console support
[*] Bootup logo --->
--- Bootup logo
[*] Standard 224-color Linux logo
anything in the graphics support section not listed above, should be either [ ] or < > . Then:
Code:
make && make modules_install
cp arch/x86/boot/bzImage /boot/vmlinuz-2.6.36-gentoo-r5
For some reason pastebin lost your /etc/make.conf. Nonetheless:
Code:
nano /etc/make.conf
Edit to include:
Quote:
VIDEO_CARDS="fglrx"
INPUT_DEVICES="evdev" #plus synaptics if you really have a touchpad
USE="consolekit dbus hal policykit udev" #plus whatever you like
then
Code:
nano /etc/env.d/90xsession
edit to include your choice of
Quote:
XSESSION="Xfce4" or XSESSION="KDE-4"
Then:
Code:
emerge dbus hal consolekit polkit udev xorg-server $(qlist -IC x11-drivers)
rc-update add dbus default
rc-update add consolekit default
then
Code:
nano /etc/conf.d/xdm
Edit to (remove #):
Quote:
DISPLAYMANAGER="xdm"
Then:
Code:
nano /boot/grub/grub.conf
Edit to remove vga line:
Quote:
default 0
timeout 30
#splashimage=(hd0,4)/boot/grub/splash.xpm.gz

title Gentoo
root (hd0,4)
kernel /boot/vmlinuz-2.6.36-gentoo-r5 root=/dev/sda5 vga=803

title Windows
rootnoverify (hd0,0)
makeactive
chainloader +1
Then
Code:
exit
reboot

_________________
Defund the FCC.
Back to top
View user's profile Send private message
prffzc
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2005
Posts: 94

PostPosted: Sat Feb 26, 2011 9:32 pm    Post subject: Reply with quote

And blank screen yet again....
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6535
Location: Goose Creek SC

PostPosted: Sat Feb 26, 2011 9:51 pm    Post subject: Reply with quote

Code:
aticonfig --initial
startx

_________________
Defund the FCC.
Back to top
View user's profile Send private message
prffzc
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2005
Posts: 94

PostPosted: Sun Feb 27, 2011 5:51 am    Post subject: Reply with quote

Same... #$%^&^%$#@
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6535
Location: Goose Creek SC

PostPosted: Sun Feb 27, 2011 6:00 am    Post subject: Reply with quote

We missed something. Please redo:
Quote:
EITHER
Code:
emerge pastebin
pastebin /etc/make.conf
pastebin  /usr/src/linux/.config
rc-update show | pastebin
emerge -pv xorg-server $(qlist -IC x11-drivers) | pastebin
lspci -k | pastebin
pastebin /etc/env.d/90xsession
pastebin /etc/conf.d/xdm
ls -l /etc/X11/Sessions | pastebin
ls -l /boot | pastebin
pastebin /boot/grub/grub.conf
eselect kernel list | pastebin
awk '/Graphics support/,/CONFIG_SOUND/' /usr/src/linux/.config | pastebin
OR
Code:
emerge wgetpaste
wgetpaste -s dpaste /etc/make.conf
wgetpaste -s dpaste  /usr/src/linux/.config
rc-update show | wgetpaste -s dpaste
emerge -pv xorg-server $(qlist -IC x11-drivers) | wgetpaste -s dpaste
lspci -k | wgetpaste -s dpaste
wgetpaste -s dpaste /etc/env.d/90xsession
wgetpaste -s dpaste /etc/conf.d/xdm
ls -l /etc/X11/Sessions | wgetpaste -s dpaste
ls -l /boot | wgetpaste -s dpaste
wgetpaste -s dpaste /boot/grub/grub.conf
eselect kernel list | wgetpaste -s dpaste
awk '/Graphics support/,/CONFIG_SOUND/' /usr/src/linux/.config | wgetpaste -s dpaste
post the new url's
_________________
Defund the FCC.
Back to top
View user's profile Send private message
prffzc
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2005
Posts: 94

PostPosted: Sun Feb 27, 2011 6:16 am    Post subject: Reply with quote

http://pastebin.com/KCv96CGJ
http://pastebin.com/0aeiktMW
http://pastebin.com/Jg4D6zpH
http://pastebin.com/rrsYHQKy
http://pastebin.com/SFfqqPNM
http://pastebin.com/8Rf7nkhW
http://pastebin.com/8ZyQQ8PM
http://pastebin.com/UEeRP6yP
http://pastebin.com/NAn4ezzi
http://pastebin.com/hxzPtLF2
http://pastebin.com/L4Pg6pmP
http://pastebin.com/RuK1K72z
Back to top
View user's profile Send private message
prffzc
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2005
Posts: 94

PostPosted: Sun Feb 27, 2011 6:18 am    Post subject: Reply with quote

With several configrations of xorg.conf I also loose the ctrl+alt+del for reboot and can't kill X (ctrl+alt+bkspace) since this started.
If this gives you any ideas...
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6535
Location: Goose Creek SC

PostPosted: Sun Feb 27, 2011 5:01 pm    Post subject: Reply with quote

several changes did not take affect. Major is the kernel configuration.
You need to try again to reconfigure, recompile, and recopy your kernel.
Code:
mount /dev/sda5 /mnt/gentoo
mount /dev/sda1 /mnt/gentoo/boot #your value if not sda1
mount -t proc none /mnt/gentoo/proc
mount -o bind /dev /mnt/gentoo/dev
chroot /mnt/gentoo /bin/bash
env-update
source /etc/profile
export PS1="(chroot) $PS1"
cd /usr/src/linux
make menuconfig
Edit general setup section of menuconfig to include:
Quote:
<*> Kernel .config support
[*] Enable access to .config through /proc/config.gz
This will allow access to the running kernels configuration when gentoo is booted.
Edit graphics support menuconfig to match:
Quote:
Device Drivers --->
Graphics support --->
<*> /dev/agpgart (AGP Support) --->
--- /dev/agpgart (AGP Support)
<M> AMD Opteron/Athlon64 on-CPU GART support
< > Intel 440LX/BX/GX, I8xx and E7x05 chipset support
< > SiS chipset support
< > VIA chipset support -*- VGA Arbitration
(2) Maximum number of GPUs
[ ] Laptop Hybrid Graphics - GPU switching support
< > Direct Rendering Manager (XFree86 4.1.0 and higher DRI support
< > Intel GMA500 Stub Driver
<*> Lowlevel video output switch controls
<*> Support for frame buffer devices --->
--- Support for frame buffer devices
[*] Enable firmware EDID
[ ] Framebuffer foreign endianness support --->
[*] Enable Video Mode Handling Helpers
[*] Enable Tile Blitting Support
*** Frame buffer hardware drivers ***
< > Cirrus Logic support
< > Permedia2 support
< > CyberPro 2000/2010/5000 support
< > Arc Monochrome LCD board support
[ ] Asiliant (Chips) 69000 display support
[ ] IMS Twin Turbo display support
< > VGA 16-color graphics support
< > Userspace VESA VGA graphics support
[ ] VESA VGA graphics support
< > N411 Apollo/Hecuba devkit support
< > Hercules mono graphics support
< > Epson S1D13XXX framebuffer support
< > nVidia Framebuffer Support
< > nVidia Riva support
< > Intel LE80578 (Vermilion) support
< > Matrox acceleration
< > ATI Radeon display support
< > ATI Rage128 display support
< > ATI Mach64 display support

< > S3 Trio/Virge support
< > S3 Savage support
< > SiS/XGI display support
< > VIA UniChrome (Pro) and Chrome9 display support
< > NeoMagic display support
< > IMG Kyro support
< > 3Dfx Banshee/Voodoo3/Voodoo5 display support
< > 3Dfx Voodoo Graphics (sst1) support
< > VIA VT8623 support
< > Trident/CyberXXX/CyberBlade support
< > ARK 2000PV support
< > Permedia3 support (EXPERIMENTAL)
< > Fujitsu carmine frame buffer support
[ ] AMD Geode family framebuffer support (EXPERIMENTAL)
< > Virtual Frame Buffer support (ONLY FOR TESTING!)
< > E-Ink Metronome/8track controller support
< > Fujitsu MB862xx GDC support
< > E-Ink Broadsheet/Epson S1D13521 controller support
[*] Backlight & LCD device support --->
--- Backlight & LCD device support
<*> Lowlevel LCD controls
< > Platform LCD controls
<*> Lowlevel Backlight controls
< > Generic (aka Sharp Corgi) Backlight Driver
< > Frontpath ProGear Backlight Driver
< > MacBook Pro Nvidia Backlight Driver
< > Tabletkiosk Sahara Touch-iT Backlight Driver
< > Backlight Driver for ADP8860/ADP8861/ADP8863 using WLED
Display device support --->
<*> Display panel/monitor support
*** Display hardware drivers
Console display driver support --->
-*- VGA text console
[*] Enable Scrollback Buffer in System RAM
(256) Scrollback Buffer Size (in KB)
<M> Framebuffer Console support
[ ] Map the console to the primary display device
[ ] Framebuffer Console Rotation
[ ] Select compiled-in fonts
[*] Bootup logo --->
--- Bootup logo
[ ] Standard black and white Linux logo
[ ] Standard 16-color Linux logo
[*] Standard 224-color Linux logo
I have attempted to highlight in red items which must change. I have included every item in the graphics support menuconfig used by my radeon hd5770. If not in red but different from your choice please change your choice.
Code:
make && make_install
cp arch/x86/boot/bzImage /boot/vmlinuz-2.6.36-gentoo-r5
exit
reboot

reboot to the gentoo systerm on the hard drive.
When rebooted to the command line: (The pastebin site is dropping posts so try wgetpaste -s dpaste)
Code:
emerge wgetpaste
zcat /proc/config.gz >> config27
awk '/Graphics support/,/CONFIG_SOUND/' config27 | wgepaste -s dpaste

post the url returned.

There are other items that did not change, let us do one at a time in order of importance.

BTW:
Quote:
With several configrations of xorg.conf I also loose the ctrl+alt+del for reboot and can't kill X (ctrl+alt+bkspace) since this started.
The xorg-server developers removed the ctrl-alt-backspace function about a year ago. there have been/are workarounds that mostly require a working X.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5571

PostPosted: Sun Feb 27, 2011 5:29 pm    Post subject: Reply with quote

Not "removed", but "turned off by default".
Switching it back on is just a matter of single XbkOptions string.
Back to top
View user's profile Send private message
prffzc
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2005
Posts: 94

PostPosted: Sun Feb 27, 2011 5:44 pm    Post subject: Reply with quote

http://dpaste.com/455571

However, the problems started after I've updated something not changed the kernel. As far as I can see now, fglrx gives me the black screen and glx or ati ...I think gives me the black screen with a static white cursor in the upper left corner.
Back to top
View user's profile Send private message
prffzc
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2005
Posts: 94

PostPosted: Sun Feb 27, 2011 5:54 pm    Post subject: Reply with quote

I have X using vesa driver....
Back to top
View user's profile Send private message
prffzc
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2005
Posts: 94

PostPosted: Sun Feb 27, 2011 5:59 pm    Post subject: Reply with quote

So, the question would be which should be the appropriate ati driver to use? Using this one I can''t change display settings.
Tried flgrx, glx, ati, dri.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6535
Location: Goose Creek SC

PostPosted: Sun Feb 27, 2011 6:12 pm    Post subject: Reply with quote

The kernel is now ok.
edit /etc/make.conf:
VIDEO_CARDS="fglrx vesa"
INPUT_DEVICES="evdev"
USE= to include consolekit dbus hal polkit udev

more follows
_________________
Defund the FCC.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6535
Location: Goose Creek SC

PostPosted: Sun Feb 27, 2011 6:26 pm    Post subject: Reply with quote

with /etc/make.conf fixed:
Code:
emerge --unmerge xorg-server ati-drivers xf86-input-evdev xf86-input-keyboard xf86-input-mouse xf86-input-synaptics xf86-video-ati xf86-video-fbdev xf86-video-glint xf86-video-intel xf86-video-mach64 xf86-video-mga xf86-video-neomagic xf86-video-nv xf86-video-openchrome xf86-video-r128 xf86-video-savage xf86-video-sis xf86-video-tdfx xf86-video-trident xf86-video-vesa
break up into chunks if/as needed
Code:
emerge xorg-server $(qlist -IC x11-drivers)
startx

_________________
Defund the FCC.
Back to top
View user's profile Send private message
prffzc
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2005
Posts: 94

PostPosted: Sun Feb 27, 2011 7:54 pm    Post subject: Reply with quote

Same thing... the only driver working is vesa.

Not to mention that the qlist gave me no drivers... and the initial way with an empty /etc/X11/Xorg.conf still doesn't work.
What file/files is used when the xorg is empty? What I saw in /usr/share/X11/xorg.conf.d has onlu evdev and synaptics conf files...
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6535
Location: Goose Creek SC

PostPosted: Sun Feb 27, 2011 8:30 pm    Post subject: Reply with quote

Code:
emerge xorg-server radeon-ucode xorg-server ati-drivers xf86-input-evdev xf86-video-vesa
modprobe fglrx
lspci -k #check vga listing for Driver in use:
aticonfig --initial
startx


Quote:
and the initial way with an empty /etc/X11/Xorg.conf still doesn't work
been the case with ati-drivers for a while now..

Quote:
qlist gave me no drivers
Code:
wgetpaste -s dpaste /etc/make.conf

_________________
Defund the FCC.


Last edited by DONAHUE on Sun Feb 27, 2011 8:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5571

PostPosted: Sun Feb 27, 2011 8:33 pm    Post subject: Reply with quote

Let's start with a few simple questions:
- do you want ati-drivers or xf86-video-ati ?
- do you need that CONFIG_FB_EFI setting ?

A minor note to DONAHUE: when I checked awhile ago, installing both of these drivers didn't made sense,
as due to module differences, there was no sane way of switching between them. With KMS, it became even harder.
Back to top
View user's profile Send private message
prffzc
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2005
Posts: 94

PostPosted: Sun Feb 27, 2011 8:50 pm    Post subject: Reply with quote

fglrx is loaded

lspci -k sais kernel modules fglrx

So, xorg with fglrx still blank, vesa still wierd.

Using only ati-drivers now.

Giving up for tonight. Thank you very much!
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6535
Location: Goose Creek SC

PostPosted: Sun Feb 27, 2011 9:15 pm    Post subject: Reply with quote

Quote:
lspci -k says kernel modules fglrx
Does it say 'Driver in use: fglrx' as well?
what does lspci -k say your card make and model is? memory has it as hd3450 or hd4350 but the paste has disappeared. Please run
Code:
dmesg | grep -i fglrx | wgetpaste -s dpaste
wgetpaste -s dpaste /var/log/Xorg.0.log
wgetpaste -s dpaste /etc/make.conf
emerge --info | wgetpaste -s dpaste
and post urls.

@void, totally agree one or the other ati driver. I believe vesa can still be on the same ticket as fglrx. I think he had kms in the kernel causing boot to go to a locked up black screen in the beginning.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
prffzc
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2005
Posts: 94

PostPosted: Mon Feb 28, 2011 7:06 am    Post subject: Reply with quote

Code:
lspci -k
01:00.0 VGA compatible controller: ATI Technologies Inc M96 [Mobility Radeon HD 4650]
        Subsystem: Hewlett-Packard Company Device 3637
        Kernel driver in use: fglrx_pci
        Kernel modules: fglrx


http://dpaste.com/457414/

I can't dpaste X.log as it't too big. Here are the EE's:
Code:

[  1249.175] (EE) SynPS/2 Synaptics TouchPad no synaptics event device found
[  1249.203] (EE) Query no Synaptics: 6003C8
[  1249.203] (EE) SynPS/2 Synaptics TouchPad Unable to query/initialize Synaptics hardware.
[  1249.216] (EE) PreInit failed for input device "SynPS/2 Synaptics TouchPad"


http://dpaste.com/457419/
http://dpaste.com/457422/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum