Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema -> Inicialização da placa de rede
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
Ds2K8
n00b
n00b


Joined: 21 Feb 2011
Posts: 3

PostPosted: Mon Feb 21, 2011 8:20 pm    Post subject: Problema -> Inicialização da placa de rede Reply with quote

Boa tarde caros,

Seguinte, estou com um grande problema ao inicializar a minha nova instalação do gentoo...
Estou instalando ele na minha máquina virtual, utilizando o VmPlayer versão 3.0.
Instalei o gentoo através do minimal CD, utilizando o guia "Quick install guide" (que ensina através do minimal cd).
Segui todos os passos da instalação, sem erros, sem problemas, porém, quando ele tenta inicializar a rede (eth0), diz que:
* network interface eth0 does not exist
* please verify hardware or kernel module (driver)
* ERROR: cannot start netmount as net.eth0 could not start

Já tentei algumas soluções que encontrei na net, como adicionar a minha placa aos modules, configurei ela pelo cd, e nada... não reconhece, alguém pode me ajudar?

Desde já agradeço!!!
Back to top
View user's profile Send private message
mfdzerohour
Tux's lil' helper
Tux's lil' helper


Joined: 31 Aug 2005
Posts: 122
Location: Campo Grande-MS

PostPosted: Tue Feb 22, 2011 4:41 pm    Post subject: Reply with quote

Olá tudo bem?

Me posta o seu lspci tem que ter a permissão do root para rodar o comando.
Back to top
View user's profile Send private message
Ds2K8
n00b
n00b


Joined: 21 Feb 2011
Posts: 3

PostPosted: Tue Feb 22, 2011 6:30 pm    Post subject: Reply with quote

mfdzerohour wrote:
Olá tudo bem?

Me posta o seu lspci tem que ter a permissão do root para rodar o comando.


Olá! Tudo certo sim!
Ok, porém esse comando eu só consigo rodar com o CD, porque direto no sistema dá erro (diz que não encontra o comando)
Segue:
http://img535.imageshack.us/i/capturadetelac.jpg/

Obrigado pela atenção!!
Back to top
View user's profile Send private message
mfdzerohour
Tux's lil' helper
Tux's lil' helper


Joined: 31 Aug 2005
Posts: 122
Location: Campo Grande-MS

PostPosted: Tue Feb 22, 2011 9:42 pm    Post subject: Reply with quote

Boa tarde,

Não sei se esse pacote vem instalado por padrão se não vem é só rodar o comando emerge sys-apps/pciutils, ele contem o lspci

Não vou explicar nada por enquanto pois acho que o link que vou te passar já é explicativo ele possui o manual de instalação do gentoo em PT_BR a parte de configurar a rede.

http://www.gentoo.org/doc/pt_br/handbook/handbook-x86.xml?part=4&chap=1

se não der certo me manda a saída do seguinte comando lsmod, é necessário instalar o pciutils primeiro antes de executar o comando, me mande também a saída do ifconfig.

Espero retorno,

Marcelo Duarte 8)
Back to top
View user's profile Send private message
Ds2K8
n00b
n00b


Joined: 21 Feb 2011
Posts: 3

PostPosted: Wed Mar 02, 2011 7:47 pm    Post subject: Reply with quote

Olá amigo!
Primeiramente, obrigado pela ajuda!

Bom, fiz todos os passos que me disseste, porém, continuo sem resultados positivos, deixa eu explicar porque...
Instalei numa boa o pciutils, e fiz o procedimento do link que me enviaste, porém, ao rodar o comando /etc/init.d/net.eth0 start, esse é o meu retorno:

http://i51.tinypic.com/2mpymq0.jpg

O comando "lsmod", não me retorna nada...

E o ifconfig: http://i52.tinypic.com/71o713.jpg3

Valeu pela ajuda amigo!!!
Back to top
View user's profile Send private message
Spidey
Apprentice
Apprentice


Joined: 07 Sep 2006
Posts: 264

PostPosted: Sat Aug 06, 2011 6:06 pm    Post subject: Reply with quote

Tá faltando carregar o módulo/driver da placa de rede, ou então compilar o kernel com o driver embutido.
Pra listar os módulos que você tem disponíveis, use o comando modprobe -l (L minúsculo). Pra ver os módulos carregados, em uso: lsmod. Ambos como root.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum