Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nevernote can't find right lib
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
sl70
Guru
Guru


Joined: 18 Jun 2002
Posts: 337
Location: Chicago, USA

PostPosted: Thu Feb 17, 2011 6:32 pm    Post subject: Nevernote can't find right lib Reply with quote

Nevernote, an open source desktop client for the nice little android app, Evernote, is available as an unsupported ebuild from here, but it doesn't run. Apparently, there are lots of libraries included in the package that reference libraries on my system that are newer than in the package. I'm getting errors like this:
Code:
Loading library: 'libQtGui.so.4'...
 - using deployment spec

        at com.trolltech.qt.internal.NativeLibraryManager.loadNativeLibrary(NativeLibraryManager.java:431)
        at com.trolltech.qt.internal.NativeLibraryManager.loadQtLibrary(NativeLibraryManager.java:355)
        at com.trolltech.qt.Utilities.loadQtLibrary(Utilities.java:140)
        at com.trolltech.qt.Utilities.loadQtLibrary(Utilities.java:136)
        at com.trolltech.qt.gui.QtJambi_LibraryInitializer.<clinit>(QtJambi_LibraryInitializer.java:7)
        ... 1 more
Caused by: java.lang.UnsatisfiedLinkError: /tmp/QtJambi_sl70_amd64_4.5.2_01_gcc-20090628-2055/lib/libQtGui.so.4: libpng12.so.0: cannot open shared object file: No such file or directory
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1803)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1699)
        at java.lang.Runtime.load0(Runtime.java:770)
        at java.lang.Runtime.load(Runtime.java:758)
        at com.trolltech.qt.internal.NativeLibraryManager.loadLibrary_helper(NativeLibraryManager.java:458)
        at com.trolltech.qt.internal.NativeLibraryManager.loadNativeLibrary(NativeLibraryManager.java:426)
        ... 5 more
Could not find the main class: cx.fbn.nevernote.NeverNote.  Program will exit.

The included libQtGui.so needs libpng12.so.0, whereas I have libpng14. And the libQtGui.so on my system in /usr/lib64 correctly refers to libpng14.so. I tried prepending LD_PATH=/usr/lib64 to the command to run nevernote, but it didn't do anything.

I have no idea how to deal with these problems in the java context. Does anyone else?

TIA.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2129
Location: Finland

PostPosted: Thu Feb 17, 2011 6:36 pm    Post subject: Reply with quote

Delete the bundled libQtGui.so.4 it came with, or "emerge libpng:1.2"
Back to top
View user's profile Send private message
sl70
Guru
Guru


Joined: 18 Jun 2002
Posts: 337
Location: Chicago, USA

PostPosted: Thu Feb 17, 2011 11:37 pm    Post subject: Reply with quote

Yeah, but the thing is that that file is not there. Here's what's in the source file (among other things):
Code:
./nevernote/usr/share/nevernote/lib/
./nevernote/usr/share/nevernote/lib/log4j.properties
./nevernote/usr/share/nevernote/lib/qtjambi-linux64-gcc-4.5.2_01.jar
./nevernote/usr/share/nevernote/lib/h2-1.2.136.jar
./nevernote/usr/share/nevernote/lib/httpcore-4.0.1.jar
./nevernote/usr/share/nevernote/lib/tika.jar
./nevernote/usr/share/nevernote/lib/commons-codec-1.3.jar
./nevernote/usr/share/nevernote/lib/apache-mime4j-0.6.jar
./nevernote/usr/share/nevernote/lib/poi-scratchpad-3.7-20101029.jar
./nevernote/usr/share/nevernote/lib/httpclient-4.0.3.jar
./nevernote/usr/share/nevernote/lib/commons-lang-2.4.jar
./nevernote/usr/share/nevernote/lib/evernote.jar
./nevernote/usr/share/nevernote/lib/xmlbeans-2.3.0.jar
./nevernote/usr/share/nevernote/lib/jazzy.jar
./nevernote/usr/share/nevernote/lib/commons-logging-1.1.1.jar
./nevernote/usr/share/nevernote/lib/xsdlib-20060615.jar
./nevernote/usr/share/nevernote/lib/jtidy-r938.jar
./nevernote/usr/share/nevernote/lib/jaxen-1.1.3.jar
./nevernote/usr/share/nevernote/lib/poi-3.7-20101029.jar
./nevernote/usr/share/nevernote/lib/log4j-1.2.14.jar
./nevernote/usr/share/nevernote/lib/PDFRenderer.jar
./nevernote/usr/share/nevernote/lib/httpmime-4.0.3.jar
./nevernote/usr/share/nevernote/lib/pdfbox-app-1.3.1.jar
./nevernote/usr/share/nevernote/lib/libthrift.jar
./nevernote/usr/share/nevernote/lib/poi-ooxml-3.7.jar
./nevernote/usr/share/nevernote/lib/qtjambi-linux64-4.5.2_01.jar
./nevernote/usr/share/nevernote/lib/commons-compress-1.1.jar
./nevernote/usr/share/nevernote/lib/poi-ooxml-schemas-3.7-20101029.jar


Then inside qtjambi-linux64-gcc-4.5.2_01.jar is this (among other things):
Code:
  testing: lib/libQtCore.so.4       OK
    testing: lib/libQtGui.so.4        OK
    testing: lib/libQtNetwork.so.4    OK
    testing: lib/libQtOpenGL.so.4     OK
    testing: lib/libQtSql.so.4        OK
    testing: lib/libQtSvg.so.4        OK
    testing: lib/libQtWebKit.so.4     OK
    testing: lib/libQtXml.so.4        OK
    testing: lib/libQtXmlPatterns.so.4   OK
    testing: lib/libcom_trolltech_qt_core.so   OK
    testing: lib/libcom_trolltech_qt_gui.so   OK
    testing: lib/libcom_trolltech_qt_network.so   OK
    testing: lib/libcom_trolltech_qt_opengl.so   OK
    testing: lib/libcom_trolltech_qt_phonon.so   OK
    testing: lib/libcom_trolltech_qt_sql.so   OK
    testing: lib/libcom_trolltech_qt_svg.so   OK
    testing: lib/libcom_trolltech_qt_webkit.so   OK
    testing: lib/libcom_trolltech_qt_xml.so   OK
    testing: lib/libcom_trolltech_qt_xmlpatterns.so   OK
    testing: lib/libphonon.so.4       OK
    testing: lib/libqtjambi.so        OK
    testing: lib/libstdc++.so.6       OK


I don't need to use any of these. I think I have all these files (except maybe libqtjambi.so, and the libcom_trolltech*.so -- what's that?). Maybe I should edit the ebuild to delete all these files after unpacking and before compiling....
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9011
Location: beyond the rim

PostPosted: Fri Feb 18, 2011 2:10 am    Post subject: Reply with quote

I don't think there is an easy fix for this other than installing the old libpng, as the QT libs are most likely loaded by the java code and not the libc linker.
Back to top
View user's profile Send private message
baumgarr
n00b
n00b


Joined: 18 Feb 2011
Posts: 1
Location: OH

PostPosted: Fri Feb 18, 2011 2:38 pm    Post subject: Reply with quote

Sorry you are having problems.

There are two things you could try. On SourceForge you can find the 4.7 version of Jambi. It is in beta (which is why it isn't used by NeverNote now), but it might use the newer libraries. You'll need to copy the jar files some place and then update /usr/share/nevernote/nevernote.sh to use the new jar files. Jambi 4.5 had two jar files, but 4.7 has three so you'll need to add another line. NeverNote should work with anything after 4.5.

The other option (and more difficult) would be to rebuild Jambi. I've never done it but there is a user mailing list which might be able to help you with it.
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Fri Feb 18, 2011 3:12 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software, it's not in the Portage tree so it's not officially supported.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Quirocha
n00b
n00b


Joined: 29 Jun 2008
Posts: 3

PostPosted: Sat Feb 19, 2011 1:00 am    Post subject: Reply with quote

Well, i was having the same problem.

Noticed that the issue was with the qt-jambi libraries. After reading in other forums i realized that qt-jambi wasn't loading with lateste libpng (like was said before) and that's because stable versions are build agains libpng.12 : you either can load that library previously to the evernote -> http://www.mail-archive.com/qt-jambi-interest@trolltech.com/msg01968.html

or download latest qt-jambi at http://sourceforge.net/projects/qtjambi/files/

Untar and then i copied the qtjambi-4.7.0.jar and qtjambi-macosx-gcc-4.7.0.jar to the $evernote/lib/
Then went to $evernote/evernote.sh and adjusted the libraries name.

then i get the following error
Code:
sh nevernote.sh
Exception in thread "main" java.lang.ExceptionInInitializerError: qtjambi.version is not set!
        at com.trolltech.qt.Utilities.<clinit>(Utilities.java:79)
        at com.trolltech.qt.QtJambi_LibraryInitializer.<clinit>(QtJambi_LibraryInitializer.java:55)
        at com.trolltech.qt.QtJambiObject.<clinit>(QtJambiObject.java:60)
Could not find the main class: cx.fbn.nevernote.NeverNote.  Program will exit.
/usr/share/nevernote


Also around the readings ( in: http://aur.archlinux.org/packages.php?ID=41226&detail=1 ) i've read that was a java-vm compatibility error:
Quote:
change java-runtime to openjdk so people don't got any error message again.

I'm guessing this could be the problem in starting up the "old" qt-jambi version

I'll keep trying, if someone solves this up, please post it.
Sorry my ways but i'm not an expert. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum