Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xfce4 4.8 and missing libs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Boczkowski_D
Apprentice
Apprentice


Joined: 06 Aug 2007
Posts: 160
Location: Poland

PostPosted: Tue Feb 01, 2011 9:39 pm    Post subject: Xfce4 4.8 and missing libs Reply with quote

Hello,
I have just upgraded Xfce4 to 4.8 version but then most of xfce apps stopped working. Revdep-rebuild showed that mainly two libs are missing:
libxfce4panel.so.1
libexo-0.3.so.1

But rebulding apps from xfce-extra package is not possible as they are removed from portage tree. How can I fix it?
Back to top
View user's profile Send private message
Ion Silverbolt
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 203

PostPosted: Tue Feb 01, 2011 10:16 pm    Post subject: Reply with quote

Did you try emerging the unstable version of exo beforehand?


I'm not sure if it's the wisest idea, but in my package.keywords file, I have xfce-base and xfce-extra listed as below since I just use the latest anything that is xfce related. Some of the older applets and stuff don't work with Xfce4.8

Code:
xfce-base/* ~x86
xfce-extra/* ~x86


emerge -DNu world after that +revdep-rebuild after that I think will take care of your issue.
Back to top
View user's profile Send private message
Boczkowski_D
Apprentice
Apprentice


Joined: 06 Aug 2007
Posts: 160
Location: Poland

PostPosted: Tue Feb 01, 2011 10:38 pm    Post subject: Reply with quote

I didn't emerge unstable exo. It was updated to 0.6.0 version.

Adding those entries to package.keywords didn't change a possibility for rebuilding old stuff. Without exo-0.3 I am not even able to run xfce-terminal...
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2132
Location: Finland

PostPosted: Tue Feb 01, 2011 10:39 pm    Post subject: Re: Xfce4 4.8 and missing libs Reply with quote

Boczkowski_D wrote:
Hello,
I have just upgraded Xfce4 to 4.8 version but then most of xfce apps stopped working. Revdep-rebuild showed that mainly two libs are missing:
libxfce4panel.so.1
libexo-0.3.so.1

But rebulding apps from xfce-extra package is not possible as they are removed from portage tree. How can I fix it?


They were removed for a reason, so emerge -C those that are not in tree anymore.
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Thu Feb 03, 2011 9:27 am    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads, please follow up to Xfce 4.8.0.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum