Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ck 4.3 and GNOME
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Galumph
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2010
Posts: 122
Location: Israel

PostPosted: Thu Jan 20, 2011 3:42 pm    Post subject: ck 4.3 and GNOME Reply with quote

Upgraded to consolekit 0.4.3 (I was on 0.4.1 previously.), and now various functions in GNOME aren't working properly. I can't mount usb drives, shutdown/reboot, and all that jazz. I've spent a couple of weeks trying to fix it, and I was hoping y'all could give me hand. Any ideas?
Back to top
View user's profile Send private message
dlaor
n00b
n00b


Joined: 27 Jan 2008
Posts: 42

PostPosted: Sat Jan 22, 2011 1:58 pm    Post subject: Reply with quote

What login manager are you using? If you're using one different from GDM, e.g. slim, qingy, etc... then the following may be helpful. (I use slim and had the same problem.)

See Samuli Suominen's comment in

http://bugs.gentoo.org/show_bug.cgi?id=348668

also see

http://bugs.gentoo.org/show_bug.cgi?id=342345

Hope that helps!
Back to top
View user's profile Send private message
Galumph
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2010
Posts: 122
Location: Israel

PostPosted: Sat Jan 29, 2011 9:19 am    Post subject: Reply with quote

So all I need to do is remove nox11 from /etc/pam.d/system-login? It doesn't seem to work.
Code:

# cat /etc/pam.d/system-login > ./system-login.bck
# sed 's/nox11//g' /etc/pam.d/system-login
# logout
$ startx

Using startx by the way, I've never liked login managers to much.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2129
Location: Finland

PostPosted: Sat Jan 29, 2011 9:56 am    Post subject: Reply with quote

duplicate thread of http://forums.gentoo.org/viewtopic-t-858965-highlight-.html
Back to top
View user's profile Send private message
Galumph
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2010
Posts: 122
Location: Israel

PostPosted: Sun Jan 30, 2011 4:12 pm    Post subject: Reply with quote

I wouldn't call it a duplicate, but whatever. Anyway, everything seems to be working so far, thanks.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2129
Location: Finland

PostPosted: Sun Jan 30, 2011 5:06 pm    Post subject: Reply with quote

Galumph wrote:
I wouldn't call it a duplicate, but whatever. Anyway, everything seems to be working so far, thanks.


well it really is, but I didn't mean it in any bad way... so don't get me wrong :)

glad to hear it's working
Back to top
View user's profile Send private message
Galumph
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2010
Posts: 122
Location: Israel

PostPosted: Sun Jan 30, 2011 6:11 pm    Post subject: Reply with quote

OK I lied. Portage is... confused?
I've got hal masked, and both udisks and polkit keyworded and at versions 1.0.2 and 0.99 respectively. gnome-polkit wants polkit at version .96, and for some reason portage is trying to downgrade udisks. I've cleaned up my world my file yesterday, and it seems to be causing trouble.
Anyway, it all looks like this:
Code:

# emerge -uDp world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD] sys-auth/polkit-0.96-r2 [0.99]
[ebuild     UD] sys-fs/udisks-1.0.1-r1 [1.0.2]
[ebuild  N    ] x11-terms/gnome-terminal-2.30.2

!!! One or more updates have been skipped due to a dependency conflict:

sys-auth/polkit:0

  (sys-auth/polkit-0.99-r1, ebuild scheduled for merge) conflicts with
    <sys-auth/polkit-0.99 required by (gnome-extra/polkit-gnome-0.96-r1, installed)


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

sys-fs/udisks:0

!!! Problems have been detected with your world file
!!! Please run emaint --check world


!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
gnome-base/gnome-volume-manager

I'll try and see what portage wants with my world file.

e, Alright, I had emaint fix the world file (It didn't seem to do anything), but I still get a message about it having problems.


Last edited by Galumph on Sun Jan 30, 2011 6:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2129
Location: Finland

PostPosted: Sun Jan 30, 2011 6:15 pm    Post subject: Reply with quote

You need both polkit, and polkit-gnome in package.keywords to get matching 0.99 versions.
And if you have udisks and upower keyworded, they need more recent dev-libs/glib keyworded too.
And finally you can emerge -C gnome-volume-manager as it's obsolete and removed from Portage while back.
Back to top
View user's profile Send private message
Galumph
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2010
Posts: 122
Location: Israel

PostPosted: Sun Jan 30, 2011 6:38 pm    Post subject: Reply with quote

Looks like I've got another package trying to downgrade everything.
Code:

# emerge -uDp world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD] sys-auth/polkit-0.96-r2 [0.99]
[ebuild     UD] gnome-extra/polkit-gnome-0.96-r1 [0.99] USE="-debug%"
[ebuild     UD] sys-fs/udisks-1.0.1-r1 [1.0.2]
[ebuild     UD] sys-power/upower-0.9.5 [0.9.8]

!!! One or more updates have been skipped due to a dependency conflict:

sys-auth/polkit:0

  (sys-auth/polkit-0.99-r1, ebuild scheduled for merge) conflicts with
    <sys-auth/polkit-0.97 required by (sys-power/upower-0.9.5, ebuild scheduled for merge)

sys-power/upower:0

  (sys-power/upower-0.9.8, ebuild scheduled for merge) conflicts with
    <sys-power/upower-0.9.6 required by (gnome-base/gnome-session-2.30.2, installed)


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

gnome-extra/polkit-gnome:0
sys-fs/udisks:0

Should I keyword gnome-session too? I mean, how stable is it?

e, Keywording gnome-session complicates things even more:
Code:

# ACCEPT_KEYWORDS=~x86 emerge -p gnome-session

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] x11-libs/gdk-pixbuf-2.22.1  USE="X jpeg tiff -debug -doc (-introspection) -jpeg2k -test"
[ebuild     U ] x11-libs/gtk+-2.22.1-r1 [2.20.1-r1] USE="-examples%"
[blocks b     ] <x11-libs/gtk+-2.21.3:2 ("<x11-libs/gtk+-2.21.3:2" is blocking x11-libs/gdk-pixbuf-2.22.1)
[ebuild     U ] gnome-base/gnome-session-2.32.1 [2.30.2]
[blocks B     ] <gnome-base/librsvg-2.31.0 ("<gnome-base/librsvg-2.31.0" is blocking x11-libs/gdk-pixbuf-2.22.1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (gnome-base/librsvg-2.26.3, installed) pulled in by
    >=gnome-base/librsvg-2.26.3 required by (gnome-base/gnome-2.30.2-r1, installed)
    >=gnome-base/librsvg-2.9.0 required by (media-video/vlc-1.1.6, installed)
    >=gnome-base/librsvg-2.0 required by (app-editors/emacs-23.2-r2, installed)
    (and 10 more)

  (x11-libs/gdk-pixbuf-2.22.1, ebuild scheduled for merge) pulled in by
    x11-libs/gdk-pixbuf:2[X,jpeg,tiff] required by (x11-libs/gtk+-2.22.1-r1, ebuild scheduled for merge)
    x11-libs/gdk-pixbuf:2 required by (media-libs/libgpod-0.8.0, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Mon Jan 31, 2011 3:57 pm    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads, please follow up to Tips, and tricks for ConsoleKit/PolicyKit/udev, without hal.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum