Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Conexão recusada.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
aleixoreis
n00b
n00b


Joined: 18 Jul 2008
Posts: 32
Location: rio de janeiro

PostPosted: Fri Jan 07, 2011 2:02 am    Post subject: Conexão recusada. Reply with quote

Oi, pessoal:
Estou com o seguinte problema ao carregar o Gentoo, porque aparece :

Starting eth0
Loading networking modules for eth0
modules: apipa arping ccwgroup iptunnel macchanger macnet rename ifconfig autoipd system dhcpcd ip6to4
ifconfig provides interface
dhcpcd provides dhcp
Configuring eth0 for mac address 70:00:AC:BB:ED:56
Bringing up eth0
dhcp
Running dhcpcd
dhcpcd [3108]: open_control: Connection refused
" " :version 5.2.8 starting
" " :eth0:waiting for carrier
" " :eth0:carrier acquired
" " :eth0:rebinding lease for 192.168.1.100
" " :eth0:acknowledged 192.168.1.100 from 192.168.1.1
" " :eth0:checking for 192.168.1.100
" " :eth0:leased 192.168.1.100 for 86400 seconds
" " :forked background child pid 3146
eth0 received address 192.168.1.100/24

Estou desde 31/12/10 sem Internet e tentando uma solução.Já procurei exaustivamente e nada.
Qualquer idéia ou sugestão será benvinda.

[ ]'s.

P.S. Esta situação apareceu de repente e eu não tinha alterado nada no sistema.
Informo, também, que o mesmo ocorre com outro Gentoo instalado em outro HD.
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4730
Location: Angra do Heroísmo (PT)

PostPosted: Mon Jan 10, 2011 12:06 pm    Post subject: Re: Conexão recusada. Reply with quote

Boas.

aleixoreis wrote:

dhcpcd [3108]: open_control: Connection refused


Vamos precisar de mais alguns detalhes. Que versão do kernel e baselayout? Está a usar o openrc? Inclua também os detalhes do emerge --info.
Para fazer diagnósticos, tem mais algum computador nessa rede? Explique o tipo de ligação que tem. Já tentou configurar um IP manual na máquina? Outra máquina na rede obtêm IP? Se tem outro SO nessa máquina, ele obtêm IP?
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
aleixoreis
n00b
n00b


Joined: 18 Jul 2008
Posts: 32
Location: rio de janeiro

PostPosted: Tue Jan 11, 2011 5:02 pm    Post subject: Reply with quote

Prezado jmbsvicetto:

Estou agradecido pelo seu interesse e respondo às perguntas:

baselayout-1.12.14-r1
openrc está "masked" para x86.
kernel: linux-2.6.36-gentoo-r5
Computadores da rede: dois com conexão por fio e um com conexão wireless; estão ligados com um modem/roteador Linksys WAG120N.
Os outros computadores acessam a Internet perfeitamente.
O SOs Ubuntu e Windows funcionam sem problemas.

emerge --info :
Portage 2.1.9.25 (default/linux/x86/10.0, gcc-4.1.2, glibc-2.11.2-r3, 2.6.36-gentoo-r5 i686)
=================================================================
System uname: Linux-2.6.36-gentoo-r5-i686-Intel-R-_Core-TM-_i5_CPU_650_@_3.20GHz-with-gentoo-1.12.14
Timestamp of tree: Tue, 11 Jan 2011 00:45:01 +0000
app-shells/bash: 4.1_p7
dev-java/java-config: 2.1.11-r1
dev-lang/python: 2.4.6, 2.5.4-r4, 2.6.6-r1, 3.1.2-r4
dev-util/cmake: 2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox: 2.4
sys-devel/autoconf: 2.13, 2.65-r1
sys-devel/automake: 1.5, 1.8.5-r3, 1.9.6-r2, 1.10.3, 1.11.1
sys-devel/binutils: 2.20.1-r1
sys-devel/gcc: 4.1.2, 4.3.4, 4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.2.10
sys-devel/make: 3.81-r2
virtual/os-headers: 2.6.30-r1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=prescott -O2 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs buildpkg ccache collision-protect distlocks fixlafiles fixpackages metadata-transfer news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://www.las.ic.unicamp.br/pub/gentoo/ / http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/"
LANG="C"
LC_ALL="pt_BR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="pt_BR en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.samerica.gentoo.org/gentoo-portage"
USE="/ X acl alsa avahi berkdb bzip2 cairo cdr cli consolekit cracklib crypt cups cupsddk cxx dbus device-mapper dri dvdr encode esd extensions extras ffmpeg firefox foomaticdb fortran gdbm gdu gnome gpm gtk hal howl iconv imlib ipv6 java jpeg kde mdnsresponder-compat mmx modules mudflap ncurses nls nm nptl nptlonly nsplugin nss ogg opengl openmp oss pam pcre perl png policykit ppds pppd pygtk python qt3 qt3support readline scanner session slit ssl svg sysfs tcpd theora tiff toolbar truetype udev unicode vorbis x86 xml xorg xscreensaver xulrunner xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pt_BR en_US" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa fbdev fgrlx nv" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Outrossim, digo que estou conectado agora usando o Gentoo! Como? Vou tentar explicar algo que acontece apesar de não entender o porquê.

1° cenário:
- cupsd carregando como default.
-não há conexão com a Internet.
-impressora (HP Deskjet F4280) funciona.

2º cenário:
-cupsd carregando como default.
-serviços carregando no boot de modo interativo.
-internet com conexão.
-impressora não funciona. hp-check informa que não encontra cups.

3° cenário:
-cupsd desativado para carregamento.( rc-update del cupsd )
-serviços carregando no boot de modo interativo.
-Internet com conexão.
-para ter impressora: /etc/init.d/cupsd start .


Espero ter sido entendido e, por favor, pergunte o que for necessário.

[ ]'s.
Back to top
View user's profile Send private message
aleixoreis
n00b
n00b


Joined: 18 Jul 2008
Posts: 32
Location: rio de janeiro

PostPosted: Wed Jan 12, 2011 12:15 am    Post subject: Reply with quote

Prezado jmbsvicetto:

Por acaso resolvi o problema.
Desativei os serviços de firewall e iptables e tudo voltou ao normal.

Porque fiz isso? Não tenho uma razão lógica. Foi apenas por intuição e deu certo.

Meu conhecimento do SO Gentoo é incipiente e me vejo como um aprendiz que ainda sabe bem pouco.

Mais uma vez agradeço, sensibilizado, pelo seu interesse.

[ ]'s.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum