Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] KDM keymap
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
meklu
n00b
n00b


Joined: 05 Dec 2010
Posts: 8
Location: Helsinki, Finland

PostPosted: Mon Dec 20, 2010 3:40 pm    Post subject: [SOLVED] KDM keymap Reply with quote

EDIT: To fix this, I edited /usr/share/config/kdm/Xsetup to include my desired commands:
Code:
#! /bin/sh
# Xsetup - run as root before the login dialog appears

#xconsole -geometry 480x130-0-0 -notify -verbose -fn fixed -exitOnFail -file /dev/xconsole &
setxkbmap fi
setxkbmap -option terminate:ctrl_alt_bksp
xmodmap "/etc/X11/xinit/Xmodmap"
numlockx on

___________________

I would like KDM to load a custom keymap (/etc/X11/xinit/Xmodmap) instead of the US keymap which it forces on by default.
I have read through a couple of config files but haven't found a way to alter this behaviour.


Last edited by meklu on Wed Dec 22, 2010 4:03 pm; edited 5 times in total
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2744
Location: Hamburg/Germany

PostPosted: Mon Dec 20, 2010 3:52 pm    Post subject: Reply with quote

Systems settings -> Personal -> Keyboard layout
At the command line sth. like :
Code:
setxkbmap -option terminate:ctrl_alt_bksp
setxkbmap -model pc105 -layout de -variant nodeadkeys
which BTW can be scripted/automated via ~/.kde4/Autostart/.
Back to top
View user's profile Send private message
meklu
n00b
n00b


Joined: 05 Dec 2010
Posts: 8
Location: Helsinki, Finland

PostPosted: Mon Dec 20, 2010 4:07 pm    Post subject: Reply with quote

toralf wrote:
Systems settings -> Personal -> Keyboard layout
At the command line sth. like :
Code:
setxkbmap -option terminate:ctrl_alt_bksp
setxkbmap -model pc105 -layout de -variant nodeadkeys
which BTW can be scripted/automated via ~/.kde4/Autostart/.


Umm...
I meant I want KDM to use a custom keymap, i.e. when typing the username and password.
I have the keyboard layout correct in KDE and Fluxbox.
Back to top
View user's profile Send private message
Rüpel
Guru
Guru


Joined: 06 Nov 2002
Posts: 316
Location: Berlin/Germany

PostPosted: Tue Dec 21, 2010 9:23 am    Post subject: Reply with quote

I'm facing exactly the same issue. It never was a problem, until the last kdelibs 4.4.5 update a few days ago.

When I switch back to the terminal, the keyboard layout is correct as it is set in /etc/conf.d/keymaps.

In the past, I also didn't have to change any keyboard settings inside KDE, it worked right out of the box with my german keyboard.

So what changed in that last kdelibs build? I think I remember that the hal useflag is not set anymore (and in fact it is marked as deprecated). So if hal worked for me in the past, what should be working for me in the future? Did I miss an important news item?
_________________
:wq
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2744
Location: Hamburg/Germany

PostPosted: Tue Dec 21, 2010 9:52 am    Post subject: Reply with quote

AFAIK the hal USE flag was removed from default profile (probably due to the stabilization of xorg-server). Therefore you should either add this flag via /etc/portage/package.use/<foo> or maybe upgrading to the new unstable xorg-server 1.9.2 (which I did few days ago w/o any problems) helps too.
Back to top
View user's profile Send private message
meklu
n00b
n00b


Joined: 05 Dec 2010
Posts: 8
Location: Helsinki, Finland

PostPosted: Tue Dec 21, 2010 5:17 pm    Post subject: Reply with quote

toralf wrote:
AFAIK the hal USE flag was removed from default profile (probably due to the stabilization of xorg-server). Therefore you should either add this flag via /etc/portage/package.use/<foo> or maybe upgrading to the new unstable xorg-server 1.9.2 (which I did few days ago w/o any problems) helps too.


I'm already running ~amd64 and have xorg-server-1.9.2.902 and KDE 4.5.4.
Back to top
View user's profile Send private message
meklu
n00b
n00b


Joined: 05 Dec 2010
Posts: 8
Location: Helsinki, Finland

PostPosted: Wed Dec 22, 2010 3:58 pm    Post subject: Reply with quote

I took another look at /usr/share/config/kdm/kdmrc, and found out that /usr/share/config/kdm/Xsetup is the file where I can put my keymap commands.
Thanks for all the help, marking as solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum