Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ati-drivers-10.10, xorg-server 1.9, kernel 2.6.36
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
DestroyFX
n00b
n00b


Joined: 05 Dec 2005
Posts: 37

PostPosted: Tue Oct 12, 2010 7:29 am    Post subject: ati-drivers-10.10, xorg-server 1.9, kernel 2.6.36 Reply with quote

**************** EXPERIMENTAL *****************
************ XORG-SERVER 1.9 ONLY *************
*********************************************

Hi all ATI users!

I have updated my ebuild for ati-drivers 10.10 on my overlay : gentoo-quebec

I made patch for kernel 2.6.36 AND kernel 2.6.35-
I have tested with 2.6.36 and xorg 1.9 but I did not got the time for testing 2.6.35-, if someone do, please feedback :)

Will not work on xorg-server 1.8 and less

What's new :
- "working" Vsync
- "working" 2D acceleration
- kernel 2.6.36 (from two of my small patchs)
* Kernel module build fix for x86_64 kernels with security fix for CVE-2010-3081
* Generalized kernel module build fix for CVE-2010-3081 to work on RHEL and SLED/SUSE
* Ubuntu 10.10 early-look support (Xserver 1.9 support)
* Updated packaging scripts to support Ubuntu
10.10
* openSUSE 11.3 production support
* Fixed packaging scripts for SLED/SUSE
* Updated packaging scripts
* Checks for available video memory in CCC-LE before allowing to enable memory-intensive features
* Fixed Xserver segfaults and soft hangs when VT switching back to X
* Fixed missing CCC-LE icons in the System-Preferences menu
* Fixed corruption in Xinerama mode
* Fixed CCC-LE Gamma correction applied to wrong displays on openSUSE 11.3
* Fixed text corruption in Steam games
* Added missing maverick symlink in Ubuntu packaging script directory
* Fixed X version detection problems in installer, fixes installation
on Fedora 11
Back to top
View user's profile Send private message
ssteinberg
Apprentice
Apprentice


Joined: 09 Jul 2010
Posts: 206
Location: Israel

PostPosted: Tue Oct 12, 2010 8:47 pm    Post subject: Reply with quote

Tried it with Xorg 1.9 kernel 2.6.35.7. It works but for some reason windows, when moved around in KDE with desktop effects, just float after the mouse. Very annoying.
Back to top
View user's profile Send private message
ssteinberg
Apprentice
Apprentice


Joined: 09 Jul 2010
Posts: 206
Location: Israel

PostPosted: Tue Oct 12, 2010 8:55 pm    Post subject: Reply with quote

And fglrx still requires a bit more CPU when playing video. At least vsync is actually fixed...
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5743
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Oct 14, 2010 1:46 pm    Post subject: Reply with quote

something's not working right:
layman -a gentoo-quebec wrote:

* Running... # /usr/bin/svn co https://gentoo-quebec.org/svn/gentoo-quebec/trunk/overlay//@ /usr/local/portage/layman/gentoo-quebec
svn: OPTIONS of 'https://gentoo-quebec.org/svn/gentoo-quebec/trunk/overlay': SSL handshake failed: SSL error: A TLS warning alert has been received. (https://gentoo-quebec.org)
* Deleting _empty_ directory "/usr/local/portage/layman/gentoo-quebec"
* Failed to add overlay "gentoo-quebec".
* Error was: Adding overlay "gentoo-quebec" failed!

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.3.0-r2
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
Da_G
n00b
n00b


Joined: 01 Nov 2006
Posts: 12

PostPosted: Thu Oct 14, 2010 10:08 pm    Post subject: Reply with quote

It's probably failing silently rather than prompting you due to this certificate error:

Error validating server certificate for 'https://gentoo-quebec.org:443':
- The certificate hostname does not match.
Certificate information:
- Hostname: secure.urent.org
- Valid: from Fri, 15 Jan 2010 20:38:02 GMT until Tue, 15 Jan 2013 20:38:02 GMT
- Issuer: 07969287, http://certificates.godaddy.com/repository, GoDaddy.com, Inc., Scottsdale, Arizona, US
- Fingerprint: 8b:9a:ac:49:d8:42:f4:6a:6b:b6:82:f7:b9:66:6a:6d:79:f1:ef:84
(R)eject, accept (t)emporarily or accept (p)ermanently?
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1149

PostPosted: Sat Oct 16, 2010 6:58 pm    Post subject: Reply with quote

Hi DestroyFX,

thank you very match for this ebuild.
The ebuild does not fit yet. It seems to be missing some more patches?
Is it the x86_64 ioctl error?

Code:

>>> Unpacking source...
>>> Unpacking fglrx-installer_8.780.orig.tar.gz to /var/tmp/portage/x11-drivers/ati-drivers-10.10/work
>>> Source unpacked in /var/tmp/portage/x11-drivers/ati-drivers-10.10/work
>>> Preparing source in /var/tmp/portage/x11-drivers/ati-drivers-10.10/work ...
* Kernel < 2.6.36 detected, Still More patching needed stupid dev :)
 * Applying arch-2.6.35_et_moins.patch ...                                                                                                                                              [ ok ]
 * Applying ati-drivers-fix_compilation-bug-297322.patch ...                                                                                                                            [ ok ]
 * Applying ati-powermode-opt-path-2.patch ...                                                                                                                                          [ ok ]
 * Converting 2.6.x/Makefile to use M= instead of SUBDIRS= ...                                                                                                                          [ ok ]
>>> Unpacking ./../usr/src/ati/fglrx_sample_source.tgz to /var/tmp/portage/x11-drivers/ati-drivers-10.10/work/extra
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-drivers/ati-drivers-10.10/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-drivers/ati-drivers-10.10/work ...
 * Preparing fglrx module
make -j7 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS= GCC_VER_MAJ=4 KVER=2.6.35-gentoo-r9 KDIR=/usr/src/linux kmod_build
make -C /usr/src/linux M=/var/tmp/portage/x11-drivers/ati-drivers-10.10/work/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-2.6.35-gentoo-r9'
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-10.10/work/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-10.10/work/lib/modules/fglrx/build_mod/2.6.x/kcl_agp.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-10.10/work/lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-10.10/work/lib/modules/fglrx/build_mod/2.6.x/kcl_debug.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-10.10/work/lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-10.10/work/lib/modules/fglrx/build_mod/2.6.x/kcl_io.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-10.10/work/lib/modules/fglrx/build_mod/2.6.x/kcl_pci.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-10.10/work/lib/modules/fglrx/build_mod/2.6.x/kcl_str.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-10.10/work/lib/modules/fglrx/build_mod/2.6.x/kcl_wait.o
/var/tmp/portage/x11-drivers/ati-drivers-10.10/work/lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.c: In function 'KCL_IOCTL_AllocUserSpace32':
/var/tmp/portage/x11-drivers/ati-drivers-10.10/work/lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.c:196: error: implicit declaration of function 'compat_alloc_user_space'
/var/tmp/portage/x11-drivers/ati-drivers-10.10/work/lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.c:196: warning: initialization makes pointer from integer without a cast
make[2]: *** [/var/tmp/portage/x11-drivers/ati-drivers-10.10/work/lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [_module_/var/tmp/portage/x11-drivers/ati-drivers-10.10/work/lib/modules/fglrx/build_mod/2.6.x] Fehler 2
make[1]: Leaving directory `/usr/src/linux-2.6.35-gentoo-r9'
make: *** [kmod_build] Fehler 2
emake failed
 * ERROR: x11-drivers/ati-drivers-10.10 failed:
 *   Unable to emake HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS=  GCC_VER_MAJ=4 KVER=2.6.35-gentoo-r9 KDIR=/usr/src/linux kmod_build
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 3725:  Called linux-mod_src_compile
 *   environment, line 2878:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"                   CROSS_COMPILE=${CHOST}-                   LDFLAGS=\"$(get_abi_LDFLAGS)\"                   ${BUILD_FIXES}                   ${BUILD_PARAMS}                   ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CROSS_COMPILE=${CHOST}- LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *
 * If you need support, post the output of 'emerge --info =x11-drivers/ati-drivers-10.10',
 * the complete build log and the output of 'emerge -pqv =x11-drivers/ati-drivers-10.10'.
 * This ebuild is from an overlay named 'lokal': '/usr/local/portage/'
 * The complete build log is located at '/var/lib/entropy/logs/x11-drivers:ati-drivers-10.10:20101016-184148.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/ati-drivers-10.10/temp/environment'.
 * S: '/var/tmp/portage/x11-drivers/ati-drivers-10.10/work'

>>> Failed to emerge x11-drivers/ati-drivers-10.10, Log file:

>>>  '/var/lib/entropy/logs/x11-drivers:ati-drivers-10.10:20101016-184148.log'


thanks again.

Ma
_________________
Test Adobe Flash Player
The Indian Shankar Drum Ganesh Machine
Back to top
View user's profile Send private message
ssteinberg
Apprentice
Apprentice


Joined: 09 Jul 2010
Posts: 206
Location: Israel

PostPosted: Sat Oct 16, 2010 7:42 pm    Post subject: Reply with quote

Yeah, got this too with the 2.6.35 kernel. Ended up making a copy of the ebuild in the local overlay and modifying the arch-2.6.35_et_moins.patch patch to:
Code:
diff -aur orig/lib/modules/fglrx/build_mod/kcl_ioctl.c final/lib/modules/fglrx/build_mod/kcl_ioctl.c
--- orig/lib/modules/fglrx/build_mod/kcl_ioctl.c        2010-09-22 03:15:33.000000000 -0400
+++ final/lib/modules/fglrx/build_mod/kcl_ioctl.c       2010-10-12 02:58:37.685811001 -0400
@@ -193,7 +193,7 @@
  */
 void* ATI_API_CALL KCL_IOCTL_AllocUserSpace32(long size)
 {
-    void __user *ret = COMPAT_ALLOC_USER_SPACE(size);
+    void __user *ret = arch_compat_alloc_user_space(size);

     /* prevent stack overflow */
     if (!access_ok(VERIFY_WRITE, ret, size))


Temporary solution. Getting lots of trouble with those drivers so far. Waiting for final 10.10.
Back to top
View user's profile Send private message
DestroyFX
n00b
n00b


Joined: 05 Dec 2005
Posts: 37

PostPosted: Sun Oct 17, 2010 3:33 am    Post subject: Reply with quote

I see.

So they backported the big hole fix in the 2.6.35 kernel. (I did not see this one, I work only with GIT kernel)

The 2.6.36 patch is the same that the one ssteinberg modified so I will need to detect with revision of the 2.6.35 is installed and use the good patch...
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1149

PostPosted: Sun Oct 17, 2010 1:02 pm    Post subject: Reply with quote

Hi ssteinberg,

I found Catalyst für Linux BETA 8.783 rc1 in the german ati forum

http://www.ati-forum.de/allgemein/downloads/treiber/3269-catalyst-10-10-beta-f%C3%BCr-linux/

and it works well.

tux# fglrxinfo wrote:

display: :0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 5700 Series
OpenGL version string: 4.0.10243 Compatibility Profile Context


tux # fgl_glxgears wrote:

Using GLX_SGIX_pbuffer
13474 frames in 5.0 seconds = 2694.800 FPS
15581 frames in 5.0 seconds = 3116.200 FPS
15561 frames in 5.0 seconds = 3112.200 FPS
15547 frames in 5.0 seconds = 3109.400 FPS
15548 frames in 5.0 seconds = 3109.600 FPS
15589 frames in 5.0 seconds = 3117.800 FPS
15516 frames in 5.0 seconds = 3103.200 FPS
..... smal

..... big
8810 frames in 5.0 seconds = 1762.000 FPS
8807 frames in 5.0 seconds = 1761.400 FPS
8808 frames in 5.0 seconds = 1761.600 FPS
8808 frames in 5.0 seconds = 1761.600 FPS
8810 frames in 5.0 seconds = 1762.000 FPS
8807 frames in 5.0 seconds = 1761.400 FPS



Ma


OS: Gentoo Base System release 2.0.1, Kernel: 2.6.35-gentoo-r9 (x86_64), Desktop: GNOME 2.30.2, Display Server: X.Org Server 1.9.0.901 (1.9.1 RC 1), 6.13.99, OpenGL: 2.1 Mesa 7.10-devel, Screen Resolution: 1920x1080
_________________
Test Adobe Flash Player
The Indian Shankar Drum Ganesh Machine
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 840
Location: halmstad

PostPosted: Fri Oct 22, 2010 6:07 pm    Post subject: Reply with quote

DestroyFX

tanks :!: :!: :!:

mybox ~ # emerge -av xorg-server ati-drivers

* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] x11-base/xorg-server-1.9.0.902 USE="ipv6 nptl udev xorg -dmx -doc -kdrive -minimal -static-libs -tslib" 0 kB [0]
[ebuild R ] x11-drivers/ati-drivers-10.10 USE="modules (multilib) qt4 -debug" 0 kB [1]

Total: 2 packages (2 reinstalls), Size of downloads: 0 kB
Portage tree and overlays:
[0] /usr/portage
[1] /var/lib/layman/gentoo-quebec

Would you like to merge these packages? [Yes/No] n

Quitting.


* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

mybox ~ # uname -a
Linux mybox 2.6.36-rc8-git5 #3 SMP Fri Oct 22 19:49:02 GMT 2010 x86_64 AMD Phenom(tm) II X6 1055T Processor AuthenticAMD GNU/Linux
mybox ~ #
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5743
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Oct 22, 2010 10:37 pm    Post subject: Reply with quote

official catalyst 10.10 is out :!:
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.3.0-r2
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
DestroyFX
n00b
n00b


Joined: 05 Dec 2005
Posts: 37

PostPosted: Tue Nov 02, 2010 3:22 am    Post subject: Reply with quote

I have updated the ebuild for the kernel 2.6.37-rc1. A new mini patch was required (currently I dont have any problem).

I was not able to update the overlay because someone in charge fucked it up or something append so here the file to manually update it :
ebuild : http://www.cosmicencounter.net/mirror/patch/ati-drivers-10.10.ebuild
New patch : http://www.cosmicencounter.net/mirror/patch/sema_init.patch

If you never used Gentoo-quebec overlay, you need ati-drivers-2.6.36.patch, arch-2.6.36.patch, arch-2.6.35_et_moins.patch.

PS : Can someone point me out the procedure to register an overlay for layman (so I will not depend on someone else.)?
Back to top
View user's profile Send private message
ComaWhite
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 125

PostPosted: Tue Nov 02, 2010 6:06 am    Post subject: Reply with quote

Shouldn't it be amd-drivers since ati was changed to amd now? Thank you for the drivers also.
Back to top
View user's profile Send private message
ssteinberg
Apprentice
Apprentice


Joined: 09 Jul 2010
Posts: 206
Location: Israel

PostPosted: Tue Nov 02, 2010 8:56 am    Post subject: Reply with quote

ComaWhite wrote:
Shouldn't it be amd-drivers since ati was changed to amd now? Thank you for the drivers also.


ATi was acquired by AMD. It is still ATi though.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5743
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Nov 02, 2010 9:15 am    Post subject: Reply with quote

DestroyFX wrote:
I have updated the ebuild for the kernel 2.6.37-rc1. A new mini patch was required (currently I dont have any problem).

I was not able to update the overlay because someone in charge fucked it up or something append so here the file to manually update it :
ebuild : http://www.cosmicencounter.net/mirror/patch/ati-drivers-10.10.ebuild
New patch : http://www.cosmicencounter.net/mirror/patch/sema_init.patch

If you never used Gentoo-quebec overlay, you need ati-drivers-2.6.36.patch, arch-2.6.36.patch, arch-2.6.35_et_moins.patch.

PS : Can someone point me out the procedure to register an overlay for layman (so I will not depend on someone else.)?


just a heads up :idea:

you better have a backup of your value data:

I also used 2.6.37 (shortly before rc1) and observed silent data corruption where /etc/init.d/killprocs, gcc, my /root/.bash_history and other valuable stuff disappeared (was zeroed or didn't exist anymore)

this was on ext4 for /root - luckily my /home-partition didn't show any data loss :?

the kernel I was using was a little modified (multi-cpu dm-crypt, partial ck-patchset, ...) so it could be due to those

anyways: always have a backup of your most important data available (including a stage4/5-tarball) :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.3.0-r2
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
DestroyFX
n00b
n00b


Joined: 05 Dec 2005
Posts: 37

PostPosted: Tue Nov 02, 2010 3:04 pm    Post subject: Reply with quote

Yeah, Always backup :P

Currently I use Reiser4 and btrfs on everything, hopefully, no corruptions will occur :)
Back to top
View user's profile Send private message
ComaWhite
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 125

PostPosted: Thu Nov 04, 2010 12:50 am    Post subject: Reply with quote

ssteinberg wrote:
ComaWhite wrote:
Shouldn't it be amd-drivers since ati was changed to amd now? Thank you for the drivers also.


ATi was acquired by AMD. It is still ATi though.


http://mashable.com/2010/08/30/amd-ditches-ati/
Back to top
View user's profile Send private message
ssteinberg
Apprentice
Apprentice


Joined: 09 Jul 2010
Posts: 206
Location: Israel

PostPosted: Thu Nov 04, 2010 4:18 pm    Post subject: Reply with quote

ComaWhite wrote:
ssteinberg wrote:
ComaWhite wrote:
Shouldn't it be amd-drivers since ati was changed to amd now? Thank you for the drivers also.


ATi was acquired by AMD. It is still ATi though.


http://mashable.com/2010/08/30/amd-ditches-ati/


For some reason they still advertise all their cards as "ATi Radeons" even on their official site. All official drivers for all platforms are still ATi drivers/ATi Catalyst thing, etc officially. *shrug*
Edit: Oh ok, it is only for future cards.
Back to top
View user's profile Send private message
miroR
Guru
Guru


Joined: 05 Mar 2008
Posts: 445

PostPosted: Sat Nov 05, 2011 10:25 pm    Post subject: bogus certificate? Reply with quote

Da_G wrote:
It's probably failing silently rather than prompting you due to this certificate error:

Error validating server certificate for 'https://gentoo-quebec.org:443':
- The certificate hostname does not match.
Certificate information:
- Hostname: secure.urent.org
- Valid: from Fri, 15 Jan 2010 20:38:02 GMT until Tue, 15 Jan 2013 20:38:02 GMT
- Issuer: 07969287, http://certificates.godaddy.com/repository, GoDaddy.com, Inc., Scottsdale, Arizona, US
- Fingerprint: 8b:9a:ac:49:d8:42:f4:6a:6b:b6:82:f7:b9:66:6a:6d:79:f1:ef:84
(R)eject, accept (t)emporarily or accept (p)ermanently?


I was asked a few minutes ago to add the same fingerprint as above.
Code:
layman -a ALL

waited for me to answer. I rushed and accepted permenently.
Here is the scrap of the output about it.
Code:
Certificate information:
 - Hostname: secure.urent.org
 - Valid: from Fri, 15 Jan 2010 20:38:02 GMT until Tue, 15 Jan 2013 20:38:02 GMT
 - Issuer: 07969287, http://certificates.godaddy.com/repository, GoDaddy.com, Inc., Scottsdale, Arizona, US
 - Fingerprint: 8b:9a:ac:49:d8:42:f4:6a:6b:b6:82:f7:b9:66:6a:6d:79:f1:ef:84
(R)eject, accept (t)emporarily or accept (p)ermanently? p
svn: OPTIONS of 'https://gentoo-quebec.org/svn/gentoo-quebec/trunk/overlay': Could not read status line: connection was closed by server (https://gentoo-quebec.org)
* Deleting _empty_ directory "/var/lib/layman/gentoo-quebec"
* Failed to add overlay "gentoo-quebec".
* Error was: Adding overlay "gentoo-quebec" failed!

How do I remove that signiture, since I obviously didn't need it?
It's not in the godaddy's repository:
https://certs.godaddy.com/anonymous/repository.seam;jsessionid=h2hYfTjCgdDJa5EU7tfzeg__.p3p01jb
Anyway, I can't figure it I was introduced into my system, because it says above the "connection was closed by server" in the meantime or whatever.
Help appreciated!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum