Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X11 fbdev driver on XVR-500
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
alexbuell
Guru
Guru


Joined: 18 Jul 2002
Posts: 471
Location: "Hemp"shire, UK

PostPosted: Mon Nov 01, 2010 10:27 pm    Post subject: X11 fbdev driver on XVR-500 Reply with quote

Has anyone ever had success using the fbdev X11 driver with the XVR-500 card? I'm getting FBIOPUT_VSCREENINFO error then it stops when starting X11. When I commented out the offending code and recompiled, I got FBIO_BLANK errors and still stops.

I get the general feeling that the fbdev X11 driver still tries to mess about with the resolution etc when it shouldn't.

Also I am looking at porting the wildcatfb driver from *BSD to Linux until I realised it actually does essentially the same thing that the fbdev X11 driver does!

Any ideas?
_________________
Cheers,
Alex.

Linux - the best text adventure game ever.
Back to top
View user's profile Send private message
JFGI_123
n00b
n00b


Joined: 03 Sep 2010
Posts: 17

PostPosted: Tue Nov 02, 2010 11:34 am    Post subject: Reply with quote

My knowledge of X11 is limited due to the fact I hardly use it, but I'll have a go..... :?

Can't you hard set the resolution in xorg.conf to try and stop it being clever?

Also I've got an XVR-100 card in my Sun blade 2000 which is basically an ATI Radeon card. I'm guessing that the XVR-500 is just another ATI card so you could try using the ATI drivers (which is what I'm doing) instead
_________________
I.T. is like a box of chocolates on a hot day.....sticky
Back to top
View user's profile Send private message
alexbuell
Guru
Guru


Joined: 18 Jul 2002
Posts: 471
Location: "Hemp"shire, UK

PostPosted: Tue Nov 02, 2010 11:58 am    Post subject: Reply with quote

JFGI_123 wrote:
My knowledge of X11 is limited due to the fact I hardly use it, but I'll have a go..... :?

Can't you hard set the resolution in xorg.conf to try and stop it being clever?

Also I've got an XVR-100 card in my Sun blade 2000 which is basically an ATI Radeon card. I'm guessing that the XVR-500 is just another ATI card so you could try using the ATI drivers (which is what I'm doing) instead


Right, I did hardwire the resolution in xorg.conf but it still tried to change the resolution, thus it stopped with that error. I'm guessing that the console fb device driver doesn't support the required ioctls. I need to dig around a bit more but basically the console driver only treats it as a dumb framebuffer, that might be why the fbdev X11 driver is having problems.

And no, the XVR-500 isn't an ATI card, it's a more powerful 3DLabs graphic card and there are no docs available, Sun hasn't released anything because there's a NDA on it by the OEM (3DLabs in this case)

I'm hoping someone out there has had success using the X11 fbdev driver with this card...
_________________
Cheers,
Alex.

Linux - the best text adventure game ever.
Back to top
View user's profile Send private message
JFGI_123
n00b
n00b


Joined: 03 Sep 2010
Posts: 17

PostPosted: Tue Nov 02, 2010 12:05 pm    Post subject: Reply with quote

Do 3DLabs offer Linux drivers for it? Sure it would have been a mainstream chipset you can get some drivers for but I suppose if they don't offer alternatives you might be a bit stuck

Think we had some 3D Creator cards in some old Ulta 10s but they've gone the way of the dodo
_________________
I.T. is like a box of chocolates on a hot day.....sticky
Back to top
View user's profile Send private message
alexbuell
Guru
Guru


Joined: 18 Jul 2002
Posts: 471
Location: "Hemp"shire, UK

PostPosted: Tue Nov 02, 2010 2:34 pm    Post subject: Reply with quote

JFGI_123 wrote:
Do 3DLabs offer Linux drivers for it? Sure it would have been a mainstream chipset you can get some drivers for but I suppose if they don't offer alternatives you might be a bit stuck

Think we had some 3D Creator cards in some old Ulta 10s but they've gone the way of the dodo


Yeah, that's why I need to get the X11 fbdev up and running. It's the only alternative out there.
_________________
Cheers,
Alex.

Linux - the best text adventure game ever.
Back to top
View user's profile Send private message
alexbuell
Guru
Guru


Joined: 18 Jul 2002
Posts: 471
Location: "Hemp"shire, UK

PostPosted: Wed Nov 03, 2010 8:01 pm    Post subject: Reply with quote

Good news folks, I've started looking into why the X11 fbdev doesn't work with the sunxvr500 console driver. Seems the ioctls needed doesn't work properly so the X11 fbdev stops with these errrors. I have filed a bug report with the Xorg people and working on a resolution for this. Hopefully this might get us a working X11 environment on XVR cards!
_________________
Cheers,
Alex.

Linux - the best text adventure game ever.
Back to top
View user's profile Send private message
alexbuell
Guru
Guru


Joined: 18 Jul 2002
Posts: 471
Location: "Hemp"shire, UK

PostPosted: Wed Nov 03, 2010 8:35 pm    Post subject: Reply with quote

OK I wrote a little program to help solve the mystery of why the fbdev driver was stopping with errors. Seems the default bit depth is 8 bits with the sunxvr500 console driver :-/ And my xorg.conf was asking it to change to 24 bit depth which it doesn't support hence the errors.

Need to work out how to get it to use 24 bit depth and all should be well.
_________________
Cheers,
Alex.

Linux - the best text adventure game ever.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum