Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome cannot run when switched to French language
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
augustin_meaulnes
Tux's lil' helper
Tux's lil' helper


Joined: 21 Oct 2010
Posts: 97
Location: France

PostPosted: Mon Nov 01, 2010 5:56 pm    Post subject: Gnome cannot run when switched to French language Reply with quote

Hi,
I am at my first install of Gentoo.
I have X running and gdm but when I log as regular user I get the gnome screen (blue background with a one eyed face) but nothing else. I mean no menu and no panel and it seems that the CPU is working at full charge.
On the contrary, if I log as root gnome works perfectly.
I need help.
Thank you.


Last edited by augustin_meaulnes on Mon Nov 01, 2010 7:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
augustin_meaulnes
Tux's lil' helper
Tux's lil' helper


Joined: 21 Oct 2010
Posts: 97
Location: France

PostPosted: Mon Nov 01, 2010 7:07 pm    Post subject: Reply with quote

Since my first attempt I did the following.
I logged as root
made a new user
switched to this user -> everything was OK
logged out
asked for a change in the language English -> French
tried to log in again
was asked if I wanted to have French for ever Answered "yes"
I had the problem anew!
Back to top
View user's profile Send private message
pingufunkybeat
l33t
l33t


Joined: 01 Dec 2004
Posts: 610

PostPosted: Mon Nov 01, 2010 8:22 pm    Post subject: Reply with quote

Can you switch to a virtual terminal (Ctrl+Alt+F2) and use "top" to see what's using the CPU?
Back to top
View user's profile Send private message
augustin_meaulnes
Tux's lil' helper
Tux's lil' helper


Joined: 21 Oct 2010
Posts: 97
Location: France

PostPosted: Tue Nov 02, 2010 5:39 am    Post subject: Reply with quote

Hi,
Thank you for helping me.
Here is the result of some tests

    Whenever I log as a user for who I changed the session language to French
    ctl-alt-F2 and log as root
    top gives:
    Quote:
    udisks-daemon 23%
    dbus-daemon 18%
    dbus-daemon 5%
    gnome-session 2.3%
    among follower (around 0.8%) gnome-panel, polkitd,gvfsdgnome-power-man

    and the graphical session is blocked on the screen background image (no menu and no panel)


    Whenever I log as a user for who I didn't change the language
    top gives everything around 0.0% and the graphical gnome session works
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4249

PostPosted: Tue Nov 02, 2010 11:00 am    Post subject: Reply with quote

it's an issue because of misconfigured local

you can :
1/ killall udiskdaemon
just to enter your session (you'll get the panel... coming after that)

2/ USE="-gdu" emerge -1 gvfs
remove usage of the automounter that bug with your local settings

3/ use utf for your local and check that one really exist
(i'm not in front of the computer that was having that issue, if you need more help i will check it on how i solve it)
Back to top
View user's profile Send private message
augustin_meaulnes
Tux's lil' helper
Tux's lil' helper


Joined: 21 Oct 2010
Posts: 97
Location: France

PostPosted: Tue Nov 02, 2010 1:08 pm    Post subject: Reply with quote

Hi,
Thank you for helping me.

When I was in front of the gdm screen I did the following:

Quote:
1- switched to a new virtual console and logged as "root"
2- did killall udisks-daemon answers was: "no such process found"
3- did USE="-gdu" emerge -1 gvfs
4-reboot


Now it works.
I didn't looked at and change the locale because I don't know how to do it.

Could you tell me what is the gvfs package and what exactly happend with this emerge ?
Maybe could you also point me to some reading about this.

Last and final, I can log in with the gdm but I still have to use US keybord layout. How to get a French layout?
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4249

PostPosted: Tue Nov 02, 2010 1:53 pm    Post subject: Reply with quote

yeah bad me i don't remember but the offending name could be udisk-deamon-monitor or something like that, try look at the pid and kill pid instead
you should also see a dead dbus-something running around.


for the locale : http://www.gentoo.org/doc/fr/utf-8.xml

gvfs is the gnome virtual filesystem, and the gdu use flag enable automounting of fs
so, you've lost automount feature by disabling gdu.
you could re-enable it as soon as you avoid the bug by setting your locale

For the gdm in azerty look here
http://forums.gentoo.org/viewtopic-p-6437086-highlight-console.html#6437086
Back to top
View user's profile Send private message
augustin_meaulnes
Tux's lil' helper
Tux's lil' helper


Joined: 21 Oct 2010
Posts: 97
Location: France

PostPosted: Tue Nov 02, 2010 2:13 pm    Post subject: Reply with quote

krinn wrote:
yeah bad me i don't remember but the offending name could be udisk-deamon-monitor or something like that, try look at the pid and kill pid instead

the name given by top is udisks-daemon (the one I used)


Quote:
for the locale : http://www.gentoo.org/doc/fr/utf-8.xml

I will see that

Quote:
gvfs is the gnome virtual filesystem, and the gdu use flag enable automounting of fs
so, you've lost automount feature by disabling gdu.

I never figured out that Gnome was using this sort of abstraction layer.

Quote:
you could re-enable it as soon as you avoid the bug by setting your locale

Yes, but how?


Quote:
For the gdm in azerty look here
http://forums.gentoo.org/viewtopic-p-6437086-highlight-console.html#6437086

I"ll look at this.

Many thanks again.
[/quote]
Back to top
View user's profile Send private message
augustin_meaulnes
Tux's lil' helper
Tux's lil' helper


Joined: 21 Oct 2010
Posts: 97
Location: France

PostPosted: Wed Nov 03, 2010 7:44 pm    Post subject: Reply with quote

From the thread I gave up.
Quote:
and if you have xorg 1.6/7 look in the doc: ttp://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.6-upgrade-guide.xml
I cannot find how to check the version of a package.
Back to top
View user's profile Send private message
Chiitoo
l33t
l33t


Joined: 28 Feb 2010
Posts: 852
Location: Here and Away Again

PostPosted: Thu Nov 04, 2010 5:42 am    Post subject: Reply with quote

There are numerous ways, but here's one to do it with the command emerge:

Code:
emerge --info xorg-server

That show a bunch of other info as well.
You could also do

Code:
emerge --pretend xorg-server

as well or even add --verbose for more info.
The version of X server would be stated in the log file as well.
For future record, a lot if not most of the commands have a manual you can access like so:

Code:
man emerge

In case you didn't know. :]
I hope this helps!
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
augustin_meaulnes
Tux's lil' helper
Tux's lil' helper


Joined: 21 Oct 2010
Posts: 97
Location: France

PostPosted: Thu Nov 04, 2010 6:33 am    Post subject: Reply with quote

OK, thanks. I used emerge --info <package> once but as it displayed a lot of info not directly related to the package, I didn't see that the info about the package was placed at the very bottom.
In fact my version is:
Quote:
x11base/xorg-server-1.7.7-r1

Now to go on my problem:
I did what is on the page
Quote:
http://forums.gentoo.org/viewtopic-p-6437086-highlight-console.html#6437086
krinn directed me to, I mean:
in make.conf add/change
Code:
USE="udev -hal"
INPUT_DEVICES="evdev"
VIDEO_CARDS="radeon"

then rebuilt the server with that
Code:
emerge -uDN1 xorg-server
emerge -1 portage-utils && emerge -1 $(qlist -IC x11-drivers/)


Code:
mkdir /etc/X11/xorg.conf.d

and put that file in here as 97-evdev.conf, so it's pathname is: /etc/X11/xorg.conf.d/97-evdev.conf

Code:

Section "InputClass"
   Identifier "mouse-all"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "AutoServerLayout" "on"
EndSection

Section "InputClass"
        Identifier "keyboard-all"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbLayout" "fr"
        Option "XkbRules"  "xorg"
        Option "XkbModel"  "pc105"
        Option "AutoServerLayout" "on"
EndSection

the locale cmd tells:
Quote:
Lang=fr_FR.UTF-8
LC_TTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=


Writing this I discover that the first line has no "" . Could it be the origin of my problem?
The actual situation is:
gdm in French text but with QWERTY keeboard instead of AZERTY
gnome session in French with French keeboard.
Back to top
View user's profile Send private message
Chiitoo
l33t
l33t


Joined: 28 Feb 2010
Posts: 852
Location: Here and Away Again

PostPosted: Thu Nov 04, 2010 6:53 am    Post subject: Reply with quote

Yeah, the 1.7.7-r1 version is the most recent _stable_ version in Portage for the time being, and I've read that it still needs hal (the last version at that), so I'm not so sure about the -hal flag... but I'm really not experienced enough to say for sure, just thinking out loud here. ^^


And yeps, I agree. That Lang=fr_FR.UTF-8 should indeed be LANG="fr_FR.UTF-8" at least if we go with what we can see here:

http://www.gentoo.org/doc/en/guide-localization.xml#doc_chap3
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
augustin_meaulnes
Tux's lil' helper
Tux's lil' helper


Joined: 21 Oct 2010
Posts: 97
Location: France

PostPosted: Thu Nov 04, 2010 7:44 am    Post subject: Reply with quote

About LANG="fr_FR.UTF-8" I had a look at /etc/env.d/02locale and the "" are present so I don't understand why local gives it with no "".
About hal, krinn's opinion would be welcome.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum