Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Update fails (OpenOffice?)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
thom_raindog
Guru
Guru


Joined: 16 May 2008
Posts: 400

PostPosted: Thu May 21, 2009 6:41 pm    Post subject: Update fails (OpenOffice?) Reply with quote

Running an update on world I get in the end:

Code:

par2script -i ../unxlngx6.pro/par,/var/tmp/portage/app-office/openoffice-3.1.0/work/ooo/build/ooo310-m11/solver/310/unxlngx6.pro/par @@/var/tmp/portage/app-office/openoffice-3.1.0/temp/mkX29wWX -o ../unxlngx6.pro/bin/osl/sdkoo.ins                                                       
Reading par files                                                                             
Collecting items                                                                               
Collecting assigned items                                                                     
Searching for Undefinitions                                                                   
Removing assigned GIDs without definitions                                                     
Adding definitions without assignment to the root                                             
Control of multiple assignments                                                               
Control of definitions with missing assignments                                               
Checking directory definitions ...                                                             
Checking module definitions ...                                                               
Checking module assignments ...                                                               
Checking StarRegistry ...                                                                     
Checking Root Module ... gid_Module_Root_SDK                                                   
Checking Shortcut assignments ...                                                             
Checking missing parents ...                                                                   
Shorten lines at modules
Creating setup script
Saving script
Running processes: 0
deliver -- version: 266154
Module 'scp2' delivered successfully. 87 files copied, 4 files unchanged

1 module(s):
        vcl
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making /var/tmp/portage/app-office/openoffice-3.1.0/work/ooo/build/ooo310-m11/vcl/util

Attention: if you build and deliver the above module(s) you may prolongue your the build issuing command "build --from vcl"

rmdir /tmp/30583
make: *** [stamp/build] Error 1
 *
 * ERROR: app-office/openoffice-3.1.0 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 5160:  Called die
 * The specific snippet of code:
 *       make || die "Build failed"
 *  The die message:
 *   Build failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-office/openoffice-3.1.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/openoffice-3.1.0/temp/environment'.
 *
!!! When you file a bug report, please include the following information:
GENTOO_VM=sun-jdk-1.5  CLASSPATH="" JAVA_HOME="/opt/sun-jdk-1.5.0.18"
JAVACFLAGS="-source 1.5 -target 1.5" COMPILER=""


I am not really sure what to do about that.. can anyone shed some light on the problem?
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2117
Location: Near Toronto

PostPosted: Thu May 21, 2009 7:10 pm    Post subject: Reply with quote

there's a bug - openoffice fails if you have the kde use flag
set. See http://bugs.gentoo.org/show_bug.cgi?id=238539

Your error looks like this bug.

I could build if I set use=-kde FWIW
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
thom_raindog
Guru
Guru


Joined: 16 May 2008
Posts: 400

PostPosted: Thu May 21, 2009 7:54 pm    Post subject: Reply with quote

Hmm.. thanks for the info..
I DO have kde set, using KDE4 and all that...

I added me to the bug report, we will see what happens.
Back to top
View user's profile Send private message
grooveman
l33t
l33t


Joined: 24 Feb 2003
Posts: 992

PostPosted: Wed Jul 08, 2009 10:09 pm    Post subject: Reply with quote

No KDE here, still got the problem

There is a bug for this topic, but they basically say update to 3.0.1... Well I'm on a dial-up :0/
_________________
To look without without looking within is like looking without without looking at all.
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4956

PostPosted: Thu Jul 09, 2009 6:08 am    Post subject: Reply with quote

got kde 4 and oo compiled, not sure if it is related, try compiling it on one processor.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
grooveman
l33t
l33t


Joined: 24 Feb 2003
Posts: 992

PostPosted: Fri Jul 10, 2009 3:14 pm    Post subject: Reply with quote

I compiled on one processor, dropped distcc and ccache... still have the same problem. It is nice enough to wait like 7 hours before it finally crashes :evil:

I'm doing 3.1 now... My use flags are pretty tame:
Code:
[ebuild     U ] app-office/openoffice-3.1.0 [3.0.0] USE="cups dbus eds gnome gstreamer gtk java ldap nsplugin opengl pam -bash-completion% -binfilter -debug -kde -mono -odk -templates" LINGUAS="en en_US* -af -ar -as_IN -be_BY -bg -bn -br -brx% -bs -ca -cs -cy -da -de -dgo% -dz -el -en_GB -en_ZA -eo -es -et -eu% -fa -fi -fr -ga -gl -gu% -he -hi_IN -hr -hu -id% -it -ja -ka% -kk% -km -kn_IN% -ko -kok% -ks% -ku -lt -mai% -mk -ml_IN -mn% -mni% -mr_IN -nb -ne -nl -nn -nr -ns -oc% -or_IN -pa_IN -pl -pt -pt_BR -ru -rw -sa_IN% -sat% -sd% -sh -sk -sl -sr -ss -st -sv -sw_TZ -ta% -ta_IN -te_IN -tg -th -ti_ER -tn -tr -ts -uk -ur_IN -uz% -ve -vi -xh -zh_CN -zh_TW -zu (-gu_IN%) (-lv%)" 0 kB


I'm on an amd64 system.

Code:
    # emerge --info
Portage 2.1.6.13 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.9_p20081201-r2, 2.6.28-gentoo-r3 x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r3-x86_64-AMD_Turion-tm-_64_X2_Mobile_Technology_TL-56-with-glibc2.2.5
Timestamp of tree: Thu, 09 Jul 2009 16:00:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.8-r1
dev-lang/python:     2.4.4-r13, 2.5.4-r3
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en"
LC_ALL="en"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X acl acpi alsa amd64 apic apm avahi avi berkdb bluetooth branding bzip2 cairo cddb cdr cli cracklib crypt cups dbus dga distcc dri dts dv dvd dvdr dvdread eds emboss encode esd ethreal evo exif fam fbcon ffmpeg firefox flac flash fortran gdbm gif gimp gimp-2.2 gimpprint gnome gphoto2 gpm gstreamer gtk gtk2 hal iconv isdnlog java jpeg ldap libnotify libusb mad madwifi midi mikmod mmx motif mp3 mpeg mudflap multilib ncurses networkmanager nls nptl nptlonly nsplugin nvidia ogg oggvorbis opengl openmp oss pam pcre pdf perl png ppds pppd python qt3support quicktime rar readline reflection samba sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd tetex tiff truetype unicode usb v4l v4l2 vorbis wmv xinerama xml xorg xscreensaver xulrunner xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="nv vesa nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

_________________
To look without without looking within is like looking without without looking at all.
Back to top
View user's profile Send private message
grooveman
l33t
l33t


Joined: 24 Feb 2003
Posts: 992

PostPosted: Sun Jul 19, 2009 2:29 pm    Post subject: Reply with quote

After a long, painful struggle and a couple updates to the portage tree, I figured out that the problem was mainly with xulrunner. OO wanted an older version than firefox 3.5 did. I backed down to firefox 3.11 and dropped my xulrunner to 1.9.0.x, and OO emerged just fine. So, I guess I'll just have to wait for the new firefox...
_________________
To look without without looking within is like looking without without looking at all.
Back to top
View user's profile Send private message
Joseph K.
Guru
Guru


Joined: 07 Jun 2006
Posts: 400
Location: Melbourne, Australia

PostPosted: Mon Oct 04, 2010 10:15 am    Post subject: Reply with quote

I just hit this "vcl" bug in 3.2.0 (and 3.2.1), having previously emerged 3.2.0 successfully in June. Is this happening to others or is it just me? I recall hitting this same bug earlier in the year too.
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1391
Location: germany

PostPosted: Mon Oct 04, 2010 12:26 pm    Post subject: Reply with quote

Guys I just opened bug 339693 after openoffice[kde] failed for me on two machines.
Can anyone confirm to suffer from the same problem by looking at the attached build.log.xz file?
_________________
The manual said "Requires Windows7 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)
Back to top
View user's profile Send private message
gerard82
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2229
Location: Netherlands

PostPosted: Mon Oct 04, 2010 1:56 pm    Post subject: Reply with quote

I did emerge -e world on sept 30th.
I am on ooffice -3.2.0 and all went OK.
I use kde-4.5.1.
My CFLAGS are march=native -O2 -pipe.
Processor AMD Phenom X4.
I do not have --as-needed.
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
Joseph K.
Guru
Guru


Joined: 07 Jun 2006
Posts: 400
Location: Melbourne, Australia

PostPosted: Tue Oct 05, 2010 11:45 am    Post subject: Reply with quote

Hmmm, interesting. Couple of quick questions just as a formality: do you use kdeprefix? And, what USE flags for openoffice?

And more out of curiosity, are you sure that you don't use --as-needed, seeing how it is now enabled in the default profile? Thanks! Cheers.
Back to top
View user's profile Send private message
gerard82
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2229
Location: Netherlands

PostPosted: Tue Oct 05, 2010 2:42 pm    Post subject: Reply with quote

Hi Joseph K,
Code:

ikke@gerard ~ $ emerge --info openoffice
Portage 2.1.8.3 (default/linux/amd64/10.0/desktop, gcc-4.4.3, glibc-2.11.2-r0, 2.6.34-gentoo-r6 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.34-gentoo-r6-x86_64-AMD_Phenom-tm-_II_X4_925_Processor-with-gentoo-2.0.1
Timestamp of tree: Tue, 05 Oct 2010 10:45:03 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.3
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests collision-protect distlocks fixpackages news notitles parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en nl"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cdda cdparanoia cdr cli consolekit cracklib crypt css cups curlwrappers cvs cxx dbus dri dts dvd dvdr emboss encode exif expat fam ffmpeg firefox flac fontconfig fortran ftp gd gdbm gif gimp glut gnutls gphoto2 gpm graphviz gstreamer gtk gzip hal handbook hddtemp iconv icu innodb ipv6 java java6 javascript jpeg kde ladspa lame lcms ldap libnotify libsamplerate lm_sensors lua lzo mad matroska mikmod mime mmap mmx mng modules mono mozilla mp3 mp4 mpeg mplayer mudflap multilib nas ncurses nls nptl nptlonly nsplugin ogg openal opengl openmp pam pango pcre pdf perl php png posix ppds python qt3support qt4 raw readline recode reflection scanner sdl session slang smp sndfile spell sql sse sse2 ssl startup-notification svg sysfs syslog sysvipc tcpd theora threads tiff tokenizer truetype unicode usb vorbis webkit wxwidgets x264 xcb xcomposite xft xine xml xorg xulrunner xv xvid zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en nl" RUBY_TARGETS="ruby18" SANE_BACKENDS="epson" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-office/openoffice-3.2.0 was built with the following:
USE="bash-completion cups dbus gnome gstreamer gtk java kde ldap mono (multilib) nsplugin opengl pam (-aqua) -binfilter -debug -eds (-kdeenablefinal) -odk -templates" LINGUAS="en nl -af -ar -as_IN -be_BY -bg -bn -br -brx -bs -ca -cs -cy -da -de -dgo -dz -el -en_GB -en_US -en_ZA -eo -es -et -eu -fa -fi -fr -ga -gl -gu -he -hi_IN -hr -hu -id -it -ja -ka -kk -km -kn_IN -ko -kok -ks -ku -lt -mai -mk -ml_IN -mn -mni -mr_IN -nb -ne -nn -nr -ns -oc -or_IN -pa_IN -pl -pt -pt_BR -ru -rw -sa_IN -sat -sd (-sh) -sk -sl -sr -ss -st -sv -sw_TZ -ta -ta_IN -te_IN -tg -th -ti_ER -tn -tr -ts -uk -ur_IN -uz -ve -vi -xh -zh_CN -zh_TW -zu"
CFLAGS="-march=native -pipe -DGL_GLEXT_PROTOTYPES"
CXXFLAGS="-march=native -pipe -DGL_GLEXT_PROTOTYPES"

ikke@gerard ~ $

As you can see no as-needed.
I can't find kdeprefix in ufed it was obsoleted quite some time ago AFAIK.
They might be in desktop/kde profile I don't know.
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
Joseph K.
Guru
Guru


Joined: 07 Jun 2006
Posts: 400
Location: Melbourne, Australia

PostPosted: Thu Oct 07, 2010 12:36 pm    Post subject: Reply with quote

Hmmm, looks like --as-needed could be the issue. I use forced --as-needed, where it is part of gcc's profile, and after turning it off, OpenOffice has delivered the vcl module successfully! Even though, --as-needed is still in my LDFLAGS because of the default profile. Guess it must be filtered. Will still be a few hours before I know if the whole emerge is successful. Cheers.
Back to top
View user's profile Send private message
Ormaaj
Guru
Guru


Joined: 28 Jan 2008
Posts: 316

PostPosted: Mon Oct 11, 2010 3:26 pm    Post subject: Reply with quote

Fails here even without explicitly stating --as-needed in make.conf
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum