Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Acer Aspire 5738ZG si spegne durante emerge
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Nio84
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2009
Posts: 140

PostPosted: Thu Jul 01, 2010 11:25 am    Post subject: Acer Aspire 5738ZG si spegne durante emerge Reply with quote

Salve , stavo emergendo una trentina di pacchetti dopo aver dato :
Code:
emerge -DNu world

(a parte il fatto che ci mette piu di un ora) ad un certo punto mentre emergeva , ho iniziato a vedere cose del tipo :

*stopping questo
*stopping quest'altro
e il computer si è spento da solo .........Ho notato che era parecchio caldo il calore si sentiva dalla tastiera e dal toucpad ....
non è la prima volta che succede quando deve emergere tanti pacchetti ........... vi posto il make.conf
Code:

####################---make.conf---###########################
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
MAKEOPTS="-j3"
USE="3dnow X a52 aac aalib acl alsa audiofile bluetooth kde cdr dvd dbus crypt cups dri seamonkey scanner qt4 win32codecs wifi vorbis"
INPUT_DEVICES="keyboard gpm  mouse evdev synaptics"
VIDEO_CARDS="fglrx"
LINGUAS="it"
FEATURES="ccache parallel-fetch userfetch"
CCACHE_SIZE="2G"
GENTOO_MIRRORS="http://mirrors.linuxant.fr/distfiles.gentoo.org/"

SYNC="rsync://rsync1.fr.gentoo.org/gentoo-portage"

_________________
IL DESTINO è CONTRO DI ME?!.....................TANTO PEGGIO PER LUI!!!
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Thu Jul 01, 2010 11:52 am    Post subject: Reply with quote

probabilmente si spegne proprio per l'eccessivo surriscaldamento, e dovrebbe essere qualche opzione gestita a livello del bios. cercare di forzarlo a rimanere acceso con sto caldo non gli fa sicuramente bene, potresti provare a comprare una di quelle basi ventilate che lo raffreddino un po', il nome preciso al momento mi sfugge XD
Back to top
View user's profile Send private message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1303
Location: Italy: Trento || Mondo

PostPosted: Thu Jul 01, 2010 11:56 am    Post subject: Reply with quote

se esce stopping questo e quell'altro a me sembra più qualcosa di controllato dal sistema che dal bios.
Che DE usi? che sia qualche applicativo desktpo che ha i suoi critical point e ti manda in spegnimento al raggiungimento della temperatura limite?
_________________
Drink more beer, save water
P u n X the system
and support http://freenetproject.org!
Back to top
View user's profile Send private message
Nio84
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2009
Posts: 140

PostPosted: Thu Jul 01, 2010 1:06 pm    Post subject: Reply with quote

Sono in fase di installazione , non ho neanche X al momento..........

Poi boh per aprire pagine qui sul forum ci vuole 3 ore mi dà sempre connection timeout....
_________________
IL DESTINO è CONTRO DI ME?!.....................TANTO PEGGIO PER LUI!!!
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 468

PostPosted: Thu Jul 01, 2010 6:47 pm    Post subject: Reply with quote

oRDeX wrote:
se esce stopping questo e quell'altro a me sembra più qualcosa di controllato dal sistema che dal bios.

Magari superata una certa soglia invia il segnale acpi di poweroff, e pochi gradi dopo stacca di brutto.


Se hai una cpu che supporta lo scaling, potresti forzarla sulla frequenza più bassa con cpufreq-set.
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
Nio84
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2009
Posts: 140

PostPosted: Fri Jul 02, 2010 11:37 am    Post subject: Reply with quote

Non ci sono programmi sotto gentoo (non ricordo il nome tecnico) che aumentano la velocità delle ventole?

Comq ho risolto risparmiando Flag USE in make.conf e togliendo opzioni come -fomit-frame-pointer ccache fetchuser e parallel-fetch ...
Probabilmente stressavano troppo la CPU
_________________
IL DESTINO è CONTRO DI ME?!.....................TANTO PEGGIO PER LUI!!!
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 468

PostPosted: Fri Jul 02, 2010 11:41 am    Post subject: Reply with quote

Le ventole girano già a manetta di predefinito, o comunque in base alla temperatura. Comunque dovrebbe esserci qualcosa, forse con lm-sensors.
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4758
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Fri Jul 02, 2010 3:34 pm    Post subject: Reply with quote

secondo i casi.
Per alcuni vecchi AMD c'è un programma che modifica il profilo energetico predefinito e di conseguenza la gestione delle ventole mentre cpufreq non ottiene nulla, non so perchè.

verifica la configurazione del kernel ed i moduli della gestione energetica che vengono caricati.

che -f-omit-frame-pointer stressi la CPU mi torna molto strano.

verificare che il dissipatore non sia sozzo...
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Nio84
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2009
Posts: 140

PostPosted: Fri Jul 02, 2010 11:40 pm    Post subject: Reply with quote

Ho un portatile....quasi nuovo...l'ho aspirato tutto ...l' ho pulito ma nada non posso andare avanti con l'istallazione di gentoo perchè quando emerge piu di 3 o 4 pacchetti...il pc si spegne dopo un po' ....
A proposito è naturale che ci metta 20 min per emergere 4 pacchetti?
Il mio processore è un intel T4300...non ho capito bene dove devo guardare nel kernel....comunque questo problema me lo dava sia con il kernel del pc che con quello fatto da me con genkernel ........
La prima volta che installai gentoo 1 setrimana fa..... non dava questi problemi ......
_________________
IL DESTINO è CONTRO DI ME?!.....................TANTO PEGGIO PER LUI!!!
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 468

PostPosted: Fri Jul 02, 2010 11:48 pm    Post subject: Reply with quote

Dipende dai pacchetti, tipo gcc da solo può metterci 2 ore tranquillamente.
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
Zizo
Apprentice
Apprentice


Joined: 04 Feb 2010
Posts: 200
Location: Padova, Italy

PostPosted: Sat Jul 03, 2010 6:37 am    Post subject: Reply with quote

Se effettivamente si tratta di un problema di surriscaldamento potresti provare a settare
Code:
MAKEOPTS="-j1"
PORTAGE_NICENESS="20"
nel tuo make.conf, così da limitare l'uso del processore al minimo ed eventualmente lasciarlo ad altri programmi che ne hanno bisogno.

Inoltre ti consiglio di disabilitare ccache, in quanto già fa poco o niente su un pc con disco fisso da 7200rpm, su un portatile fa solo peggio e rallenta la compilazione.
Puoi farlo levando la voce "ccache" da "FEATURES".
Back to top
View user's profile Send private message
Nio84
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2009
Posts: 140

PostPosted: Sat Jul 03, 2010 9:19 am    Post subject: Reply with quote

Si si infatti ho tolto parallel-fetch ccache -fomit-frame-pointer ma continua a farlo di nuovo ..... comunque ora provo settando quei valori
_________________
IL DESTINO è CONTRO DI ME?!.....................TANTO PEGGIO PER LUI!!!
Back to top
View user's profile Send private message
Zizo
Apprentice
Apprentice


Joined: 04 Feb 2010
Posts: 200
Location: Padova, Italy

PostPosted: Sat Jul 03, 2010 9:27 am    Post subject: Reply with quote

"parallel-fetch" e "-fomit-frame-pointer" non influiscono minimamente nell'uso del processore, rimettili pure (anzi, con il secondo forse i tempi si allungano).
"ccache" influisce principalmente sul disco.

Con le opzioni che ti ho fornito prima i tempi si allungano di parecchio, ma almeno non hai la cpu al 100%
Back to top
View user's profile Send private message
Nio84
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2009
Posts: 140

PostPosted: Sat Jul 03, 2010 10:26 am    Post subject: Reply with quote

Si spegne lo stesso
_________________
IL DESTINO è CONTRO DI ME?!.....................TANTO PEGGIO PER LUI!!!
Back to top
View user's profile Send private message
Zizo
Apprentice
Apprentice


Joined: 04 Feb 2010
Posts: 200
Location: Padova, Italy

PostPosted: Sat Jul 03, 2010 10:36 am    Post subject: Reply with quote

Allora mi sa proprio che il surriscaldamento non c'entra gran che. Posta in un sito tipo http://pastebin.com/ il file "/var/log/messages"
Back to top
View user's profile Send private message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1303
Location: Italy: Trento || Mondo

PostPosted: Sat Jul 03, 2010 10:45 am    Post subject: Reply with quote

Comunque sia con lm_sensors potresti guardare i valori della temperatura mentre compili, così almeno ti rendi conto se possiamo davvero eliminare questo problema..
_________________
Drink more beer, save water
P u n X the system
and support http://freenetproject.org!
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4758
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Sat Jul 03, 2010 11:23 am    Post subject: Reply with quote

Non è che sia l'HD a mandare a fuoco il sistema? Prova ad agire sull'I/O nice.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Nio84
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2009
Posts: 140

PostPosted: Sat Jul 03, 2010 11:33 am    Post subject: Reply with quote

Allora nel kernel ho settato built-in tutte le features che parlavano di risparmio energetico , frequence scaling e ho settato userspace invece di performance .
Ho provato a emergere cpufreq ma mi dice che non c'è nessun ebuild .....forse perche sono in fase di installazione e non ho X ancora...

Quote:
Prova ad agire sull'I/O nice

emmm sarebbe a dire? Scusate l'ignoranza

tra due min vi posto quei logs....
_________________
IL DESTINO è CONTRO DI ME?!.....................TANTO PEGGIO PER LUI!!!
Back to top
View user's profile Send private message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1303
Location: Italy: Trento || Mondo

PostPosted: Sat Jul 03, 2010 11:47 am    Post subject: Reply with quote

io, prima di fare modifiche a tutto, installerei lm-sensors e hddtemp e monitorerei le temperature delle componenti per esser certo che sia questo il problema...è inutile andare avanti a tentativi..
_________________
Drink more beer, save water
P u n X the system
and support http://freenetproject.org!
Back to top
View user's profile Send private message
Nio84
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2009
Posts: 140

PostPosted: Sat Jul 03, 2010 11:51 am    Post subject: Reply with quote

http://pastebin.com/3zYXx9tN
_________________
IL DESTINO è CONTRO DI ME?!.....................TANTO PEGGIO PER LUI!!!
Back to top
View user's profile Send private message
Zizo
Apprentice
Apprentice


Joined: 04 Feb 2010
Posts: 200
Location: Padova, Italy

PostPosted: Sat Jul 03, 2010 12:03 pm    Post subject: Reply with quote

Ehhh, ritiro tutto, calduccio la dentro:
Code:
Jul  2 22:05:10 Athena kernel: CPU1: Temperature above threshold, cpu clock throttled (total events = 1)
Jul  2 22:05:10 Athena kernel: Disabling lock debugging due to kernel taint
Jul  2 22:05:10 Athena kernel: CPU1: Temperature/speed normal
Jul  2 22:05:12 Athena kernel: Critical temperature reached (103 C), shutting down.
Jul  2 22:05:12 Athena kernel: Critical temperature reached (103 C), shutting down.

E si ripete per 7 volte, quindi 8 in totale se non ho contato male.

P.S.: Grigliatina?! ;)
Back to top
View user's profile Send private message
Nio84
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2009
Posts: 140

PostPosted: Sat Jul 03, 2010 12:06 pm    Post subject: Reply with quote

Ah ok..... e quindi che faccio? :cry: mica posso mettere il pc in frigo mentre emerge! :D

EDIT:

Quote:
installerei lm-sensors e hddtemp


Si ora provo.........sempre che non si spenga prima
_________________
IL DESTINO è CONTRO DI ME?!.....................TANTO PEGGIO PER LUI!!!
Back to top
View user's profile Send private message
Zizo
Apprentice
Apprentice


Joined: 04 Feb 2010
Posts: 200
Location: Padova, Italy

PostPosted: Sat Jul 03, 2010 12:14 pm    Post subject: Reply with quote

Per raggiungere temperature così alte dopo appena pochi minuti mi sa proprio che c'è un problema hardware, o il sensore è sbagliato.
Partiamo dalla meno drammatica: lo fai lavorare un bel po', cerca di non farlo spegnere di nuovo, poi lo riavvii e vai nel bios, dovresti avere (non è detto) una sezione che ti informa della temperatura della cpu.
Se anche quella segna valori elevati allora buona fortuna, perchè le cause che generalmente portano a temperature così alte possono essere molte, dalla banale rottura della ventola, al distaccamento del dissipatore, alla rottura del processore (es.: cpu crepate che scaldano come stufe) solo per citare le più comuni.
Non è il discorso di metterlo in frigo per emerge, è che non è saggio utilizzare un pc in quelle condizioni.
Back to top
View user's profile Send private message
Nio84
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2009
Posts: 140

PostPosted: Sat Jul 03, 2010 12:29 pm    Post subject: Reply with quote

Emerso hddtemp ,(non sn riuscito a capire come funziona) lm-sensors dice che non ci sono ebuild.....

P.S con windows non da nessun problema....

Il bios non mi dice un tubo se non il nome della cpu e ste cose qui....

Il computer ha un anno.....secondo voi la garanzia copre sti danni?
_________________
IL DESTINO è CONTRO DI ME?!.....................TANTO PEGGIO PER LUI!!!
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sat Jul 03, 2010 12:39 pm    Post subject: Reply with quote

da root:
Code:
 hddtemp /dev/sda


i pacchetti si possono cercare con emerge -s nomepacchetto, il nome giusto è sys-apps/lm_sensors

ma windows non succede niente nemmeno quando è sotto sforzo per lunghi periodi? se lasci il computer acceso a far nulla penso che neanche gentoo si spenga
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum