Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to Resolve x11-libs/qt:3 revdep-rebuild problem?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
KayZee
Apprentice
Apprentice


Joined: 15 Oct 2003
Posts: 198
Location: Arlington, VA

PostPosted: Sun Apr 11, 2010 12:51 pm    Post subject: How to Resolve x11-libs/qt:3 revdep-rebuild problem? Reply with quote

After and update, I had a message to run revdep-rebuild for a library

Code:
revdep-rebuild --library libjpeg.so.7


Running that turned up a problem with x11-libs/qt:3 that I am not sure how to resolve. It says x11-libs/qt:3 is not in portage.

Code:
media-libs/netpbm:0
media-video/dvdauthor:0
net-libs/xulrunner:1.8
net-misc/tightvnc:0
net-print/cups:0
www-client/seamonkey:0
x11-libs/qt:3
x11-misc/xscreensaver:0
..........

 
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "x11-libs/qt:3".

*
 * revdep-rebuild failed to emerge all packages.
 * you have the following choices:
 * - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
 * - Use /etc/portage/package.keywords to unmask a newer version of the package.
 *   (and remove 5_order.rr to be evaluated again)
 * - Modify the above emerge command and run it manually.
 * - Compile or unmerge unsatisfied packages manually,
 *   remove temporary files, and try again.
 *   (you can edit package/ebuild list first)
 *
 * To remove temporary files, please run:
 * rm /var/cache/revdep-rebuild/*.rr



equery depends shows just this

Code:
 equery d x11-libs/qt
[ Searching for packages depending on x11-libs/qt... ]
kde-base/arts-3.5.9 (=x11-libs/qt-3.3*)


So do I just remove kde-base/arts-3.5.9?
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Sun Apr 11, 2010 2:31 pm    Post subject: Reply with quote

Yes, and remove the arts and qt USE flags from make.conf

Better post your emerge --info because something is screwey on your box. :)
Back to top
View user's profile Send private message
KayZee
Apprentice
Apprentice


Joined: 15 Oct 2003
Posts: 198
Location: Arlington, VA

PostPosted: Sun Apr 11, 2010 2:41 pm    Post subject: Reply with quote

Thanks.

I have neither "arts" nor "qt" in make.conf or package.use.
Quote:
more /etc/make.conf
# These settings were set by the catalyst build script that automatically built
this stage
# Please consult /etc/make.conf.example for a more detailed example
#
CFLAGS="-O2 -march=pentium4 -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"

USE="-qt4 -kde -bluetooth gtk gnome hal howl java browserplgin cups foomaticdb ppds ldap nptl nptlonly caps theora ieee1394 avahi
mdnsresponder-compat dbus dvd dvdr dvdread nsplugin"
INPUT_DEVICES="keyboard mouse evdev"
VIDEO_CARDS="vesa fbdev intel"

GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo http://gentoo.chem.wisc.edu/ge
ntoo/ ftp://gentoo.chem.wisc.edu/gentoo/ http://gentoo.mirrors.tds.net/gentoo ht
tp://gentoo.mirrors.easynews.com/linux/gentoo/"



Code:
emerge --info
Portage 2.1.7.17 (default/linux/x86/10.0/desktop, gcc-4.1.2, glibc-2.10.1-r1, 2.6.31-gentoo-r6 i686)
=================================================================
System uname: Linux-2.6.31-gentoo-r6-i686-Intel-R-_Pentium-R-_4_CPU_3.00GHz-with-gentoo-1.12.13
Timestamp of tree: Sat, 10 Apr 2010 13:00:01 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.10
dev-lang/python:     2.4.6, 2.5.4-r3, 2.6.4-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.3, 1.11.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       3.3.6-r1, 3.4.6-r2, 4.1.2, 4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium4 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo http://gentoo.chem.wisc.edu/gentoo/ ftp://gentoo.chem.wisc.edu/gentoo/ http://gentoo.mirrors.tds.net/gentoo http://gentoo.mirrors.easynews.com/linux/gentoo/"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa avahi berkdb branding browserplgin bzip2 cairo caps cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr dvdread emboss encode exif fam firefox flac foomaticdb fortran gdbm gif gnome gpm gtk hal howl iconv ieee1394 ipv6 java jpeg lcms ldap libnotify mad mdnsresponder-compat mikmod mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf perl png ppds pppd python qt3support readline reflection sdl session spell spl ssl startup-notification svg sysfs tcpd theora tiff truetype unicode usb vorbis x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa fbdev intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4398
Location: Suzhou, China

PostPosted: Sun Apr 11, 2010 2:44 pm    Post subject: Reply with quote

kde-3 was removed a while ago and qt-3 has been removed last month. We recommend you to unmerge those packages.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
KayZee
Apprentice
Apprentice


Joined: 15 Oct 2003
Posts: 198
Location: Arlington, VA

PostPosted: Sun Apr 11, 2010 3:21 pm    Post subject: Reply with quote

Thank you.

I think x11-libs/qt and kde-base/arts-3.5.9 were just orphaned packages on my system. Not sure why they were not cleaned up before. I have removed both now. Systems seems to be happy for the moment. The original revdep-rebuild that triggered the issue is now running.
Back to top
View user's profile Send private message
luboss
n00b
n00b


Joined: 29 May 2009
Posts: 17

PostPosted: Sat May 29, 2010 11:32 am    Post subject: What about Twinkle Reply with quote

yngwin wrote:
kde-3 was removed a while ago and qt-3 has been removed last month. We recommend you to unmerge those packages.


Hi, I have the same issue as KayZee but the problem is that Twinkle depends on x11-libs/qt:3.
I also noticed that Twinkle does not exist in portage anymore. May I ask why?
I know that last version (1.4.2) has been released over year ago but it's still the best voip phone I know.
I can't run it now:
"twinkle: error while loading shared libraries: libjpeg.so.7: cannot open shared object file: No such file or directory"

Does it mean that I'm forced to NOT use it and look for other one?
I thought that Gentoo was always about choice.
It's a shame.
Back to top
View user's profile Send private message
rh1
Guru
Guru


Joined: 10 Apr 2010
Posts: 501

PostPosted: Sat May 29, 2010 12:15 pm    Post subject: Reply with quote

Quote:

Does it mean that I'm forced to NOT use it and look for other one?


You can always add it to your local overlay if you wish to keep using.
Back to top
View user's profile Send private message
luboss
n00b
n00b


Joined: 29 May 2009
Posts: 17

PostPosted: Sat May 29, 2010 1:18 pm    Post subject: Reply with quote

rh1 wrote:
Quote:

Does it mean that I'm forced to NOT use it and look for other one?


You can always add it to your local overlay if you wish to keep using.


But how? QT3 is not supported anymore in Gentoo.
I tried to find ebuilds for qt3 an twinkle on packages.gentoo.org but none of them exists anymore.
It looks like that I will have to restore them from backup.
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Sat May 29, 2010 2:09 pm    Post subject: Reply with quote

... but don't they still have all that qt3 stuff in kde-sunset overlay?

See layman -L

Bye,

MH
Back to top
View user's profile Send private message
luboss
n00b
n00b


Joined: 29 May 2009
Posts: 17

PostPosted: Sat May 29, 2010 2:50 pm    Post subject: Reply with quote

Mike Hunt wrote:
... but don't they still have all that qt3 stuff in kde-sunset overlay?

See layman -L

Bye,

MH


Yes, it is.
Thank you
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Sat May 29, 2010 2:57 pm    Post subject: Reply with quote

Sure, you're welcome my friend.

Smile, :D

MH
Back to top
View user's profile Send private message
rh1
Guru
Guru


Joined: 10 Apr 2010
Posts: 501

PostPosted: Sat May 29, 2010 7:11 pm    Post subject: Reply with quote

Also if you need something not in the overlay, you can always use a funtoo portage git snapshot. It has a gentoo branch that goes back to '08. You can always checkout an old commit to get whatever you need. Best way i found to get ebuilds and stuff that have been removed from portage.
Back to top
View user's profile Send private message
mamac
l33t
l33t


Joined: 29 Feb 2004
Posts: 851

PostPosted: Tue Jul 20, 2010 1:52 pm    Post subject: Reply with quote

KayZee wrote:
Thank you.

I think x11-libs/qt and kde-base/arts-3.5.9 were just orphaned packages on my system. Not sure why they were not cleaned up before. I have removed both now. Systems seems to be happy for the moment. The original revdep-rebuild that triggered the issue is now running.

Hi,

I have the same problem here but I can't unmerge qt-3, system says:
Code:

FRPC285 ~ # emerge -Cav qt-3
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

>>> These are the packages that would be unmerged:

--- Couldn't find '=x11-libs/qt-3' to unmerge.

>>> No packages selected for removal by unmerge

How did you remove qt-3 ?

My emerge --info below:
Code:

FRPC285 ~ # emerge --info
Portage 2.1.8.3 (default/linux/x86/10.0/desktop/kde, gcc-4.4.3, glibc-2.11.2-r0, 2.6.32-gentoo-r7 i686)
=================================================================
System uname: Linux-2.6.32-gentoo-r7-i686-Genuine_Intel-R-_CPU_U2500_@_1.20GHz-with-gentoo-1.12.13
Timestamp of tree: Tue, 20 Jul 2010 07:30:01 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"                                     
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org"                                                                                                                           
LANG="en_US"                                                                                                                                                                       
LC_ALL="en_US"                                                                                                                                                                     
LDFLAGS="-Wl,-O1"                                                                                                                                                                   
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa apm berkdb bluetooth branding bzip2 cairo cdparanoia cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam fbcon ffmpeg firefox flac fortran gdbm gif gpm hal iconv ipv6 java jpeg kde lcms ldap libnotify lm_sensors mad mikmod mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf perl pmu png ppds pppd python qt3support qt4 readline reflection scanner sdl session spell spl ssl startup-notification svg symlink sysfs tcpd tiff truetype unicode usb vorbis wifi x264 x86 xcb xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="*" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" NETBEANS_MODULES="apisupport harness ide java nb websvccommon php" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

should I unmerge qt3-support?

Thank you
_________________
Powered by (x86) Gentoo Linux since 2003
Back to top
View user's profile Send private message
mamac
l33t
l33t


Joined: 29 Feb 2004
Posts: 851

PostPosted: Tue Jul 20, 2010 1:59 pm    Post subject: Reply with quote

qt-3 removed with:
Code:

emerge -Cav qt-3*

_________________
Powered by (x86) Gentoo Linux since 2003
Back to top
View user's profile Send private message
njcwotx
Guru
Guru


Joined: 25 Feb 2005
Posts: 514
Location: Texas

PostPosted: Thu Jul 29, 2010 9:11 pm    Post subject: Reply with quote

for older packages, there is still the ebuild for qt3support in the portage tree. My latest is qt-qt3support-4.6.3
_________________
Drinking from the fountain of knowldege.
Sometimes sipping.
Sometimes gulping.
Always thirsting.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum