Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome 2.28 and 2.30 coming soon?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
wormite
n00b
n00b


Joined: 05 Apr 2010
Posts: 19

PostPosted: Tue May 04, 2010 8:14 pm    Post subject: gnome 2.28 and 2.30 coming soon? Reply with quote

64bit Gentoo seems to lag behind in the sense of gnome.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31711
Location: 56N 3W

PostPosted: Tue May 04, 2010 8:57 pm    Post subject: Reply with quote

wormite,

2.28 has been in ~amd64 for a long time now. Its always worked for me.

2.30 is in the overlay if you want to try it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
wormite
n00b
n00b


Joined: 05 Apr 2010
Posts: 19

PostPosted: Tue May 04, 2010 10:25 pm    Post subject: Reply with quote

Thank you, I was kinda worried that ~amd64 can destroy the dependencies.
What is the best way to quickly install it?
I am currently using emerge av gnome-base/gnome and I have to
put the keywords one by one into the /etc/portage/package.keywords file
Back to top
View user's profile Send private message
wormite
n00b
n00b


Joined: 05 Apr 2010
Posts: 19

PostPosted: Tue May 04, 2010 10:47 pm    Post subject: Reply with quote

I just tried the overlay package for gnome 2.30 with
Code:
 ~ $ ACCEPT_KEYWORDS="~amd64" emerge -av gnome

Code:
Total: 101 packages (75 upgrades, 1 downgrade, 25 new), Size of downloads: 306,057 kB
Conflict: 1 block

Code:
[blocks b     ] <net-fs/samba-3.3 ("<net-fs/samba-3.3" is blocking sys-libs/tdb-1.2.1, sys-libs/talloc-2.0.1-r1)

What is the best option here? remove samba and try again?
[/profile]
Back to top
View user's profile Send private message
wormite
n00b
n00b


Joined: 05 Apr 2010
Posts: 19

PostPosted: Tue May 04, 2010 10:59 pm    Post subject: Reply with quote

I removed samba, gst-plugin to resolve the conflict. I wonder if they will be a mess in the future.
Back to top
View user's profile Send private message
huckabuck
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2007
Posts: 110
Location: Bronx, NY

PostPosted: Wed May 05, 2010 12:28 am    Post subject: Reply with quote

gnome 2.28 is building right now on my amd64 stable machine
Back to top
View user's profile Send private message
wormite
n00b
n00b


Joined: 05 Apr 2010
Posts: 19

PostPosted: Wed May 05, 2010 3:34 am    Post subject: Reply with quote

I installed the gnome 2.28, then with a emerge -uND world, everything went back.
anyone knows how to make the installation permanent?
Do I have to put everything into the package.keywords file?
Back to top
View user's profile Send private message
huckabuck
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2007
Posts: 110
Location: Bronx, NY

PostPosted: Wed May 05, 2010 3:42 am    Post subject: Reply with quote

After i updated 2.26 to 2.28 , i ran --depclean and the revdep-rebuild ... i'm on 2.28 stable. I've got nothing in package.keywords related to gnome.
Back to top
View user's profile Send private message
jonnevers
Veteran
Veteran


Joined: 02 Jan 2003
Posts: 1593
Location: Gentoo64 land

PostPosted: Wed May 05, 2010 3:29 pm    Post subject: Reply with quote

wormite wrote:
I installed the gnome 2.28, then with a emerge -uND world, everything went back.
anyone knows how to make the installation permanent?
Do I have to put everything into the package.keywords file?

the way you did it (above) with ACCEPT_KEYWORDS on the command line, isn't permanent. yes, you'd want to put the packages into package.keywords. perhaps using autounmask or similar utility and doing it manually is a frustratingly tedious experience.

by the by, gnome-2.30 ebuilds are in the gnome overlay but there is no gnome-2.30 meta-ebuild, so you end up with gnome2.28 meta-ebuild with 2.30 components. then you'll need to manually bring in the new 2.30 stuff (gnome-shell for example). not the greatest.
Back to top
View user's profile Send private message
wormite
n00b
n00b


Joined: 05 Apr 2010
Posts: 19

PostPosted: Fri May 07, 2010 7:46 pm    Post subject: Reply with quote

huckabuck wrote:
After i updated 2.26 to 2.28 , i ran --depclean and the revdep-rebuild ... i'm on 2.28 stable. I've got nothing in package.keywords related to gnome.

2.28 is officially available on gentoo 64 now.
but there is still this conflict
Code:

[blocks b     ] <net-fs/samba-3.3 ("<net-fs/samba-3.3" is blocking sys-libs/tdb-1.2.1, sys-libs/talloc-2.0.1-r1)

waiting for the solution
Back to top
View user's profile Send private message
jonnevers
Veteran
Veteran


Joined: 02 Jan 2003
Posts: 1593
Location: Gentoo64 land

PostPosted: Fri May 07, 2010 7:50 pm    Post subject: Reply with quote

Code:
emerge -C samba
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum