Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
startx does't run on nvidia & xorg 1.7.5, broken record?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
wilk_u
n00b
n00b


Joined: 12 Mar 2010
Posts: 3

PostPosted: Fri Mar 12, 2010 3:15 pm    Post subject: startx does't run on nvidia & xorg 1.7.5, broken record? Reply with quote

Hello.

My problem looks like this, when I try to run startx, I get:

Code:
xauth:  creating new authority file /home/wilk/.serverauth.9149


X.Org X Server 1.7.5
Release Date: 2010-02-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.33-rc5-zen1 x86_64
Current Operating System: Linux localhost 2.6.33-rc5-zen1 #3 ZEN SMP Wed Mar 10
Kernel command line: root=/dev/sda4 vga=ask video=vesafb,mtrr:3,ywrap
Build Date: 12 March 2010  02:39:42PM

Current version of pixman: 0.17.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Mar 12 15:52:41 2010
(==) Using config file: "/etc/X11/xorg.conf"
(EE) Failed to load module "dri" (module does not exist, 0)
(EE) Failed to load module "dri2" (module does not exist, 0)
record: RECORD extension enabled at configure time.
record: This extension is known to be broken, disabling extension now..
record: http://bugs.freedesktop.org/show_bug.cgi?id=20500
/etc/X11/xinit/xinitrc.d/11-xdg-menu-KDE-4: line 3: [: =: unary operator expecte
/etc/X11/xinit/xinitrc: line 58: twm: command not found
/etc/X11/xinit/xinitrc: line 59: xclock: command not found
/etc/X11/xinit/xinitrc: line 60: xterm: command not found
/etc/X11/xinit/xinitrc: line 61: xterm: command not found
/etc/X11/xinit/xinitrc: line 62: exec: xterm: not found

waiting for X server to shut down ..



I looked through forum and downgraded to 1.6.5 according to

http://forums.gentoo.org/viewtopic-t-799568.html

But nothing changed, I got the same error I posted above.

I got back to 1.7.5 to apply a patch from:

http://bugs.freedesktop.org/show_bug.cgi?id=20500

but after: patch -p1 --dry-run < patch_file_name

I have to enter the path of file to patch and I just don't know what path I should type in. And my newbie question is: how to applay that patch or maybe I do something wrong with it or there's another way to deal with it?

emerge --info:

Code:
Portage 2.1.8.3 (default/linux/amd64/10.0, gcc-4.3.4, glibc-2.11-r1, 2.6.33-rc5-zen1 x86_64)
=================================================================
System uname: Linux-2.6.33-rc5-zen1-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-gentoo-2.0.
Timestamp of tree: Wed, 10 Mar 2010 21:15:02 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:     4.1_p2
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4-r1, 3.1.1-r1
dev-util/cmake:      2.8.0-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.0-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.65
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1
sys-devel/gcc:       4.3.4, 4.4.3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer -msse4.1"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/
/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer -msse4.1"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests confcache distlocks fixpackages news parallel-fetch protect-owned sandbox sfp
GENTOO_MIRRORS="http://gentoo.mirror.pw.edu.pl/"
LDFLAGS="-Wl,-O1"
LINGUAS="pl"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file -
de=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="32bit X aalib acl acpi addressbook admin administrator alsa amd64 apache2 arts aspell audio batte
 consolekit cpufreq cracklib crypt cups custom-cflags cxx dav dbus device-mapper dri dvb dvd dvdr dvdr
t flac fortran ftp fts3 fuse gdbm gdu gif glib glitz gnutls gpm gstreamer gtk h323 hal hddtemp iconv j
ard laptop lcms ldap libnotify lm_sensors mad midi mikmod mjpeg mmx mmxext mng modules mouse mp3 mpeg
tl nptlonly ogg old-deamons opengl openmp opera pam pango pcre pdf perl php pmu png policykit powerkad
tion sandbox sdl secure-delete see2 semantic-desktop session sip smbclient source spell spl sql sqlite
link sysfs tcpd threads threadsX tiff tk truetype unicode unzip usb vcd vcdinfo vcdx vorbis wav webkit
 zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extp
ap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="*" ELIBC="glibc" INPUT_DE
DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" RUBY_TARG
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS,



and the basic xorg.conf just to make it run:
Code:
Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath      "/usr/lib64/xorg/modules"
    FontPath        "/usr/share/fonts/misc/"
    FontPath        "/usr/share/fonts/TTF/"
    FontPath        "/usr/share/fonts/OTF"
    FontPath        "/usr/share/fonts/Type1/"
    FontPath        "/usr/share/fonts/100dpi/"
    FontPath        "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
    Load           "glx"
    Load           "dbe"
    Load           "record"
    Load           "extmod"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
EndSection

Section "Device"
    Identifier     "Card0"
    Driver         "nvidia"
    VendorName     "nVidia Corporation"
    BoardName      "G96 [GeForce GT 130M]"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
     Depth       24
    EndSubSection
EndSection



Thanks for Your time and advices.
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Fri Mar 12, 2010 3:21 pm    Post subject: Reply with quote

I think it works. Just emerge xterm, xclock and twm.
Back to top
View user's profile Send private message
Raistlin Majere
n00b
n00b


Joined: 04 Feb 2010
Posts: 61

PostPosted: Fri Mar 12, 2010 3:27 pm    Post subject: Reply with quote

Quote:
/etc/X11/xinit/xinitrc: line 58: twm: command not found
/etc/X11/xinit/xinitrc: line 59: xclock: command not found
/etc/X11/xinit/xinitrc: line 60: xterm: command not found
/etc/X11/xinit/xinitrc: line 61: xterm: command not found
/etc/X11/xinit/xinitrc: line 62: exec: xterm: not found


i could be wrong but it looks like your trying to start twm
It's not installed with xorg-server anymore , you have to emerge a window manager or desktop.

Also , your using hal , you should delete some stuff from xorg.conf , basically get rid of the input device stuff , hal takes care of it for you, you want it to look like this :

Code:
Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
EndSection
Section "Device"
    Identifier     "Card0"
    Driver         "nvidia"
    VendorName     "nVidia Corporation"
    BoardName      "G96 [GeForce GT 130M]"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
     Depth       24
    EndSubSection
EndSection
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Fri Mar 12, 2010 3:32 pm    Post subject: Reply with quote

In fact, there is nothing really in the xorg.conf, so you should be good to go without one.
Back to top
View user's profile Send private message
wilk_u
n00b
n00b


Joined: 12 Mar 2010
Posts: 3

PostPosted: Fri Mar 12, 2010 3:44 pm    Post subject: Reply with quote

I made it as You both guys said, emerged and deleted these entries in xorg.conf. It helped, twm starts but if freezes after startup. Any ideas?
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Fri Mar 12, 2010 3:54 pm    Post subject: Reply with quote

Make sure that everything is configured and started:
Code:
 ~ # grep INPUT /etc/make.conf
INPUT_DEVICES="evdev"
Code:
 ~ # grep EVDEV /usr/src/linux/.config
CONFIG_INPUT_EVDEV=y
Code:
 ~ # /etc/init.d/hald status
* status: started
Code:
 ~ # eselect profile show
Current make.profile symlink:
  default/linux/amd64/10.0/desktop
If required
Code:
emerge -uDNav world

And rebuild all x11-drivers after emerging xorg-server
Code:
emerge app-portage/portage-utils && emerge -1av $(qlist -IC x11-drivers)
Code:
eselect opengl set nvidia
rmmod nvidia && modprobe nvidia


And look at the Gentoo Linux nVidia Guide
Make sure that your kernel is configured exactly that way.
Back to top
View user's profile Send private message
wilk_u
n00b
n00b


Joined: 12 Mar 2010
Posts: 3

PostPosted: Fri Mar 12, 2010 4:09 pm    Post subject: Reply with quote

Solved, thank You :)
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Fri Mar 12, 2010 4:52 pm    Post subject: Reply with quote

Cool :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum