Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO conveniently convert videos using mencoder, x264
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
fangorn
Veteran
Veteran


Joined: 31 Jul 2004
Posts: 1886

PostPosted: Sat Jan 30, 2010 8:32 am    Post subject: Reply with quote

I just uploaded new versions of menc, blu2mkv and choose_x264_encoding_parameters.sh.

menc writes to temporary directory now (configurable) and you can specify a output name and output directory.

I corrected some errors in filetype detection in blu2mkv

And i changed format of presets in choose_x264_encoding_parameters.sh. Now they should be easier to read (and maintain, as I still copy them from h264enc :wink: )
_________________
Video Encoding scripts collection | Project page
Back to top
View user's profile Send private message
fangorn
Veteran
Veteran


Joined: 31 Jul 2004
Posts: 1886

PostPosted: Mon Feb 08, 2010 8:35 pm    Post subject: Reply with quote

It was a very productive weekend.

I just updated all my scripts. If you update, be sure to update them all.

avi2mkv now finally automatically checks output container and audio format when a preset is specified. Also it can now mux to OGM container. Please test it and write if you find any problems.

choose_x264_encoding_parameters.sh now supports checking output video geometry and video bitrate. All encoding scripts now depend on it for scaling video!

menc, riptoh264 and blu2mkv now support user specified or x264 given output geometries and video bitrates. If there are multiple geometries allowed, the maximum resolution is used. When Bitrate is above preset limits, the maximum allowed value is used. User can specify output video width and height. Should only one parameter be given, video is scaled to calculated value given by specified value and source aspect ratio and black borders are added if the selected x264 video preset/playback device demands it.

Additionally riptoh264 now supports linear pcm audio streams.

blu2mkv also now supports the cropping of black borders and user specified output container selection (instead of Matroska use MPEG Transport Stream, ISO MP4 or OGM).

If you find any problems, report back here. Have Fun.
_________________
Video Encoding scripts collection | Project page
Back to top
View user's profile Send private message
fuzzybee
Apprentice
Apprentice


Joined: 09 May 2005
Posts: 156

PostPosted: Tue Feb 09, 2010 4:15 pm    Post subject: Reply with quote

Thanks for the updates.

For some reason, when I try to use blu2mkv, it displays:

Code:
 blu2mkv -p bd40 Pirates_of_the_Carribean_3.mkv
Search pattern not terminated at -e line 1.
Source file is of Type  Matroska
Width =
Height =
Aspect =
Aspect should be 1.77777777777778
Source Framerate: 23.976
Input Framerate used: 24000/1001
Output Framerate used: 24000/1001
No audio stream specified. Trying to use specified languages if available in source file. If not, default stream will be used.
AUDIO1 is -aid 0 1
Resolution = 1280:720
Do not scale is no
video is interlaced: no
dynamic noise reduction is active: no



Any suggestion as to why it's not pulling the file width/height/AR?
Back to top
View user's profile Send private message
fangorn
Veteran
Veteran


Joined: 31 Jul 2004
Posts: 1886

PostPosted: Wed Feb 10, 2010 8:17 am    Post subject: Reply with quote

I silently fixed some bugs since monday, so please try the newest version. :?
_________________
Video Encoding scripts collection | Project page
Back to top
View user's profile Send private message
fuzzybee
Apprentice
Apprentice


Joined: 09 May 2005
Posts: 156

PostPosted: Fri Feb 12, 2010 3:13 am    Post subject: Reply with quote

So far, it's working on the audio, but I still get this:
Code:

blu2mkv -b 3000 -pbd40 Doubt-2.mkv
Search pattern not terminated at -e line 1.
Source file is of Type  Matroska
Width =
Height =
Aspect =
Aspect should be 1.77777777777778
Source Framerate: 23.976
Input Framerate used: 24000/1001
Output Framerate used: 24000/1001
No audio stream specified. Trying to use specified languages if available in source file. If not, default stream will be used.
AUDIO1 is -aid 0 1
Resolution = 1280:720
Do not scale is no
video is interlaced: no
dynamic noise reduction is active: no
Back to top
View user's profile Send private message
fangorn
Veteran
Veteran


Joined: 31 Jul 2004
Posts: 1886

PostPosted: Fri Feb 12, 2010 6:26 am    Post subject: Reply with quote

fuzzybee wrote:
So far, it's working on the audio, but I still get this:
Code:

Search pattern not terminated at -e line 1.
...
Width =
Height =
Aspect =
...
No audio stream specified. Trying to use specified languages if available in source file. If not, default stream will be used.
AUDIO1 is -aid 0 1
...
Do not scale is no


So we have multiple minor and major problems here.

First: you have to put a space between -p and the preset. I don't know if this is a typo.

Then a problem with an if-file-exists statement as it seems.

The width and height problem is more serious.
What does
Code:
mplayer -msglevel identify=6 -frames 0 -identify -vc null -vo null -ao null Doubt-2.mkv
print?
do the following command lines print something?
Code:
ffmpeg -i Doubt-2.mkv 2>&1 | grep "Video" | cut -d' ' -f 10 | cut -d 'x' -f 1
ffmpeg -i Doubt-2.mkv 2>&1 | grep "Video" | cut -d' ' -f 10 | cut -d 'x' -f 2 | cut -d',' -f 1

If not, what does does
Code:
ffmpeg -i Doubt-2.mkv
print?

And: are there no language tags to the audio streams in the MKV file? You can correct that using the mmg header editor without copying all streams to a new file.
Or if you prefer other than the default languages (ger and eng), just set them in the beginning of the script (variables mkv_firstlanguage and mkv_secondlanguage).
But it is strange why it wants to encode two streams at once. ("-aid 0 1") I have to look into this to see if this is just a stupid output or a serious bug. :roll:

And last just a tip: if you don't want your FullHD content to be scaled down to 720p you have to specify the -n option (--noscale if I find the time to rewrite the option system :wink: )

Edit: I am not used to my own programming logic atm. :roll: With the new feature of preset based geometry checks, it is not clear if it gets scaled or if it doesn't. I will have to rethink the default values. Oh, those nifty library tool changes that affect multiple programs from different times. There is always an aspect you have not thought of. :roll:
_________________
Video Encoding scripts collection | Project page
Back to top
View user's profile Send private message
fuzzybee
Apprentice
Apprentice


Joined: 09 May 2005
Posts: 156

PostPosted: Sat Feb 13, 2010 1:50 pm    Post subject: Reply with quote

OK - I found part of my problem. For some reason, I no longer had ffmpeg installed.

I still have the following, though:

Code:
 blu2mkv -b 3000 -p bd40 -n Doubt-2.mkv
Search pattern not terminated at -e line 1.
Source file is of Type  Matroska
Width =
Height =
Aspect =
Aspect should be 1.77777777777778
Source Framerate: 23.976
Input Framerate used: 24000/1001
Output Framerate used: 24000/1001
No audio stream specified. Trying to use specified languages if available in source file. If not, default stream will be used.
AUDIO1 is -aid 0 1
Resolution = 1280:720
Do not scale is yes
video is interlaced: no
dynamic noise reduction is active: no

using audio stream: eng which is stream 0 1
Back to top
View user's profile Send private message
fangorn
Veteran
Veteran


Joined: 31 Jul 2004
Posts: 1886

PostPosted: Sun Feb 14, 2010 7:43 am    Post subject: Reply with quote

Is the path to ffmpeg in the beginning of the script set correctly?

run "which ffmpeg" and use the result there.

Also you might check your source file. It seems to have two audio streams of a preferred language, which irritates the script in the last version.

I corrected that in my development version, but I already changed major features and my version is absolutely untested. So if you want to test further, consider changing the language setting of the unneeded audio stream in your source to something else (mmg has a header editor that can do that "in place" for Matroska sources). I don't know when i will release the corrected version. There are already some features i have in queue that seem easy to implement and maybe I will include them before the next release. :roll:
_________________
Video Encoding scripts collection | Project page
Back to top
View user's profile Send private message
fuzzybee
Apprentice
Apprentice


Joined: 09 May 2005
Posts: 156

PostPosted: Mon Feb 15, 2010 1:23 am    Post subject: Reply with quote

OK - I don't know what went wrong with my ffmpeg install, but that's taken care of now, and the script points to the right spot. I've altered the .mkv to call my DTS-HD file as Finnish. Now, I get:

Code:
blu2mkv -b 3000 -p bd40 -n Doubt-1.mkv
Source file is of Type  Matroska
Width = 1920
Height = 1080
Aspect = 1.77777777777778
Aspect should be 1.77777777777778
Source Framerate: 23.976
Input Framerate used: 24000/1001
Output Framerate used: 24000/1001
No audio stream specified. Trying to use specified languages if available in source file. If not, default stream will be used.
AUDIO1 is -aid 0
Resolution = 1280:720
Do not scale is yes
video is interlaced: no
dynamic noise reduction is active: no

using audio stream: eng which is stream 0
which is a DTS stream. To prevent sync problems, it will be converted to MP3 and muxed later
MPlayer SVN-r30425-4.3.4 (C) 2000-2010 MPlayer Team

Playing Doubt-1.mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_DTS) "3/2+1", -aid 0, -alang eng
[mkv] Track ID 3: audio (A_DTS) "HD Lossless", -aid 1, -alang fin
[mkv] Subtitle type 'S_HDMV/PGS' is not supported.
[mkv] Track ID 4: subtitles (S_HDMV/PGS), -sid 0, -slang eng
[mkv] Subtitle type 'S_HDMV/PGS' is not supported.
[mkv] Track ID 5: subtitles (S_HDMV/PGS), -sid 1, -slang eng
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO:  [avc1]  1920x1080  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)


Why is it still trying to resize down to 1280:720?
Back to top
View user's profile Send private message
fangorn
Veteran
Veteran


Joined: 31 Jul 2004
Posts: 1886

PostPosted: Mon Feb 15, 2010 10:07 am    Post subject: Reply with quote

Your version scales video to 720p by default. To prevent that you have to specify the -n option. I thought I pointed that out in the script somewhere. :roll:

My development version has other defaults. But I changed/added about 500 lines of code in one and a half days and have to test a little. :wink:

Edit: As I recognize now, you already got the -n option. The output is a little bit distracting in this case.
Quote:
Resolution = 1280:720
Do not scale is yes
means that default resolution is 720p, but source video is not scaled, so stays 1080p.
_________________
Video Encoding scripts collection | Project page
Back to top
View user's profile Send private message
fuzzybee
Apprentice
Apprentice


Joined: 09 May 2005
Posts: 156

PostPosted: Mon Feb 15, 2010 3:08 pm    Post subject: Reply with quote

It's cool - you missed the -n, I missed the "Do not scale is yes". :)

I'm really confused now, though. I know I've used this script successfully before, and I'm not sure what's changed on my system. Now, the script complains that it can't find tsmuxer. I have no indication that tsmuxer has ever been on this install. I installed tsMuxeR, and it complains that it can't find libfreetype.so.6

Have the scripts changed to require tsMuxeR?
Back to top
View user's profile Send private message
fangorn
Veteran
Veteran


Joined: 31 Jul 2004
Posts: 1886

PostPosted: Mon Feb 15, 2010 7:44 pm    Post subject: Reply with quote

Avi2mkv needs tsMuxer when muxing to MPEG transport stream (which is used by default by several x264 encoding profiles - for instance the avchd or bluray presets but also ps3 and others). Some also support other containers, but you have to specify them on the command line with blu2mkv.

blu2mkv needs tsMuxer when automatically reading BluRay/AVCHD structures from directory or ISO image. Oh, that is my development version only. :twisted:
_________________
Video Encoding scripts collection | Project page
Back to top
View user's profile Send private message
fuzzybee
Apprentice
Apprentice


Joined: 09 May 2005
Posts: 156

PostPosted: Mon Feb 15, 2010 7:49 pm    Post subject: Reply with quote

Gotcha. I see what I did before - I muxed using vhq rather than bd40. I'll try a shot at vhq.
Back to top
View user's profile Send private message
fuzzybee
Apprentice
Apprentice


Joined: 09 May 2005
Posts: 156

PostPosted: Tue Feb 16, 2010 2:20 am    Post subject: Reply with quote

Argh.

So I edited the original MKV and took our the DTS-HD track altogether. Now, I get this:

blu2mkv -b 3000 -p vhq -n Doubt-3.mkv
Code:
Source file is of Type  Matroska
Width = 1920
Height = 1080
Aspect = 1.77777777777778
Aspect should be 1.77777777777778
Source Framerate: 23.976
Input Framerate used: 24000/1001
Output Framerate used: 24000/1001
No audio stream specified. Trying to use specified languages if available in source file. If not, default stream will be used.
AUDIO1 is -aid 0
Resolution = 1280:720
Do not scale is yes
video is interlaced: no
dynamic noise reduction is active: no

using audio stream: eng which is stream 0
which is a DTS stream. To prevent sync problems, it will be converted to MP3 and muxed later
MPlayer SVN-r30425-4.3.4 (C) 2000-2010 MPlayer Team

Playing Doubt-3.mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_DTS) "3/2+1", -aid 0, -alang eng
[mkv] Subtitle type 'S_HDMV/PGS' is not supported.
[mkv] Track ID 3: subtitles (S_HDMV/PGS), -sid 0, -slang eng
[mkv] Subtitle type 'S_HDMV/PGS' is not supported.
[mkv] Track ID 4: subtitles (S_HDMV/PGS), -sid 1, -slang eng
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO:  [avc1]  1920x1080  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
Core dumped ;)

Exiting... (End of file)
not resizing video
calling external program choose_x264_encoding_parameters.sh
external call was successfull
using seleted preset vhq
using nombtree for compatibility reasons with mp3 audio conversion
geometryfilteroptions expand=1920:1080
video filters used for first pass:  -vf expand=1920:1080,hqdn3d=2:1:2,harddup
AUDIO channel used -aid 0
second audio
MEncoder SVN-r30425-4.3.4 (C) 2000-2010 MPlayer Team
success: format: 0  data: 0x0 - 0x654b0620
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_DTS) "3/2+1", -aid 0, -alang eng
[mkv] Track ID 3: subtitles (S_HDMV/PGS), -sid 0, -slang eng
[mkv] Track ID 4: subtitles (S_HDMV/PGS), -sid 1, -slang eng
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO:  [avc1]  1920x1080  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:31  fourcc:0x31637661  size:1920x1080  fps:23.976  ftime:=0.0417
Input fps will be interpreted as 23.976 instead.
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 1536.0 kbit/100.00% (ratio: 192000->192000)
Selected audio codec: [ffdca] afm: ffmpeg (FFmpeg DTS)
==========================================================================
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
Opening video filter: [harddup]
Opening video filter: [hqdn3d=2:1:2]
Opening video filter: [expand w=1920 h=1080]
Expand: 1920 x 1080, -1 ; -1, osd: 0, aspect: 0.000000, round: 1
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
audiocodec: framecopy (format=2001 chans=2 rate=48000 bits=16 B/s=192000 sample-1)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.

Exiting...
video filters used for second pass:  -vf spp,expand=1920:1080,hqdn3d=2:1:2,harddup
MEncoder SVN-r30425-4.3.4 (C) 2000-2010 MPlayer Team
success: format: 0  data: 0x0 - 0x654b0620
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_DTS) "3/2+1", -aid 0, -alang eng
[mkv] Track ID 3: subtitles (S_HDMV/PGS), -sid 0, -slang eng
[mkv] Track ID 4: subtitles (S_HDMV/PGS), -sid 1, -slang eng
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO:  [avc1]  1920x1080  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:31  fourcc:0x31637661  size:1920x1080  fps:23.976  ftime:=0.0417
Input fps will be interpreted as 23.976 instead.
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 1536.0 kbit/100.00% (ratio: 192000->192000)
Selected audio codec: [ffdca] afm: ffmpeg (FFmpeg DTS)
==========================================================================
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
Opening video filter: [harddup]
Opening video filter: [hqdn3d=2:1:2]
Opening video filter: [expand w=1920 h=1080]
Expand: 1920 x 1080, -1 ; -1, osd: 0, aspect: 0.000000, round: 1
Opening video filter: [spp]
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
[PP] Using external postprocessing filter, max q = 6.
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.

Exiting...
Source files has subtitle tracks
Track numbers 3 4
extract subtitle track 3
format not found, skipping
extract subtitle track 4
format not found, skipping
muxing to Matroska container
mkvmerge v2.9.7 ('Tenderness') built on Jan 21 2010 20:47:46
Error: The file 'Doubt-3.avi' has unknown type. Please have a look at the supported file types ('mkvmerge --list-types') and contact the author Moritz Bunkus <moritz@bunkus.org> if your file type is supported but not recognized properly.


I'm really not sure why this has ceased working.
Back to top
View user's profile Send private message
fangorn
Veteran
Veteran


Joined: 31 Jul 2004
Posts: 1886

PostPosted: Tue Feb 16, 2010 6:39 am    Post subject: Reply with quote

There should be a *_commands.log or *_mencoder.log with the command lines used for encoding.

Try to run those on the command line (in the same directory) and see what mencoder spits out.

I had cases, where mencoder was not built with x264 support, where mencoder could not handle one or more of the x264 preset parameters, ... If you did not recompile mplayer lately, the second option is more likely.
_________________
Video Encoding scripts collection | Project page
Back to top
View user's profile Send private message
fuzzybee
Apprentice
Apprentice


Joined: 09 May 2005
Posts: 156

PostPosted: Tue Feb 16, 2010 6:18 pm    Post subject: Reply with quote

OK - here's where I've gotten. It's bombing out on:

Code:
/usr/local/bin/mencoder Doubt-3.mkv -aid 0 -oac copy -nosub -ovc x264 -x264encopts me=umh:me_range=24:nodct_decimate:8x8dct:nofast_pskip:trellis=1:partitions=p8x8,b8x8,i8x8,i4x4:mixed_refs:keyint=240:psy_rd=0.8,0.2:frameref=4:bframes=5:b_adapt=2:b_pyramid=normal:weight_b:weightp=2:direct_pred=auto:subq=7:nombtree/:chroma_me:cabac:aq_mode=1:deblock:vbv_maxrate=9500:vbv_bufsize=12000:level_idc=41:threads=auto:ssim:psnr:bitrate=3000:pass=1:turbo=2 -passlogfile Doubt-3_2pass.log -vf expand=1920:1080,hqdn3d=2:1:2,harddup -fps 24000/1001 -ofps 24000/1001 -o /dev/null


The error I get is:

Code:
FATAL: Cannot initialize video driver.


I can understand why it's not initializing the video driver, because I'm just SSHd in to the box. Can mencoder no longer work from command line?
Back to top
View user's profile Send private message
fangorn
Veteran
Veteran


Joined: 31 Jul 2004
Posts: 1886

PostPosted: Tue Feb 16, 2010 7:05 pm    Post subject: Reply with quote

try removing the -vf expand=1920:1080,hqdn3d=2:1:2,harddup part. I can't understand anyway why it wants to expand the video.

mencoder does not open display windows. So the "video driver" is the decoding chain, the filter set or the encoder. when it is a x264 option there is a small statement somewhere that option xyz is not recognized.
_________________
Video Encoding scripts collection | Project page
Back to top
View user's profile Send private message
fuzzybee
Apprentice
Apprentice


Joined: 09 May 2005
Posts: 156

PostPosted: Tue Feb 16, 2010 7:07 pm    Post subject: Reply with quote

Thanks for all your help with this.

Here's what I get after removing the -vf part:

Code:
/usr/local/bin/mencoder Doubt-3.mkv -aid 0 -oac copy -nosub -ovc x264 -x264encopts me=umh:me_range=24:nodct_decimate:8x8dct:nofast_pskip:trellis=1:partitions=p8x8,b8x8,i8x8,i4x4:mixed_refs:keyint=240:psy_rd=0.8,0.2:frameref=4:bframes=5:b_adapt=2:b_pyramid=normal:weight_b:weightp=2:direct_pred=auto:subq=7:nombtree/:chroma_me:cabac:aq_mode=1:deblock:vbv_maxrate=9500:vbv_bufsize=12000:level_idc=41:threads=auto:ssim:psnr:bitrate=3000:pass=1:turbo=2 -passlogfile Doubt-3_2pass.log -fps 24000/1001 -ofps 24000/1001 -o /dev/null
MEncoder SVN-r30425-4.3.4 (C) 2000-2010 MPlayer Team
Option x264encopts: Unknown suboption nombtree/
success: format: 0  data: 0x0 - 0x654b0620
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_DTS) "3/2+1", -aid 0, -alang eng
[mkv] Subtitle type 'S_HDMV/PGS' is not supported.
[mkv] Track ID 3: subtitles (S_HDMV/PGS), -sid 0, -slang eng
[mkv] Subtitle type 'S_HDMV/PGS' is not supported.
[mkv] Track ID 4: subtitles (S_HDMV/PGS), -sid 1, -slang eng
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO:  [avc1]  1920x1080  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:31  fourcc:0x31637661  size:1920x1080  fps:23.976  ftime:=0.0417
Input fps will be interpreted as 23.976 instead.
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 1536.0 kbit/100.00% (ratio: 192000->192000)
Selected audio codec: [ffdca] afm: ffmpeg (FFmpeg DTS)
==========================================================================
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
audiocodec: framecopy (format=2001 chans=2 rate=48000 bits=16 B/s=192000 sample-1)
[h264 @ 0x13df760]non-existing SPS 1 referenced in buffering period
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
FATAL: Cannot initialize video driver.
Back to top
View user's profile Send private message
fuzzybee
Apprentice
Apprentice


Joined: 09 May 2005
Posts: 156

PostPosted: Tue Feb 16, 2010 7:08 pm    Post subject: Reply with quote

Ah!

Code:
Option x264encopts: Unknown suboption nombtree/
Back to top
View user's profile Send private message
fangorn
Veteran
Veteran


Joined: 31 Jul 2004
Posts: 1886

PostPosted: Wed Feb 17, 2010 6:41 am    Post subject: Reply with quote

Most likely it is the slash at the end. Have not seen that before. You can also test if mbtree works for you. It is said to have good quality improvement with slight impact on the conversion time. (But in my experience there is not a visible difference in most sources when encoding fullHD in two-pass mode with 6000 kBit/s average bitrate, which is the default of blu2mkv - might be different when converting MTV-cut source material, but I could not watch that for a whole movie length :wink: )

Edit:
Thank you, you found a bug.

My replacement when encoding DTS audio sources is wrong.
encopts="${encopts//:mbtree/:nombtree/}"
is sed style. bash does not need the last /.

Edit:
It is corrected in the recent version. Just re-download blu2mkv
_________________
Video Encoding scripts collection | Project page


Last edited by fangorn on Thu Feb 18, 2010 3:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
fangorn
Veteran
Veteran


Joined: 31 Jul 2004
Posts: 1886

PostPosted: Mon Feb 22, 2010 7:07 pm    Post subject: Reply with quote

I just uploaded an updated version of blu2mkv. It will still take a while to implement the "killer feature" of version 1.0.0.

I recognized that tsMuxeR can't reproducibly report language codes, so I had to search for an alternative. I found one, but it is a C program that maybe will be a part of handbrake later. So I decided to reimplement the parser and add my functions to the program. Thanks to the developer(s) for providing this excellently working parser code. Took me less time to write it as my first real Perl program than it would have taken to read the documentation of the binary format. If they are interested, I will provide them with the additional functions to output tsMuxeR .meta files.
_________________
Video Encoding scripts collection | Project page
Back to top
View user's profile Send private message
fuzzybee
Apprentice
Apprentice


Joined: 09 May 2005
Posts: 156

PostPosted: Mon Feb 22, 2010 8:24 pm    Post subject: Reply with quote

Thanks for the update!

It's me again :)

Working on the same file blu2mkv doesn't seem to recognize the command-line switches:

Code:
blu2mkv -b 3000 -p vhq -n Doubt.mkv
head: cannot open `3000' for reading: No such file or directory
Search pattern not terminated at -e line 1.
Source file is of Type  Unknown :(
Width =
Height =
Aspect =
Aspect should be 1.77777777777778
Source Framerate:
Input Framerate used:
Output Framerate used:
No audio stream specified. Trying to use specified languages if available in source file. If not, default stream will be used.
Resolution = 1920:1080
Do not scale is yes
video is interlaced: no
dynamic noise reduction is active: no

using audio stream: default
/usr/bin/blu2mkv: line 612: [: : integer expression expected
/usr/bin/blu2mkv: line 615: [: : integer expression expected
syntax error at -e line 1, at EOF
Execution of -e aborted due to compilation errors.
/usr/bin/blu2mkv: line 647: [: : integer expression expected
calling external program choose_x264_encoding_parameters.sh
-> No preset specified!
choose_x264_encoding_parameters.sh Version 0.2.1

Program to choose x264 encoding presets.

Usage: choose_x264_encoding_parameters.sh -p <preset>  -W <sourcewidth> -H <sourceheight> -f <fps> -o <outputfile> -B <bitrate>
                [-eL] [-c <CROPparameters>] [-w <outputwidth>] [-h <outputheight>]
                [-l <level>] [-b <max_bufsize>] [-r <max_bitrate]

 -o <outputfile>
            specify outputfile to log settings (mandatory)
 -f <fps>
            frames per second of source video (mandatory)
 -p <preset>
            x264 encoding preset (mandatory)
 -W <sourcewidth>
 -H <sourceheight>
            input video width and height (mandatory)
 -B <bitrate>
            video bitrate (mandatory)
 -w <outputwidth>
 -h <outputheight>
            output video width and height (optional)
            when none of them are given, source video or preset maximum geometry is used
            if only one is given, the other is calculated from the given value and the source or target aspect ratio
               if -e option is present, black borders are added to reach output aspect ratio
            if both are given, these are used
 -c <CROPparameters>
            parameters created by a "mplayer -cropdetect" run (optional)
 -l <level>
            h.264 level [Default: 4.1]
 -b <max_bufsize>
            maximum bufsize for video stream (optional)
 -r <max_bitrate>
            maximum bitrate for video stream (optional)
 -e         expand video with black borders to match given or demanded aspect ratio (optional)
 -L         list available presets and exit (optional)

            Use a predefined H.264 quality preset. You can
            choose from 61 different presets:

            PC Presets
            ~~~~~~~~~~
            ulq -------> Ultra Low Quality preset
            elq -------> Extreme Low Quality preset
            vlq -------> Very Low Quality preset
            lq --------> Low Quality preset
            mq --------> Medium Quality preset
            nq --------> Normal Quality preset
            hq --------> High Quality preset (recommended)
            vhq -------> Very High Quality preset (recommended)
            ehq -------> Extreme High Quality preset (recommended)
            uhq -------> Ultra High Quality preset
            ihq -------> Insane High Quality preset
            nlq -------> Near Lossless Quality preset
            fghq ------> Film Grain optimized High Quality preset
            ani -------> Anime preset
            anihq -----> Anime High Quality preset
            vdhq ------> VDPAU/DXVA High Quality (High@L4.1) preset
            vdehq -----> VDPAU/DXVA Extreme High Quality (High@L4.1) preset
            vdihq -----> VDPAU/DXVA Insane High Quality (High@L4.1) preset

            Software Compatible Presets
            ~~~~~~~~~~~~~~~~~~~~~~~~~~~
            fl --------> Flash Player preset
            flhq ------> Flash Player High Quality preset
            qt --------> QuickTime preset
            qthq ------> QuickTime High Quality preset

            Device Presets
            ~~~~~~~~~~~~~~
            bd40 ------> Blu-ray (Main@L4.0) preset
            bdhq40 ----> Blu-ray High Quality (High@L4.0) preset
            bd41 ------> Blu-ray (Main@L4.1) preset
            bdhq41 ----> Blu-ray High Quality (High@L4.1) preset
            avchd -----> AVCHD (Main@L4.0) preset
            avchdhq ---> AVCHD High Quality (High@L4.1) preset
            sdb -------> Stand-alone HW players SD (Baseline@L3.0) preset
            sdm -------> Stand-alone HW players SD (Main@L3.0) preset
            sdh -------> Stand-alone HW players SD (High@L3.0) preset
            hdb -------> Stand-alone HW players HD (Baseline@L4.0) preset
            hdm -------> Stand-alone HW players HD (Main@L4.0) preset
            hdh -------> Stand-alone HW players HD (High@L4.0) preset
            ag1 -------> Android G1 preset
            ag1hq -----> Android G1 High Quality preset
            ipc -------> Apple iPod Classic preset
            ipchq -----> Apple iPod Classic High Quality preset
            ip --------> Apple iPod preset
            iphq ------> Apple iPod High Quality preset
            iph -------> Apple iPhone preset
            iphhq -----> Apple iPhone High Quality preset
            atv -------> AppleTV preset
            atvhq -----> AppleTV High Quality preset
            ar --------> Archos 605 preset
            arhq ------> Archos 605 High Quality preset
            ar5 -------> Archos 5 preset
            ar5hq -----> Archos 5 High Quality preset
            bb --------> Blackberry Bold 9000 preset
            bbhq ------> Blackberry Bold 9000 High Quality preset
            nks60 -----> Nokia S60 preset
            nks60hq ---> Nokia S60 High Quality preset
            psp -------> Sony PSP preset
            psphq -----> Sony PSP High Quality preset
            ps3 -------> Sony PS3 preset
            ps3hq -----> Sony PS3 High Quality preset
            mz --------> Microsoft Zune preset
            mzhq ------> Microsoft Zune High Quality preset
            mx --------> Microsoft XBOX 360 preset
            mxhq ------> Microsoft XBOX 360 High Quality preset
            htm -------> HTC Magic

external call was successfull
grep: 3000_x264_encoding_parameters.txt: No such file or directory
encoder options by preset are empty. Using default settings.
grep: 3000_x264_encoding_parameters.txt: No such file or directory
geometryfilteroptions
video filters used for first pass:  -vf harddup
AUDIO channel used
second audio
MEncoder SVN-r30425-4.3.4 (C) 2000-2010 MPlayer Team

Exiting... (error parsing command line)
video filters used for second pass:  -vf harddup
MEncoder SVN-r30425-4.3.4 (C) 2000-2010 MPlayer Team

Exiting... (error parsing command line)
Please specify an existing file as input
Call to external program avi2mkv failed.


It does seem to work without the options, though.
Back to top
View user's profile Send private message
fangorn
Veteran
Veteran


Joined: 31 Jul 2004
Posts: 1886

PostPosted: Tue Feb 23, 2010 6:50 am    Post subject: Reply with quote

OK, maybe the release was a little bit hasty. :oops:

As you might have read in the Changelog, I have rewritten the option handling. But -b should normally work. For a try, use --bitrate instead. I think the long version of -p is --preset, but I am not sure atm. :roll:

And -n is not needed/supported any more.

Note to self: Do not remove options, just drop them dead when not needed any more. :evil:
_________________
Video Encoding scripts collection | Project page
Back to top
View user's profile Send private message
fangorn
Veteran
Veteran


Joined: 31 Jul 2004
Posts: 1886

PostPosted: Tue Feb 23, 2010 6:14 pm    Post subject: Reply with quote

Found the bug. I assigned -n option twice. :roll:

New version of blu2mkv is online. Sorry.
_________________
Video Encoding scripts collection | Project page
Back to top
View user's profile Send private message
miroR
Guru
Guru


Joined: 05 Mar 2008
Posts: 386

PostPosted: Sat Feb 27, 2010 8:07 pm    Post subject: looks great, but is nearly ILLEGIBLE Reply with quote

Can the viewing be fixed perchance?
https://docs.google.com/leaf?id=0B27EDPvRqbLKYTAyNDI5YTYtMTNjNi00ZTYxLWExMWQtZGI3OTgwOWZhYzBh&hl=en
https://docs.google.com/leaf?id=0B27EDPvRqbLKNjczMmZlODQtMTY2Mi00NDgyLTg5NzAtYjI0NzQyODIzNDIx&hl=en
(I hope anyone can see what I mean...)
Can that be fixed?
Because the scripts look great...
Or could something else be the matter... I wouldn't think so, as I browse the http://forums.gentoo.org/ just fine anywhere else...
Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
Page 3 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum