Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
krossruby emerge fails to find Ruby [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
shaunole
n00b
n00b


Joined: 13 Sep 2008
Posts: 47

PostPosted: Tue Feb 02, 2010 1:37 pm    Post subject: krossruby emerge fails to find Ruby [SOLVED] Reply with quote

When emerging krossruby, it fails with the error:
Ruby Libraries: RUBY_LIBRARY-NOTFOUND

I've confirmed that Ruby is installed and that I have version: 1.8.7_p249

I'm not sure how to get krossruby to recognize the Ruby version. I've added my example to:
Gentoo Bug: 256703

However that bug report mentions that it's in reference to Ruby 1.9, which is not my case. Perhaps someone here can shed some light on what I'm missing.

Thanks.
_________________
Shaun Oleson
My personal Rants on Technology and Nonsense.


Last edited by shaunole on Thu Feb 04, 2010 3:51 pm; edited 2 times in total
Back to top
View user's profile Send private message
shaunole
n00b
n00b


Joined: 13 Sep 2008
Posts: 47

PostPosted: Wed Feb 03, 2010 12:12 pm    Post subject: Reply with quote

I have completed a bug report. Any guidance on what could be the issue here would be greatly appreciated. I take it by the lack of response that other's are not seeing the same issue.

Gentoo Bug 303217

Thanks.
_________________
Shaun Oleson
My personal Rants on Technology and Nonsense.
Back to top
View user's profile Send private message
shaunole
n00b
n00b


Joined: 13 Sep 2008
Posts: 47

PostPosted: Thu Feb 04, 2010 3:45 pm    Post subject: Reply with quote

what is the portage command to determine what packages are requiring a specific package. I noticed that I don't have krossruby built in another i7 system of mine, yet this one is requiring it. There must be a package or series of packages trying to pull it in.

Thanks.
_________________
Shaun Oleson
My personal Rants on Technology and Nonsense.
Back to top
View user's profile Send private message
shaunole
n00b
n00b


Joined: 13 Sep 2008
Posts: 47

PostPosted: Thu Feb 04, 2010 3:54 pm    Post subject: Reply with quote

shaunole wrote:
what is the portage command to determine what packages are requiring a specific package. I noticed that I don't have krossruby built in another i7 system of mine, yet this one is requiring it. There must be a package or series of packages trying to pull it in.

Thanks.


The solution was found in:

Gentoo Bug 265370

You need to create a libruby.so symlink in /usr/lib to point to the correct libruby so file for your install. eselect does not properly create this link.
_________________
Shaun Oleson
My personal Rants on Technology and Nonsense.
Back to top
View user's profile Send private message
a3li
Developer
Developer


Joined: 02 Sep 2008
Posts: 97
Location: 德国

PostPosted: Thu Feb 04, 2010 9:44 pm    Post subject: Reply with quote

shaunole wrote:

You need to create a libruby.so symlink in /usr/lib to point to the correct libruby so file for your install. eselect does not properly create this link.


Don't do that. eselect ruby does not create this link _on purpose_. It will break horribly when there's Ruby 1.8 and Ruby 1.9 around, as my comment on the bug stated.
_________________
I am Confuism. Do not bother me.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum