Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Compiz for Enlightenment-0.17
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
sian
Apprentice
Apprentice


Joined: 26 Jan 2004
Posts: 288

PostPosted: Sat Mar 28, 2009 6:45 pm    Post subject: Reply with quote

@ppurka : I am using your ebuilds. I have the same problem. I do not have switcher nor exposé.
I am lauching ecomorph via entrance.

Quote:

GNU nano 2.1.7 Fichier : /usr/share/xsessions/ecomorph.desktop

[Desktop Entry]
Encoding=UTF-8
Name=E17 - Ecomorph
Comment=Log in using Ecomorph (Version 0.16.999.050)
Comment[it]=Effettua accesso con Ecomorph (Versione 0.16.999.050)
Type=XSession
Icon=/usr/share/enlightenment/data/images/enlightenment.png
Exec=/usr/bin/enlightenment_start.sh
TryExec=/usr/bin/enlightenment_start.sh

_________________
Kernel : 2.6.32 - E17 - OpenRC-0.61 - gcc-4.4.3
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3206

PostPosted: Sat Mar 28, 2009 7:17 pm    Post subject: Reply with quote

If you had hit the same LDFLAGS problem as I had run into, then try the following:
  • Backup your ~/.ecomp:
    Code:
    mv ~/.ecomp ~/.ecomp.old

  • Kill ecomorph.
    Code:
    killall ecomorph

  • Start ecomorph as follows, on a terminal:
    Code:
    ecomorph --loose-binding ini inotify &

If you get the error message that it could not load ini, then it means that you have run into the same problem that I faced. In this case, you will notice that no fresh ~/.ecomp directory will be created and no ~/.ecomp/ecomp.eet file will be created. In this situation, you will need to recompile ecomp with the new ebuilds I posted yesterday.

However, if you do not get the error message regarding ini, then your ~/.ecomp/ecomp.eet file should be automatically created. This means that ecomorph is running properly on your system. You can now remove the newly created ~/.ecomp directory and replace it with ~/.ecomp.old (which contains your custom modifications). This probably means that you have not set up your keybindings/edgebindings for switcher/expose, etc. You will need to go to e17 keybinding dialog and set your keybindings for that. If the problem persists, then I suggest you create a new bug report (issue) in the ecomorph website.

If my ebuilds don't work, can you post your emerge --info?
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
sian
Apprentice
Apprentice


Joined: 26 Jan 2004
Posts: 288

PostPosted: Sat Mar 28, 2009 9:06 pm    Post subject: Reply with quote

@ppurka : I used your ebuild. In fact I did not configure my keybindings. All works fine except the switcher. But I will wait a little bit for a new version of ecomp.

Thank you for your ebuild and your help.
Now e17 rocks !
_________________
Kernel : 2.6.32 - E17 - OpenRC-0.61 - gcc-4.4.3
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3206

PostPosted: Sat Mar 28, 2009 9:22 pm    Post subject: Reply with quote

sian wrote:
@ppurka : I used your ebuild. In fact I did not configure my keybindings. All works fine except the switcher. But I will wait a little bit for a new version of ecomp.

Thank you for your ebuild and your help.
Now e17 rocks !
Yes, it does rock. But, I am unable to make flash videos fullscreen. The videos become fullscreen and then instantly collapse back to the browser. :cry:
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
sian
Apprentice
Apprentice


Joined: 26 Jan 2004
Posts: 288

PostPosted: Sun Mar 29, 2009 8:17 am    Post subject: Reply with quote

@ppurka : do you have switcher ? water ?
_________________
Kernel : 2.6.32 - E17 - OpenRC-0.61 - gcc-4.4.3
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3206

PostPosted: Sun Mar 29, 2009 5:36 pm    Post subject: Reply with quote

sian wrote:
@ppurka : do you have switcher ? water ?
I just updated e17 from svn. I am waiting for the e17 from git to be updated (looking for "svn up") messages. Once I am able to update the e17 from git, I will test those plugins. From earlier, I remember that I was able to get ring, expo, wall, animation, blur, mblur, move, wobbly, and thumbnail (not present in config dialog) to work. I didn't try switcher since I typically use e17 internal window switcher.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 414
Location: Berlin

PostPosted: Sun Mar 29, 2009 8:00 pm    Post subject: Reply with quote

thanks for the ebuilds but today i'am getting problems!

Code:
Total: 13 packages (5 upgrades, 1 downgrade, 4 new, 3 reinstalls), Size of downloads: 30,352 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage/layman/gnome
 [2] /usr/local/portage/layman/kde-testing
 [3] /usr/local/portage/overlayees
 [4] /usr/local/portage/layman/enlightenment

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-wm/enlightenment:0.17

  ('installed', '/', 'x11-wm/enlightenment-9999-r1', 'nomerge') pulled in by
    >=x11-wm/enlightenment-9999-r1 required by ('installed', '/', 'x11-wm/ecomp-9999', 'nomerge')
    (and 2 more)

  ('ebuild', '/', 'x11-wm/enlightenment-9999', 'merge') pulled in by
    =x11-wm/enlightenment-9999 required by @world
    (and 2 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


THX

CooSee ' Ya
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3206

PostPosted: Sun Mar 29, 2009 8:42 pm    Post subject: Reply with quote

CooSee wrote:
thanks for the ebuilds but today i'am getting problems

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-wm/enlightenment:0.17
THX

CooSee ' Ya
Update to the new ebuilds I provided 2 days ago. The slot conflict comes up due to an update done by vapier in which he made enlightenment to belong to slot 0.17 (as opposed to slot 0 earlier).
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3206

PostPosted: Mon Mar 30, 2009 5:02 am    Post subject: Reply with quote

sian wrote:
@ppurka : do you have switcher ? water ?
I just updated e from git. You are right, the switcher plugin does not work. In fact it gives the error that it could not load switcher. This time I recompiled ecomp with no ldflags and with "strip-flags" command in ebuild. It still didn't work. So, it definitely seems to be some kind of bug. I get no error that water plugin could not be loaded, but then I am not sure (not interested either) on how to activate water.

I am still suffering from the problem that flash videos can not be made fullscreen. This problem persists even if I disable ecomorph and restart (not re-login) e17.

If I start e17 without -evil flag and without ecomorph, then fullscreen flash videos work fine.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
sian
Apprentice
Apprentice


Joined: 26 Jan 2004
Posts: 288

PostPosted: Mon Mar 30, 2009 10:50 am    Post subject: Reply with quote

@ppurka : which video ? I would like to try. Youtube ? Dailymotion ?
_________________
Kernel : 2.6.32 - E17 - OpenRC-0.61 - gcc-4.4.3
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3206

PostPosted: Mon Mar 30, 2009 3:18 pm    Post subject: Reply with quote

sian wrote:
@ppurka : which video ? I would like to try. Youtube ? Dailymotion ?
Yes, youtube will fail. At least it fails on mine. I had the same problem with most (all?) flash videos.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
sian
Apprentice
Apprentice


Joined: 26 Jan 2004
Posts: 288

PostPosted: Mon Mar 30, 2009 6:56 pm    Post subject: Reply with quote

@ppurka : it works on mine. Sometimes I have to click on the fullscreen several times
_________________
Kernel : 2.6.32 - E17 - OpenRC-0.61 - gcc-4.4.3
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3206

PostPosted: Mon Mar 30, 2009 11:38 pm    Post subject: Reply with quote

I tried it on a clean config. It works :roll:
Now, I have to rebuild my settings all over again :evil:

EDIT: It works on a clean config for a very short while. Then this flash problem again happens. I don't even know where to look to debug this. :roll:

EDIT2: Unloading the eco module fixes this problem. But we need to load the eco module in order for ecomorph to work properly. I will need more testing. Enough for today.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3206

PostPosted: Fri Apr 03, 2009 6:52 am    Post subject: Reply with quote

Finally got the time to figure out why I wasn't getting fullscreen flash videos. If you enable "Ecomorph mode" in the config dialog, then you will be bitten by not being able to fullscreen flash videos. Not much seems to be missing by not enabling "Ecomorph mode". So I have turned it off for now.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 414
Location: Berlin

PostPosted: Sat Apr 18, 2009 3:05 am    Post subject: Reply with quote

ppurka wrote:
CooSee wrote:
thanks for the ebuilds but today i'am getting problems

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-wm/enlightenment:0.17
THX

CooSee ' Ya
Update to the new ebuilds I provided 2 days ago. The slot conflict comes up due to an update done by vapier in which he made enlightenment to belong to slot 0.17 (as opposed to slot 0 earlier).


my mistake :oops: :roll: :!:

because i used the TIP from http://en.gentoo-wiki.com/wiki/E17 to prepare a set:

Code:
Preparing a Set
Note: This is a feature only availible in Portage versions 2.2 or greater.

The Portage feature of sets is practical to use when dealing with "live" ebuilds. Create and add to /etc/portage/sets/enlightenment-live
Note: You might need to create the sets directory.
mkdir /etc/portage/sets
File: /etc/portage/sets/enlightenment-live

=dev-libs/eina-9999
=dev-libs/eet-9999
=x11-libs/evas-9999
=x11-libs/ecore-9999
=dev-libs/embryo-9999
=media-libs/edje-9999
=dev-libs/efreet-9999
=x11-libs/e_dbus-9999
=x11-wm/enlightenment-9999


and thats why " emerge -uvaDN world " told me about " slot conflict " :!:

THX again for the ebuild, everthing is fine now :D 8) :!:

E17 is great with ecomorph, Yay :!: :!: :!:

CooSee ' Ya
Back to top
View user's profile Send private message
Hell-Razor
Guru
Guru


Joined: 10 Jun 2004
Posts: 434

PostPosted: Tue Apr 21, 2009 11:32 am    Post subject: Reply with quote

I am really interested in trying this but what overlay are you using? The only how-to I found on this that youve been talking about is your own and the first page seems to be...out dated.

EDIT: Alright well I think I have it isntalled, the module is loaded but nothing really happens. I have gone into the config but the "Start Ecomorph" button is highlighted, and the Stop button is not clickable so I dont think I did something correct. Oh and no animations are working..
_________________
Don't ever tell anybody anything. If you do, you start missing everybody.
Back to top
View user's profile Send private message
sian
Apprentice
Apprentice


Joined: 26 Jan 2004
Posts: 288

PostPosted: Tue Apr 21, 2009 6:03 pm    Post subject: Reply with quote

@Hell-Razor : in the module, clic on the stop ecomorph button and start ecormorph. What happens ?
_________________
Kernel : 2.6.32 - E17 - OpenRC-0.61 - gcc-4.4.3
Back to top
View user's profile Send private message
Mountstuart
n00b
n00b


Joined: 14 Dec 2007
Posts: 2

PostPosted: Wed Jul 29, 2009 12:22 am    Post subject: Setting Panel Reply with quote

As you all are probably also using the Enlightenment SVN and Jeff Dameth's modified E17, I wonder if you also cannot access the top bar in the setting panel since some recent update I cannot pin down (I have only reinstalled Enlightenment this week).

I have ecomorph and the modified E17 installed according to the installation instructions on his page.

My suspicion is that the enlightenment developers changed the graphical arrangement of the panel from the two column layout to the horizontal layout, which looks way better, but unfortunately broke the panel in combination with the modified E17.

Can anyone confirm this, or did I screw something up on my own?
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3206

PostPosted: Wed Jul 29, 2009 1:39 am    Post subject: Reply with quote

I had experienced this about a month ago. This is definitely some bug in ecomorph code. One workaround is to enable the "everything" module and search for your settings modules in the "run everything" dialog.

I have stopped using ecomorph since I have not been able to resolve the flash fullscreen problem. I miss the eye-candy though :roll:
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
nordic bro
Guru
Guru


Joined: 25 Oct 2003
Posts: 569

PostPosted: Wed Jul 29, 2009 3:37 am    Post subject: Re: Setting Panel Reply with quote

I can't test this before posting because I have reverted to about a year-old svn of e but when I was trying the latest ecomorph about a month ago, I stumbled on how to make that work. I *think* if the section between the arrows was clicked in (or just the panel itself had focus), you can use kb arrow keys to rotate through them. or the scroll wheel works but you can't see anything changing so doesn't seem like it's working? sorry it's just not coming to me atm. all I remember now is that I too thought that was completely busted until I did something or other and was then able to rotate through the options. hope I didn't dream that and are sending you on a wild goose chase :)
Back to top
View user's profile Send private message
Mountstuart
n00b
n00b


Joined: 14 Dec 2007
Posts: 2

PostPosted: Wed Jul 29, 2009 1:20 pm    Post subject: Setting Panel Workarounds Reply with quote

Thanks to both of you for your terrific workarounds! I've tried out both of them and they work as expected.

nordic bro: As you correctly remember, you can click into the area between the arrows and use the keyboard arrows to get to another section. I blame myself for not trying this out before posting :)
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 806
Location: Greece

PostPosted: Thu Jul 30, 2009 5:34 pm    Post subject: Reply with quote

I'm getting this during enlightenment compilation:
Code:
/usr/bin/edje_cc: Error. Unable to load image for image "exq-bglight.png" part entry to ../../data/themes/default.edj. Missing PNG or JPEG loader modules for Evas or file does not exist, or is not readable.


Any clue?
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Who will save us from pulseaudio and systemd?
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3206

PostPosted: Fri Jul 31, 2009 8:14 pm    Post subject: Reply with quote

Holysword wrote:
I'm getting this during enlightenment compilation:
Code:
/usr/bin/edje_cc: Error. Unable to load image for image "exq-bglight.png" part entry to ../../data/themes/default.edj. Missing PNG or JPEG loader modules for Evas or file does not exist, or is not readable.


Any clue?
An update: this image file seems to be missing from e17 git repository. ( I was curious as to how the git works now :P )
If you simply checkout the e17 svn sources then you will get this image file.

EDIT: In fact, the git is missing *all* the exg-* image files. I will try to put a bug report on the itask-ng site if I get the time.

EDIT 2: Here is what you need to do:
Code:
ebuild <path to enlightenment-9999 ebuild> unpack
ebuild <path to enlightenment-9999 ebuild> clean
ebuild <path to enlightenment-9999-r1 ebuild> unpack
cd /var/tmp/portage/x11-wm/enlightenment-9999-r1/work/enlightenment-9999/data/themes/images
cp -a /opt/distfiles/svn-src/enlightenment/e/data/themes/images/exq-* .
ebuild <path to enlightenment-9999-r1 ebuild> compile
ebuild <path to enlightenment-9999-r1 ebuild> install
ebuild <path to enlightenment-9999-r1 ebuild> qmerge
ebuild <path to enlightenment-9999-r1 ebuild> clean

_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 806
Location: Greece

PostPosted: Sat Aug 01, 2009 2:47 am    Post subject: Reply with quote

Strange stuffs, I don't have enlightenment-9999-r1 in my system, and updating layman overlay does nt generates it. I'm pretty sure that few time ago it was here =S
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Who will save us from pulseaudio and systemd?
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 806
Location: Greece

PostPosted: Sun Jan 31, 2010 8:12 pm    Post subject: Reply with quote

Hi there
I could put ecomorph to work again /o/

But now that I have it I want to configure some things with cube plugin, that I don't see in ecomorph configuration window. I don't know if its a problem with the GUI or if the plugin itself doesn't support it...

I noticed that in "Key Bindings Settings" there is "Custom Action" under Ecomorph section, but I don't know what kind of commands I can put there. Any documentation about that?
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Who will save us from pulseaudio and systemd?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
Page 6 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum