Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installing gentoo 10, first time linux user!
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Cougarxr7
n00b
n00b


Joined: 09 Jan 2010
Posts: 7

PostPosted: Sun Jan 17, 2010 4:51 pm    Post subject: Installing gentoo 10, first time linux user! Reply with quote

I have never used linux before. Interested in the inner workings of an OS, thought I'd give linux a try.
I'm sure some of you are asking why gentoo 10.
Why not pace myself, a few olympic size pools, a couple of rivers, then the english channel, well I fell in.
OK, with that question answered, here are my results.
Specs,
x6800 extreme
nforcei680 mb

I have 3 physical harddrives, booting according to boot priority in the bios.
First drive unallocated.
Second drive Windows.
Third drive Windows.

As far as configuring network, it works, just need to install dhcpcd, which is later.
I fdisk and partition my unallocated drive which is sdb.
/dev/sdb1 boot ext2
/dev/sdb3 / ext3
/dev/sdb2 swap

I mount the drive partitions.
Set date and time.
I download stage3-amd64-20091231.tar.bz2, tar it xvjpf , no problems there.
I download portage-201001xx.tar.bz2 , tar it xvjf -C /mnt/gentoo/usr, no problems there.

Compile options, it says,
"The default values contained in the stage3 archive you unpacked should be good enough."
So I went with the default values a few times.
Did not work.
I change these flags to,
CFLAGS="-02 -march=nocona -pipe"
CXXFLAGS="${CFLAGS}"
No change in end results.
So I use default settings.
I also tried this,
MAKEOPTS="J2"
I believe when I used this, compiling the kernel threw an error.

I selected my mirrors.
Copied DNS info, /etc/resolv.conf
Mounted proc , dev.
chrooted, with no problems.
Updated portage, I have the lastest version, I'm sure I don't need to update however, just to see if it's working I do it anyway.
Profile, I use recommended default.
Use variable, I used default.
#locale-gen, 2/2 en.

Configuring Kernel
Set my timezone
#emerge gentoo-sources
Using gen-kernel
#emerge genkernel
#zcat
#genkernel all
#ls /boot/kernel* /boot/initramfs*
/boot/kernel-genkernel-x86_64-2.6.31-gentoo-r6
/boot/initramfs-genkernel-x86_64-2.6.31-gentoo-r6

Configuring modules.
#find /lib/modules/genkernel-x86_64-2.6.31-gentoo-r6/ -type f -iname '*.o' -or -iname '*.ko' | less
It could not find the kernel, I tried different version names such as "x86_64, ect...
I know I am not using/finding the correct kernel name and this problem is on my end.
#nano -w /etc/modules.autoload.d/kernel-2.6
I get "permission denied" , when I use this with nano.

Configuring my system.
#nano -w /etc/fstab
The only changes I made and saved, were,
all the sda partitions are now sdb.
That's all I changed.

Networking.
I use dhcpcd, so I believe I do not need to do anything here.
I install the client later.
#passwd, changed.
#nano -w /etc/rc.conf < gave me permission denied.


Installing tools.
#emerge syslog-ng
#rc-update add syslog-ng default
#emerge dcron
#rc-update add dcron default
#emerge slocate
#emerge dhcpcd

Bootloader.
#emerge grub
#nano -w /boot/grub/grub.conf
default 0
timeout 5
splashimage=(hd1,0)/boot/grub/splash/xpm/gz

title Gentoo Linux 2.6.31-r6
root (hd1,0)
kernel /boot/kernel-genkernel-x86_64-2.6.31-gentoo-r6
root=/dev/ram0
init=/linuxrc
ramdisk=8192
real_root=/devsdb3
initrd= /boot/initramfs-genkernel-x86_64-2.6.31-gentoo-r6

#grep -v rootfs /proc/mounts > /etc/mtab
#grub-install --no-floppy /dev/sdb
#exit
#cd
#umount /mnt/gentoo/boot /mnt/gentoo/dev /mnt/gentoo/proc /mnt/gentoo
#reboot

When I reboot, my first drive in boot priority is sdb.
My computer boot to windows, of which is the second drive in boot priority.
It does not even see a boot sector on my first drive.
I know this is because of me, something I'm doing, something I'm not doing.
If anyone can see my my mistake/mistakes, please reply.
Remmember, I have never use a linux system before! I know nothing about linux, nada!
Thanks!


Last edited by Cougarxr7 on Mon Jan 18, 2010 3:20 am; edited 1 time in total
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Sun Jan 17, 2010 5:10 pm    Post subject: Reply with quote

From what I understand, the drive you are installing gentoo on is not the first drive presented by the bios irrespective of the fact that you asked bios for it to be the first one.
I think it is the same problem I faced as described here :
http://forums.gentoo.org/viewtopic-t-809298-highlight-.html
I wrote a small howto at the end (using lilo and not grub).


Last edited by aCOSwt on Sun Jan 17, 2010 6:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Sun Jan 17, 2010 5:18 pm    Post subject: Re: Installing gentoo 10, first time linux user! Reply with quote

Cougarxr7 wrote:
I change these flags to,
CFLAGS="-02 -march=nocano -pipe"
CXXFLAGS="${CFLAGS}"
No change in end results.
So I use default settings.
I also tried this,
MAKEOPTS="J2"
No that won't work.

This would be correct, depending on which type of processor you have, and if you want a 64 bit system:
Code:
CHOST="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"


or
Code:
CHOST="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"


:arrow: See: Safe Cflags
Back to top
View user's profile Send private message
Zaknafein
n00b
n00b


Joined: 17 Jan 2010
Posts: 8

PostPosted: Sun Jan 17, 2010 6:00 pm    Post subject: Reply with quote

Since your new to linux , when you have a chance , take a look at this book ,linux sea , good book , written by retired gentoo developer.

http://swift.siphos.be/linux_sea/

Also on the gentoo website are a bunch of articles under "IBM dW/Intel article archive"
some are a little dated but still valid
i recommend the "LPI certification 101" articles, they teach you alot about linux
also the ones on Bash scripting are invaluable.
Back to top
View user's profile Send private message
cyrillic
Watchman
Watchman


Joined: 19 Feb 2003
Posts: 7301
Location: Groton, Massachusetts USA

PostPosted: Sun Jan 17, 2010 10:11 pm    Post subject: Re: Installing gentoo 10, first time linux user! Reply with quote

Cougarxr7 wrote:
I have never used linux before.
...
I have 3 physical harddrives, booting according to boot priority in the bios.

Configuring and installing the bootloader correctly is one area where beginners can get really confused / frustrated.

If you want to make life easier for yourself, try this :
    Unplug all your harddrives, except the one you are installing Gentoo onto
    Install and configure Gentoo in the usual way
    Reboot without the CD, and see if it actually works
    Then plug your other harddrives back in, and see if it still works
Back to top
View user's profile Send private message
Shining Arcanine
Veteran
Veteran


Joined: 24 Sep 2009
Posts: 1110

PostPosted: Sun Jan 17, 2010 11:27 pm    Post subject: Reply with quote

Your CFLAGS are wrong. Your CPU supports SSSE3, which the Nocona microarchitecture does not support:

http://www.cpu-world.com/CPUs/Core_2/Intel-Core%202%20Extreme%20X6800%20HH80557PH0774M%20%28BX80557X6800%29.html
http://en.wikipedia.org/wiki/List_of_Intel_Xeon_microprocessors#.22Nocona.22_.28standard-voltage.2C_90_nm.29

GCC 4.3.4 supports -march=core2, which enables support for SSSE3:

http://gcc.gnu.org/onlinedocs/gcc-4.3.4/gcc/i386-and-x86_002d64-Options.html#i386-and-x86_002d64-Options

I would also expect GCC could take more into account when given the march flag such as the number of clock cycles each instruction requires, so it should theoretically be able to produce more optimized binaries, even if the instructions involved are the same. Your CPU also has support for SAHF and LAHF instructions, which I believe that Nocona does not support. I am not sure if the -march=core2 instruction enables it so you would likely want to also add -msahf. The correct cflags for your architecture are:

Code:
CFLAGS="-march=core2 -msahf -O2 -pipe"


Also, you have a dual core processor, so set MAKEOPTS to -j3, not -j2.
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4280

PostPosted: Mon Jan 18, 2010 12:22 am    Post subject: Re: Installing gentoo 10, first time linux user! Reply with quote

Cougarxr7 wrote:
...
I have 3 physical harddrives, booting according to boot priority in the bios.
First drive unallocated.
Second drive Windows.
Third drive Windows.
...

I fdisk and partition my unallocated drive which is sdb.
/dev/sdb1 boot ext2
/dev/sdb3 / ext3
/dev/sdb2 swap


Note that sdb is 2nd drive and you say your unallocated drive is the first, so it should be sda.
It's not wrong right now, as you might see that drive as sdb because sda is taken by the cdrom when you boot a livecd for example. But keep in mind, if that unallocated drive you wish to use is FIRST drive, it is sda and not sdb (think how linux see it when booting, not how livecd see it)

Cougarxr7 wrote:

Configuring my system.
#nano -w /etc/fstab
The only changes I made and saved, were,
all the sda partitions are now sdb.
That's all I changed.

This is a failure here: your drive in fstab is sda if it's the primary drive as i said before, even if livecd see it as sdb, it's because first drive is taken by cdrom on install, this won't be the case on booting, so sdb will get its correct name, and this will be sda.

Cougarxr7 wrote:

Bootloader.
#emerge grub
#nano -w /boot/grub/grub.conf
default 0
timeout 5
splashimage=(hd1,0)/boot/grub/splash/xpm/gz

:) the common mistake continue, for grub: drives are named from 0 to x, and 0 is the 1st drive. Consider sda as 0 and sdb as 1...
So hd1,0 = sdb1 and again, failure, your boot partition is in sda1 as explain upper. So grub should follow that rule too...
correct boot drive value should be hd0,0

Cougarxr7 wrote:

When I reboot, my first drive in boot priority is sdb.
My computer boot to windows, of which is the second drive in boot priority.

This time is suppose you call it "sdb" to help people get clear you're still speaking of that 1st unallocated drive.
So why it boot windows ? just because your bios check first drive (as you call it sdb here) just as you wish.
Bios check for boot flag and none is set, bios will check 2nd drive (the windows one) and tada! boot flag set, so bios will load that bootloader and so windows is coming...

You can easy correct that by doing from livecd (so drive will be sdb again, still following the logic? )
fdisk /dev/sdb
a (i use french version but i suppose it's call "a" in all language anyway LC_ALL="C" fdisk tell me it's also a and help show it as toggle a bootable flag, that's the option we need to set)
1 (first partition in that drive, so targeting sdb1)
w (write partition change)

Look for that, and you will go a step further to hell... hu, i mean installing gentoo
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4280

PostPosted: Mon Jan 18, 2010 12:33 am    Post subject: Re: Installing gentoo 10, first time linux user! Reply with quote

Mike Hunt wrote:
Cougarxr7 wrote:
I change these flags to,
CFLAGS="-02 -march=nocano -pipe"
CXXFLAGS="${CFLAGS}"
No change in end results.
So I use default settings.
I also tried this,
MAKEOPTS="J2"
No that won't work.


you're a bit hard mike, it will work, that's not perfect for sure but it will. nobody dies from using a 32bits version with working but not perfect cflags.

It's wrong, yes, really really wrong if he try to get a 64bits install, but it will work.
So far we don't know if he use a 64bits livecd or not. (or i miss that part)

But as mike suggest: check if you wish a 64bits install to add correct CHOST, but who cares for a 32bits if you even use a -march=pentium4 as long as the march you pickup is handle by your cpu, you'll be fine.
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Mon Jan 18, 2010 12:42 am    Post subject: Reply with quote

Hmmmm,
Code:
make J2 CC=i686-pc-linux-gnu-gcc                                                         
make: *** No rule to make target `J2'.  Stop.


:D
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4280

PostPosted: Mon Jan 18, 2010 12:52 am    Post subject: Reply with quote

i hate you mike :)
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Mon Jan 18, 2010 12:58 am    Post subject: Reply with quote

Hihi. :)
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Mon Jan 18, 2010 1:09 am    Post subject: Reply with quote

And :

Code:

-02 -march=nocano -pipe


it's

Code:

-02 -march=nocona -pipe

_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
Shining Arcanine
Veteran
Veteran


Joined: 24 Sep 2009
Posts: 1110

PostPosted: Mon Jan 18, 2010 1:53 am    Post subject: Reply with quote

d2_racing wrote:
And :

Code:

-02 -march=nocano -pipe


it's

Code:

-02 -march=nocona -pipe


As I said above, for his processor, it should be:

Code:
CFLAGS="-march=core2 -msahf -O2 -pipe"


By the way, did you really type -02 instead of -O2?
Back to top
View user's profile Send private message
Cougarxr7
n00b
n00b


Joined: 09 Jan 2010
Posts: 7

PostPosted: Mon Jan 18, 2010 7:02 am    Post subject: Reply with quote

wow, thanks for the help!
I took cyrillic's advice. I disconected my 2 other drives and installed gentoo.

krinn, I should of said more about my setup. 3 drives, 1 IDE , 2 SATA
I thought I read some where that IDEs are looked for first at boot and assigned their boot (hd0).
Then the SATA drives get assigned, (hd1), (hd2).
Maybe I dreamt that. The reason for it being sdb, Device manager said it was sdb also.
I do understand what you are saying, thanks!

Shining Arcanine, I set my CFLAGS to what you said, worked great, thanks!

Progress,
I got to grub boot, however with an error 11.
root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel/boot/kernel-genkernel-x86_64-2.6.31-r6
[Linux-bzImage, setup=0x3200, size=0x2a1640]
root=/dev/ram0 real_root=/dev/sda3

Error 11 : Unrecongnized device string

Again, thanks, I'm surprised at all the great help!
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4280

PostPosted: Mon Jan 18, 2010 11:10 am    Post subject: Reply with quote

Cougarxr7 wrote:

I thought I read some where that IDEs are looked for first at boot and assigned their boot (hd0).
Then the SATA drives get assigned, (hd1), (hd2).
Maybe I dreamt that. The reason for it being sdb, Device manager said it was sdb also.


It's quite simple, but it could really be tricky:
for grub it's really simple, it assign numbers by booting order... this is simple to guess because most modern bios show you that booting order (it show drive name). It was harder before because bios were allowing you to choose not who boot first, but what kind will boot (harddrive, cdrom...) and bios then were just ordering them by master/slave and channel order.

For linux the rought logic is simple : it's who have its driver load first get the drives letters first. So when booting from a cdrom, its driver must be load first, and so the cdrom will grab sda, others drives will be named by udev scanning the pci bus for controller, this way if you have a raid card that appears last, the drives attach to it will get latest letters. But once you will boot your own kernel, as that raid controller driver will be load by kernel and not by udev, the pci scanning rules is break (as you must built them as include in kernel and not as module) and these drives will take first drives letters: in that case you can have for example an "sde" drive from livecd that will be see as sda when booting your own kernel.

eheh now say you have 2 ide and 1 sata drives also plug in that computer: these 3 drives are partitionned and are use as data disks and you didn't setup their bootflag AND your bios boot order is : ide, raid, sata: you will have the worst tricky scenario : for grub your boot drive will be hd2 (because 3rd drive that will be check to boot), for livecd this drive will be sde (because ide loading will take sda for cdrom, sdb&sdc for disks, then sata will grab sdd) and for linux that same drive will be sda (because you setup the raid include and ide+sata as module).
Now considering you could spice that up (for example building the kernel by including sata support and raid but still use ide as module), it could be hell.

This is for mike's "Best explanation ever about booting" bookmark :)

To get back on your problem you have invalid string in your menu.lst
kernel(space) /blahbalh is a valid grub command but kernel/blahblha isn't... and if you didn't typo when showing the error, that must be that.
I suppose that's also told us you're using the 64bits version, recheck mike hunt first comment (AND NO DON'T REREAD HIS 2ND COMMENT EVER !)
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Mon Jan 18, 2010 1:12 pm    Post subject: Reply with quote

And why not use this instead :

Code:

"-march=native -pipe -O2"

_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
Cougarxr7
n00b
n00b


Joined: 09 Jan 2010
Posts: 7

PostPosted: Mon Jan 18, 2010 3:13 pm    Post subject: Reply with quote

krinn, I typo'd, it is kernel /boot , not kernel/boot . :roll:

d2_racing, this , "-march=native -pipe -O2" is better than "-march=core2 -msahf -O2 -pipe" ?

I did a search for Error 11 and did not find anything. Doesn't mean it's not out there, I'd just didn't find it.
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Mon Jan 18, 2010 4:08 pm    Post subject: Reply with quote

Grub Error 11:
Quote:
# 11 : "File not found"

This error is returned if the specified filename cannot be found, but everything else (like the disk/partition info) is OK.


It probably means that the kernel line and your /boot/grub/grub.conf and the exact name of the kernel in /boot don't match.

krinn wrote:
So grub should follow that rule too...
correct boot drive value should be hd0,0


Boot the installCD, mount your partition and post the output of:
  • ls -l /mnt/gentoo//boot
  • cat /mnt/gentoo/boot/grub/grub.conf
  • cat /mnt/gentoo/etc/fstab

BTW, if you want to see what -march=native sets as CFLAGS, run (I think you probably need to be chrooted or booted into your system for this - not sure):
Code:
gcc -### -march=native -E /usr/include/stdlib.h 2>&1 | grep "/usr/libexec/gcc/.*cc1"


-march=native is probably a better choice. It's what I use. :)
Back to top
View user's profile Send private message
Shining Arcanine
Veteran
Veteran


Joined: 24 Sep 2009
Posts: 1110

PostPosted: Mon Jan 18, 2010 5:17 pm    Post subject: Reply with quote

d2_racing wrote:
And why not use this instead :

Code:

"-march=native -pipe -O2"


GCC should translate -march=native -pipe -O2 internally to -march=core2 -msahf -O2 -pipe, so they are probably the same, but my cflags do not take any chances on that.
Back to top
View user's profile Send private message
Cougarxr7
n00b
n00b


Joined: 09 Jan 2010
Posts: 7

PostPosted: Mon Jan 18, 2010 6:26 pm    Post subject: Reply with quote

Mike, thanks for the help!
ls -l /mnt/gentoo//boot
total 7416
-rw-r--r-- 1 root root 1619451 Jan 17 22:58 System.map-genkernel-x86_64-2.6.31-gentoo-r6
lrwxrwxrwx 1 root root 1 Jan 17 21:40 boot -> .
drwxr-xr-x 1 root root 1024 Jan 17 23:30 grub
-rw-r--r-- 1 root root 3154903 Jan 17 32:07 initramfs-genkernel-x86_64-2.6.31-gentoo-r6
-rw-r--r-- 1 root root 2771520 Jan 17 22:58 kernel-genkernel-x86_64-2.6.31-gentoo-r6
drwx------ 2 root root 12288 Jan 16 20:38 lost+found

cat /mnt/gentoo/boot/grub/grub.conf
default 0
timeout 30
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title Gentoo Linux 2.6.31-r6
root (hd0,0)
kernel /boot/kernel-genkernel-x86_64-2.6.31-gentoo-r6
root=/dev/ram0 real_root=/dev/sda3
initrd /boot/initramfs-genkernel-x86_64-2.6.31-gentoo-r6

#vim:ft=conf:

cat /mnt/gentoo/etc/fstab
/dev/sda1 /boot ext2 noauto,noatime 1 2
/dev/sda3 / ext3 noatime 0 1
/dev/sda2 none swap sw 0 0
/dev/cdrom /mnt/cdrom auto noauto,ro 0 0
#/dev/fd0 /mnt/floppy auto noauto 0 0

shm /dev/shm tmpfs nodev,nosuid,noexec 0 0

Again, thanks Mike, I hope you can see where the problem/my screwup is!
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Mon Jan 18, 2010 6:36 pm    Post subject: Reply with quote

Cougarxr7 wrote:
kernel /boot/kernel-genkernel-x86_64-2.6.31-gentoo-r6
root=/dev/ram0 real_root=/dev/sda3


In your actual grub.conf are these 2 lines on one line or 2 like in your posting, because that should be one line in grub.conf like this.
this is all one line:
kernel /boot/kernel-genkernel-x86_64-2.6.31-gentoo-r6 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sda3


The rest looks fine.
If that's not it then maybe a kernel config problem. If so then pastebin your /mnt/gentoo/usr/src/linux/.config

http://pastebin.com
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6612
Location: Goose Creek SC

PostPosted: Mon Jan 18, 2010 6:47 pm    Post subject: Reply with quote

BTW:
Using the libata drivers; cdrom's will use /dev/sr0, /dev/sr1, etc.
Using the legacy drivers; cdrom's will use /dev/hda, /dev/hdb, etc.
cdrom should not affect sd nomenclature.
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4280

PostPosted: Mon Jan 18, 2010 7:28 pm    Post subject: Reply with quote

right donahue, i always fail on examples :)

cougarxr7: did you get any good result following mike's comment (i think he point out your problem)
Back to top
View user's profile Send private message
Cougarxr7
n00b
n00b


Joined: 09 Jan 2010
Posts: 7

PostPosted: Mon Jan 18, 2010 8:17 pm    Post subject: Reply with quote

Getting closer!
Mike was dead on, about those lines!
Now it boots to login & password, of which I thought I set, however thats not the case!
Is there anyway to disable login & password, I really don't need them nor do I even use them!
Thanks!
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Mon Jan 18, 2010 8:23 pm    Post subject: Reply with quote

No, you will have to reboot the installCD, mount the partitions, chroot like before, as per the Handbook, create a password at least for the root account:
Code:
passwd


You can also create a user while you're at it:
Code:
adduser -g users -G lp,wheel,audio,cdrom,portage,cron -m john
passwd john


exit chroot, unmount partitions, reboot.

PS, you're not the first who forgot to set a password. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum