Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
unable to --unmerge blocks B
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Sun Nov 01, 2009 11:59 am    Post subject: unable to --unmerge blocks B Reply with quote

hi im trying to emerge ati-drivrivers but get a block =

(chroot) livecd / # emerge ati-drivers
Calculating dependencies... done!
[ebuild N ] dev-util/gperf-3.0.4
[ebuild N ] sys-apps/dmidecode-2.10
[ebuild N ] sys-libs/libutempter-1.1.5
[ebuild N ] sys-apps/eject-2.1.5-r2 USE="nls"
[ebuild N ] app-admin/eselect-opengl-1.0.9
[ebuild N ] media-libs/freetype-2.3.11 USE="X -bindist -debug -doc -fontforge -utils"
[ebuild N ] x11-libs/libxkbfile-1.0.6 USE="-debug"
[ebuild N ] x11-proto/xf86vidmodeproto-2.3
[ebuild N ] x11-proto/randrproto-1.3.1
[ebuild N ] x11-proto/xineramaproto-1.2
[ebuild N ] x11-proto/renderproto-0.11
[ebuild N ] x11-libs/libfontenc-1.0.5 USE="-debug"
[ebuild N ] x11-proto/damageproto-1.2.0
[ebuild N ] x11-proto/dri2proto-2.1
[ebuild N ] x11-proto/xf86driproto-2.1.0
[ebuild N ] x11-proto/fontsproto-2.1.0
[ebuild N ] x11-proto/resourceproto-1.1.0
[ebuild N ] x11-libs/libdrm-2.4.15 USE="-debug"
[ebuild N ] x11-proto/fixesproto-4.1.1
[ebuild N ] dev-perl/XML-Parser-2.36
[ebuild N ] x11-proto/xf86miscproto-0.9.3
[ebuild N ] sys-power/acpid-1.0.10_p4
[ebuild N ] x11-proto/trapproto-3.4.3
[ebuild N ] x11-proto/compositeproto-0.4.1
[ebuild N ] x11-proto/xf86dgaproto-2.1
[ebuild N ] x11-proto/videoproto-2.3.0
[ebuild N ] x11-proto/scrnsaverproto-1.2.0
[ebuild N ] x11-libs/libpciaccess-0.10.9 USE="-debug -minimal"
[ebuild N ] x11-apps/rgb-1.0.3 USE="-debug"
[ebuild N ] x11-apps/iceauth-1.0.3 USE="-debug"
[ebuild N ] x11-proto/xf86rushproto-1.1.2
[ebuild N ] x11-misc/xbitmaps-1.1.0
[ebuild N ] x11-proto/recordproto-1.14
[ebuild N ] x11-libs/pixman-0.16.2 USE="mmx sse2 (-altivec) -debug"
[ebuild N ] sys-apps/pciutils-3.1.4 USE="zlib -network-cron"
[ebuild N ] sys-apps/dbus-1.3.0 USE="X -debug -doc (-selinux) -test"
[ebuild N ] x11-apps/xrdb-1.0.6 USE="-debug"
[ebuild N ] x11-wm/twm-1.0.4 USE="-debug"
[ebuild N ] net-misc/netkit-rsh-0.17-r9 USE="pam"
[ebuild N ] x11-apps/xmessage-1.0.2-r1 USE="-debug"
[ebuild N ] media-fonts/font-util-1.1.1 USE="-debug"
[ebuild N ] x11-misc/makedepend-1.0.2 USE="-debug"
[ebuild N ] x11-libs/libXi-1.3 USE="-debug"
[ebuild N ] app-emulation/emul-linux-x86-baselibs-20081109
[ebuild N ] sys-fs/lvm2-2.02.51-r2 USE="lvm1 readline static (-clvm) (-cman) (-selinux)"
[ebuild N ] dev-libs/libusb-0.1.12-r5 USE="-debug -doc -nocxx"
[ebuild N ] virtual/eject-0
[ebuild N ] x11-libs/libXrender-0.9.5 USE="-debug"
[ebuild N ] x11-apps/mkfontscale-1.0.7 USE="-debug"
[ebuild N ] x11-apps/xkbcomp-1.1.1 USE="-debug"
[ebuild N ] x11-libs/libXfont-1.4.1 USE="-debug -ipv6"
[ebuild N ] x11-proto/glproto-1.4.10
[ebuild N ] dev-util/intltool-0.40.6-r1
[ebuild N ] virtual/libusb-0
[ebuild N ] x11-libs/libXinerama-1.1 USE="-debug"
[ebuild N ] x11-libs/libxkbui-1.0.2 USE="-debug"
[ebuild N ] x11-libs/libXres-1.0.4 USE="-debug"
[ebuild N ] sys-fs/cryptsetup-1.0.6-r2 USE="nls -dynamic (-selinux)"
[ebuild N ] dev-libs/dbus-glib-0.80 USE="-bash-completion -debug -doc -test"
[ebuild N ] x11-apps/xsm-1.0.1-r1 USE="-debug"
[ebuild N ] x11-apps/luit-1.0.4 USE="-debug"
[ebuild N ] x11-libs/libXxf86vm-1.1.0 USE="-debug"
[ebuild N ] x11-libs/libXfixes-4.0.4 USE="-debug"
[ebuild N ] x11-libs/libXrandr-1.3.0 USE="-debug"
[ebuild N ] x11-misc/xkeyboard-config-1.7
[ebuild N ] sys-apps/usbutils-0.86-r1 USE="zlib -network-cron"
[ebuild N ] x11-apps/mkfontdir-1.0.5 USE="-debug"
[ebuild N ] media-fonts/encodings-1.0.3 USE="-debug"
[ebuild N ] x11-apps/bdftopcf-1.0.2 USE="-debug"
[ebuild N ] media-fonts/font-alias-1.0.1 USE="-debug"
[ebuild N ] x11-libs/libXdamage-1.1.2 USE="-debug"
[ebuild N ] media-libs/mesa-7.5.2 USE="nptl xcb -debug -motif -pic" VIDEO_CARDS="-intel -mach64 -mga -none -r128 -radeon -radeonhd -s3virge -savage -sis (-sunffb) -tdfx -trident -via"
[ebuild N ] app-emulation/emul-linux-x86-xlibs-20081109 USE="opengl"
[ebuild N ] virtual/glu-7.0
[ebuild N ] virtual/opengl-7.0
[ebuild N ] media-libs/glew-1.5.1
[ebuild N ] media-libs/fontconfig-2.7.3 USE="-doc"
[ebuild N ] app-admin/eselect-fontconfig-1.0
[ebuild N ] x11-libs/libXft-2.1.14 USE="-debug"
[ebuild N ] media-fonts/font-misc-misc-1.0.0 USE="X nls"
[ebuild N ] x11-terms/xterm-250 USE="unicode -Xaw3d -toolbar -truetype"
[ebuild N ] x11-apps/xclock-1.0.4 USE="-debug"
[ebuild N ] x11-apps/xinit-1.0.8-r10 USE="pam -consolekit -debug -minimal"
[ebuild N ] sys-apps/hal-0.5.13-r2 USE="X crypt -acpi -apm -consolekit -debug -dell -disk-partition -doc -laptop -policykit (-selinux)"
[ebuild N ] app-misc/hal-info-20090716
[ebuild N ] x11-base/xorg-server-1.7.1 USE="hal nptl xorg -debug -dmx -ipv6 -kdrive -minimal -sdl -tslib"
[ebuild N ] x11-drivers/ati-drivers-9.10 USE="modules (multilib) -debug"
[ebuild N ] x11-drivers/xf86-input-keyboard-1.4.0 USE="-debug"
[ebuild N ] x11-drivers/xf86-input-evdev-2.3.0 USE="-debug"
[ebuild N ] x11-drivers/xf86-input-mouse-1.5.0 USE="-debug"
[ebuild N ] x11-base/xorg-drivers-1.7 INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -citron -elographics -fpit -hyperpen -joystick -mutouch -penmount -synaptics -tslib -virtualbox -vmmouse -void -wacom" VIDEO_CARDS="fglrx -apm -ark -ast -chips -cirrus -dummy -epson -fbdev (-geode) -glint -i128 (-i740) (-impact) (-imstt) -intel -mach64 -mga -neomagic (-newport) -nv -nvidia -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l (-vermilion) -vesa -via -virtualbox -vmware (-voodoo) (-xgi)"
[blocks B ] >=x11-base/xorg-server-1.7.0 (">=x11-base/xorg-server-1.7.0" is blocking x11-drivers/ati-drivers-9.10)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'x11-base/xorg-server-1.7.1', 'merge') pulled in by
>=x11-base/xorg-server-1.6.3 required by ('ebuild', '/', 'x11-drivers/xf86-input-evdev-2.3.0', 'merge')
>=x11-base/xorg-server-1.6.3 required by ('ebuild', '/', 'x11-drivers/xf86-input-keyboard-1.4.0', 'merge')
>=x11-base/xorg-server-1.5.99.901 required by ('ebuild', '/', 'x11-drivers/xf86-input-mouse-1.5.0', 'merge')
(and 1 more)

('ebuild', '/', 'x11-drivers/ati-drivers-9.10', 'merge') pulled in by
x11-drivers/ati-drivers required by ('ebuild', '/', 'x11-base/xorg-drivers-1.7', 'merge')
ati-drivers


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

(chroot) livecd / #
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Sun Nov 01, 2009 12:03 pm    Post subject: Reply with quote

ati-drivers is incompatible with xorg-server-1.7 --> read here

to mask it, do the following
Code:
# mkdir -p /etc/portage
echo ">=x11-base/xorg-server-1.7*" >> /etc/portage/package.mask


cheers
V.


Last edited by Veldrin on Sun Nov 01, 2009 12:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7785
Location: Somewhere over Atlanta, Georgia

PostPosted: Sun Nov 01, 2009 12:04 pm    Post subject: Reply with quote

Sometimes blocks are legitimate issues, not just annoyances to solve. Currently xorg-server-1.7* doesn't get along with the ATI drivers. See this thread.

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum