Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
qt-script, qt-core, qt-sdl, qt-dbus, qt-gui slot conflict
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Maragato
Apprentice
Apprentice


Joined: 10 Mar 2005
Posts: 150

PostPosted: Wed Oct 14, 2009 4:16 pm    Post subject: Reply with quote

I could not fix it here I nut both qt3-support enabled and disabled any ideas for me?

Code:
emerge: there are no ebuilds built with USE flags to satisfy "~x11-libs/qt-core-4.5.2[qt3support,-debug]".
!!! One of the following packages is required to complete your request:
- x11-libs/qt-core-4.5.2 (Change USE: +qt3support)
(dependency required by "x11-libs/qt-qt3support-4.5.2" [ebuild])
(dependency required by "kde-base/kuser-4.2.4" [installed])
(dependency required by "kde-base/kdeadmin-meta-4.2.4" [installed])
(dependency required by "kde-base/kde-meta-4.2.4" [installed])
(dependency required by "world" [argument])


Code:
emerge -uDpv world
>>> --pretend disables --ask... removing --ask from options.

These are the packages that would be merged, in order:

Calculating dependencies ... done!

emerge: there are no ebuilds built with USE flags to satisfy "~x11-libs/qt-core-4.5.2[glib,-debug,-qt3support]".
!!! One of the following packages is required to complete your request:                                         
- x11-libs/qt-core-4.5.2 (Change USE: -qt3support)                                                             
(dependency required by "x11-libs/qt-gui-4.5.2-r2" [ebuild])                                                   
(dependency required by "media-sound/lastfmplayer-1.5.1.31879-r3" [installed])                                 
(dependency required by "world" [argument])         


Should I buy a quantum computer? :?
Back to top
View user's profile Send private message
jonfr
l33t
l33t


Joined: 20 Jul 2003
Posts: 923
Location: Denmark

PostPosted: Thu Oct 15, 2009 9:49 pm    Post subject: Reply with quote

I have read this tread, and I am no closer to a fix then before. But I am trying anyway. On a system that I have, I get this message.

Code:

[ebuild     U ] x11-libs/qt-core-4.5.2 [4.5.1]
[ebuild     U ] x11-libs/qt-dbus-4.5.2 [4.5.1]
[ebuild     U ] x11-libs/qt-script-4.5.2 [4.5.1]
[ebuild     U ] x11-libs/qt-sql-4.5.2 [4.5.1]
[ebuild     U ] x11-libs/qt-gui-4.5.2-r2 [4.5.1] USE="gtk%*"
[ebuild     U ] x11-libs/qt-qt3support-4.5.2 [4.5.1]
[uninstall    ] x11-libs/qt-xmlpatterns-4.5.1
[blocks b     ] <x11-libs/qt-xmlpatterns-4.5.2 ("<x11-libs/qt-xmlpatterns-4.5.2" is blocking x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)
[uninstall    ] x11-libs/qt-assistant-4.5.1
[blocks b     ] <x11-libs/qt-assistant-4.5.2 ("<x11-libs/qt-assistant-4.5.2" is blocking x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)
[uninstall    ] x11-libs/qt-webkit-4.5.1
[blocks b     ] >x11-libs/qt-script-4.5.1-r9999 (">x11-libs/qt-script-4.5.1-r9999" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-webkit-4.5.1)
[blocks b     ] >x11-libs/qt-sql-4.5.1-r9999 (">x11-libs/qt-sql-4.5.1-r9999" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-webkit-4.5.1)
[blocks b     ] >x11-libs/qt-qt3support-4.5.1-r9999 (">x11-libs/qt-qt3support-4.5.1-r9999" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-webkit-4.5.1)
[blocks b     ] >x11-libs/qt-core-4.5.1-r9999 (">x11-libs/qt-core-4.5.1-r9999" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-webkit-4.5.1)
[blocks b     ] <x11-libs/qt-webkit-4.5.2 ("<x11-libs/qt-webkit-4.5.2" is blocking x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)
[blocks b     ] >x11-libs/qt-gui-4.5.1-r9999 (">x11-libs/qt-gui-4.5.1-r9999" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-webkit-4.5.1)
[blocks b     ] >x11-libs/qt-dbus-4.5.1-r9999 (">x11-libs/qt-dbus-4.5.1-r9999" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild   R   ] dev-python/PyQt-3.18.1
[blocks B     ] >x11-libs/qt-qt3support-4.5.1-r9999 (">x11-libs/qt-qt3support-4.5.1-r9999" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-webkit-4.5.1)
[blocks B     ] <x11-libs/qt-qt3support-4.5.2 ("<x11-libs/qt-qt3support-4.5.2" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-sql-4.5.2, x11-libs/qt-core-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2)
[blocks B     ] >x11-libs/qt-dbus-4.5.1-r9999 (">x11-libs/qt-dbus-4.5.1-r9999" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-webkit-4.5.1)
[blocks B     ] <x11-libs/qt-sql-4.5.2 ("<x11-libs/qt-sql-4.5.2" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-core-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2)
[blocks B     ] <x11-libs/qt-core-4.5.2 ("<x11-libs/qt-core-4.5.2" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-sql-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2)
[blocks B     ] <x11-libs/qt-script-4.5.2 ("<x11-libs/qt-script-4.5.2" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-core-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-sql-4.5.2)
[blocks B     ] <x11-libs/qt-dbus-4.5.2 ("<x11-libs/qt-dbus-4.5.2" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-sql-4.5.2, x11-libs/qt-core-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-script-4.5.2)
[blocks B     ] <x11-libs/qt-gui-4.5.2 ("<x11-libs/qt-gui-4.5.2" is blocking x11-libs/qt-sql-4.5.2, x11-libs/qt-core-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2)
[blocks B     ] >x11-libs/qt-script-4.5.1-r9999 (">x11-libs/qt-script-4.5.1-r9999" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-webkit-4.5.1)
[blocks B     ] <x11-libs/qt-opengl-4.5.2 ("<x11-libs/qt-opengl-4.5.2" is blocking x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)
[blocks B     ] >x11-libs/qt-sql-4.5.1-r9999 (">x11-libs/qt-sql-4.5.1-r9999" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-webkit-4.5.1)
[blocks B     ] >x11-libs/qt-core-4.5.1-r9999 (">x11-libs/qt-core-4.5.1-r9999" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-webkit-4.5.1)
[blocks B     ] <x11-libs/qt-svg-4.5.2 ("<x11-libs/qt-svg-4.5.2" is blocking x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)
[blocks B     ] >x11-libs/qt-gui-4.5.1-r9999 (">x11-libs/qt-gui-4.5.1-r9999" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-webkit-4.5.1)
[blocks B     ] <x11-libs/qt-test-4.5.2 ("<x11-libs/qt-test-4.5.2" is blocking x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'x11-libs/qt-script-4.5.2', 'merge') pulled in by
    ~x11-libs/qt-script-4.5.2[-debug] required by ('ebuild', '/', 'x11-libs/qt-gui-4.5.2-r2', 'merge')
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')

  ('installed', '/', 'x11-libs/qt-test-4.5.1', 'nomerge') pulled in by
    >=x11-libs/qt-test-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')

  ('installed', '/', 'x11-libs/qt-gui-4.5.1', 'nomerge') pulled in by
    x11-libs/qt-gui:4 required by ('installed', '/', 'x11-libs/qscintilla-2.3.2', 'nomerge')
    ~x11-libs/qt-gui-4.5.1[qt3support,accessibility,-debug] required by ('installed', '/', 'x11-libs/qt-qt3support-4.5.1', 'nomerge')
    >=x11-libs/qt-gui-4.5.1:4[dbus] required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')
    (and 4 more)

  ('ebuild', '/', 'x11-libs/qt-dbus-4.5.2', 'merge') pulled in by
    ~x11-libs/qt-dbus-4.5.2[-debug] required by ('ebuild', '/', 'x11-libs/qt-gui-4.5.2-r2', 'merge')
    >=x11-libs/qt-dbus-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')

  ('installed', '/', 'x11-libs/qt-opengl-4.5.1', 'nomerge') pulled in by
    >=x11-libs/qt-opengl-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')

  ('installed', '/', 'x11-libs/qt-core-4.5.1', 'nomerge') pulled in by
    ~x11-libs/qt-core-4.5.1[qt3support,-debug] required by ('installed', '/', 'x11-libs/qt-qt3support-4.5.1', 'nomerge')
    >=x11-libs/qt-core-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')
    ~x11-libs/qt-core-4.5.1[qt3support,-debug] required by ('installed', '/', 'x11-libs/qt-sql-4.5.1', 'nomerge')
    (and 5 more)

  ('installed', '/', 'x11-libs/qt-script-4.5.1', 'nomerge') pulled in by
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')
    ~x11-libs/qt-script-4.5.1[-debug] required by ('installed', '/', 'x11-libs/qt-gui-4.5.1', 'nomerge')

  ('ebuild', '/', 'x11-libs/qt-core-4.5.2', 'merge') pulled in by
    >=x11-libs/qt-core-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')
    ~x11-libs/qt-core-4.5.2[qt3support,-debug] required by ('ebuild', '/', 'x11-libs/qt-sql-4.5.2', 'merge')
    ~x11-libs/qt-core-4.5.2[qt3support,-debug] required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.5.2', 'merge')
    (and 3 more)

  ('ebuild', '/', 'x11-libs/qt-gui-4.5.2-r2', 'merge') pulled in by
    x11-libs/qt-gui:4 required by ('installed', '/', 'x11-libs/qscintilla-2.3.2', 'nomerge')
    x11-libs/qt-gui:4
    >=x11-libs/qt-gui-4.5.1:4[dbus] required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')
    (and 2 more)

  ('installed', '/', 'x11-libs/qt-dbus-4.5.1', 'nomerge') pulled in by
    ~x11-libs/qt-dbus-4.5.1[-debug] required by ('installed', '/', 'x11-libs/qt-gui-4.5.1', 'nomerge')
    >=x11-libs/qt-dbus-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')

  ('installed', '/', 'x11-libs/qt-svg-4.5.1-r1', 'nomerge') pulled in by
    >=x11-libs/qt-svg-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')


How can this be ?

emerge --info

Code:
emerge --info
Portage 2.1.6.13 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.29 i686)
=================================================================
System uname: Linux-2.6.29-i686-AMD_Sempron-tm-_2200+-with-gentoo-1.12.11.1
Timestamp of tree: Thu, 15 Oct 2009 05:45:02 +0000
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.4.6, 2.5.4-r3, 2.6.2-r1
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe -ftracer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe -ftracer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://trumpetti.atm.tut.fi/gentoo/"
LDFLAGS="-Wl,-O1"
LINGUAS="is en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aalib acl acpi afs alsa apache2 asf bundled-adodb bundledlibevent bzip2 cddb cli cracklib crypt ctype curl dba dbus dga dnsdb dri dts dv dvb dvbplayer dvd dvdr dvdread dvi exif fat ffmpeg flac font-server fortran freetype gd gdbm gpm gtk gtk2 gtkhtml gzip h323 hal http httpd iconv id3 id3tag ieee1394 ipalias ipfilter iproute2 ipsec ipv6 isdnlog jack java-external java-internal java5 javacomm javascript jpeg jpeg2k kde live mad md5sum mjpeg mmx modules mp3 mp4 mp4live mpd-mad mpe mpeg mpeg2 mpeg4 mudflap mysql mysqlfriends mysqli nagios-dns nagios-ntp nagios-ping nagios-ssh nat ncurses netcdf network nfs nls nptl nptlonly ogg on-the-fly-crypt openal opengl openmp optimisememory oss pam pcre pdf perl php png posix python qt3 qt3support qt4 quotas rar readline reflection rtsp samba session snmp sockets speedo speex spl sse ssl stream svg svgz sysfs szip tcpd tga tokenizer tordns truetype type1 unicode ups v4l v4l2 vcd vcdimager vfat vorbis win32codecs winbind wma wmf wmp wxgtk1 wxwindows x86 xml xorg xosd xpm xprint xrandr xv xvid zip zlib zvbi" ALSA_CARDS="ens1371" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="is en" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


There must be a way to fix this issue.
Back to top
View user's profile Send private message
noddyt
n00b
n00b


Joined: 28 Feb 2006
Posts: 68

PostPosted: Fri Oct 16, 2009 4:15 pm    Post subject: Reply with quote

Hi

I've had this problem and found the source to be this:

Code:
('installed', '/', 'x11-libs/qt-gui-4.5.1', 'nomerge') pulled in by
...
>=x11-libs/qt-gui-4.5.1:4[dbus] required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')


qt-gui > 4.5.1 defaults at -dbus

I fixed it by adding this line to /etc/portage/package.use

Code:
x11-libs/qt-gui dbus


Hope this helps
Back to top
View user's profile Send private message
gr650
n00b
n00b


Joined: 07 Jan 2005
Posts: 42
Location: Uzwil, Switzerland

PostPosted: Wed Oct 21, 2009 12:31 pm    Post subject: solved for now Reply with quote

Thanks, adding the dbus use flag for x11-libs/qt-gui to /etc/portage/package.use fixed the thing for me.
Back to top
View user's profile Send private message
snIP3r
l33t
l33t


Joined: 21 May 2004
Posts: 784
Location: germany

PostPosted: Thu Oct 22, 2009 7:04 pm    Post subject: Reply with quote

noddyt wrote:
Hi

I've had this problem and found the source to be this:

Code:
('installed', '/', 'x11-libs/qt-gui-4.5.1', 'nomerge') pulled in by
...
>=x11-libs/qt-gui-4.5.1:4[dbus] required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')


qt-gui > 4.5.1 defaults at -dbus

I fixed it by adding this line to /etc/portage/package.use

Code:
x11-libs/qt-gui dbus


Hope this helps


hi!

same issue here, adding the line in package.use fixed it for me too.

thx & greets
snIP3r
_________________
Intel G3220 on ASUS P9D-X
Gentoo Base System 2.2
Kernel 3.12.20-gentoo SMP
-----------------------------------------------
if your problem is fixed please add something like [solved] to the topic!
Back to top
View user's profile Send private message
HeXiLeD
l33t
l33t


Joined: 20 Aug 2005
Posts: 973
Location: online

PostPosted: Fri Oct 23, 2009 3:03 pm    Post subject: Reply with quote

Similar problem here while doing emerge -e world

Code:
[blocks B     ] <x11-libs/qt-qt3support-4.5.2 ("<x11-libs/qt-qt3support-4.5.2" is blocking x11-libs/qt-test-4.5.2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)
[blocks B     ] >x11-libs/qt-test-4.5.1-r9999 (">x11-libs/qt-test-4.5.1-r9999" is blocking x11-libs/qt-sql-4.5.1, x11-libs/qt-qt3support-4.5.1)
[blocks B     ] <x11-libs/qt-sql-4.5.2 ("<x11-libs/qt-sql-4.5.2" is blocking x11-libs/qt-test-4.5.2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-core-4.5.2)
[blocks B     ] >x11-libs/qt-xmlpatterns-4.5.1-r9999 (">x11-libs/qt-xmlpatterns-4.5.1-r9999" is blocking x11-libs/qt-sql-4.5.1, x11-libs/qt-qt3support-4.5.1)
[blocks B     ] >x11-libs/qt-script-4.5.1-r9999 (">x11-libs/qt-script-4.5.1-r9999" is blocking x11-libs/qt-sql-4.5.1, x11-libs/qt-qt3support-4.5.1)
[blocks B     ] >x11-libs/qt-core-4.5.1-r9999 (">x11-libs/qt-core-4.5.1-r9999" is blocking x11-libs/qt-sql-4.5.1, x11-libs/qt-qt3support-4.5.1)
[blocks B     ] >x11-libs/qt-gui-4.5.1-r9999 (">x11-libs/qt-gui-4.5.1-r9999" is blocking x11-libs/qt-sql-4.5.1, x11-libs/qt-qt3support-4.5.1)
[blocks B     ] >x11-libs/qt-dbus-4.5.1-r9999 (">x11-libs/qt-dbus-4.5.1-r9999" is blocking x11-libs/qt-sql-4.5.1, x11-libs/qt-qt3support-4.5.1)
[blocks B     ] >x11-libs/qt-opengl-4.5.1-r9999 (">x11-libs/qt-opengl-4.5.1-r9999" is blocking x11-libs/qt-sql-4.5.1, x11-libs/qt-qt3support-4.5.1)


* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.


Code:
 ('ebuild', '/', 'x11-libs/qt-script-4.5.2', 'merge') pulled in by
    ~x11-libs/qt-script-4.5.2[-debug] required by ('ebuild', '/', 'x11-libs/qt-gui-4.5.2-r2', 'merge')
    >=x11-libs/qt-script-4.5.1:4 required by ('ebuild', '/', 'dev-python/PyQt4-4.5.4-r4', 'merge')
    x11-libs/qt-script:4 required by ('ebuild', '/', 'sci-astronomy/stellarium-0.10.2', 'merge')

  ('ebuild', '/', 'x11-libs/qt-test-4.5.2', 'merge') pulled in by
    >=x11-libs/qt-test-4.5.1:4 required by ('ebuild', '/', 'dev-python/PyQt4-4.5.4-r4', 'merge')

  ('ebuild', '/', 'x11-libs/qt-qt3support-4.5.1', 'merge') pulled in by
    ~x11-libs/qt-qt3support-4.5.1[-debug] required by ('ebuild', '/', 'x11-libs/qt-gui-4.5.1', 'merge')

  ('ebuild', '/', 'x11-libs/qt-sql-4.5.1', 'merge') pulled in by
    x11-libs/qt-sql:4[sqlite] required by ('ebuild', '/', 'media-sound/murmur-1.1.8', 'merge')
    ~x11-libs/qt-sql-4.5.1[qt3support,-debug] required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.5.1', 'merge')
    x11-libs/qt-sql:4[sqlite] required by ('ebuild', '/', 'media-sound/mumble-1.1.8', 'merge')

  ('ebuild', '/', 'x11-libs/qt-xmlpatterns-4.5.2', 'merge') pulled in by
    x11-libs/qt-xmlpatterns:4 required by ('ebuild', '/', 'app-admin/keepassx-0.3.4', 'merge')

  ('ebuild', '/', 'x11-libs/qt-dbus-4.5.2', 'merge') pulled in by
    >=x11-libs/qt-dbus-4.5.1:4 required by ('ebuild', '/', 'dev-python/PyQt4-4.5.4-r4', 'merge')
    x11-libs/qt-dbus:4 required by ('ebuild', '/', 'media-sound/mumble-1.1.8', 'merge')
    x11-libs/qt-dbus:4 required by ('ebuild', '/', 'media-sound/murmur-1.1.8', 'merge')
    (and 1 more)

  ('ebuild', '/', 'x11-libs/qt-opengl-4.5.2-r1', 'merge') pulled in by
    >=x11-libs/qt-opengl-4.5.1:4 required by ('ebuild', '/', 'dev-python/PyQt4-4.5.4-r4', 'merge')
    x11-libs/qt-opengl:4 required by ('ebuild', '/', 'media-sound/mumble-1.1.8', 'merge')
    x11-libs/qt-opengl:4 required by ('ebuild', '/', 'sci-astronomy/stellarium-0.10.2', 'merge')

  ('ebuild', '/', 'x11-libs/qt-core-4.5.2', 'merge') pulled in by
    x11-libs/qt-core required by ('ebuild', '/', 'www-client/opera-10.00', 'merge')
    x11-libs/qt-core:4 required by ('ebuild', '/', 'sci-astronomy/stellarium-0.10.2', 'merge')
    x11-libs/qt-core:4 required by ('ebuild', '/', 'media-video/vlc-1.0.2', 'merge')
    (and 11 more)

  ('ebuild', '/', 'x11-libs/qt-gui-4.5.2-r2', 'merge') pulled in by
    x11-libs/qt-gui:4 required by ('ebuild', '/', 'media-sound/mumble-1.1.8', 'merge')
    x11-libs/qt-gui:4 required by ('ebuild', '/', 'sci-astronomy/stellarium-0.10.2', 'merge')
    x11-libs/qt-gui:4 required by ('ebuild', '/', 'media-video/vlc-1.0.2', 'merge')
    (and 8 more)


qt-gui flags

Code:
x11-libs/qt-gui-4.5.2-r2  USE="accessibility cups dbus -debug glib gtk -mng -nas -nis -pch -qt3support -raster -tiff -xinerama"


According to the message the block is caused by :
x11-libs/qt-qt3support-4.5.2

Code:
# emerge -s x11-libs/qt-qt3support
Searching...   
[ Results for search key : x11-libs/qt-qt3support ]
[ Applications found : 0 ]


Code:
# equery d qt-qt3support
[ Searching for packages depending on qt-qt3support... ]
app-office/openoffice-3.1.1 (kde? >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde])
x11-libs/qt-4.5.1 (qt3support? ~x11-libs/qt-qt3support-4.5.1)
x11-libs/qt-gui-4.5.2-r2 (qt3support? ~x11-libs/qt-qt3support-4.5.2[debug=])


Code:
# equery b qt-qt3support
[ Searching for file(s) qt-qt3support in *... ]


/etc/make.conf with qt3 flag and i have one package using qt4 ( which i need )
Code:
net-print/hplip-3.9.8  USE="cups -cupsddk dbus -doc fax foomatic gtk -minimal -parport -policykit ppds -qt3 qt4 scanner snmp


Solutions ?
_________________
443640, Questioning, Unsolved, BinHost
Back to top
View user's profile Send private message
tundra
Tux's lil' helper
Tux's lil' helper


Joined: 27 Jan 2005
Posts: 94

PostPosted: Thu Oct 29, 2009 7:26 pm    Post subject: Reply with quote

I don't know if this helps anyone, but I just got out of qt hell by putting >=x11-libs/qt-opengl-4.5.3 in my ./etc/portage/package.keywords. Otherwise it tried to pull in 4.5.2, which conflicted with all the other qt-*-4.5.3 that it wanted to install.
_________________
Enlightenment comes when you hear the sound of one hand slapping your forehead.
Back to top
View user's profile Send private message
SteveBallmersChair
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jul 2006
Posts: 84
Location: Being thrown around in Redmond

PostPosted: Mon Nov 02, 2009 12:36 am    Post subject: Reply with quote

I was also met with this dependency hell and the only way I got out of it was to simply put all of the qt modules >=4.5.3 in my package.mask since some of the 4.5.3 modules block other 4.5.3 modules, but the 4.5.2 modules play nicely with each other and with the latest stable kde 4.3 stuff.

I ran into this problem in a completely fresh install, which was a bit annoying :x
_________________
Unix is user friendly- it is just picky who its friends are.
Back to top
View user's profile Send private message
Jim6
Tux's lil' helper
Tux's lil' helper


Joined: 08 Apr 2005
Posts: 101

PostPosted: Mon Nov 02, 2009 2:48 pm    Post subject: Reply with quote

I was having conflicts between 4.5.1 and 4.5.3. I masked all older versions than 4.5.3.

Code:
<=x11-libs/qt-core-4.5.2
<=x11-libs/qt-gui-4.5.2
<=x11-libs/qt-gui-4.5.2
<=x11-libs/qt-dbus-4.5.2
<=x11-libs/qt-opengl-4.5.2
<=x11-libs/qt-svg-4.5.2
<=x11-libs/qt-qt3support-4.5.2
<=x11-libs/qt-assistant-4.5.2
<=x11-libs/qt-script-4.5.2
<=x11-libs/qt-sql-4.5.2
<=x11-libs/qt-test-4.5.2
<=x11-libs/qt-webkit-4.5.2
<=x11-libs/qt-xmlpatterns-4.5.2
<=x11-libs/qt-phonon-4.5.2
Back to top
View user's profile Send private message
calicoman
Apprentice
Apprentice


Joined: 18 Feb 2004
Posts: 171

PostPosted: Tue Nov 03, 2009 8:58 pm    Post subject: Reply with quote

I may be lucky, but after trying some of the things listed above, I got my conflicts solved by putting the following USE flags in /etc/make.conf:
ssl svg webkit mysql sql qt3support
Back to top
View user's profile Send private message
Maragato
Apprentice
Apprentice


Joined: 10 Mar 2005
Posts: 150

PostPosted: Wed Nov 04, 2009 2:19 am    Post subject: Reply with quote

I had fixed it some days ago now it comes back.... I dont want to unmerge kde and lots of libs to have it right again any ideas?
Code:

[ebuild     U ] x11-libs/qt-sql-4.5.3 [4.5.2] USE="iconv mysql qt3support sqlite -debug (-firebird) -odbc -pch -postgres" 0 kB                   
[blocks b     ] <x11-libs/qt-sql-4.5.3 ("<x11-libs/qt-sql-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-webkit-4.5.3)                                                                                                               
[ebuild     U ] x11-libs/qt-test-4.5.3-r1 [4.5.2] USE="iconv -debug -pch" 0 kB                                                                   
[blocks b     ] <x11-libs/qt-test-4.5.3 ("<x11-libs/qt-test-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4.5.3)                                                                                                                 
[ebuild     U ] x11-libs/qt-script-4.5.3-r1 [4.5.2] USE="iconv -debug -pch" 0 kB                                                                 
[blocks b     ] <x11-libs/qt-script-4.5.3 ("<x11-libs/qt-script-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4.5.3)                                                                                                               
[ebuild     U ] x11-libs/qt-dbus-4.5.3-r1 [4.5.2] USE="-debug -pch" 0 kB                                                                         
[blocks b     ] <x11-libs/qt-dbus-4.5.3 ("<x11-libs/qt-dbus-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4.5.3)                                                                                                                 
[ebuild     U ] x11-libs/qt-gui-4.5.3-r2 [4.5.2-r2] USE="accessibility cups dbus glib gtk mng qt3support tiff -debug -nas -nis -pch -raster -xinerama" 0 kB                                                                                                                                       
[blocks b     ] <x11-libs/qt-gui-4.5.3 ("<x11-libs/qt-gui-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4.5.3)                                                                                                                   
[ebuild     U ] x11-libs/qt-qt3support-4.5.3 [4.5.2] USE="accessibility kde -debug -pch -phonon" 0 kB                                           
[blocks b     ] <x11-libs/qt-qt3support-4.5.3 ("<x11-libs/qt-qt3support-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4.5.3)                                                                                                         
[ebuild     U ] dev-util/cmake-2.6.4-r3 [2.6.4] USE="qt4 vim-syntax -emacs" 0 kB                                                                 
[ebuild     U ] x11-libs/qt-svg-4.5.3-r1 [4.5.2] USE="iconv -debug -pch" 0 kB                                                                   
[blocks b     ] <x11-libs/qt-svg-4.5.3 ("<x11-libs/qt-svg-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4.5.3)                                                                                                                   
[ebuild     U ] x11-libs/qt-opengl-4.5.3-r1 [4.5.2-r1] USE="qt3support -debug -pch" 0 kB                                                         
[blocks b     ] >x11-libs/qt-webkit-4.5.2-r9999 (">x11-libs/qt-webkit-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                                                                                               
[blocks b     ] <x11-libs/qt-opengl-4.5.3 ("<x11-libs/qt-opengl-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4.5.3)                                                                                                               
[ebuild     U ] kde-base/oxygen-icons-4.3.3 [4.3.2-r1] USE="(-kdeprefix)" 121,152 kB                                                             
[ebuild     U ] x11-libs/qt-webkit-4.5.3 [4.5.2-r1] USE="kde -debug -pch" 0 kB                                                                   
[blocks b     ] >x11-libs/qt-svg-4.5.2-r9999 (">x11-libs/qt-svg-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                                                                                               
[blocks b     ] >x11-libs/qt-dbus-4.5.2-r9999 (">x11-libs/qt-dbus-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                                                                                               
[blocks b     ] <x11-libs/qt-webkit-4.5.3 ("<x11-libs/qt-webkit-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)                                                                                                             
[blocks b     ] >x11-libs/qt-core-4.5.2-r9999 (">x11-libs/qt-core-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-sql-4.5.2)                                                                                                               
[blocks b     ] >x11-libs/qt-sql-4.5.2-r9999 (">x11-libs/qt-sql-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2)                                                                                                               
[blocks b     ] >x11-libs/qt-opengl-4.5.2-r9999 (">x11-libs/qt-opengl-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                                                                                               
[blocks b     ] >x11-libs/qt-test-4.5.2-r9999 (">x11-libs/qt-test-4.5.2-r9999" is blocking x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                                                                                               
[blocks b     ] >x11-libs/qt-gui-4.5.2-r9999 (">x11-libs/qt-gui-4.5.2-r9999" is blocking x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                                                                                                   
[blocks b     ] >x11-libs/qt-qt3support-4.5.2-r9999 (">x11-libs/qt-qt3support-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                                                                                         
[blocks b     ] >x11-libs/qt-script-4.5.2-r9999 (">x11-libs/qt-script-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2) 


If I try to go ahead I have billions of errors like:
Code:
emerge  x11-libs/qt-sql

These are the packages that would be merged, in order:

Calculating dependencies ... done!
[ebuild     U ] x11-libs/qt-core-4.5.3-r2 [4.5.2] USE="glib iconv qt3support ssl -debug -doc -pch" 122,446 kB                                                                                                 
[ebuild     U ] x11-libs/qt-sql-4.5.3 [4.5.2] USE="iconv mysql qt3support sqlite -debug (-firebird) -odbc -pch -postgres" 0 kB                                                                               
[ebuild     U ] x11-libs/qt-script-4.5.3-r1 [4.5.2] USE="iconv -debug -pch" 0 kB                       
[ebuild     U ] x11-libs/qt-dbus-4.5.3-r1 [4.5.2] USE="-debug -pch" 0 kB                               
[ebuild     U ] x11-libs/qt-gui-4.5.3-r2 [4.5.2-r2] USE="accessibility cups dbus glib gtk mng qt3support tiff -debug -nas -nis -pch -raster -xinerama" 0 kB                                                   
[ebuild     U ] x11-libs/qt-qt3support-4.5.3 [4.5.2] USE="accessibility kde -debug -pch -phonon" 0 kB 
[blocks B     ] >x11-libs/qt-dbus-4.5.2-r9999 (">x11-libs/qt-dbus-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                                                                       
[blocks B     ] <x11-libs/qt-svg-4.5.3 ("<x11-libs/qt-svg-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)                                                                       
[blocks B     ] <x11-libs/qt-sql-4.5.3 ("<x11-libs/qt-sql-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-script-4.5.3-r1)                                                                                             
[blocks B     ] <x11-libs/qt-webkit-4.5.3 ("<x11-libs/qt-webkit-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)                                                                 
[blocks B     ] >x11-libs/qt-core-4.5.2-r9999 (">x11-libs/qt-core-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-sql-4.5.2)                                                                                       
[blocks B     ] <x11-libs/qt-test-4.5.3 ("<x11-libs/qt-test-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)                                                                     
[blocks B     ] <x11-libs/qt-qt3support-4.5.3 ("<x11-libs/qt-qt3support-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-sql-4.5.3, x11-libs/qt-script-4.5.3-r1)                                                                                       
[blocks B     ] <x11-libs/qt-core-4.5.3 ("<x11-libs/qt-core-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-sql-4.5.3, x11-libs/qt-script-4.5.3-r1)                                                                                               
[blocks B     ] <x11-libs/qt-script-4.5.3 ("<x11-libs/qt-script-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-sql-4.5.3)                                                                                             
[blocks B     ] >x11-libs/qt-gui-4.5.2-r9999 (">x11-libs/qt-gui-4.5.2-r9999" is blocking x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                                                                           
[blocks B     ] >x11-libs/qt-qt3support-4.5.2-r9999 (">x11-libs/qt-qt3support-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                                                                 
[blocks B     ] >x11-libs/qt-script-4.5.2-r9999 (">x11-libs/qt-script-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                                                                     
[blocks B     ] >x11-libs/qt-sql-4.5.2-r9999 (">x11-libs/qt-sql-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2)                                                                                         
[blocks B     ] <x11-libs/qt-dbus-4.5.3 ("<x11-libs/qt-dbus-4.5.3" is blocking x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-sql-4.5.3, x11-libs/qt-script-4.5.3-r1)                                                                                               
[blocks B     ] <x11-libs/qt-opengl-4.5.3 ("<x11-libs/qt-opengl-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)                                                                 
[blocks B     ] <x11-libs/qt-gui-4.5.3 ("<x11-libs/qt-gui-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-sql-4.5.3, x11-libs/qt-script-4.5.3-r1)                                                                                                 

Total: 6 packages (6 upgrades), Size of downloads: 122,446 kB
Conflict: 16 blocks (16 unsatisfied)                         

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.                 

  ('installed', '/', 'x11-libs/qt-webkit-4.5.2-r1', 'nomerge') pulled in by
    >=x11-libs/qt-webkit-4.5.1:4[kde] required by ('installed', '/', 'kde-base/kdelibs-4.3.2-r3', 'nomerge')                                                                                                 
    >=x11-libs/qt-webkit-4.5.1:4[kde] required by ('installed', '/', 'kde-base/kdeplasma-addons-4.3.2', 'nomerge')                                                                                           
    >=x11-libs/qt-webkit-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')

  ('installed', '/', 'x11-libs/qt-dbus-4.5.2', 'nomerge') pulled in by
    x11-libs/qt-dbus:4 required by ('installed', '/', 'app-misc/strigi-0.7.0', 'nomerge')
    >=x11-libs/qt-dbus-4.4.0:4 required by ('installed', '/', 'media-sound/phonon-4.4_pre20090520', 'nomerge')                                                                                               
    x11-libs/qt-dbus:4 required by ('installed', '/', 'dev-libs/soprano-2.3.1', 'nomerge')             
    (and 2 more)                                                                                       

  ('ebuild', '/', 'x11-libs/qt-dbus-4.5.3-r1', 'merge') pulled in by
    >=x11-libs/qt-dbus-4.4.0:4 required by ('installed', '/', 'media-sound/phonon-4.4_pre20090520', 'nomerge')                                                                                               
    x11-libs/qt-dbus:4 required by ('installed', '/', 'dev-libs/soprano-2.3.1', 'nomerge')             
    >=x11-libs/qt-dbus-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge') 
    (and 2 more)                                                                                       

  ('ebuild', '/', 'x11-libs/qt-gui-4.5.3-r2', 'merge') pulled in by
    >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('installed', '/', 'kde-base/kde-env-4.3.2', 'nomerge')                                                                                         
    >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('installed', '/', 'kde-base/okular-4.3.2', 'nomerge')                                                                                         
    >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('installed', '/', 'kde-base/kcheckpass-4.3.2', 'nomerge')                                                                                     
    (and 242 more)                                                                                     

  ('installed', '/', 'x11-libs/qt-qt3support-4.5.2', 'nomerge') pulled in by
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'kde-base/kdeartwork-weatherwallpapers-4.3.2', 'nomerge')                                                             
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'kde-base/ksmserver-4.3.2', 'nomerge')                                                                                 
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'kde-base/kdelibs-4.3.2-r3', 'nomerge')                                                                               
    (and 232 more)                                                                                     

  ('installed', '/', 'x11-libs/qt-script-4.5.2', 'nomerge') pulled in by
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/ktimezoned-4.3.2', 'nomerge')
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/kdebase-desktoptheme-4.3.2', 'nomerge')                                                                                             
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/solidautoeject-4.3.2', 'nomerge')                                                                                                   
    (and 233 more)                                                                                     

  ('installed', '/', 'x11-libs/qt-core-4.5.2', 'nomerge') pulled in by
    >=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('installed', '/', 'kde-base/kcalc-4.3.2', 'nomerge')                                                                                             
    >=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('installed', '/', 'kde-base/kdiamond-4.3.2', 'nomerge')                                                                                           
    >=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('installed', '/', 'kde-base/libkleo-4.3.2', 'nomerge')                                                                                           
    (and 246 more)                                                                                     

  ('ebuild', '/', 'x11-libs/qt-qt3support-4.5.3', 'merge') pulled in by
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'kde-base/kmimetypefinder-4.3.2', 'nomerge')                                                                           
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'kde-base/ksmserver-4.3.2', 'nomerge')                                                                                 
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'kde-base/kdelibs-4.3.2-r3', 'nomerge')                                                                               
    (and 232 more)                                                                                     

  ('ebuild', '/', 'x11-libs/qt-script-4.5.3-r1', 'merge') pulled in by
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/ktimezoned-4.3.2', 'nomerge')
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/kdebase-desktoptheme-4.3.2', 'nomerge')                                                                                             
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/solidautoeject-4.3.2', 'nomerge')                                                                                                   
    (and 233 more)                                                                                     

  ('installed', '/', 'x11-libs/qt-svg-4.5.2', 'nomerge') pulled in by
    >=x11-libs/qt-svg-4.5.1:4 required by ('installed', '/', 'kde-base/libknotificationitem-4.3.2', 'nomerge')                                                                                               
    >=x11-libs/qt-svg-4.5.1:4 required by ('installed', '/', 'kde-base/kweather-4.3.2', 'nomerge')     
    >=x11-libs/qt-svg-4.5.1:4 required by ('installed', '/', 'kde-base/kopete-4.3.2', 'nomerge')       
    (and 232 more)                                                                                     

  ('installed', '/', 'x11-libs/qt-test-4.5.2', 'nomerge') pulled in by
    >=x11-libs/qt-test-4.5.1:4 required by ('installed', '/', 'kde-base/kfilereplace-4.3.2', 'nomerge')
    >=x11-libs/qt-test-4.5.1:4 required by ('installed', '/', 'kde-base/marble-4.3.2', 'nomerge')     
    >=x11-libs/qt-test-4.5.1:4 required by ('installed', '/', 'kde-base/keditfiletype-4.3.2', 'nomerge')                                                                                                     
    (and 234 more)                                                                                     

  ('installed', '/', 'x11-libs/qt-sql-4.5.2', 'nomerge') pulled in by
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/libkdcraw-4.3.2', 'nomerge')                                                                                               
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/kontactinterfaces-4.3.2', 'nomerge')                                                                                       
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/katomic-4.3.2', 'nomerge')                                                                                                 
    (and 236 more)                                                                                     

  ('installed', '/', 'x11-libs/qt-opengl-4.5.2-r1', 'nomerge') pulled in by
    >=x11-libs/qt-opengl-4.5.1:4 required by ('installed', '/', 'kde-base/kscreensaver-4.3.2', 'nomerge')                                                                                                     
    >=x11-libs/qt-opengl-4.5.1:4 required by ('installed', '/', 'kde-base/systemsettings-4.3.2', 'nomerge')                                                                                                   
    >=x11-libs/qt-opengl-4.5.1:4 required by ('installed', '/', 'kde-base/kdeartwork-kscreensaver-4.3.2', 'nomerge')                                                                                         
    (and 13 more)                                                                                     

  ('installed', '/', 'x11-libs/qt-gui-4.5.2-r2', 'nomerge') pulled in by
    >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('installed', '/', 'kde-base/kgpg-4.3.2', 'nomerge')                                                                                           
    >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('installed', '/', 'kde-base/kde-env-4.3.2', 'nomerge')                                                                                         
    >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('installed', '/', 'kde-base/okular-4.3.2', 'nomerge')                                                                                         
    (and 245 more)                                                                                     

  ('ebuild', '/', 'x11-libs/qt-core-4.5.3-r2', 'merge') pulled in by
    >=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('installed', '/', 'kde-base/kcalc-4.3.2', 'nomerge')
    >=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('installed', '/', 'kde-base/kdiamond-4.3.2', 'nomerge')
    >=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('installed', '/', 'kde-base/libkleo-4.3.2', 'nomerge')
    (and 243 more)

  ('ebuild', '/', 'x11-libs/qt-sql-4.5.3', 'merge') pulled in by
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/kdeartwork-desktopthemes-4.3.2', 'nomerge')
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/libkdcraw-4.3.2', 'nomerge')
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/katomic-4.3.2', 'nomerge')
    (and 236 more)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- sys-kernel/gentoo-sources-2.6.28-r5 (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
calicoman
Apprentice
Apprentice


Joined: 18 Feb 2004
Posts: 171

PostPosted: Wed Nov 04, 2009 6:14 pm    Post subject: Reply with quote

While I got my first computer resolved of conflicts (see previous post), I am having much difficulty with the second. I finally got to the stage where all the major blocks are resolved, but now I get the following error messages. (I did change my profile during the days I have been trying to solve problems):

Total: 172 packages (9 upgrades, 79 new, 38 in new slots, 46 reinstalls), Size of downloads: 418,483 kB
Conflict: 14 blocks

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/PyQt4:0

('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge') pulled in by
>=dev-python/PyQt4-4.5[dbus,sql,svg,webkit,X] required by ('ebuild', '/', 'kde-base/pykde4-4.3.1', 'merge')
(and 3 more)

('ebuild', '/', 'dev-python/PyQt4-4.5.4-r4', 'merge') pulled in by
>=dev-python/PyQt4-4.4.0[X] required by ('ebuild', '/', 'kde-base/plasma-workspace-4.3.1', 'merge')
dev-python/PyQt4 required by world
>=dev-python/PyQt4-4.5[X] required by ('installed', '/', 'dev-python/qscintilla-python-2.4', 'nomerge')

Explanation:

New USE for 'dev-python/PyQt4:0' are incorrectly set. In order to
solve this, adjust USE to satisfy '>=dev-
python/PyQt4-4.5[dbus,sql,svg,webkit,X]'.


frank ~ #




I have no clue as to how to solve the slot conflict. With PyQt4 I just go around in circles - when I emerge USE="dbus sql svg webkit X" --nodeps dev-python/PyQt4-4.5.4-r4 I get an error message that I need to emerge PyQt4 with +sql. When I remove existing version and do that, I get the above error message.

Any help would be appreciated.
Back to top
View user's profile Send private message
HeXiLeD
l33t
l33t


Joined: 20 Aug 2005
Posts: 973
Location: online

PostPosted: Thu Nov 05, 2009 10:27 pm    Post subject: Reply with quote

adding:

Code:
>=x11-libs/qt-sql-4.5.3
>=x11-libs/qt-test-4.5.3
>=x11-libs/qt-script-4.5.3
>=x11-libs/qt-qt3support-4.5.3
>=x11-libs/qt-opengl-4.5.3
>=x11-libs/qt-gui-4.5.3
>=x11-libs/qt-dbus-4.5.3
>=x11-libs/qt-core-4.5.3
>=x11-libs/qt-xmlpatterns-4.5.3


.... to /etc/portage/package.mask almost solved the problem for me.

However:

Code:
emerge: there are no ebuilds built with USE flags to satisfy "x11-libs/qt-gui:4[qt3support]".
!!! One of the following packages is required to complete your request:
- x11-libs/qt-gui-4.5.2-r2 (Change USE: +qt3support)
(dependency required by "app-admin/keepassx-0.4.1" [ebuild])
(dependency required by "world" [argument])


keepassx asks for qt-gui with +qt3support which if i allow it; then i will have a tone of other packages wanting qt-gui without qt3support

keppassx version 0.4.1

_________________
443640, Questioning, Unsolved, BinHost
Back to top
View user's profile Send private message
calicoman
Apprentice
Apprentice


Joined: 18 Feb 2004
Posts: 171

PostPosted: Fri Nov 06, 2009 2:07 am    Post subject: Reply with quote

I found an answer over in Desktop Enviroments that solved my problem.

Don't know how to paste the reference here, but the subject is about not being able to update from 3.5 to 4.3.
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8032

PostPosted: Fri Nov 06, 2009 4:38 am    Post subject: Reply with quote

calicoman wrote:
Don't know how to paste the reference here, but the subject is about not being able to update from 3.5 to 4.3.
Just use the appropriate tags to link to a topic or a specific post.
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4398
Location: Suzhou, China

PostPosted: Mon Nov 09, 2009 4:51 pm    Post subject: Reply with quote

If you have a problem installing or upgrading Qt libraries, then you most likely have your useflags set wrong. Using the desktop profile (or soon the kde profile, which is in the works), you should have no problem. The base profile does not enable a number of useflags you will need for most desktop applications.

Most users will want these useflags enabled: dbus glib qt3support ssl
KDE4 users will also need: accessibility kde mng

When upgrading Qt, don't try to upgrade individual modules, portage won't let you do that, as all modules must be of the same release version. Doing a world update should work, if your useflags are set right. Portage will then automatically solve the softblocks. You can unmask x11-libs/qt:4 for convenience to pull in all qt modules, but you may not want that. If you want to upgrade just the Qt libs, and you have eix installed, you can also use:
Code:
emerge -a1 `eix --only-names -C x11-libs -I qt`


Please do not mask Qt 4.5.3, as all earlier versions have known security bugs and will be removed soon.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
HeXiLeD
l33t
l33t


Joined: 20 Aug 2005
Posts: 973
Location: online

PostPosted: Tue Nov 10, 2009 7:13 pm    Post subject: Reply with quote

I unmasked all qt 4.5.3 packages. Removed qt3/qt4 ( i had only one of them) use flag from make.conf and added qt3support

Problem is [SOLVED] for me
_________________
443640, Questioning, Unsolved, BinHost
Back to top
View user's profile Send private message
Sade
Guru
Guru


Joined: 22 Mar 2005
Posts: 406
Location: Netherlands - Eindhoven

PostPosted: Sun Nov 15, 2009 9:43 am    Post subject: Reply with quote

is there a general solution to be found anywhere in this thread?
_________________
| 1.6Ghz atom N270 | adopt an unanswerd post | a nice way to post a config file |
Back to top
View user's profile Send private message
Caleb9
n00b
n00b


Joined: 22 Nov 2005
Posts: 65
Location: PL & DK

PostPosted: Sun Nov 15, 2009 12:07 pm    Post subject: Reply with quote

Can't upgrade system for couple of weeks now, anyone can help me?

emerge -uDpvt world
Code:
[nomerge      ] app-cdr/k3b-1.68.0_alpha3 [1.0.5-r6] USE="dvd encode flac mad vcd vorbis wav (-aqua) -debug -emovix -ffmpeg -lame -musicbrainz -sndfile -sox -taglib"  [0]
[nomerge      ]  x11-libs/qt-webkit-4.5.2-r1  USE="kde -debug -pch"  [0]
[uninstall    ]    x11-libs/qt-xmlpatterns-4.5.2  USE="-debug -pch"  [0]
[nomerge      ] gnome-extra/gnome-media-2.26.0-r1  USE="sound -debug -esd -gnomecd -ipv6 -pulseaudio"  [0]
[nomerge      ]  media-libs/gst-plugins-good-0.10.16 [0.10.14] USE="-debug"  [0]
[uninstall    ]    media-libs/gst-plugins-bad-0.10.13  USE="-debug"  [0]
[nomerge      ] media-video/totem-2.26.3-r1  USE="bluetooth nsplugin python -debug -doc -galago -lirc -nautilus (-tracker)"  [0]
[ebuild     U ]  media-plugins/gst-plugins-soup-0.10.16 [0.10.14] 2,514 kB [0]
[ebuild     U ]  media-plugins/gst-plugins-gio-0.10.24 [0.10.23] 2,148 kB [0]
[ebuild     U ]  media-plugins/gst-plugins-pango-0.10.24 [0.10.23] 0 kB [0]
[nomerge      ] dev-util/eclipse-sdk-3.4-r2  USE="java6 -doc"  [0]
[ebuild     U ]  dev-java/tomcat-servlet-api-5.5.27-r1 [5.5.27] USE="-doc -source (-java5%*)" 0 kB [0]
[ebuild     U ]  dev-java/swt-3.4-r4 [3.4-r3] USE="cairo gnome opengl xulrunner" 0 kB [0]
[blocks b     ] <media-libs/gst-plugins-bad-0.10.14 ("<media-libs/gst-plugins-bad-0.10.14" is blocking media-libs/gst-plugins-good-0.10.16)
[ebuild     U ]  media-libs/gst-plugins-bad-0.10.14 [0.10.13] USE="-debug" 2,718 kB [0]
[nomerge      ] app-text/acroread-9.2  USE="cups nsplugin -ldap -minimal" LINGUAS="en -de -fr -ja"  [0]
[ebuild     U ]  app-emulation/emul-linux-x86-gtklibs-20081109 [20071214] USE="-qt3*" 4,653 kB [0]
[nomerge      ] x11-wm/compiz-fusion-0.8.4  USE="emerald gnome -kde -unsupported"  [0]
[ebuild     U ]  x11-plugins/compiz-plugins-extra-0.8.4-r1 [0.8.4] USE="gnome" 0 kB [0]
[nomerge      ] media-video/mplayer-1.0_rc2_p20090731  USE="3dnow 3dnowext X a52 aac alsa ass cddb cdio dirac dts dv dvd dvdnav enca encode faac faad fbcon gif iconv jack jpeg live mad mmx mmxext mp2 mp3 network opengl osdmenu png quicktime rar real rtc schroedinger sdl shm speex sse sse2 theora tremor truetype unicode v4l v4l2 vorbis x264 xscreensaver xv xvid xvmc -aalib (-altivec) -bidi -bindist -bl -cdparanoia -cpudetection -custom-cflags -custom-cpuopts -debug -dga -directfb -doc -dvb -dxr3 -esd -ftp -ggi -gmplayer -ipv6 -joystick -ladspa -libcaca -lirc -lzo -md5sum -mng -nas -openal -oss -pnm -pulseaudio -pvr -radio -samba -ssse3 (-svga) -teletext -tga -vdpau (-vidix) (-win32codecs) -xanim -xinerama -zoran" VIDEO_CARDS="nvidia -mga -s3virge -tdfx -vesa"  [0]
[ebuild     U ]  media-libs/schroedinger-1.0.8 [1.0.7] USE="(-gstreamer%*)" 844 kB [0]
[nomerge      ] gnome-extra/gnome-media-2.26.0-r1  USE="sound -debug -esd -gnomecd -ipv6 -pulseaudio"  [0]
[nomerge      ]  media-plugins/gst-plugins-meta-0.10-r2  USE="X a52 alsa dvd flac mad mpeg ogg vorbis xv -dvb -esd -ffmpeg -mythtv -oss -theora"  [0]
[ebuild     U ]   media-plugins/gst-plugins-mpeg2dec-0.10.12 [0.10.11] 1,004 kB [0]
[ebuild     U ]   media-plugins/gst-plugins-vorbis-0.10.24 [0.10.23] 0 kB [0]
[ebuild     U ]   media-plugins/gst-plugins-ogg-0.10.24 [0.10.23] 0 kB [0]
[ebuild     U ]   media-plugins/gst-plugins-flac-0.10.16 [0.10.14] 0 kB [0]
[ebuild     U ]   media-plugins/gst-plugins-mad-0.10.12 [0.10.11] 0 kB [0]
[ebuild     U ]   media-plugins/gst-plugins-a52dec-0.10.12 [0.10.11] 0 kB [0]
[ebuild     U ]   media-plugins/gst-plugins-alsa-0.10.24 [0.10.23] 0 kB [0]
[ebuild     U ]   media-libs/gst-plugins-ugly-0.10.12 [0.10.11] USE="-debug" 0 kB [0]
[ebuild     U ]   media-plugins/gst-plugins-xvideo-0.10.24 [0.10.23] 0 kB [0]
[ebuild     U ]   media-plugins/gst-plugins-x-0.10.24 [0.10.23] 0 kB [0]
[ebuild     U ]   media-plugins/gst-plugins-dvdread-0.10.12 [0.10.11] 0 kB [0]
[ebuild     U ]  media-plugins/gst-plugins-gconf-0.10.16 [0.10.14] 0 kB [0]
[nomerge      ] x11-libs/qt-xmlpatterns-4.5.2  USE="-debug -pch"  [0]
[blocks b     ]  >x11-libs/qt-svg-4.5.2-r9999 (">x11-libs/qt-svg-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2)
[blocks b     ]  >x11-libs/qt-qt3support-4.5.2-r9999 (">x11-libs/qt-qt3support-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-svg-4.5.2)
[blocks b     ]  >x11-libs/qt-gui-4.5.2-r9999 (">x11-libs/qt-gui-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-svg-4.5.2)
[blocks b     ]  >x11-libs/qt-test-4.5.2-r9999 (">x11-libs/qt-test-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-svg-4.5.2)
[nomerge      ] x11-libs/qt-opengl-4.5.3-r1 [4.5.2-r1] USE="qt3support -debug -pch"  [0]
[blocks b     ]  <x11-libs/qt-xmlpatterns-4.5.3 ("<x11-libs/qt-xmlpatterns-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)
[nomerge      ] x11-libs/qt-opengl-4.5.2-r1  USE="qt3support -debug -pch"  [0]
[blocks b     ]  >x11-libs/qt-sql-4.5.2-r9999 (">x11-libs/qt-sql-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-svg-4.5.2)
[blocks b     ]  >x11-libs/qt-core-4.5.2-r9999 (">x11-libs/qt-core-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-svg-4.5.2)
[nomerge      ] kde-base/kdelibs-4.3.1-r2  USE="3dnow acl alsa bzip2 fam handbook mmx nls opengl semantic-desktop spell sse sse2 ssl (-altivec) (-aqua) -bindist -debug -doc -jpeg2k (-kdeprefix) -kerberos -openexr -test -zeroconf"  [0]
[nomerge      ]  x11-libs/qt-webkit-4.5.2-r1  USE="kde -debug -pch"  [0]
[blocks b     ]   >x11-libs/qt-opengl-4.5.2-r9999 (">x11-libs/qt-opengl-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-svg-4.5.2)
[blocks b     ]   >x11-libs/qt-dbus-4.5.2-r9999 (">x11-libs/qt-dbus-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-svg-4.5.2)
[blocks b     ]   >x11-libs/qt-script-4.5.2-r9999 (">x11-libs/qt-script-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-svg-4.5.2)
[ebuild     U ]    x11-libs/qt-xmlpatterns-4.5.3-r1 [4.5.2] USE="-debug -pch" 122,446 kB [0]
[nomerge      ] net-misc/vpnc-0.5.3  USE="-bindist -hybrid-auth -resolvconf"  [0]
[ebuild     U ]  sys-apps/iproute2-2.6.29.1-r1 [2.6.28] USE="berkdb -atm -minimal" 360 kB [0]
[nomerge      ] gnome-base/gdm-2.20.10-r2  USE="branding consolekit gnome-keyring pam tcpd -accessibility -afs -debug -dmx -ipv6 -remote (-selinux) -xinerama"  [0]
[nomerge      ]  x11-libs/gksu-2.0.2  USE="gnome -debug -doc"  [0]
[ebuild     U ]   x11-libs/libgksu-2.0.12 [2.0.9] USE="nls -doc (-debug%)" 467 kB [0]
[nomerge      ] dev-util/subversion-1.6.5  USE="apache2 bash-completion berkdb dso emacs gnome-keyring java nls perl python webdav-neon -ctypes-python -debug -doc -extras -ruby -sasl -test -vim-syntax -webdav-serf"  [0]
[ebuild     U ]  www-servers/apache-2.2.14-r1 [2.2.11-r2] USE="ssl threads -debug -doc -ldap (-selinux) -static -suexec (-sni%)" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias -asis -auth_digest -authn_dbd -cern_meta -charset_lite -dbd -dumpio -ident -imagemap -log_forensic -proxy -proxy_ajp -proxy_balancer -proxy_connect -proxy_ftp -proxy_http -substitute -version" APACHE2_MPMS="-event -itk -peruser -prefork -worker" 5,088 kB [0]
[ebuild     U ] www-client/opera-10.01 [10.00] USE="gnome -ia32 -qt-static -qt3*" LINGUAS="pl -be -bg -cs -da -de -el -en_GB -es_ES -es_LA -et -fi -fr -fr_CA -fy -hi -hr -hu -id -it -ja -ka -ko -lt -mk -nb -nl -nn -pt -pt_BR -ro -ru -sk -sr -sv -ta -te -tr -uk -zh_CN -zh_HK -zh_TW" 9,065 kB [0]
[ebuild  NS   ] app-cdr/k3b-1.68.0_alpha3 [1.0.5-r6] USE="dvd encode flac mad vcd vorbis wav (-aqua) -debug -emovix -ffmpeg -lame -musicbrainz -sndfile -sox -taglib" 3,808 kB [0]
[ebuild     U ] www-client/mozilla-firefox-3.5.4 [3.5.3-r1] USE="alsa dbus gnome java startup-notification -bindist -custom-optimization -iceweasel -mozdevelop -restrict-javascript -sqlite" LINGUAS="en pl -af -ar -as -be -bg -bn -bn_BD -bn_IN -ca -cs -cy -da -de -el -en_GB -en_US -eo -es -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy -fy_NL -ga -ga_IE -gl -gu -gu_IN -he -hi -hi_IN -hr -hu -id -is -it -ja -ka -kk -kn -ko -ku -lt -lv -mk -ml -mn -mr -nb -nb_NO -nl -nn -nn_NO -oc -or -pa -pa_IN -pt -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -sq -sr -sv -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zh_CN -zh_TW" 45,934 kB [0]
[ebuild  NS   ] media-video/kaffeine-1.0_pre2 [0.8.6] USE="(-aqua) -debug" LINGUAS="pl -cs -da -de -el -en_GB -es -et -fi -fr -ga -gl -hu -it -ja -km -ko -ku -lt -mai -nb -nds -nl -nn -pa -pt -pt_BR -ro -ru -se -sk -sv -th -tr -uk -zh_CN -zh_TW" 267 kB [0]
[ebuild     U ] media-sound/sox-14.3.0 [14.2.0] USE="alsa encode flac mad ogg png wavpack -ao -debug -ffmpeg -id3tag -ladspa -oss -pulseaudio% -sndfile (-amrnb%) (-amrwb%) (-libsamplerate%)" 985 kB [0]
[ebuild     U ] dev-java/sun-jdk-1.5.0.22 [1.5.0.20] USE="X alsa -doc -examples -jce (-nsplugin) -odbc" 43,177 kB [0]
[ebuild     U ] app-misc/mc-4.7.0_pre3 [4.7.0_pre1] USE="edit%* gpm nls slang -X -samba (-chdir%)" 2,750 kB [0]
[ebuild     U ] app-emulation/emul-linux-x86-java-1.6.0.17 [1.6.0.15] USE="X alsa nsplugin" 79,907 kB [0]
[ebuild     U ] media-libs/sdl-gfx-2.0.20 [2.0.19] USE="(-mmx)" 2,134 kB [0]
[ebuild     U ] sys-apps/busybox-1.14.2 [1.13.2] USE="pam -debug -make-symlinks -savedconfig (-selinux) -static" 2,149 kB [0]
[ebuild  NS   ] kde-base/kdelibs-3.5.10-r6 [4.3.1-r2] USE="acl alsa avahi branding cups fam spell tiff (-arts) -bindist -debug -doc -jpeg2k -kdehiddenvisibility -kerberos -legacyssl -lua -openexr -utempter" 0 kB [0]
[nomerge      ] media-video/kaffeine-1.0_pre2 [0.8.6] USE="(-aqua) -debug" LINGUAS="pl -cs -da -de -el -en_GB -es -et -fi -fr -ga -gl -hu -it -ja -km -ko -ku -lt -mai -nb -nds -nl -nn -pa -pt -pt_BR -ro -ru -se -sk -sv -th -tr -uk -zh_CN -zh_TW"  [0]
[ebuild  N    ]  kde-base/solid-4.3.1  USE="bluetooth (-aqua) -debug (-kdeprefix) -networkmanager -wicd" 60,827 kB [0]
[nomerge      ] app-cdr/k3b-1.68.0_alpha3 [1.0.5-r6] USE="dvd encode flac mad vcd vorbis wav (-aqua) -debug -emovix -ffmpeg -lame -musicbrainz -sndfile -sox -taglib"  [0]
[ebuild  N    ]  kde-base/libkcddb-4.3.1  USE="(-aqua) -debug (-kdeprefix) -musicbrainz" 0 kB [0]
[nomerge      ] gnome-base/gnome-light-2.26.3  [0]
[nomerge      ]  gnome-extra/yelp-2.26.0  USE="-beagle -debug -lzma"  [0]
[ebuild     U ]   net-libs/xulrunner-1.9.1.4 [1.9.1.3-r1] USE="alsa dbus gnome java python startup-notification -custom-optimization -debug -sqlite" 9 kB [0]
[nomerge      ] x11-libs/qt-opengl-4.5.2-r1  USE="qt3support -debug -pch"  [0]
[blocks b     ]  >x11-libs/qt-xmlpatterns-4.5.2-r9999 (">x11-libs/qt-xmlpatterns-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-svg-4.5.2)
[nomerge      ] x11-libs/qt-svg-4.5.3-r1 [4.5.2] USE="iconv -debug -pch"  [0]
[blocks b     ]  <x11-libs/qt-opengl-4.5.3 ("<x11-libs/qt-opengl-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)
[ebuild     U ]   x11-libs/qt-opengl-4.5.3-r1 [4.5.2-r1] USE="qt3support -debug -pch" 0 kB [0]
[nomerge      ] app-cdr/k3b-1.68.0_alpha3 [1.0.5-r6] USE="dvd encode flac mad vcd vorbis wav (-aqua) -debug -emovix -ffmpeg -lame -musicbrainz -sndfile -sox -taglib"  [0]
[ebuild     U ]  dev-util/cmake-2.6.4-r3 [2.6.4] USE="qt4 -emacs -vim-syntax" 0 kB [0]
[nomerge      ] x11-libs/qt-opengl-4.5.3-r1 [4.5.2-r1] USE="qt3support -debug -pch"  [0]
[blocks b     ]  <x11-libs/qt-svg-4.5.3 ("<x11-libs/qt-svg-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)
[ebuild     U ]   x11-libs/qt-svg-4.5.3-r1 [4.5.2] USE="iconv -debug -pch" 0 kB [0]
[blocks b     ]    <x11-libs/qt-test-4.5.3 ("<x11-libs/qt-test-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)
[ebuild     U ]     x11-libs/qt-test-4.5.3-r1 [4.5.2] USE="iconv -debug -pch" 0 kB [0]
[ebuild     U ] x11-libs/qt-qt3support-4.5.3 [4.5.2] USE="accessibility kde -debug -pch -phonon" 0 kB [0]
[ebuild     U ]  x11-libs/qt-gui-4.5.3-r2 [4.5.2-r2] USE="accessibility cups dbus glib gtk qt3support tiff -debug -mng -nas -nis -pch -raster -xinerama" 0 kB [0]
[ebuild     U ]   x11-libs/qt-dbus-4.5.3-r1 [4.5.2] USE="-debug -pch" 0 kB [0]
[ebuild     U ]  x11-libs/qt-sql-4.5.3 [4.5.2] USE="iconv qt3support sqlite -debug (-firebird) -mysql -odbc -pch -postgres" 0 kB [0]
[nomerge      ] media-video/kaffeine-1.0_pre2 [0.8.6] USE="(-aqua) -debug" LINGUAS="pl -cs -da -de -el -en_GB -es -et -fi -fr -ga -gl -hu -it -ja -km -ko -ku -lt -mai -nb -nds -nl -nn -pa -pt -pt_BR -ro -ru -se -sk -sv -th -tr -uk -zh_CN -zh_TW"  [0]
[ebuild     U ]  x11-libs/qt-script-4.5.3-r1 [4.5.2] USE="iconv -debug -pch" 0 kB [0]
[ebuild     U ]   x11-libs/qt-core-4.5.3-r2 [4.5.2] USE="glib iconv qt3support ssl -debug -doc -pch" 0 kB [0]
[nomerge      ] net-im/pidgin-2.6.3  USE="dbus eds gstreamer gtk ncurses nls perl spell -bonjour -debug -doc -gadu -gnutls -groupwise -idn -meanwhile -networkmanager -prediction -qq -sasl -silc -tcl -tk -zephyr"  [0]
[ebuild     U ]  media-libs/gst-plugins-good-0.10.16 [0.10.14] USE="-debug" 0 kB [0]
[nomerge      ] games-fps/sauerbraten-2008.06.17  [0]
[ebuild     U ]  app-emulation/emul-linux-x86-sdl-20081109 [20080316] 1,345 kB [0]
[ebuild     U ]   app-emulation/emul-linux-x86-soundlibs-20081109 [20080418] USE="alsa -arts -esd" 5,044 kB [0]
[ebuild     U ]    app-emulation/emul-linux-x86-medialibs-20081109 [20071114] 1,860 kB [0]
[ebuild     U ] sys-apps/baselayout-1.12.13 [1.12.11.1] USE="unicode -bootstrap -build -static" 264 kB [0]
[nomerge      ] mail-client/mozilla-thunderbird-2.0.0.23  USE="crypt gnome -bindist -debug -ipv6 -ldap -mozdom -moznopango -replytolist -xinerama" LINGUAS="en pl -af -be -bg -ca -cs -da -de -el -en_GB -en_US -es -es_AR -es_ES -eu -fi -fr -ga -ga_IE -he -hu -it -ja -ko -lt -mk -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pt -pt_BR -pt_PT -ru -sk -sl -sv -sv_SE -tr -uk -zh -zh_CN -zh_TW"  [0]
[nomerge      ]  x11-plugins/enigmail-0.95.7-r5  LINGUAS="pl -ar -ca -cs -de -el -es -es_ES -fi -fr -hu -it -ja -ko -nb -nb_NO -pt -pt_BR -ro -ru -sk -sl -sv -tr -zh -zh_CN"  [0]
[nomerge      ]   app-crypt/gnupg-2.0.11  USE="bzip2 nls -caps -doc -ldap -openct -pcsc-lite (-selinux) -smartcard -static"  [0]
[nomerge      ]    app-crypt/pinentry-0.7.5  USE="gtk ncurses qt3 -caps"  [0]
[ebuild     U ]     x11-libs/qt-3.3.8b-r2 [3.3.8b-r1] USE="cups opengl -debug -doc -examples (-firebird) -immqt -immqt-bc -ipv6 -mysql -nas -nis -odbc -postgres -sqlite -xinerama" 0 kB [0]
[nomerge      ] media-plugins/gst-plugins-pango-0.10.24 [0.10.23] [0]
[ebuild     U ]  media-libs/gst-plugins-base-0.10.24 [0.10.23] USE="nls -debug" 0 kB [0]
[ebuild     U ]   media-libs/gstreamer-0.10.24 [0.10.23] USE="nls -test" 2,913 kB [0]
[nomerge      ] gnome-extra/gnome-screensaver-2.26.1  USE="libnotify opengl pam -debug -doc"  [0]
[ebuild     UD]  dev-libs/dbus-glib-0.76 [0.78] USE="-debug -doc (-selinux) (-bash-completion%*) (-test%)" 0 kB [0]
[ebuild     U ]   dev-libs/glib-2.20.5-r1 [2.20.5] USE="fam -debug -doc -hardened (-selinux) -xattr" 0 kB [0]
[nomerge      ] app-emulation/emul-linux-x86-medialibs-20081109 [20071114] [0]
[ebuild     U ]  app-emulation/emul-linux-x86-xlibs-20081109 [20080810] USE="opengl" 16,499 kB [0]
[nomerge      ] www-servers/apache-2.2.14-r1 [2.2.11-r2] USE="ssl threads -debug -doc -ldap (-selinux) -static -suexec (-sni%)" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias -asis -auth_digest -authn_dbd -cern_meta -charset_lite -dbd -dumpio -ident -imagemap -log_forensic -proxy -proxy_ajp -proxy_balancer -proxy_connect -proxy_ftp -proxy_http -substitute -version" APACHE2_MPMS="-event -itk -peruser -prefork -worker"  [0]
[ebuild     U ]  app-admin/apache-tools-2.2.14 [2.2.11] USE="ssl" 0 kB [0]
[nomerge      ] media-gfx/inkscape-0.46-r5  USE="gnome perl spell -debug -dia -doc -inkjar -jabber -lcms (-mmx) -postscript -wmf"  [0]
[nomerge      ]  dev-python/numpy-1.3.0-r1  USE="-lapack -test"  [0]
[ebuild     U ]   dev-python/setuptools-0.6.4 [0.6-r1] 508 kB [0]
[nomerge      ] media-video/totem-2.26.3-r1  USE="bluetooth nsplugin python -debug -doc -galago -lirc -nautilus (-tracker)"  [0]
[ebuild     U ]  app-text/iso-codes-3.10 [3.8] 5,226 kB [0]
[ebuild     U ] dev-java/sun-jdk-1.6.0.17 [1.6.0.15] USE="X alsa nsplugin -derby -doc -examples -jce -odbc" 79,986 kB [0]
[ebuild     U ] net-libs/gnutls-2.8.4 [2.8.3] USE="cxx nls zlib -bindist -doc -examples -guile -lzo" 6,048 kB [0]
[nomerge      ] dev-util/subversion-1.6.5  USE="apache2 bash-completion berkdb dso emacs gnome-keyring java nls perl python webdav-neon -ctypes-python -debug -doc -extras -ruby -sasl -test -vim-syntax -webdav-serf"  [0]
[ebuild     U ]  net-misc/neon-0.29.0 [0.28.6] USE="nls ssl zlib -doc -expat -gnutls -kerberos -libproxy% -pkcs11 (-socks5%)" LINGUAS="pl -cs -de -fr -ja -nn -ru -tr -zh_CN" 859 kB [0]
[nomerge      ] net-p2p/amule-2.2.5  USE="daemon gtk nls remote unicode -debug -geoip -stats -upnp"  [0]
[ebuild     U ]  media-libs/gd-2.0.35-r1 [2.0.35] USE="jpeg png truetype -fontconfig -xpm" 0 kB [?=>0]
[nomerge      ] www-servers/apache-2.2.14-r1 [2.2.11-r2] USE="ssl threads -debug -doc -ldap (-selinux) -static -suexec (-sni%)" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias -asis -auth_digest -authn_dbd -cern_meta -charset_lite -dbd -dumpio -ident -imagemap -log_forensic -proxy -proxy_ajp -proxy_balancer -proxy_connect -proxy_ftp -proxy_http -substitute -version" APACHE2_MPMS="-event -itk -peruser -prefork -worker"  [0]
[ebuild     U ]  dev-libs/apr-1.3.9 [1.3.8] USE="urandom -debug -doc -older-kernels-compatibility%" 906 kB [0]
[nomerge      ] net-wireless/aircrack-ng-1.0  USE="sqlite"  [0]
[ebuild     U ]  net-wireless/iw-0.9.16 [0.9.11] 38 kB [0]
[nomerge      ] app-emulation/emul-linux-x86-java-1.6.0.17 [1.6.0.15] USE="X alsa nsplugin"  [0]
[ebuild     U ]  app-emulation/emul-linux-x86-compat-20081109 [20071125-r1] 948 kB [0]
[nomerge      ] app-emulation/emul-linux-x86-medialibs-20081109 [20071114] [0]
[ebuild     U ]  app-emulation/emul-linux-x86-baselibs-20081109 [20080316] 21,875 kB [0]
[nomerge      ] sys-libs/glibc-2.9_p20081201-r2  USE="(multilib) nls -debug -gd -glibc-omitfp (-hardened) -profile (-selinux) -vanilla"  [0]
[ebuild     U ]  sys-libs/timezone-data-2009p [2009m] USE="nls" 179 kB [0]
[nomerge      ] kde-base/kdelibs-3.5.10-r6 [4.3.1-r2] USE="acl alsa avahi branding cups fam spell tiff (-arts) -bindist -debug -doc -jpeg2k -kdehiddenvisibility -kerberos -legacyssl -lua -openexr -utempter"  [0]
[nomerge      ]  kde-misc/kdnssd-avahi-0.1.2-r1  USE="(-arts) -debug -xinerama"  [0]
[nomerge      ]   net-dns/avahi-0.6.24-r2  USE="dbus gdbm gtk python qt3 qt4 -autoipd -bookmarks -doc -howl-compat -ipv6 -mdnsresponder-compat -mono -test"  [0]
[ebuild     U ]    dev-libs/libdaemon-0.13-r1 [0.12] USE="-doc -examples" 360 kB [0]
[nomerge      ] sys-devel/autoconf-2.13  [?]
[ebuild     U ]  sys-devel/autoconf-wrapper-7 [6] 0 kB [0]
[nomerge      ] gnome-base/gnome-light-2.26.3  [0]
[nomerge      ]  gnome-base/gnome-control-center-2.26.0  USE="eds hal -debug -policykit"  [0]
[nomerge      ]   gnome-extra/evolution-data-server-2.26.3  USE="gnome-keyring ssl -debug -doc -ipv6 -kerberos -krb4 -ldap"  [0]
[ebuild     U ]    dev-db/sqlite-3.6.18 [3.6.17] USE="readline threadsafe -debug -doc -icu% -soundex -tcl" 2,880 kB [0]
[nomerge      ] media-gfx/gthumb-2.10.11  USE="gphoto2 tiff -debug -iptc -raw -test"  [0]
[ebuild     U ]  media-libs/tiff-3.9.2 [3.8.2-r8] USE="cxx%* jpeg zlib -jbig (-nocxx%)" 1,387 kB [0]
[blocks B     ]   >x11-libs/qt-svg-4.5.2-r9999 (">x11-libs/qt-svg-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2)
[blocks B     ]   <media-libs/gst-plugins-bad-0.10.14 ("<media-libs/gst-plugins-bad-0.10.14" is blocking media-libs/gst-plugins-good-0.10.16)
[blocks B     ] <x11-libs/qt-gui-4.5.3 ("<x11-libs/qt-gui-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)
[blocks B     ] >x11-libs/qt-xmlpatterns-4.5.2-r9999 (">x11-libs/qt-xmlpatterns-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-svg-4.5.2)
[blocks B     ] <x11-libs/qt-dbus-4.5.3 ("<x11-libs/qt-dbus-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)
[blocks B     ] >x11-libs/qt-sql-4.5.2-r9999 (">x11-libs/qt-sql-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-svg-4.5.2)
[blocks B     ] >x11-libs/qt-svg-4.5.2-r9999 (">x11-libs/qt-svg-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2)
[blocks B     ] >x11-libs/qt-script-4.5.2-r9999 (">x11-libs/qt-script-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-svg-4.5.2)
[blocks B     ] >x11-libs/qt-gui-4.5.2-r9999 (">x11-libs/qt-gui-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-svg-4.5.2)
[blocks B     ] <x11-libs/qt-script-4.5.3 ("<x11-libs/qt-script-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-sql-4.5.3)
[blocks B     ] <x11-libs/qt-core-4.5.3 ("<x11-libs/qt-core-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)
[blocks B     ] >x11-libs/qt-test-4.5.2-r9999 (">x11-libs/qt-test-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-svg-4.5.2)
[blocks B     ] >x11-libs/qt-opengl-4.5.2-r9999 (">x11-libs/qt-opengl-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-svg-4.5.2)
[blocks B     ] <x11-libs/qt-qt3support-4.5.3 ("<x11-libs/qt-qt3support-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)
[blocks B     ] >x11-libs/qt-core-4.5.2-r9999 (">x11-libs/qt-core-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-svg-4.5.2)
[blocks B     ] <x11-libs/qt-webkit-4.5.3 ("<x11-libs/qt-webkit-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-sql-4.5.3)
[blocks B     ] <x11-libs/qt-sql-4.5.3 ("<x11-libs/qt-sql-4.5.3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-xmlpatterns-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1)
[blocks B     ] >x11-libs/qt-dbus-4.5.2-r9999 (">x11-libs/qt-dbus-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-svg-4.5.2)
[blocks B     ] >x11-libs/qt-qt3support-4.5.2-r9999 (">x11-libs/qt-qt3support-4.5.2-r9999" is blocking x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-opengl-4.5.2-r1, x11-libs/qt-xmlpatterns-4.5.2, x11-libs/qt-svg-4.5.2)

Total: 76 packages (70 upgrades, 1 downgrade, 2 new, 3 in new slots, 2 uninstalls), Size of downloads: 542,358 kB
Conflict: 32 blocks (17 unsatisfied)
Portage tree and overlays:
 [0] /usr/portage
 [?] indicates that the source repository could not be determined

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'x11-libs/qt-opengl-4.5.3-r1', 'merge') pulled in by
    x11-libs/qt-opengl required by world
    x11-libs/qt-opengl:4 required by ('installed', '/', 'x11-libs/qtscriptgenerator-0.1.0', 'nomerge')
    >=x11-libs/qt-opengl-4.5.1:4 required by ('installed', '/', 'kde-base/kdelibs-4.3.1-r2', 'nomerge')
    (and 3 more)

  ('installed', '/', 'x11-libs/qt-webkit-4.5.2-r1', 'nomerge') pulled in by
    >=x11-libs/qt-webkit-4.5.1:4[kde] required by ('installed', '/', 'kde-base/kdelibs-4.3.1-r2', 'nomerge')
    >=x11-libs/qt-webkit-4.5.1:4[kde] required by ('ebuild', '/', 'app-cdr/k3b-1.68.0_alpha3', 'merge')
    x11-libs/qt-webkit:4 required by ('installed', '/', 'x11-libs/qtscriptgenerator-0.1.0', 'nomerge')

  ('ebuild', '/', 'x11-libs/qt-svg-4.5.3-r1', 'merge') pulled in by
    >=x11-libs/qt-svg-4.5.1:4 required by ('installed', '/', 'kde-base/ktimezoned-4.3.1', 'nomerge')
    x11-libs/qt-svg required by world
    x11-libs/qt-svg:4 required by ('installed', '/', 'x11-libs/qtscriptgenerator-0.1.0', 'nomerge')
    (and 13 more)

  ('ebuild', '/', 'x11-libs/qt-dbus-4.5.3-r1', 'merge') pulled in by
    x11-libs/qt-dbus:4 required by ('installed', '/', 'app-misc/strigi-0.7.0', 'nomerge')
    >=x11-libs/qt-dbus-4.4.0:4 required by ('installed', '/', 'media-sound/phonon-4.4_pre20090520', 'nomerge')
    >=x11-libs/qt-dbus-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')
    (and 5 more)

  ('ebuild', '/', 'x11-libs/qt-gui-4.5.3-r2', 'merge') pulled in by
    >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('ebuild', '/', 'kde-base/solid-4.3.1', 'merge')
    x11-libs/qt-gui required by ('ebuild', '/', 'www-client/opera-10.01', 'merge')
    >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('installed', '/', 'kde-base/ktimezoned-4.3.1', 'nomerge')
    (and 27 more)

  ('installed', '/', 'x11-libs/qt-qt3support-4.5.2', 'nomerge') pulled in by
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'kde-base/ktimezoned-4.3.1', 'nomerge')
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'kde-base/nepomuk-4.3.1', 'nomerge')
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('ebuild', '/', 'media-video/kaffeine-1.0_pre2', 'merge')
    (and 11 more)

  ('installed', '/', 'x11-libs/qt-script-4.5.2', 'nomerge') pulled in by
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/phonon-kde-4.3.1', 'nomerge')
    x11-libs/qt-script:4 required by ('installed', '/', 'x11-libs/qtscriptgenerator-0.1.0', 'nomerge')
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/kde-env-4.3.1', 'nomerge')
    (and 12 more)

  ('installed', '/', 'x11-libs/qt-core-4.5.2', 'nomerge') pulled in by
    x11-libs/qt-core required by world
    >=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('installed', '/', 'kde-base/libknotificationitem-4.3.1', 'nomerge')
    x11-libs/qt-core required by ('installed', '/', 'app-crypt/qca-gnupg-2.0.0_beta3', 'nomerge')
    (and 27 more)

  ('ebuild', '/', 'x11-libs/qt-qt3support-4.5.3', 'merge') pulled in by
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'media-sound/amarok-2.2.0', 'nomerge')
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('installed', '/', 'kde-base/nepomuk-4.3.1', 'nomerge')
    >=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('ebuild', '/', 'media-video/kaffeine-1.0_pre2', 'merge')
    (and 11 more)

  ('installed', '/', 'x11-libs/qt-gui-4.5.2-r2', 'nomerge') pulled in by
    >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('installed', '/', 'kde-base/kdebase-data-4.3.1', 'nomerge')
    x11-libs/qt-gui required by ('ebuild', '/', 'www-client/opera-10.01', 'merge')
    >=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('installed', '/', 'kde-base/ktimezoned-4.3.1', 'nomerge')
    (and 26 more)

  ('ebuild', '/', 'x11-libs/qt-test-4.5.3-r1', 'merge') pulled in by
    >=x11-libs/qt-test-4.5.1:4 required by ('installed', '/', 'kde-base/kdelibs-4.3.1-r2', 'nomerge')
    >=x11-libs/qt-test-4.5.1:4 required by ('installed', '/', 'kde-base/kde-env-4.3.1', 'nomerge')
    >=x11-libs/qt-test-4.4.0:4 required by ('installed', '/', 'media-sound/phonon-4.4_pre20090520', 'nomerge')
    (and 11 more)

  ('ebuild', '/', 'x11-libs/qt-xmlpatterns-4.5.3-r1', 'merge') pulled in by
    x11-libs/qt-xmlpatterns:4 required by ('installed', '/', 'x11-libs/qtscriptgenerator-0.1.0', 'nomerge')

  ('installed', '/', 'x11-libs/qt-sql-4.5.2', 'nomerge') pulled in by
    x11-libs/qt-sql required by world
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/libknotificationitem-4.3.1', 'nomerge')
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/kdelibs-4.3.1-r2', 'nomerge')
    (and 13 more)

  ('ebuild', '/', 'x11-libs/qt-script-4.5.3-r1', 'merge') pulled in by
    >=x11-libs/qt-script-4.5.1:4 required by ('ebuild', '/', 'kde-base/libkcddb-4.3.1', 'merge')
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/phonon-kde-4.3.1', 'nomerge')
    >=x11-libs/qt-script-4.5.1:4 required by ('installed', '/', 'kde-base/ktimezoned-4.3.1', 'nomerge')
    (and 12 more)

  ('ebuild', '/', 'x11-libs/qt-core-4.5.3-r2', 'merge') pulled in by
    x11-libs/qt-core required by world
    >=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('installed', '/', 'kde-base/libknotificationitem-4.3.1', 'nomerge')
    x11-libs/qt-core required by ('installed', '/', 'app-crypt/qca-gnupg-2.0.0_beta3', 'nomerge')
    (and 29 more)

  ('ebuild', '/', 'x11-libs/qt-sql-4.5.3', 'merge') pulled in by
    x11-libs/qt-sql required by world
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/libknotificationitem-4.3.1', 'nomerge')
    >=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('installed', '/', 'kde-base/ktimezoned-4.3.1', 'nomerge')
    (and 13 more)

  ('installed', '/', 'x11-libs/qt-dbus-4.5.2', 'nomerge') pulled in by
    >=x11-libs/qt-dbus-4.4.0:4 required by ('installed', '/', 'media-sound/phonon-4.4_pre20090520', 'nomerge')
    x11-libs/qt-dbus:4 required by ('installed', '/', 'dev-libs/soprano-2.3.1', 'nomerge')
    >=x11-libs/qt-dbus-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')
    (and 5 more)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


emerge --info
Code:
Portage 2.1.6.13 (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-r5-x86_64-AMD_Turion-tm-_64_X2_Mobile_Technology_TL-56-with-gentoo-1.12.11.1
Timestamp of tree: Sun, 15 Nov 2009 09:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.9-r1
dev-lang/python:     2.6.2-r1
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache collision-protect distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.uni-c.dk/pub/gentoo/ ftp://ftp.klid.dk/gentoo/ http://src.gentoo.pl ftp://gentoo.po.opole.pl"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="en pl"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa amd64 apache2 avahi bash-completion berkdb bluetooth branding bzip2 cairo cddb cdr cli consolekit cracklib crypt cups dbus djvu dri dts dvd dvdr eds emacs emboss encode evo exif fam fbcon firefox flac fortran gcj gdbm gif gnome gnome-keyring gpm gstreamer gtk hal iconv ieee1394 jack jack-tmpfs java jpeg latex leim libnotify lm_sensors mad madwifi midi mikmod mmx modules mp3 mp4 mpeg mudflap multilib musepack ncurses nls nptl nptlonly nsplugin nvidia ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl startup-notification svg symlink sysfs tcpd threads thunar tiff truetype unicode urandom usb userlocales v4l v4l2 vorbis wavpack wifi x264 xml xorg xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="hda-intel usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="keyboard ps2mouse mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en pl" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
flinkdeldinky
n00b
n00b


Joined: 06 Jun 2003
Posts: 18

PostPosted: Wed Nov 18, 2009 11:41 am    Post subject: QT Blockers - My fix Reply with quote

I was having the massive Blocks related to the recet upgrade to QT 4.5.3 from 4.5.2. My fix (which I'm pretty sure is wrong) was to unmask x11-libs/qt-4.5.3 (which I did via porthole). I believe this is a meta package and the devs have it masked because it pulls in all of qt and I guess that's not supposed to be necessary as the various ebuilds that depend on qt are supposed to be smart enough to grab only the parts of qt they need.

I'm not sure how I wound up on this path and if there's a way to fix it so that I don't have to unmask this meta build with each upgrade please tell me how to do it.
Back to top
View user's profile Send private message
StringCheesian
l33t
l33t


Joined: 21 Oct 2003
Posts: 887

PostPosted: Wed Nov 18, 2009 11:56 am    Post subject: Reply with quote

qt-assistant-4.6.9999 needs the same fix 4.6.0_beta1 got in gentoo bug #289811: "qt-assistant-4.6.0_beta1 fails". 4.6.9999 is failing to build in exactly the same way described in the bug.
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4398
Location: Suzhou, China

PostPosted: Wed Nov 18, 2009 8:42 pm    Post subject: Reply with quote

Sade: 2 posts above yours.

Caleb9: enable accessibility useflag.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
whams
n00b
n00b


Joined: 11 Aug 2006
Posts: 9
Location: amsterdam, netherlands

PostPosted: Wed Nov 25, 2009 1:44 pm    Post subject: What are the plans for x11-lib/qt-3.x in portage? Reply with quote

A few weeks ago i cleaned out any older Qt remnants from my system in order as to get it purely onto Qt-4.5.3.
In the process of course i had to remove several apps which are still depending on x11-libs/qt-3.3.x.
I understand that Qt-3 will eventually be removed from portage: could someone from the Qt herd please comment on the plans and time-line regarding Qt-3 support ?

The point is that i would like to reinstall some of the apps i've had to remove, but if x11-libs/qt-3 will shortly be cleaned out of portage alltogether, it's not worth the bother.
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4398
Location: Suzhou, China

PostPosted: Thu Nov 26, 2009 9:14 pm    Post subject: Reply with quote

As Qt team lead, I can tell you we plan to remove Qt3 within the next three months. What packages do you want that have no adequate Qt4 port or equivalent yet?
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
whams
n00b
n00b


Joined: 11 Aug 2006
Posts: 9
Location: amsterdam, netherlands

PostPosted: Thu Nov 26, 2009 10:18 pm    Post subject: Reply with quote

yngwin wrote:
As Qt team lead, I can tell you we plan to remove Qt3 within the next three months. What packages do you want that have no adequate Qt4 port or equivalent yet?


Luma (LDAP manager) and SqliteBrowser are the two packages I would really like to have back, Qucs (Electronic Circuit Sim) would be nice. These three report straight dependencies on x11-libs/qt-3.

One package that I couldn't rebuild but I'm not certain of is linked to Qt3 is Rkward (Statistics GUI), which fails to rebuild since cleaning out old Qt libs:

CMake Error at /usr/share/apps/cmake/modules/FindKDE4Internal.cmake:1098 (message):
Qt compiled without support for -fvisibility=hidden. This will break
plugins and linking of some applications. Please fix your Qt installation.
Call Stack (most recent call first):
/usr/share/cmake/Modules/FindKDE4.cmake:81 (FIND_PACKAGE)
CMakeLists.txt:10 (FIND_PACKAGE)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next
Page 6 of 8

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum