Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ALSA & 2.6 kernel mini HOW-TO?
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Helena
Veteran
Veteran


Joined: 02 Apr 2003
Posts: 1027
Location: De Meern, The Netherlands

PostPosted: Thu Oct 16, 2003 8:38 pm    Post subject: ALSA & 2.6 kernel mini HOW-TO? Reply with quote

I had some trouble enabling ALSA on my 2.6 kernel. I was able to get it working when i applied the following changes to the standard ALSA-guide (http://www.gentoo.org/doc/en/alsa-guide.xml):

In 2.6 ALSA support is built into the kernel, so you have to enable it there (do NOT build it as a module). Also make sure that all relevant options are set:
Code:
cd /usr/src/linux-beta
make menuconfig

Choose the Sound option, and answer Y to:
    <*> Sound card support
and, under Advanced Linux Sound Architecture --->
    <*> Advanced Linux Sound Architecture
    <*> Sequencer support
    <*> OSS API emulation
    <*> OSS Mixer API
    <*> OSS PCM (digital audio) API
    <*> OSS Sequencer API
and enable your soundcard under the correct subheading (mine is under "PCI devices"). Make sure you disable
    < > Open Sound System (DEPRECATED)
Now rebuild your kernel with
Code:
make clean bzImage modules modules_install
mount /boot
cp arch/i386/boot/bzImage /boot

and reboot. So you no longer have to emerge any ALSA drivers. But you still have to emerge the utilities with
Code:
emerge alsa-utils

Clearly there is no need anymore to add alsasound to the boot runlevel since it's built into the kernel already, so skip that and proceed to unmuting the sound channels as described in the guide:
Code:
amixer set Master 100 unmute
amixer set PCM 100 unmute

Now sound should be working when you start KDE!

/EDIT Note: I just found out that unmuting is not preserved across reboots!
Back to top
View user's profile Send private message
agent_jdh
Veteran
Veteran


Joined: 08 Aug 2002
Posts: 1776
Location: Scotland

PostPosted: Fri Oct 17, 2003 10:47 am    Post subject: Reply with quote

Well, the real way to get ALSA to work with 2.6 kernels is -

1. Configure the kernel with the ALSA stuff as _modules_
Code:
make && make modules_install
then copy the /usr/src/arch/i386/boot/bzImage to /boot

2.
Code:
emerge alsa-lib alsa-utils


3. edit /etc/modules.d/alsa for your card (see the Gentoo ALSA guide and also the individual card pages on the ALSA website for how to do this)

4.
Code:
update-modules


5.
Code:
rc-update add alsasound boot


6.
Code:
alsamixer
- unmute what you need and set your levels

7.
Code:
alsactl store


8. Instead of rebooting, you can
Code:
/etc/init.d/alsasound start


Now this method means that the alsasound script takes care of loading the modules at boot, and restores your mixer settings, and also stores them when you shut down.
_________________
Jingle Jangle Jewellery
Back to top
View user's profile Send private message
Viha
Tux's lil' helper
Tux's lil' helper


Joined: 04 Oct 2003
Posts: 121
Location: Jon's World

PostPosted: Fri Oct 17, 2003 10:52 am    Post subject: Reply with quote

They don't have to be modules.
Back to top
View user's profile Send private message
agent_jdh
Veteran
Veteran


Joined: 08 Aug 2002
Posts: 1776
Location: Scotland

PostPosted: Fri Oct 17, 2003 11:04 am    Post subject: Reply with quote

Viha wrote:
They don't have to be modules.


But the alsasound init script looks for them as modules. And it keeps your bzImage file smaller, which is useful for some.
_________________
Jingle Jangle Jewellery
Back to top
View user's profile Send private message
pi-cubic
Tux's lil' helper
Tux's lil' helper


Joined: 25 May 2003
Posts: 143

PostPosted: Fri Oct 17, 2003 1:38 pm    Post subject: Reply with quote

when i compiled the alsa stuff in the kernel, i had all the important devices like /dev/dsp. when i compiled alsa as modules, only the mixer device was there!

i also recommend the built-in way!
Back to top
View user's profile Send private message
agent_jdh
Veteran
Veteran


Joined: 08 Aug 2002
Posts: 1776
Location: Scotland

PostPosted: Fri Oct 17, 2003 1:53 pm    Post subject: Reply with quote

pi-cubiq wrote:
when i compiled the alsa stuff in the kernel, i had all the important devices like /dev/dsp. when i compiled alsa as modules, only the mixer device was there!

i also recommend the built-in way!


No problems of that sort here. Do you have your /etc/modules.d/alsa set up correctly w.r.t. the oss portion? And do an update-modules before re-booting?
_________________
Jingle Jangle Jewellery
Back to top
View user's profile Send private message
Helena
Veteran
Veteran


Joined: 02 Apr 2003
Posts: 1027
Location: De Meern, The Netherlands

PostPosted: Fri Oct 17, 2003 2:53 pm    Post subject: Reply with quote

agent_jdh wrote:
pi-cubiq wrote:
when i compiled the alsa stuff in the kernel, i had all the important devices like /dev/dsp. when i compiled alsa as modules, only the mixer device was there!

i also recommend the built-in way!


No problems of that sort here. Do you have your /etc/modules.d/alsa set up correctly w.r.t. the oss portion? And do an update-modules before re-booting?

OK I'm glad my little contribution stimulated some discussion. First of all, I am not a Linux expert. So I apologize for any oversights or incompleteness. In fact I was seeking help a week ago, but since that post got no reply I decided to go another and perhaps better way.

So agent-jdh, thank you for providing an alternative way. I immediately tried to follow your suggestions, however I am unable to reproduce them completely. Your first step was:
Quote:
Configure the kernel with the ALSA stuff as modules
I interpreted that as answering "M" instead of "Y" to all options that were mentioned in my post. This is however not possible for OSS API simulation and OSS Sequencer API, so it should look like
Code:
<M> Advanced Linux Sound Architecture
<M> Sequencer support
< >  Sequencer dummy client
<*> OSS API emulation
<M> OSS Mixer API
<M> OSS PCM (digital audio) API
<*> OSS Sequencer API
[ ]   Verbose printk
[ ]   Debug
       Generic devices  --->
       PCI devices  --->
       ALSA USB devices  --->

However, after recompiling and the kernel and re-merging alsa-lib & alsa-utils, I still noticed that /etc/modules.d/alsa is missing, as it was before. Maybe I should create my own, or even edit /etc/modules.conf directly? The latter is suggested by the ALSA 2.6 documentation (/usr/src/linux-2.6.0-test6/Documentation/sound/alsa/ALSA-Configuration.txt), but strongly discouraged by comments in the file itself!

Further, alsasound was nowhere to be found, and I don't want of course to emerge alsa-driver. So what did I miss?

Finally, the problem that I have with my own setup is that I can't enable the mixer PCM control, and also that settings are not persistent across reboots. I admit that I have not enough knowledge to know why, but I may accidentally discover a solution, somehow. However, expert advice is more than welcome!
Back to top
View user's profile Send private message
agent_jdh
Veteran
Veteran


Joined: 08 Aug 2002
Posts: 1776
Location: Scotland

PostPosted: Fri Oct 17, 2003 4:48 pm    Post subject: Reply with quote

Helena wrote:
agent_jdh wrote:
pi-cubiq wrote:
when i compiled the alsa stuff in the kernel, i had all the important devices like /dev/dsp. when i compiled alsa as modules, only the mixer device was there!

i also recommend the built-in way!


No problems of that sort here. Do you have your /etc/modules.d/alsa set up correctly w.r.t. the oss portion? And do an update-modules before re-booting?

OK I'm glad my little contribution stimulated some discussion. First of all, I am not a Linux expert. So I apologize for any oversights or incompleteness. In fact I was seeking help a week ago, but since that post got no reply I decided to go another and perhaps better way.

So agent-jdh, thank you for providing an alternative way. I immediately tried to follow your suggestions, however I am unable to reproduce them completely. Your first step was:
Quote:
Configure the kernel with the ALSA stuff as modules
I interpreted that as answering "M" instead of "Y" to all options that were mentioned in my post. This is however not possible for OSS API simulation and OSS Sequencer API, so it should look like
Code:
<M> Advanced Linux Sound Architecture
<M> Sequencer support
< >  Sequencer dummy client
<*> OSS API emulation
<M> OSS Mixer API
<M> OSS PCM (digital audio) API
<*> OSS Sequencer API
[ ]   Verbose printk
[ ]   Debug
       Generic devices  --->
       PCI devices  --->
       ALSA USB devices  --->

However, after recompiling and the kernel and re-merging alsa-lib & alsa-utils, I still noticed that /etc/modules.d/alsa is missing, as it was before. Maybe I should create my own, or even edit /etc/modules.conf directly? The latter is suggested by the ALSA 2.6 documentation (/usr/src/linux-2.6.0-test6/Documentation/sound/alsa/ALSA-Configuration.txt), but strongly discouraged by comments in the file itself!

Further, alsasound was nowhere to be found, and I don't want of course to emerge alsa-driver. So what did I miss?

Finally, the problem that I have with my own setup is that I can't enable the mixer PCM control, and also that settings are not persistent across reboots. I admit that I have not enough knowledge to know why, but I may accidentally discover a solution, somehow. However, expert advice is more than welcome!


Yes, you should be using 'M' dor _all_ the Alsa options when configuring your kernel. I notice you've still got some as <*> , they should al lbe <M>.

You should create your own /etc/modules.d/alsa then run update-modules. What update-modules does, incidentally, is to build your /etc/modules.conf for you by using the files stored in the /etc/modules.d folder. This means you don't have to edit /etc/modules.conf by hand.

The alsasound script should be installed with the latest alsa-utils (0.97). You might need to use the ACCEPT_KEYWORDS="~x86" (can't remember if you need the quotes, I have this option enabled in /etc/make.conf globally) to get the latest ebuild. You'll notice that when you emerge the latest alsa-utils, it pauses before copying the files across with a message about alsasound, and how it is now included with alsa-utils instead of alsa-driver for use with 2.6 kernels that don't work with alsa-driver.

However, at least one other user in a different alsa/2.6 kernel discussion thread said the /etc/init.d/alsasound file was never created (although he never told me what version of alsa-utils he was emerging), but the actual file is in the 'files' folder under the location of the alsa-utils ebuilds (I'm not at my Gentoo box at the moment, it's something like /usr/portage/media-sound/alsa-utils/files), so you can copy it over manually to /etc/init.d (as he did), and then do 'rc-update add alsasound boot'. To test alsasound is installed, run '/etc/init.d/alsasound start'.

As for OSS emulation, this depends on the contents of the /etc/modules.d/alsa file (remember, if you ever edit this file, you'll need to run update-modules and reboot for changes to take effect). Now I've just had a look at the Gentoo ALSA guide, and the information there is a bit thin. IIRC, I used a combination of the Gentoo ALSA guide and the information on the ALSA Project homepage for card-specific instructions. I can post my /etc/modules.d/alsa file later on from my Gentoo box if that would help you.

So after you've got all this set up, you can set the mixer settings using alsamixer, and once you have them to your satisfaction, running 'alsactl store' will save the settings to a file that the alsasound boot initialisation script will look for when you next boot, which should solve your problem with the mixer settings vanishing at boot. It also saves your current settings to the mixer file when you shut down.
_________________
Jingle Jangle Jewellery
Back to top
View user's profile Send private message
Helena
Veteran
Veteran


Joined: 02 Apr 2003
Posts: 1027
Location: De Meern, The Netherlands

PostPosted: Fri Oct 17, 2003 5:35 pm    Post subject: Reply with quote

OK thanks once more :o . I'll give it a try later. My first reaction, however, is that it all seems a bit complicated :? since ALSA was included in the kernel, as well as the drivers. Also, manually creating such an important and complicated file like /etc/modules.d/alsa should never be necessary in my opinion, and at least be decently described in the documentation :cry: .

Kernel size to me is BTW not an issue since I never boot from floppies.
Back to top
View user's profile Send private message
agent_jdh
Veteran
Veteran


Joined: 08 Aug 2002
Posts: 1776
Location: Scotland

PostPosted: Fri Oct 17, 2003 5:39 pm    Post subject: Reply with quote

Helena wrote:
OK thanks once more :o . I'll give it a try later. My first reaction, however, is that it all seems a bit complicated :? since ALSA was included in the kernel, as well as the drivers. Also, manually creating such an important and complicated file like /etc/modules.d/alsa should never be necessary in my opinion, and at least be decently described in the documentation :cry: .

Kernel size to me is BTW not an issue since I never boot from floppies.


The whole Alsa thing is a bit of a pain actually. You've got to remember though, that 2.6 kernels are still beta, so you can't expect distros, even Gentoo, from playing 100% with them as easily as they would with a 2.4 kernel. Basically, if you're competent enough to feel safe using an unstable kernel, you should be capable of copying and editing a few files.

Now I've never had to copy across the alsasound file anyway, the alsa-utils ebuild installs it just fine here. Once you get your head around exactly how Alsa works, what the alsasound script does, and how it all interacts with your system/kernel, it all becomes clear.
_________________
Jingle Jangle Jewellery
Back to top
View user's profile Send private message
Helena
Veteran
Veteran


Joined: 02 Apr 2003
Posts: 1027
Location: De Meern, The Netherlands

PostPosted: Sat Oct 18, 2003 7:35 am    Post subject: Reply with quote

OK please post your /etc/modules.d/alsa file as I may learn from that. However, I should note that 2.6.0-test6 is not "unstable", just development. So far I haven't used ACCEPT_KEYWORDS="~x86"!
Back to top
View user's profile Send private message
agent_jdh
Veteran
Veteran


Joined: 08 Aug 2002
Posts: 1776
Location: Scotland

PostPosted: Sat Oct 18, 2003 8:10 am    Post subject: Reply with quote

Helena wrote:
OK please post your /etc/modules.d/alsa file as I may learn from that. However, I should note that 2.6.0-test6 is not "unstable", just development. So far I haven't used ACCEPT_KEYWORDS="~x86"!


I didn't say it was unstable (although "doesn't boot on my system without kernel boot options I've _never_ had to use before, due to recent major APIC/ACPI surgery, could be interpreted as unstable by some), just a constantly moving target at the moment - which might mean it takes a while for other apps/distros to catch up with the changes. Just don't expect it to integrate as seamlessly as a 2.4 kernel quite yet.

Question - without the ~x86 keyword, what is the version of alsa-utils that is being installed?

Here's a copy of my /etc/modules.d/alsa. The only things you should need to change are the 'alias snd-card-0 snd-cs46xx' line for your card, and remove the last line as it is cs46xx-specific.

Quote:
# Alsa 0.9.X kernel modules' configuration file.
# $Header: /home/cvsroot/gentoo-x86/media-sound/alsa-driver/files/alsa-modules.conf-rc,v 1.1 2002/12/21 06:31:52 agenkin Exp $

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
## ALSA portion
alias snd-card-0 snd-cs46xx
## alias snd-card-1 snd-ens1371
## OSS/Free portion
alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
## OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=1
options snd-cs46xx mmap_valid=1

_________________
Jingle Jangle Jewellery
Back to top
View user's profile Send private message
pi-cubic
Tux's lil' helper
Tux's lil' helper


Joined: 25 May 2003
Posts: 143

PostPosted: Sat Oct 18, 2003 2:44 pm    Post subject: Reply with quote

Helena wrote:
OK please post your /etc/modules.d/alsa file as I may learn from that. However, I should note that 2.6.0-test6 is not "unstable", just development. So far I haven't used ACCEPT_KEYWORDS="~x86"!


actually, you just have to emerge the alsa-utils with # ACCEPT_KEYWORDS="~x86" emerge alsa-utils and youre fine cause /etc/modules.d/alsa will be created automaticly. i had the same problem that i couldn't find the alsa file, but the new ebuild provides this file! then adjust your personal settings...
Back to top
View user's profile Send private message
agent_jdh
Veteran
Veteran


Joined: 08 Aug 2002
Posts: 1776
Location: Scotland

PostPosted: Sat Oct 18, 2003 5:05 pm    Post subject: Reply with quote

pi-cubiq wrote:
Helena wrote:
OK please post your /etc/modules.d/alsa file as I may learn from that. However, I should note that 2.6.0-test6 is not "unstable", just development. So far I haven't used ACCEPT_KEYWORDS="~x86"!


actually, you just have to emerge the alsa-utils with # ACCEPT_KEYWORDS="~x86" emerge alsa-utils and youre fine cause /etc/modules.d/alsa will be created automaticly. i had the same problem that i couldn't find the alsa file, but the new ebuild provides this file! then adjust your personal settings...


As well as providing the /etc/init.d/alsasound file. So it seems for best compatability with 2.6 kernels, you should be using the alsa-utils-0.9.7.ebuild.
_________________
Jingle Jangle Jewellery
Back to top
View user's profile Send private message
Helena
Veteran
Veteran


Joined: 02 Apr 2003
Posts: 1027
Location: De Meern, The Netherlands

PostPosted: Sat Oct 18, 2003 5:15 pm    Post subject: Reply with quote

The following versions are available:
Code:
Ajax root # emerge -p alsa-utils alsa-lib

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] media-sound/alsa-utils-0.9.2
[ebuild   R   ] media-libs/alsa-lib-0.9.2

Ajax root # ACCEPT_KEYWORDS="~x86" emerge -p alsa-utils alsa-lib

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild     U ] media-libs/alsa-lib-0.9.7 [0.9.2]
[ebuild     U ] media-sound/alsa-utils-0.9.7 [0.9.2]

I'll follow your new suggestions and will let you know.
Back to top
View user's profile Send private message
Helena
Veteran
Veteran


Joined: 02 Apr 2003
Posts: 1027
Location: De Meern, The Netherlands

PostPosted: Sat Oct 18, 2003 7:20 pm    Post subject: Reply with quote

OK I now have sound in KDE again. But I also have strange start-up messages:
Code:
Loading ALSA drivers ...
Loading: snd-seq-oss
Loading: snd-mixer-oss
Loading: snd-pcm-oss
Loading: snd_intel8x0
FATAL: Modules snd_intel8x0 already in kernel.
Loading: snd_cmipci
Loading: snd-seq-oss
FATAL: Modules snd_seq_oss already in kernel.
Running card-dependent scripts
Restoring mixer levels

and boot continues normally. BTW I have also compiled CMI's sound driver (cmipci) but will remove that next time.

I would guess that these stem from the etc/modules.d/alsa file that was included with
Code:
modules-update
The listing follows:
Code:
# Alsa 0.9.X kernel modules' configuration file.
# $Header: /home/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsa-modules.conf-rc,v 1.1 2003/08/05 21:07:55 johnm Exp $

# ALSA portion

alias char-major-116 snd

# OSS/Free portion

alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion

alias snd-card-0 snd-intel8x0

## alias snd-card-1 snd-ens1371
##  OSS/Free portion

alias sound-slot-0 snd-card-0

## alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1

alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.

options snd cards_limit=1

Indeed, there are 2 "alias" references to "snd-seq-oss" so that would imply twice "insmod"/"modprobe" and hence explain the error message?!

Also, I have now even set Sound Core support to "M" in the kernel.
Back to top
View user's profile Send private message
xlyz
Veteran
Veteran


Joined: 27 Oct 2002
Posts: 1470
Location: Italy

PostPosted: Sat Oct 18, 2003 9:52 pm    Post subject: Reply with quote

same problem here. any hint?
_________________
wanna change how bootsplash or qingy look like? try here
Back to top
View user's profile Send private message
Mr. Pointy
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2002
Posts: 77

PostPosted: Sun Oct 19, 2003 8:29 am    Post subject: Reply with quote

With alsa now in the test kernels I decided to go without modules (and module support) entirely. That's how Linus does it, well i think i read that somewhere :) Just an experiment for me.

Any way, my sblive just plain works. As another mentioned I removed alsasoud from boot. Also, I haven't re-emerged alsa-utils or alsa-libs since switching over, wonder if I should...
Back to top
View user's profile Send private message
agent_jdh
Veteran
Veteran


Joined: 08 Aug 2002
Posts: 1776
Location: Scotland

PostPosted: Sun Oct 19, 2003 11:42 am    Post subject: Reply with quote

Helena wrote:
OK I now have sound in KDE again. But I also have strange start-up messages:
Code:
Loading ALSA drivers ...
Loading: snd-seq-oss
Loading: snd-mixer-oss
Loading: snd-pcm-oss
Loading: snd_intel8x0
FATAL: Modules snd_intel8x0 already in kernel.
Loading: snd_cmipci
Loading: snd-seq-oss
FATAL: Modules snd_seq_oss already in kernel.
Running card-dependent scripts
Restoring mixer levels

and boot continues normally. BTW I have also compiled CMI's sound driver (cmipci) but will remove that next time.

I would guess that these stem from the etc/modules.d/alsa file that was included with
Code:
modules-update
The listing follows:
Code:
# Alsa 0.9.X kernel modules' configuration file.
# $Header: /home/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsa-modules.conf-rc,v 1.1 2003/08/05 21:07:55 johnm Exp $

# ALSA portion

alias char-major-116 snd

# OSS/Free portion

alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion

alias snd-card-0 snd-intel8x0

## alias snd-card-1 snd-ens1371
##  OSS/Free portion

alias sound-slot-0 snd-card-0

## alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1

alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.

options snd cards_limit=1

Indeed, there are 2 "alias" references to "snd-seq-oss" so that would imply twice "insmod"/"modprobe" and hence explain the error message?!

Also, I have now even set Sound Core support to "M" in the kernel.


I've got the same thing happening here, I wouldn't worry about it though, it doesn't have any effect on sound performance. It's just to do with the sequence the modules are loaded in. You could try playing around with the /etc/modules.d/alsa file, although I think the problem may lie in the alsasound script. Like I said, it is probably not set up to work 100% with 2.6 kernels yet, so don't expect it to be perfect. As long as it works ... (and correctly saves/restores your mixer settings ... that's the most important thing for me).
_________________
Jingle Jangle Jewellery
Back to top
View user's profile Send private message
Helena
Veteran
Veteran


Joined: 02 Apr 2003
Posts: 1027
Location: De Meern, The Netherlands

PostPosted: Wed Oct 22, 2003 5:14 pm    Post subject: Reply with quote

Well I've made it! I finally have complete and unabridged sound in KDE and even in UT2003! However the line
Code:
alsactl store
seems unnecessary, since mixer levels are already (re)stored (by alsasound?). I still can't enable the PCM control, however. Moreover, to get sound in UT2003 I have to start it with
Code:
artsdsp -m /usr/games/bin/ut2003
a trick I found somewhere else. The error messages I mentioned before are still there and keep me puzzled.
Back to top
View user's profile Send private message
malcolmG54
n00b
n00b


Joined: 19 Oct 2003
Posts: 4

PostPosted: Thu Oct 23, 2003 2:44 am    Post subject: Reply with quote

Thanks Helena
Excelent guide. Got my sound working in no time.
The alsa guide is really meant for 2.4 kernels and I don't there is no alsasound file when you go with 2.6.0 kernel and no need to search for it in the portage tree.

I've chosen a kernel support for my ALSA except OSS and PCI which I compiled as modules and added to
/etc/modules.autoload.d/kernel-2.6
trident
snd-pcm-oss (for /dev/dsp support)

and voila sound is working.
I used alsamixer to setup the sound to my liking and
alsactl store
To restore the the sound levels during the boot I added a line to
/etc/conf.d/local.start
alsactl restore
Back to top
View user's profile Send private message
triad
Apprentice
Apprentice


Joined: 10 Jul 2003
Posts: 234
Location: Dark Side of the Moon

PostPosted: Thu Oct 23, 2003 11:02 am    Post subject: Reply with quote

Thanks agent_jdh. Worked fine here.

Triad
_________________
It's not the size of your processor that matters... But how you use it!
Back to top
View user's profile Send private message
dsd
Developer
Developer


Joined: 30 Mar 2003
Posts: 2162
Location: nr London

PostPosted: Thu Oct 23, 2003 2:43 pm    Post subject: Reply with quote

dont suppose anyone can help out? im trying to get dmix going. ive followed agent_jdh's method. what now?
_________________
http://dev.gentoo.org/~dsd
Back to top
View user's profile Send private message
Helena
Veteran
Veteran


Joined: 02 Apr 2003
Posts: 1027
Location: De Meern, The Netherlands

PostPosted: Sun Oct 26, 2003 5:59 pm    Post subject: Reply with quote

Thanks malcolmG54!

You added the last, missing information. BTW, I also added
Code:
alsactl store
to the shutdown script in /etc/conf.d/local.stop. After trying agent_jdh's method for a while, I have now returned to my first method. It seems to me that built-in methods should always be preferred, and it also saves some time & effort when recompiling the kernel.
Back to top
View user's profile Send private message
idoneus
Apprentice
Apprentice


Joined: 26 Mar 2003
Posts: 243
Location: Graz, Austria

PostPosted: Tue Oct 28, 2003 10:40 am    Post subject: Reply with quote

Thanks Helena for this nice little mini howto.

I too compiled alsa into the kernel, so I needed a way to restore the alsa settings.
I did not like the idea of writing alsactl into local.start/stop so I wrote a very simple script that will restore the settings at boot and store them at shutdown.
Code:
#!/sbin/runscript

#
#-----------------------------------------------------
# simple script that will set / save your alsa settings
#-----------------------------------------------------
#

#depend() {
#
#}

start() {
        ebegin "Restoring alsa settings"
        /usr/sbin/alsactl restore
        eend $? "Failed to restore alsa settings"
}

stop() {
        ebegin "Storing alsa settings"
        /usr/sbin/alsactl store
        eend $? "Failed to store alsa settings"
}

maybe it is of some use to somebody. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Goto page 1, 2, 3, 4, 5, 6, 7  Next
Page 1 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum