Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Slow searches after migration (unanswered, user posts, etc.)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo Forums Feedback
View previous topic :: View next topic  
Author Message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Tue Aug 04, 2009 3:14 am    Post subject: Slow searches after migration (unanswered, user posts, etc.) Reply with quote

two links I pulled off of here:
http://forums.gentoo.org/search.php?search_author=desultory : works with a count of 4049 (less than his real post count, interestingly enough - deleted posts? nvm that tho)

http://forums.gentoo.org/search.php?search_author=bunder : for examply. Neddy, me, others are all like this. I suspect it has to do with the over-6666-ness of the real posts (including otw)...

please fix?

Mod edit: Changed topic title to indicate that several kinds of searches are affected.
--timeBandit

_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.


Last edited by poly_poly-man on Tue Aug 04, 2009 4:58 am; edited 1 time in total
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Tue Aug 04, 2009 3:29 am    Post subject: Reply with quote

After I saw this, I ran the query for all posts for my user and got the '6666' results (fine, what I expected) and 257 pages of results. When I tried to jump to page 257 to see the oldest results, I got the following error message:

http://omploader.org/vMjNjMg

I used a screenshot so that you could see the URL as well as the message and where it was displayed.
Back to top
View user's profile Send private message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Tue Aug 04, 2009 3:38 am    Post subject: Reply with quote

yabbadabbadont wrote:
After I saw this, I ran the query for all posts for my user and got the '6666' results (fine, what I expected) and 257 pages of results. When I tried to jump to page 257 to see the oldest results, I got the following error message:

http://omploader.org/vMjNjMg

I used a screenshot so that you could see the URL as well as the message and where it was displayed.
can you see bunder's?
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Tue Aug 04, 2009 3:39 am    Post subject: Reply with quote

poly_poly-man wrote:
can you see bunder's?

I'm letting it run now. Mine took a few minutes to return...

Edit: I mean I got up and refilled my beverage, nuked a couple of frozen burritos, and made a pitstop in the restroom before the query completed...

Edit2: It just returned fine. Took it a little over two minutes to finish.
Back to top
View user's profile Send private message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Tue Aug 04, 2009 3:44 am    Post subject: Reply with quote

yabbadabbadont wrote:
poly_poly-man wrote:
can you see bunder's?

I'm letting it run now. Mine took a few minutes to return...

Edit: I mean I got up and refilled my beverage, nuked a couple of frozen burritos, and made a pitstop in the restroom before the query completed...

Edit2: It just returned fine. Took it a little over two minutes to finish.
more patience than I have... wonder why it's limited to certain users. Fixing title.
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.
Back to top
View user's profile Send private message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Tue Aug 04, 2009 3:46 am    Post subject: Reply with quote

nope.. you were just searching differently than I was... http://forums.gentoo.org/search.php?search_author=yabbadabbadont

I go to your profile then click search posts by.
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Tue Aug 04, 2009 3:48 am    Post subject: Reply with quote

I clicked the link you provided in your first post for bunder....
Back to top
View user's profile Send private message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Tue Aug 04, 2009 3:50 am    Post subject: Reply with quote

yabbadabbadont wrote:
I clicked the link you provided in your first post for bunder....
and that took a few minutes.

EDIT: I get it... it turns into a search id when you go to a page.. nvm...


btw, desultory's last page is "no posts match"... EDIT... or was the first time..


what did you guys do to searching? I didn't know it was possible for it to get *worse* :P
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.


Last edited by poly_poly-man on Tue Aug 04, 2009 3:52 am; edited 1 time in total
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Tue Aug 04, 2009 3:51 am    Post subject: Reply with quote

poly_poly-man wrote:
yabbadabbadont wrote:
I clicked the link you provided in your first post for bunder....
and that took a few minutes.

EDIT: I get it... it turns into a search id when you go to a page.. nvm...


btw, desultory's last page is "no posts match"...

A little over two, yes.
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5213

PostPosted: Tue Aug 04, 2009 3:42 pm    Post subject: Reply with quote

this also affects "view unanswered posts", it has something to do with the hardware upgrade, but from what i understand they're looking into it.
_________________
goodbye fgo. it was nice knowing you.
Back to top
View user's profile Send private message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Tue Aug 04, 2009 3:59 pm    Post subject: Reply with quote

bunder wrote:
this also affects "view unanswered posts", it has something to do with the hardware upgrade, but from what i understand they're looking into it.
unanswered has only ever hung for a small number of seconds for me...
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Tue Aug 04, 2009 7:40 pm    Post subject: Reply with quote

poly_poly-man wrote:
bunder wrote:
this also affects "view unanswered posts", it has something to do with the hardware upgrade, but from what i understand they're looking into it.
unanswered has only ever hung for a small number of seconds for me...

It just took 166 seconds for me...
Back to top
View user's profile Send private message
think4urs11
Administrator
Administrator


Joined: 25 Jun 2003
Posts: 6659
Location: above the cloud

PostPosted: Tue Aug 04, 2009 8:27 pm    Post subject: Re: >6666 realpost count users - search takes 2+min Reply with quote

poly_poly-man wrote:
two links I pulled off of here:
http://forums.gentoo.org/search.php?search_author=desultory : works with a count of 4049 (less than his real post count, interestingly enough - deleted posts? nvm that tho)

http://forums.gentoo.org/search.php?search_author=bunder : for examply. Neddy, me, others are all like this. I suspect it has to do with the over-6666-ness of the real posts (including otw)...

please fix?

The first one should be ok, as long as you don't find an account where viewprofile>search_author # of posts.
The second one sees strange; contrary to the old setup i see now (but only for my own account) a search_author value of >6666, for e.g. Neddy though it shows 6666...
unanswered-search is known to be slow in the new setup, see http://forums.gentoo.org/viewtopic-t-785980.html
_________________
Nothing is secure / Security is always a trade-off with usability / Do not assume anything / Trust no-one, nothing / Paranoia is your friend / Think for yourself
Back to top
View user's profile Send private message
timeBandit
Bodhisattva
Bodhisattva


Joined: 31 Dec 2004
Posts: 2672
Location: here, there or in transit

PostPosted: Tue Aug 04, 2009 10:04 pm    Post subject: Reply with quote

bunder wrote:
... from what i understand they're looking into it.
Correct, if by "looking into it" you mean "someone ensured infra and desultory are aware of the problem and this thread" and if "someone" is me. :)
_________________
Plants are pithy, brooks tend to babble--I'm content to lie between them.
Super-short f.g.o checklist: Search first, strip comments, mark solved, help others.
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4665
Location: Theux (Belgium)

PostPosted: Wed Aug 05, 2009 10:55 am    Post subject: Is there a problem with unanswered posts? Reply with quote

Hi admins.

For two days I've been trying to get the list of unanswered posts and it takes a very, very long time -- too long to me and I'd rather stop the request instead. So the list of unanswered posts doesn't appear and it's been more or less two days it is so. Has anybody reported a problem around that?

Thanks.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
simon_irl
Guru
Guru


Joined: 07 Oct 2004
Posts: 403
Location: New Zealand

PostPosted: Wed Aug 05, 2009 11:24 am    Post subject: Reply with quote

i'm having this problem too: i logged in to look through the unanswered questions, but gave up waiting for the screen to load.
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5213

PostPosted: Wed Aug 05, 2009 12:04 pm    Post subject: Reply with quote

http://forums.gentoo.org/viewtopic-t-785980.html
_________________
goodbye fgo. it was nice knowing you.
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4665
Location: Theux (Belgium)

PostPosted: Wed Aug 05, 2009 12:24 pm    Post subject: Reply with quote

Okay, thanks... Sorry I didn't [bother] see the announcement :oops: ...

Take it as a suggestion: in some forum software is a place to provide a note or link on top of each browsed page. That note/link appears until it's acknowledged by the [subscribed] visitor. That's how I knew TombRaider forums there was a soundtrack community pack, IIRC.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
timeBandit
Bodhisattva
Bodhisattva


Joined: 31 Dec 2004
Posts: 2672
Location: here, there or in transit

PostPosted: Wed Aug 05, 2009 3:08 pm    Post subject: Reply with quote

VinzC wrote:
Okay, thanks... Sorry I didn't [bother] see the announcement :oops: ...
Thank you for at least being honest. :wink:

Quote:
Take it as a suggestion: in some forum software is a place to provide a note or link on top of each browsed page. That note/link appears until it's acknowledged by the [subscribed] visitor. That's how I knew TombRaider forums there was a soundtrack community pack, IIRC.
If it's provided by phpBB v3, it might appear here after the upgrade (officially, Real Soon Now, edging closer by the day). Sounds more annoying than useful though.

The Latest Site News section at the top of the forums main index serves the purpose nicely. Items are marked new until you read them. As of this writing all three announcements pertain to the migration. Honestly, there's only so much we can do short of reaching through the monitor, knocking you gently on the head, saying "Hey! Read this!" and pointing to the news item. :roll:
_________________
Plants are pithy, brooks tend to babble--I'm content to lie between them.
Super-short f.g.o checklist: Search first, strip comments, mark solved, help others.
Back to top
View user's profile Send private message
timeBandit
Bodhisattva
Bodhisattva


Joined: 31 Dec 2004
Posts: 2672
Location: here, there or in transit

PostPosted: Wed Aug 05, 2009 3:22 pm    Post subject: Reply with quote

Merged above five posts here and changed the original topic title to reflect the more general nature of the problem.
_________________
Plants are pithy, brooks tend to babble--I'm content to lie between them.
Super-short f.g.o checklist: Search first, strip comments, mark solved, help others.
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4665
Location: Theux (Belgium)

PostPosted: Wed Aug 05, 2009 3:45 pm    Post subject: Reply with quote

Quote:
Take it as a suggestion: in some forum software is a place to provide a note or link on top of each browsed page. That note/link appears until it's acknowledged by the [subscribed] visitor. That's how I knew TombRaider forums there was a soundtrack community pack, IIRC.

timeBandit wrote:
If it's provided by phpBB v3, it might appear here after the upgrade (officially, Real Soon Now, edging closer by the day). Sounds more annoying than useful though.

The Latest Site News section at the top of the forums main index serves the purpose nicely. Items are marked new until you read them. As of this writing all three announcements pertain to the migration. Honestly, there's only so much we can do short of reaching through the monitor, knocking you gently on the head, saying "Hey! Read this!" and pointing to the news item. :roll:


I'm not sure I understood but the trick is to gently avoid to have to read forum announcements everyday, knowing such a thing [as this one move] happens very, very, very rarely -- in the spirit «notifications are better than polling».
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Wed Aug 05, 2009 4:03 pm    Post subject: Reply with quote

VinzC wrote:
Quote:
Take it as a suggestion: in some forum software is a place to provide a note or link on top of each browsed page. That note/link appears until it's acknowledged by the [subscribed] visitor. That's how I knew TombRaider forums there was a soundtrack community pack, IIRC.

timeBandit wrote:
If it's provided by phpBB v3, it might appear here after the upgrade (officially, Real Soon Now, edging closer by the day). Sounds more annoying than useful though.

The Latest Site News section at the top of the forums main index serves the purpose nicely. Items are marked new until you read them. As of this writing all three announcements pertain to the migration. Honestly, there's only so much we can do short of reaching through the monitor, knocking you gently on the head, saying "Hey! Read this!" and pointing to the news item. :roll:


I'm not sure I understood but the trick is to gently avoid to have to read forum announcements everyday, knowing such a thing [as this one move] happens very, very, very rarely -- in the spirit «notifications are better than polling».
++ - most of us do not actually hit forums.gentoo.org/ on any more than about a monthly basis...and even then it's not to look at that, it's to quick hit egosearch or another forum (like goaa, which hardly ever shows up in 24 hours)
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7908

PostPosted: Tue Aug 18, 2009 5:46 am    Post subject: Reply with quote

poly_poly-man wrote:
http://forums.gentoo.org/search.php?search_author=desultory : works with a count of 4049 (less than his real post count, interestingly enough - deleted posts? nvm that tho)
Those posts exist, they just happen to be hidden.
poly_poly-man wrote:
http://forums.gentoo.org/search.php?search_author=bunder : for examply. Neddy, me, others are all like this. I suspect it has to do with the over-6666-ness of the real posts (including otw)...

please fix?
Done, robbat2 managed to generally locate, and correct, some interesting behavior on the part of the intermediate database interface which manifested under exactly the conditions you described. It should work in a more timely manner now.
Back to top
View user's profile Send private message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Tue Aug 18, 2009 5:56 am    Post subject: Reply with quote

desultory wrote:
poly_poly-man wrote:
http://forums.gentoo.org/search.php?search_author=desultory : works with a count of 4049 (less than his real post count, interestingly enough - deleted posts? nvm that tho)
Those posts exist, they just happen to be hidden.
poly_poly-man wrote:
http://forums.gentoo.org/search.php?search_author=bunder : for examply. Neddy, me, others are all like this. I suspect it has to do with the over-6666-ness of the real posts (including otw)...

please fix?
Done, robbat2 managed to generally locate, and correct, some interesting behavior on the part of the intermediate database interface which manifested under exactly the conditions you described. It should work in a more timely manner now.
that explains the short database outage as well? cool, thanks.
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7908

PostPosted: Tue Aug 18, 2009 6:18 am    Post subject: Reply with quote

That it does, there was a glitch in switching over which got fixed by the next automated pass.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Forums Feedback All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum