Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Feedback for the KDE 4 support guide.
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Gentoo Forums Feedback
View previous topic :: View next topic  
Author Message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Mon Nov 10, 2008 10:28 am    Post subject: Reply with quote

small (silly?) update

In Portage section change 4.1.2 to 4.1.3 and update link to http://www.kde.org/announcements/announce-4.1.3.php as well please.
Please change 4.1.2 to 4.1 in first answer in FAQ as well.
_________________
Maciek
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8045

PostPosted: Tue Nov 11, 2008 9:14 am    Post subject: Reply with quote

reavertm wrote:
small
Yes.
reavertm wrote:
(silly?)
No.
reavertm wrote:
update
Done.

Thanks.
Back to top
View user's profile Send private message
craigg4c
n00b
n00b


Joined: 05 Nov 2007
Posts: 7
Location: Las Vegas

PostPosted: Sat Nov 22, 2008 8:21 am    Post subject: 3.5.10? Reply with quote

In the intro post to this thread, it says update to KDE 3.5.10. But the only 3.5.10 ebuild is for kdelibs, and in fact that ebuild is preventing me from updating ANY 3.5 kde. Where are the 3.5.10 ebuilds?
Back to top
View user's profile Send private message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Sat Nov 22, 2008 1:03 pm    Post subject: Reply with quote

requested update (as new users are lost it seems...)
replace:
Quote:
If you have any suggestions for improvements regarding this guide, feel free to post them here.

with:
Quote:
If you have any suggestions for improvements regarding this guide, feel free to post them here. Please refrain from general discussion and do not post ebuild/installation questions there.


I suggest off-topic posts like the one above should be deleted/moved on sight as they only distract moderators/admin who watch this thread for updates.
_________________
Maciek
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8045

PostPosted: Sun Nov 23, 2008 12:27 am    Post subject: Reply with quote

craigg4c wrote:
In the intro post to this thread, it says update to KDE 3.5.10. But the only 3.5.10 ebuild is for kdelibs, and in fact that ebuild is preventing me from updating ANY 3.5 kde. Where are the 3.5.10 ebuilds?
They are not yet marked stable, and the 3.5.10 series is no longer available via monolithic packages.

reavertm wrote:
requested update (as new users are lost it seems...)
replace:
Quote:
If you have any suggestions for improvements regarding this guide, feel free to post them here.

with:
Quote:
If you have any suggestions for improvements regarding this guide, feel free to post them here. Please refrain from general discussion and do not post ebuild/installation questions there.
That question appears to be in regards to one of the questions in the FAQ.
reavertm wrote:
Q: When I start KDE 3, Plasma is being executed and my KDE 3 applications are either crashing or just not working. Konqueror refuses to start, complaining about default stylesheet version mismatch. What's going on?

A: This is the conflict related to mixed KDE3/KDE4 sessions. To fix this issue you need to upgrade your existing KDE 3.5.x installations to 3.5.10 or newer.
As such, it seems to me to be valid feedback.
reavertm wrote:
I suggest off-topic posts like the one above should be deleted/moved on sight as they only distract moderators/admin who watch this thread for updates.
Off topic posts will be dealt with as necessary.

What is your opinion on adding a note to the above quoted FAQ along the lines of: "Note that the 3.5.10 series has not been given stable keywords yet and that the monolithic packages have been discontinued."?
Back to top
View user's profile Send private message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Sun Nov 23, 2008 4:02 pm    Post subject: Reply with quote

This note about monolithic packages being discontinued is mentioned in all KDE guides already - http://www.gentoo.org/proj/en/desktop/kde/kde-config.xml and http://www.gentoo.org/proj/en/desktop/kde/kde4-guide.xml as well - it's not that easy to spot though.

The problem is, the mentioned reader has interpreted FAQ literally as
"To fix this issue you need to upgrade your existing KDE 3.5.x installations to 3.5.10 or newer."
doesn't tell to emerge kde-base/kde-3.5.10 (we know that such monolithic ebuild no longer exists) - it is just a hint to upgrade KDE3 - hence in my opinion his question was ebuild/installation-related not dierctly guide related (well, one would say then it's related because it shows that threads guide is misleading).

It may be a good idea to add note:
Code:
Note that the 3.5.10 series has not been given stable keywords yet and that the monolithic packages have been discontinued.

but I really think that it won't help either as it requires basic knowledge about "what are monolithic packages?" and further "how to migrate from monolithic to split/meta ebuilds" and in this scenario "how to unmask/unkeyword 3.5.10" and then maybe "how to use kde sets?" - and the conclusion is - people who install KDE4 (which is unstable = keyword masked) should already have required knowledge to proceed further (with upgrading existing KDE3 etc). Anyway feel free to add it.
_________________
Maciek
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8045

PostPosted: Tue Nov 25, 2008 8:48 am    Post subject: Reply with quote

Made the updates discussed above and added a link to "The KDE Split Ebuilds HOWTO" in the FAQ.
Back to top
View user's profile Send private message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Sat Nov 29, 2008 10:04 pm    Post subject: Reply with quote

update request (add annoncement) - suspended for now

replace
Quote:
This is the official guide for KDE 4 related threads.

KDE 4 for Gentoo is delivered in several ways:


with
Quote:
This is the official guide for KDE 4 related threads.

Quote:
Announcement
Still waiting for a new shiny KDE to appear in Portage? You would like to help but you're afraid to ask? Don't wait - join today!
Now hiring at positions: bug wrangler
Requirements:
- good social skills and sense of humour ("how to approach users and developers without being bitten")
- general knowledge about KDE in Gentoo ("how to live and not be bitten")
- a bit of time to spare
- bash/ebuild writing skills are welcome but not required
More info on #gentoo-kde


KDE 4 for Gentoo is delivered in several ways:


please apply any grammatical corrections if applicable (I'm not native speaker) - if there are any doubts related to Gentoo policy, please refer to this discussion
_________________
Maciek


Last edited by reavertm on Fri Dec 05, 2008 4:23 am; edited 2 times in total
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8045

PostPosted: Mon Dec 01, 2008 2:30 am    Post subject: Reply with quote

While I agree that bug wranglers are worth recruiting, I am not yet sure of adding such an announcement to the guide. So I offer a counterproposal: if you can get a project member to do a quick write up along those lines it could be posted as an announcement, so that it would appear at the top of the index, then after it no longer appeared there, due to additional announcements being posted, it can either be merged with the guide or placed as a separate section specific announcement for some period to be determined later.
Back to top
View user's profile Send private message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Mon Dec 01, 2008 6:29 am    Post subject: Reply with quote

Just before putting announcement here - the idea was discussed with Gentoo KDE HT lead Tomáš Chvátal (scarabeus), but of course the form of the announcement was mine, then I decided post it here. Links were given to scarabeus and Jorge Manuel B. S. Vicetto (jmbsvicetto) as well, who I'm working closely with (I'm one of contributors/maintainers of official experimental gentoo kde overlay [kde-crazy]). Gentoo KDE herd needs should be officially clarified during next meeting that should take place on #gentoo-kde this week.
_________________
Maciek
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8045

PostPosted: Mon Dec 01, 2008 7:52 am    Post subject: Reply with quote

Any objections to waiting until then to proceed with the recruiting of bug wranglers?
Back to top
View user's profile Send private message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Wed Jan 07, 2009 2:05 am    Post subject: Reply with quote

Update request

in kde-testing section replace:
Quote:
This is overlay used by Gentoo KDE team, it's official but unsupported. It contains only KDE4 applications that are compatible with KDE4 from Portage repository but they are not there for some reasons. Some of those packages may appear in Portage repository in a future. Note that no KDE releases will be available in this overlay

with
Quote:
This is overlay used by Gentoo KDE team, it's official but unsupported. It contains KDE4 unstable releases as well as releases that are supposed to appear in the Portage repository. There are as well 3rd party applications that are compatible with KDE4 from Portage repository but they are not there for some reasons. Some of those packages may appear in Portage in a future.


in kde-crazy section replace:
Quote:
This overlay is playground for Gentoo KDE team. That being said it's known to eat puppies and kill kittens. It contains unstable KDE4 releases as well as live (Subversion) ebuilds. Please DON'T report any bugs regarding this overlay.

with
Quote:
This overlay is playground for Gentoo KDE team. That being said it's known to eat puppies and kill kittens. It contains live (Subversion) KDE4 ebuilds and some other packages considered experimental. Please DON'T report any bugs regarding this overlay.


regards
_________________
Maciek
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8045

PostPosted: Wed Jan 07, 2009 5:16 am    Post subject: Reply with quote

Done, thanks for the updates.
Back to top
View user's profile Send private message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Sun Jan 18, 2009 9:55 pm    Post subject: merging overlays Reply with quote

update request

replace in kde-testing section:
Quote:
This is overlay used by Gentoo KDE team, it's official but unsupported. It contains KDE4 unstable releases as well as releases that are supposed to appear in the Portage repository. There are as well 3rd party applications that are compatible with KDE4 from Portage repository but they are not there for some reasons. Some of those packages may appear in Portage in a future.
You can get support for this overlay in #gentoo-kde and help Gentoo KDE team testing it.
Support thread for official KDE4 testing overlay is here:
http://forums.gentoo.org/viewtopic-t-722264.html


with:
Quote:
This is overlay used by Gentoo KDE team, it's official but unsupported. It contains KDE4 unstable releases as well as releases that are supposed to appear in the Portage repository. There are as well 3rd party applications that are compatible with KDE4 from Portage repository but they are not there for some reasons. Some of those packages may appear in Portage in a future.
Additionally, this overlay contains live (Subversion) KDE4 ebuilds as well as some other highly experimental (and probably broken) packages.
If you have some suggestions or you would like to contribute, contact Gentoo KDE team on #gentoo-kde.
Please DON'T report any bugs regarding live packages in this overlay. For bugs related KDE release candidates you should add [kde-testing] to description, but it's always better to ask on forum or IRC channel first.
Support thread for official KDE4 testing overlay is here:
http://forums.gentoo.org/viewtopic-t-722264.html


replace in kde-crazy section:
Quote:
This overlay is playground for Gentoo KDE team. That being said it's known to eat puppies and kill kittens. It contains live (Subversion) KDE4 ebuilds and some other packages considered experimental. Please DON'T report any bugs regarding this overlay.
If you have some suggestions or you would like to contribute, contact Gentoo KDE team on #gentoo-kde.
Support thread for official KDE4 experimental overlay is here:
http://forums.gentoo.org/viewtopic-t-722264.html

with:
Quote:
This overlay is deprecated and will be removed in a future. All its contents can be found in kde-testing overlay now.
Note that live KDE4 packages are now masked by package.mask in kde-testing, so to migrate seamlessly one will need to manually unmask those -9999 ebuilds.
Qt4 live ebuilds have been moved from kde-crazy overlay recently and can be found in Qt-exclusive experimental overlay now.
To make use of them, choose qting-edge overlay in layman.


As always, feel free to correct any grammar/spelling errors.
_________________
Maciek
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8045

PostPosted: Mon Jan 19, 2009 5:06 am    Post subject: Reply with quote

Done, thanks again.
Back to top
View user's profile Send private message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Tue Jan 27, 2009 3:24 am    Post subject: Reply with quote

Tiny update:

in Portage repository section replace:
Quote:
KDE4 (4.1.3 recently)

with
Quote:
KDE4 (4.1.4 recently)


and in kde-crazy section replace:
Quote:
Note that live KDE4 packages are now masked by package.mask in kde-testing, so to migrate seamlessly one will need to manually unmask those -9999 ebuilds.

with
Quote:
Note that live KDE4 packages are now masked by package.mask in kde-testing, so to migrate seamlessly one will need to manually unmask those -9999 ebuilds. Gentoo KDE team has prepared appropriate files in Documentation/package.unmask/kde-live directory in overlay.

_________________
Maciek
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8045

PostPosted: Tue Jan 27, 2009 4:09 am    Post subject: Reply with quote

Done and done, thanks again.
Back to top
View user's profile Send private message
AllenJB
Veteran
Veteran


Joined: 02 Sep 2005
Posts: 1283
Location: Ashford, Kent

PostPosted: Mon Feb 09, 2009 4:56 pm    Post subject: Reply with quote

Using KDE 4.2: If you're having problems with KDE3 applications giving "file not found" type errors, it may be because the $PATH is filtered to exclude KDE3 (for example, the weekalarm script in Amarok 1.4 fails in this manner). The solution to this is to launch KDE3 apps using the "kde3" script. eg. Change the run command of the amarok menu item to: kde3 amarok %U
_________________
http://gentoo-wiki.com :: http://lug.org.uk :: http://www.linux.org/groups/ :: User Blogs
Back to top
View user's profile Send private message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Wed Mar 11, 2009 5:09 pm    Post subject: Reply with quote

Oh God.... could anyone replace KDE
Quote:
4.1
occurrences in portage repository section and FAQ with
Quote:
4.2
and update link (portage repository section) to KDE 4.2.1 release announcement to http://www.kde.org/announcements/announce-4.2.1.php ?
(I probably need to get some mod rights...)

Sorry for delay (when one is preparing ebuilds - he's starting to hang out on IRC only and forgets about forum...)
_________________
Maciek
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8045

PostPosted: Thu Mar 12, 2009 12:03 am    Post subject: Reply with quote

Done, thanks.
Back to top
View user's profile Send private message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Mon Apr 20, 2009 11:25 pm    Post subject: Reply with quote

Update request

In Portage repository section
replace:
Quote:
The only officially supported and recommended way to get KDE4 (4.2.1 recently)

with:
Quote:
The only officially supported and recommended way to get KDE4 (4.2.2 recently)


In Official Gentoo KDE team testing overlay [kde-testing] section
replace:
Quote:
This is overlay used by Gentoo KDE team, it's official but unsupported. It contains KDE4 unstable releases as well as releases that are supposed to appear in the Portage repository. There are as well 3rd party applications that are compatible with KDE4 from Portage repository but they are not there for some reasons. Some of those packages may appear in Portage in the future.
Additionally, this overlay contains live (Subversion) KDE4 ebuilds as well as some other highly experimental (and probably broken) packages.

with:
Quote:
This is overlay used by Gentoo KDE team, it's official but unsupported.
It contains:

  • KDE releases that will later appear in the Portage repository (-4.2.x)
  • live KDE ebuilds tracking main development tree (-9999)
  • periodically updated main development tree snapshots (-4.2.xx)
  • live KDE ebuilds tracking 4.2.x development branch (-4.2.9999)
  • 3rd party KDE packages that are not in Portage repository for various reasons


_________________
Maciek
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8045

PostPosted: Tue Apr 21, 2009 2:20 am    Post subject: Reply with quote

Done, thanks.
Back to top
View user's profile Send private message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Mon May 18, 2009 7:50 pm    Post subject: Reply with quote

Damn, I lag again...
please replace in Portage section:
Quote:
KDE4 (4.2.2 recently)

with:
Quote:
KDE4 (4.2.3 recently)


As we're here, in [kde-testing] section, please replace:
Quote:
Support thread for official KDE4 testing overlay is here:
http://forums.gentoo.org/viewtopic-t-722264.html

with:
Quote:
Support thread for official KDE4 testing overlay is here:
http://forums.gentoo.org/viewtopic-t-722264.html

Qt4 live ebuilds can be found in Qt-exclusive experimental overlay now.
To make use of them, choose the qting-edge overlay in layman.


also in [kde-crazy] section replace:
Quote:
This overlay is deprecated and will be removed in a future. All its contents can be found in kde-testing overlay now.
Note that live KDE4 packages are now masked by package.mask in kde-testing, so to migrate seamlessly one will need to manually unmask those -9999 ebuilds. Gentoo KDE team has prepared appropriate files in Documentation/package.unmask/kde-live directory in overlay.
Qt4 live ebuilds have been moved from kde-crazy overlay recently and can be found in a Qt-exclusive experimental overlay now.
To make use of them, choose the qting-edge overlay in layman.

with:
Quote:
This overlay currently contains experimental work related to KDE3 (3.5.10), especially regarding cooperation with already installed KDE4. If you experience various KDE 3/4 mixed sessions issues or duplicated menu entries, you may want to give it a try and help Gentoo KDE team with testing.
Gentoo KDE team can be found on #gentoo-kde.

_________________
Maciek
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8045

PostPosted: Wed May 20, 2009 7:13 am    Post subject: Reply with quote

reavertm wrote:
Damn, I lag again...
Both of us, it seems.

Updates applied, thanks again.
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3215

PostPosted: Fri Jun 05, 2009 7:01 pm    Post subject: Reply with quote

Topic: Kdeprefix for KDE 4.2: yes or no?
Reason: Make this post sticky with a clear answer by a moderator in the first post. I believe the gentoo kde devs' reply is "NO"

There already is a sticky that answers this. -- nixnut
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde4 :-/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Forums Feedback All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum