Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Which update killed sound in virtualbox-bin? [SOLVED]
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
groenoord
n00b
n00b


Joined: 30 Apr 2007
Posts: 5

PostPosted: Sat May 09, 2009 3:30 pm    Post subject: Reply with quote

When I read that people identified libsdl as cause of the problem I checked my use flags. I am using virtualbox on my laptop, but I remembered that a long time ago I had other problems with esound on my desktop computer, where I finally decided to put -esd in make.conf. So I did the same on my laptop and this solved the virtualbox sound problem as well.

/Andreas
Back to top
View user's profile Send private message
overkll
Veteran
Veteran


Joined: 21 Sep 2004
Posts: 1244
Location: Austin, Texas

PostPosted: Sat May 09, 2009 3:35 pm    Post subject: Reply with quote

Well I'll be! SOB! Disabling esd worked here as well.

Good catch groenoord/Andreas!
Back to top
View user's profile Send private message
joefish
Guru
Guru


Joined: 27 Jan 2004
Posts: 316
Location: New Zealand

PostPosted: Sun May 10, 2009 4:05 am    Post subject: Reply with quote

Fixes it for me too!
Back to top
View user's profile Send private message
cyrre
n00b
n00b


Joined: 02 Jul 2007
Posts: 26

PostPosted: Sun May 10, 2009 2:34 pm    Post subject: Reply with quote

Re-emerging libsdl without the esd USE-flag didn't solve it for me.

Issue still remains when using ALSA :(
Back to top
View user's profile Send private message
overkll
Veteran
Veteran


Joined: 21 Sep 2004
Posts: 1244
Location: Austin, Texas

PostPosted: Sun May 10, 2009 5:05 pm    Post subject: Reply with quote

Sorry to hear that. It worked for me on two systems - one laptop and one desktop. I don't know what else to suggest. I didn't even have to reboot or logout/login to test. Just recompiling libsdl w/o esd worked.

Which version of libsdl are you using?
Back to top
View user's profile Send private message
overkll
Veteran
Veteran


Joined: 21 Sep 2004
Posts: 1244
Location: Austin, Texas

PostPosted: Sun May 10, 2009 5:49 pm    Post subject: Reply with quote

@cyrre,

What happens if you rollback esound from 0.2.41 to 0.2.38-r1? It's still in portage so you shouldn't have to make an overlay to test.
Back to top
View user's profile Send private message
cyrre
n00b
n00b


Joined: 02 Jul 2007
Posts: 26

PostPosted: Sun May 10, 2009 7:32 pm    Post subject: Reply with quote

Heyy, thanks for your quick replies :)

Downgrading esound didn't solve it.

But I noticed after I posted earlier that the issue is probably related to ALSA. I realised that only one application at the time can use audio. For some weird reason some of my apps seems to have stopped using dmix? Everything has been working flawless after I set up ALSA+dmix when I installed Gentoo in 2007. But since today or yesterday this doesn't work anymore.

The weird thing is that mpd+skype can use audio at the same time. But no other application plays sound (i.e Firefox+flash) when mpd is running, this has always been working earlier since I configured dmix. So I guess my VirtualBox-issue also will be solved when I figure out what has been messing up my system.

Any comments on what could be causing this will be appreciated. :)

Kind of a frustrating coincidence that this would happen around the same time a solution to the VirtualBox+libsdl issue was found. :twisted:
Back to top
View user's profile Send private message
overkll
Veteran
Veteran


Joined: 21 Sep 2004
Posts: 1244
Location: Austin, Texas

PostPosted: Sun May 10, 2009 7:58 pm    Post subject: Reply with quote

I've never set up dmix before, but maybe that's the issue you are having. Check out this link:

http://alsa.opensrc.org/home/w/org/opensrc/alsa/index.php?title=DmixPlugin

To quote directly:

NOTE: For ALSA 1.0.9rc2 and higher you don't need to setup dmix. Dmix is enabled as default for soundcards which don't support hw mixing.


What are we at now? 1.0.18 or so?

Maybe you could try disabling dmix and just use a standard alsa setup. I also recall reading (an emerge warning?) that any .asoundrc files need to be deleted as they can cause issues.

Good luck.

EDIT: Found the warning in alsa-lib ebuild:

Code:
 Starting from alsa 1.0.11_rc3 the configuration for dmix is changed.
 Leaving around old asound.conf or ~/.asoundrc might make all apps
 using ALSA output crash.
 Note that dmix output is enabled by default on the 'default' device
 since ALSA 1.0.9.
Back to top
View user's profile Send private message
cyrre
n00b
n00b


Joined: 02 Jul 2007
Posts: 26

PostPosted: Sun May 10, 2009 8:31 pm    Post subject: Reply with quote

I remember I've read about this before, but since my setup with dmix has worked I haven't cared about it I guess.

Don't have time right now, but tomorrow I will remove asound.conf and ~/.asoundrc and see if it makes any difference.

Thank you very much! :)

overkll wrote:
I've never set up dmix before, but maybe that's the issue you are having. Check out this link:

http://alsa.opensrc.org/home/w/org/opensrc/alsa/index.php?title=DmixPlugin

To quote directly:

NOTE: For ALSA 1.0.9rc2 and higher you don't need to setup dmix. Dmix is enabled as default for soundcards which don't support hw mixing.


What are we at now? 1.0.18 or so?

Maybe you could try disabling dmix and just use a standard alsa setup. I also recall reading (an emerge warning?) that any .asoundrc files need to be deleted as they can cause issues.

Good luck.

EDIT: Found the warning in alsa-lib ebuild:

Code:
 Starting from alsa 1.0.11_rc3 the configuration for dmix is changed.
 Leaving around old asound.conf or ~/.asoundrc might make all apps
 using ALSA output crash.
 Note that dmix output is enabled by default on the 'default' device
 since ALSA 1.0.9.
Back to top
View user's profile Send private message
AlienPenguin
n00b
n00b


Joined: 08 Sep 2004
Posts: 9
Location: Pisa, Italy

PostPosted: Mon May 11, 2009 8:17 am    Post subject: Reply with quote

I am glad to confirm that disabling the esd USE for libsdl fixed it for me too. :D (on two systems)
Back to top
View user's profile Send private message
bigsun
n00b
n00b


Joined: 19 Mar 2009
Posts: 2

PostPosted: Tue May 12, 2009 12:12 pm    Post subject: Reply with quote

very happy , the problem is resolved by -esd USE flag at last.
Back to top
View user's profile Send private message
cyrre
n00b
n00b


Joined: 02 Jul 2007
Posts: 26

PostPosted: Wed May 13, 2009 4:31 am    Post subject: Reply with quote

I had messed up my mpd.conf which was causing my issues ALSA.

The sound in VirtualBox works fine after disabling the -esd USE-flag. 8)
Back to top
View user's profile Send private message
lkraav
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2004
Posts: 121
Location: Estonia

PostPosted: Sun Mar 07, 2010 7:23 pm    Post subject: Reply with quote

thanks ladies and gents, libsdl -esd fixed virtualbox-bin-3.1.4 audio for me.
Back to top
View user's profile Send private message
Master of the Darkside
Tux's lil' helper
Tux's lil' helper


Joined: 02 Sep 2004
Posts: 94
Location: Iasi, Romania

PostPosted: Sat Apr 03, 2010 6:47 pm    Post subject: Reply with quote

I can confirm that downgrading libsdl (from ~ to stable amd64), solved it for me. I never used the esd use flag.
_________________
No weight nor mass nor beauty of execution can outweigh a grain or fragment of thought
Back to top
View user's profile Send private message
SDNick484
Apprentice
Apprentice


Joined: 05 Dec 2005
Posts: 185

PostPosted: Thu Apr 29, 2010 7:27 am    Post subject: Reply with quote

This issue is still open. I'm running app-emulation/virtualbox-bin-3.1.6 and sound wasn't working with media-libs/libsdl-1.2.14-r2 (current ~amd64). Downgrading to media-libs/libsdl-1.2.13-r1 (current stable) resolved the issue for me. Also I should note that there's no "esd" USE for 1.2.14.

So to be clear, the following failed (no sound in VirtualBox with ALSA):
[ebuild R ] media-libs/libsdl-1.2.14-r2 USE="X alsa audio joystick opengl video xv -aalib -custom-cflags -dga -directfb -fbcon -ggi -libcaca -nas -oss (-ps3) -pulseaudio -static-libs (-svga) -tslib -xinerama"

Downgrading to the following fixed the issue:
[ebuild R ] media-libs/libsdl-1.2.13-r1 USE="X alsa audio joystick opengl video xv -aalib -custom-cflags -dga -directfb -esd -fbcon -ggi -libcaca -nas -oss -pulseaudio (-svga) -tslib -xinerama"
Back to top
View user's profile Send private message
cyrius
n00b
n00b


Joined: 27 Jan 2007
Posts: 56

PostPosted: Sat May 29, 2010 6:03 pm    Post subject: Reply with quote

Unfortunately, i use Virtual Box.
Allright, i think i found the solution for newest ebuild of libsdl.
In the ebuild the option --disable-alsa-shared is on. Then by removing it, it works now.
I post a bugg for gentoo.
Back to top
View user's profile Send private message
rh1
Guru
Guru


Joined: 10 Apr 2010
Posts: 501

PostPosted: Sat Jun 26, 2010 2:04 am    Post subject: Reply with quote

Quote:
In the ebuild the option --disable-alsa-shared is on. Then by removing it, it works now.

Thanks, this fix worked for me also. :D
Back to top
View user's profile Send private message
meyerm
Veteran
Veteran


Joined: 27 Jun 2002
Posts: 1311
Location: Munich / Germany

PostPosted: Thu Aug 19, 2010 10:50 am    Post subject: Reply with quote

rh1 wrote:
Quote:
In the ebuild the option --disable-alsa-shared is on. Then by removing it, it works now.

Thanks, this fix worked for me also. :D


+1 :-)

~amd64
libsdl-1.2.14-r3
virtualbox-bin-3.2.8
Back to top
View user's profile Send private message
agent_jdh
Veteran
Veteran


Joined: 08 Aug 2002
Posts: 1776
Location: Scotland

PostPosted: Wed Aug 25, 2010 10:18 pm    Post subject: Reply with quote

YES! This has been irritating me for some time now, and removing --disable-alsa-shared from the libsdl ebuild has fixed it. Thanks guys. Maybe a bug should be filed?
_________________
Jingle Jangle Jewellery
Back to top
View user's profile Send private message
mgromit
n00b
n00b


Joined: 14 Apr 2011
Posts: 1

PostPosted: Thu Apr 14, 2011 5:40 pm    Post subject: Reply with quote

SDNick484 wrote:
This issue is still open. I'm running app-emulation/virtualbox-bin-3.1.6 and sound wasn't working with media-libs/libsdl-1.2.14-r2 (current ~amd64). Downgrading to media-libs/libsdl-1.2.13-r1 (current stable) resolved the issue for me. Also I should note that there's no "esd" USE for 1.2.14.

So to be clear, the following failed (no sound in VirtualBox with ALSA):
[ebuild R ] media-libs/libsdl-1.2.14-r2 USE="X alsa audio joystick opengl video xv -aalib -custom-cflags -dga -directfb -fbcon -ggi -libcaca -nas -oss (-ps3) -pulseaudio -static-libs (-svga) -tslib -xinerama"

Downgrading to the following fixed the issue:
[ebuild R ] media-libs/libsdl-1.2.13-r1 USE="X alsa audio joystick opengl video xv -aalib -custom-cflags -dga -directfb -esd -fbcon -ggi -libcaca -nas -oss -pulseaudio (-svga) -tslib -xinerama"



Hello everybody.
The problem is still actual for virtualbox-bin-4.0.4, libsdl-1.2.14-r6, x86
Downgrade to libsdl-1.2.13-r1 (as it's shown above) fixes it.
Please note, that libsdl-1.2.14-r6 doesn't have the disable-alsa-shared use flag.
Back to top
View user's profile Send private message
IceSunrise
n00b
n00b


Joined: 03 Mar 2008
Posts: 14
Location: Russia, Saint-Petersburg

PostPosted: Fri Apr 15, 2011 10:44 am    Post subject: Reply with quote

mgromit wrote:

Hello everybody.
The problem is still actual for virtualbox-bin-4.0.4, libsdl-1.2.14-r6, x86
Downgrade to libsdl-1.2.13-r1 (as it's shown above) fixes it.
Please note, that libsdl-1.2.14-r6 doesn't have the disable-alsa-shared use flag.


Confirm that, has the same problem.
I've found a bug report on Gentoo's Bugzilla, waiting for any replies.
http://bugs.gentoo.org/show_bug.cgi?id=363635
Back to top
View user's profile Send private message
fleed
l33t
l33t


Joined: 28 Aug 2002
Posts: 756
Location: London

PostPosted: Tue May 03, 2011 9:24 am    Post subject: Reply with quote

Another me too here.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum