Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kde4: can't set up file associations
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
kos
n00b
n00b


Joined: 28 May 2003
Posts: 63
Location: Mountain View, CA

PostPosted: Thu Apr 23, 2009 2:58 am    Post subject: kde4: can't set up file associations Reply with quote

Hi

My KDE4 mime associations suddenly vanished, and I can't add them.
For instance I run
Code:
keditfiletype video/x-msvideo
and there are no applications in the list.
I hit 'add', point to /usr/bin/mplayer, OK -> it shows 'updating system configuration' and nothing happens.
I see this message in the console:
Code:
kbuildsycoca4 running...
keditfiletype(32495) KServiceFactory::findServiceByDesktopPath: "findServiceByDesktopPath: mplayer-11.desktop not found"

Tried to kill .kde, .kde4 - same thing.

any help appreciated
_________________
/KoS
Back to top
View user's profile Send private message
TheAbu
Apprentice
Apprentice


Joined: 08 Jun 2008
Posts: 160
Location: Lyon, France

PostPosted: Thu Apr 23, 2009 7:29 pm    Post subject: Reply with quote

Try reemerging kdelibs and startkde, it should do the trick :)
_________________
"Please, forgive my bad English"
Gentoo made me love using my computer again. Thank you to the Gentoo devs and more generally to all the people who makes GNU/Linux possible :)
Back to top
View user's profile Send private message
kos
n00b
n00b


Joined: 28 May 2003
Posts: 63
Location: Mountain View, CA

PostPosted: Fri Apr 24, 2009 12:59 pm    Post subject: Reply with quote

didn't help, still the same behavior
_________________
/KoS
Back to top
View user's profile Send private message
Indech
n00b
n00b


Joined: 10 Jan 2005
Posts: 21

PostPosted: Fri May 01, 2009 11:25 pm    Post subject: Reply with quote

I'm having the same issue, did you ever have any progress in solving the problem? Otherwise I'll probably try reinstalling Gentoo in a bit.
Back to top
View user's profile Send private message
pipip
n00b
n00b


Joined: 28 Aug 2006
Posts: 5

PostPosted: Sun May 03, 2009 11:25 am    Post subject: Reply with quote

i've the same problem ... any solutions yet?
Back to top
View user's profile Send private message
kos
n00b
n00b


Joined: 28 May 2003
Posts: 63
Location: Mountain View, CA

PostPosted: Mon May 04, 2009 2:11 am    Post subject: Reply with quote

http://bugs.gentoo.org/show_bug.cgi?id=267793

surprisingly it works for root, but not for the other users
_________________
/KoS
Back to top
View user's profile Send private message
AlyM
n00b
n00b


Joined: 02 Sep 2003
Posts: 62
Location: Edinburgh, Scotland

PostPosted: Fri May 08, 2009 4:20 pm    Post subject: Reply with quote

I'm also having this problem (no file associations and it won't remember any I enter) and been unable to fix it (see another forum topic, 2nd page onwards).

I've not been able to fix it (and this mornings upgrade to 4.2.3 didn't fix it). Though I note that keditfiletype is trying to find e.g. smplayer-2.desktop, which doesn't exist, but smplayer.desktop does exist. And if you rerun kdeditfiletype it tries to find smplayer-3.desktop.

Googling suggests deleting '/var/tmp/kdecache-$USER/ksycoca4' but that doesn't help me (and it may be the same as kbuildsycoca4 --noincremental).
Back to top
View user's profile Send private message
kos
n00b
n00b


Joined: 28 May 2003
Posts: 63
Location: Mountain View, CA

PostPosted: Sat May 09, 2009 2:26 am    Post subject: Reply with quote

no luck after removing those dirs and upgrading to 4.2.3 as well
_________________
/KoS
Back to top
View user's profile Send private message
AlyM
n00b
n00b


Joined: 02 Sep 2003
Posts: 62
Location: Edinburgh, Scotland

PostPosted: Sat May 09, 2009 12:55 pm    Post subject: Reply with quote

I just managed to fix the problem (for me at least), in a semi-hacky way.

See my comment (#5) on the bug for details.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum