Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xserver1.5 with Hal and evdev - og dansk keyboard[solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
scaramanga
Apprentice
Apprentice


Joined: 31 May 2005
Posts: 160

PostPosted: Sun Apr 26, 2009 11:21 am    Post subject: Xserver1.5 with Hal and evdev - og dansk keyboard[solved] Reply with quote

Jeg har lige opgraderet til Xserver-1.5, og konfigurerer hal og evdev......mit keyboard og min mus fungerer fint, med hjælp fra KDE, idet jeg har måttet sætte KDEs instillinger til dansk keyboard, for at få æ ø og å.

Min Xserver er tilsyneladende ikke korrekt sat op, da jeg i min X log her;

Code:
(II) config/hal: Adding input device Logitech Logitech BT Mini-Receiver
(II) LoadModule: "evdev"

(II) Loading /usr/lib/xorg/modules/input//evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 2.1.3
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.1
(**) Logitech Logitech BT Mini-Receiver: always reports core events
(**) Logitech Logitech BT Mini-Receiver: Device: "/dev/input/event4"
(II) Logitech Logitech BT Mini-Receiver: Found 13 mouse buttons
(II) Logitech Logitech BT Mini-Receiver: Found x and y relative axes
(II) Logitech Logitech BT Mini-Receiver: Found keys
(II) Logitech Logitech BT Mini-Receiver: Configuring as mouse
(II) Logitech Logitech BT Mini-Receiver: Configuring as keyboard
(**) Logitech Logitech BT Mini-Receiver: YAxisMapping: buttons 4 and 5
(**) Logitech Logitech BT Mini-Receiver: EmulateWheelButton: 4,
EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech Logitech BT
Mini-Receiver" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device Logitech Logitech BT Mini-Receiver
(**) Logitech Logitech BT Mini-Receiver: always reports core events
(**) Logitech Logitech BT Mini-Receiver: Device: "/dev/input/event3"
(II) Logitech Logitech BT Mini-Receiver: Found keys
(II) Logitech Logitech BT Mini-Receiver: Configuring as keyboard
(II) XINPUT: Adding extended input device "Logitech Logitech BT
Mini-Receiver" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device Logitech USB Receiver
(**) Logitech USB Receiver: always reports core events
(**) Logitech USB Receiver: Device: "/dev/input/event2"
(II) Logitech USB Receiver: Found 8 mouse buttons
(II) Logitech USB Receiver: Found x and y relative axes
(II) Logitech USB Receiver: Configuring as mouse
(**) Logitech USB Receiver: YAxisMapping: buttons 4 and 5
(**) Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10,
EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech USB Receiver" (type:
MOUSE)
(II) NVIDIA(0): Setting mode "1280x1024_60"

Hvor jeg ser der står "us" for keyboard layout, på trods af min 10-11x-input.fdi som er;
Code:

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
<device>
    <!-- Mouse configuration -->
    <match key="info.capabilities" contains="input.mouse">
      <merge key="input.x11_driver" type="string">evdev</merge>
    </match>

    <!-- Keyboard configuration -->
 <match key="info.capabilities" contains="input.keys">
      <merge key="input.x11_options.XkbRules" type="string">xorg</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           kbd otherwise). -->
      <merge key="input.x11_driver" type="string">evdev</merge>
      <merge key="input.x11_options.XkbModel" type="string">pc104</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.x11_driver" type="string">evdev</merge>
        <merge key="input.x11_options.XkbModel" type="string">evdev</merge>
      <merge key="input.x11_options.XkbLayout" type="string">dk</merge>
<!--
      <merge key="input.x11_options.XkbVariant"
type="string">nodeadkeys</merge>
      <merge key="input.x11_options.XkbOptions" type="string"></merge>
-->
    </match>
  </device>
</deviceinfo> 

hvor dk burde være korrekt angivet i
Code:
 
<merge key="input.x11_options.XkbLayout" type="string">dk</merge>

Jeg har prøvet med da istedetfor, men det giver samme resultat.

Nogen tips?


Last edited by scaramanga on Wed Apr 29, 2009 9:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4831
Location: Gothenburg, Sweden

PostPosted: Tue Apr 28, 2009 6:25 pm    Post subject: Reply with quote

Följande fungerade för mig även om jag gått tillbaka till att använda xorg.conf helt och hållet då jag inte fick min seriella mus att fungera med hal.
Code:
<deviceinfo version="0.2">
   <match key="info.capabilities" contains="input.keyboard">
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">se</merge>
   </match>
</deviceinfo>

_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
scaramanga
Apprentice
Apprentice


Joined: 31 May 2005
Posts: 160

PostPosted: Wed Apr 29, 2009 9:34 pm    Post subject: Reply with quote

Hej Kallemej,

Jeg brugte din kode, med ændringen
Code:

<merge key="input.xkb.layout" type="string">dk</merge>

og nu fungerer det !. Mange tak.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum