Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE4 on Sparc
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 164
Location: Italy, Torino

PostPosted: Thu Apr 09, 2009 7:58 am    Post subject: KDE4 on Sparc Reply with quote

Hallo!

have anybody tried to install kde 4.2 on any sparc system? I am upgrading my Ultra5 (512mb/400mhz/USB 2.0/ATA-133 controller) right now and, before going the suicidal way of downloading/compiling everything by hand, i want to get some inputs from others.

Seems than none of the ebuilds have the sparc keyword, not even unstable, so i guess its never been tested. Which is the best way to proceed? Should i try the kde-testing overlay first or simply make my overlay and start keywording the various packages one a time?
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
blu3bird
Retired Dev
Retired Dev


Joined: 04 Oct 2003
Posts: 610
Location: Munich, Germany

PostPosted: Thu Apr 09, 2009 8:47 am    Post subject: Re: KDE4 on Sparc Reply with quote

shimitar wrote:
Seems than none of the ebuilds have the sparc keyword, not even unstable, so i guess its never been tested.

The main reason for this is that webkit(which KDE-4 heavily relies on) doesn't work on sparc. Work is going on to get it working, but we're not there yet. If you want to help check out bug #235685. :)
_________________
Black Holes are created when God divides by zero!
Back to top
View user's profile Send private message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 164
Location: Italy, Torino

PostPosted: Thu Apr 09, 2009 8:59 am    Post subject: Reply with quote

Very clear answer... thanks!

I read all of the bug, i might try to apply the patch and see what happens, but i do not guarantee.

I will write more here when and if i do.
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
guido-pe
n00b
n00b


Joined: 10 May 2004
Posts: 52

PostPosted: Sun Apr 26, 2009 10:15 pm    Post subject: Reply with quote

I just finished compiling KDE 4.2.2 on an Ultra 60. I had to manually remove a useflag-mask for webkit to this and add a few non-obvious use flags (mysql for example), but then it worked.

Unfortunately, I did not know about that patch when I started compiling, so my webkit is broken, and consequently, all applications that try to use it crash with SIGBUS on startup. That concerns mostly KMail and Konqueror in web-browsing mode, Konqueror in file-manager mode works.

Apart from that, most things work with minor brokenness here and there.

- The playlist view in juk shows only the song name and nothing else, and as soon as I select it with the mouse, even that disappears (but reappears when I select something else)
- The virtual desktop switcher shows only one virtual desktop, even though 4 are configured
- About 50% of the time, the color of an icon is off. It looks fine otherwise, but the main color is just the wrong one. Happens to both icons in the UI and in the filelist view, though so far not to preview icons. Sometimes they revert to the correct color as long as I hover the mouse cursor over them, sometimes not. I can't make out a pattern for which icons are affected and why and when.
- qt designer crashes on startup (but it's not really a part of KDE anyway)

Runtime performance is not bad, the desktop feels surprisingly snappy, considering just how old this machine is. (Ultra 60s were first sold in 1998.)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum