Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge openmotif errors
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
wheatthin
n00b
n00b


Joined: 25 Sep 2003
Posts: 22
Location: Maumee, OH

PostPosted: Mon Sep 29, 2003 12:47 pm    Post subject: emerge openmotif errors Reply with quote

I am trying to emerge openmotif and I get the following:

Calculating dependencies ...done!
>>> emerge (1 of 1) x11-libs/openmotif-2.1.30-r1 to /
>>> md5 src_uri ;-) openmotif-2.1.30-4_MLI.src.tar.gz
>>> Unpacking source...
>>> Unpacking openmotif-2.1.30-4_MLI.src.tar.gz to /var/tmp/portage/openmotif-2.1.30-r1/work
cp: cannot create regular file `/var/tmp/portage/openmotif-2.1.30-r1/work/motif/config/cf/site.def': Permission denied
>>> Source unpacked.

Building Release 2.1.30 of Motif

I hope you checked the configuration parameters in ./config/cf
to see if you need to pass BOOTSTRAPCFLAGS.

Mon Sep 29 08:29:28 UTC 2003

cd ./config/imake && make -f Makefile.ini BOOTSTRAPCFLAGS="" clean
make[1]: Entering directory `/var/tmp/portage/openmotif-2.1.30-r1/work/motif/config/imake'
rm -f ccimake imake.o imake
rm -f *.CKP *.ln *.BAK *.bak *.o core errs ,* *~ *.a tags TAGS make.log \#*
rm -f -r Makefile.proto Makefile Makefile.dep bootstrap
make[1]: Leaving directory `/var/tmp/portage/openmotif-2.1.30-r1/work/motif/config/imake'
make Makefile.boot
make[1]: Entering directory `/var/tmp/portage/openmotif-2.1.30-r1/work/motif'
cd ./config/imake && make -w -f Makefile.ini BOOTSTRAPCFLAGS=""
make[2]: Entering directory `/var/tmp/portage/openmotif-2.1.30-r1/work/motif/config/imake'
making imake with BOOTSTRAPCFLAGS= in config/imake
cc -o ccimake -O -I../../include -I../../imports/x11/include/X11 ccimake.c
cc -c -O -I../../include -I../../imports/x11/include/X11 `./ccimake` imake.c
cc -o imake -O -I../../include -I../../imports/x11/include/X11 imake.o
imake.o(.text+0xf0c): In function `get_libc_version':
: the use of `tmpnam' is dangerous, better use `mkstemp'
make[2]: Leaving directory `/var/tmp/portage/openmotif-2.1.30-r1/work/motif/config/imake'
rm -f ./config/makedepend/Makefile.proto
./config/imake/imake -I./config/cf -s ./config/makedepend/Makefile.proto -f ./config/makedepend/Imakefile -DTOPDIR=../.. -DCURDIR=./config/makedepend
cd ./config/makedepend && rm -f -r Makefile Makefile.dep makedepend *.o bootstrap
cd ./config/makedepend && make -f Makefile.proto bootstrap
make[2]: Entering directory `/var/tmp/portage/openmotif-2.1.30-r1/work/motif/config/makedepend'
make[2]: Nothing to be done for `bootstrap'.
make[2]: Leaving directory `/var/tmp/portage/openmotif-2.1.30-r1/work/motif/config/makedepend'
./config/imake/imake -I./config/cf -s ./config/imake/Makefile.proto -f ./config/imake/Imakefile -DTOPDIR=../.. -DCURDIR=./config/imake
cd ./config/imake && make -f Makefile.proto bootstrapdepend
make[2]: Entering directory `/var/tmp/portage/openmotif-2.1.30-r1/work/motif/config/imake'
make[2]: Nothing to be done for `bootstrapdepend'.
make[2]: Leaving directory `/var/tmp/portage/openmotif-2.1.30-r1/work/motif/conf
ig/imake'
cd ./config/imake && make -w -f Makefile.ini BOOTSTRAPCFLAGS="" bootstrap
make[2]: Entering directory `/var/tmp/portage/openmotif-2.1.30-r1/work/motif/config/imake'
+ mkdir bootstrap
mv *.o imake bootstrap
make[2]: Leaving directory `/var/tmp/portage/openmotif-2.1.30-r1/work/motif/config/imake'
cd ./config/imake && make -f Makefile.proto all
make[2]: Entering directory `/var/tmp/portage/openmotif-2.1.30-r1/work/motif/config/imake'
gcc -O -I../../include -I../../imports/x11/include/X11 -I../.. -I../../exports/include -I../../imports/x11/include -Dlinux LinuxMachineDefines -D_POSIX_C_SOURCE=199309L -D_POSIX_SOURCE -D_XOPEN_SOURCE=500L -D_BSD_SOURCE -D_SVID_SOURCE -DNO_MESSAGE_CATALOG -DFUNCPROTO=15 -DNARROWPROTO -DCPP_PROGRAM="\"/lib/cpp\"" -c -o imake.o imake.c
gcc: cannot specify -o with -c or -S and multiple compilations
make[2]: *** [imake.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/openmotif-2.1.30-r1/work/motif/config/imake'
make[1]: *** [imake.bootstrap] Error 2
make[1]: Leaving directory `/var/tmp/portage/openmotif-2.1.30-r1/work/motif'
make: *** [World] Error 2

!!! ERROR: x11-libs/openmotif-2.1.30-r1 failed.
!!! Function src_compile, Line 29, Exitcode 2
!!! (no error message)


I see there is a bug http://bugs.gentoo.org/show_bug.cgi?id=28670 about emerging openmotif when lesstif is installed, but I don't have lesstif installed and there doesn't seem to be a definate fix. This is on a Sparc5 with a fresh stage1 install. I am trying to get kde installed and this is one of the packages emerge -p kde wants installed. Has anyone else ran into this problem?
Back to top
View user's profile Send private message
bazik
Retired Dev
Retired Dev


Joined: 22 Jul 2002
Posts: 277
Location: Behind you.

PostPosted: Mon Sep 29, 2003 3:10 pm    Post subject: Reply with quote

Output of `emerge info` please.
Back to top
View user's profile Send private message
bazik
Retired Dev
Retired Dev


Joined: 22 Jul 2002
Posts: 277
Location: Behind you.

PostPosted: Mon Sep 29, 2003 3:10 pm    Post subject: Reply with quote

Output of `emerge info` please.
Back to top
View user's profile Send private message
wheatthin
n00b
n00b


Joined: 25 Sep 2003
Posts: 22
Location: Maumee, OH

PostPosted: Mon Sep 29, 2003 4:05 pm    Post subject: Reply with quote

Portage 2.0.49-r3 (default-sparc64-1.4, gcc-3.2.3, glibc-2.3.1-r4, 2.4.21-sparc-r1)
=================================================================
System uname: 2.4.21-sparc-r1 sparc64 sun4u
ccache version 2.2 [enabled]
ACCEPT_KEYWORDS="sparc"
AUTOCLEAN="yes"
CFLAGS="-mcpu=ultrasparc -O3 -pipe"
CHOST="sparc-unknown-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config /usr/kde/3/share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config /usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-mcpu=ultrasparc -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="sandbox buildpkg ccache distcc userpriv usersandbox"
GENTOO_MIRRORS="http://mirrors.tds.net/gentoo ftp://gentoo.noved.org/ http://212.219.247.21/sites/www.ibiblio.org/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="/usr/sbin/mirrorselect: line 1: --title: command not found"
USE="sparc avi crypt cups encode esd foomaticdb gif imlib libwww mad mikmod motif ncurses nls oss png sdl spell truetype xml2 zlib gdbm berkdb slang readline arts tcpd pam ssl perl python oggvorbis qt opengl X gtk gnome kde cdr dga fbcon gpm java jpeg mozilla mpeg mysql pdflib tcltk xmms xv -alsa"
Back to top
View user's profile Send private message
wheatthin
n00b
n00b


Joined: 25 Sep 2003
Posts: 22
Location: Maumee, OH

PostPosted: Mon Sep 29, 2003 11:15 pm    Post subject: Reply with quote

Anyone see anything obvious in the output of emerge info that would cause this problem with openmotif???
Back to top
View user's profile Send private message
wheatthin
n00b
n00b


Joined: 25 Sep 2003
Posts: 22
Location: Maumee, OH

PostPosted: Wed Oct 01, 2003 2:04 pm    Post subject: Reply with quote

Should I have posted this somewhere else?
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Thu Oct 02, 2003 12:44 am    Post subject: Reply with quote

Your config looks good other than the SYNC line, but that wouldn't cause this problem.

Can you replicate this? I tested building openmotif with lesstif installed and it worked fine here.
Back to top
View user's profile Send private message
wheatthin
n00b
n00b


Joined: 25 Sep 2003
Posts: 22
Location: Maumee, OH

PostPosted: Thu Oct 02, 2003 1:31 am    Post subject: Reply with quote

Well, here is what I get when trying to do an emerge -p lesstif:

These are the packages that I would merge, in order:

Calculating dependencies
emerge: there are no masked or unmasked ebuilds to satisfy "lesstif".

!!! Error calculating dependencies. Please correct.
Back to top
View user's profile Send private message
bazik
Retired Dev
Retired Dev


Joined: 22 Jul 2002
Posts: 277
Location: Behind you.

PostPosted: Thu Oct 02, 2003 11:09 am    Post subject: Reply with quote

wheatthin wrote:
Well, here is what I get when trying to do an emerge -p lesstif:

These are the packages that I would merge, in order:

Calculating dependencies
emerge: there are no masked or unmasked ebuilds to satisfy "lesstif".

!!! Error calculating dependencies. Please correct.


Try `ACCEPT_KEYWORDS="~sparc" emerge openmotif` and see if the latest version works.
Back to top
View user's profile Send private message
wheatthin
n00b
n00b


Joined: 25 Sep 2003
Posts: 22
Location: Maumee, OH

PostPosted: Thu Oct 02, 2003 12:47 pm    Post subject: Reply with quote

Well, I figured out the problem. Turns out I had userpriv feature in my /etc/make.conf which was not letting emerge openmotif manipulate my system the way it needed to. It is currently emerging and after that its on to the rest of KDE and I can say bye-bye to gnome.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum