Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge Portage - required EAPI 1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
TheCykor
n00b
n00b


Joined: 16 Feb 2004
Posts: 8

PostPosted: Fri Mar 20, 2009 9:02 am    Post subject: Emerge Portage - required EAPI 1 Reply with quote

Hi all!

I had some very stable Gentoo System and did some time no upgrade, i executed now some synch and want to upgrade portage (or anything else) and get the following output:
Code:

bash-3.2# emerge portage

!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:
        default/linux/x86/2008.0/server

To upgrade do the following steps:
# cd /etc/
# rm make.profile
# ln -s ../usr/portage/profiles/default/linux/x86/2008.0/server make.profile



Calculating dependencies /
!!! All ebuilds that could satisfy ">=dev-lang/python-2.5" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/python-2.5.4-r2 (masked by: required EAPI 1, supported EAPI 0)
- dev-lang/python-2.5.2-r7 (masked by: required EAPI 1, supported EAPI 0)
- dev-lang/python-2.5.2-r8 (masked by: required EAPI 1, supported EAPI 0)
- dev-lang/python-2.6-r5 (masked by: required EAPI 2, supported EAPI 0)
# Ali Polatel <hawking@gentoo.org> (05 Oct 2008)
# Masked until packages that don't work with it are fixed.
# see bug #230205 for more info

- dev-lang/python-2.6.1 (masked by: required EAPI 2, supported EAPI 0)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "dev-python/pycrypto-2.0.1-r8" [ebuild])

As far i researched Python needs newer version of portage and portage needs newer version of Python --> deathlock??
Also unmasks did not work for EAPI

Do you have any ideas?

Upgrading the profile as suggested is not working (2008 directory is not there). Originaly link from make.profile was to 2008 so some error message was displayed and i manually corrected it to 2007 directory which is the most recent existing dir.

Thanks in Advance!

Gabriel[/code]

Code:
bash-3.2# emerge --info

!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:
        default/linux/x86/2008.0/server

To upgrade do the following steps:
# cd /etc/
# rm make.profile
# ln -s ../usr/portage/profiles/default/linux/x86/2008.0/server make.profile



Portage 2.1.2.2 (default-linux/x86/2007.0/server, gcc-3.3.5-20050130, glibc-2.3.4.20041102-r1, 2.6.14-gentoo-r5 i686)
=================================================================
System uname: 2.6.14-gentoo-r5 i686 Intel(R) Pentium(R) 4 CPU 3.20GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Fri, 20 Mar 2009 01:45:01 +0000
app-shells/bash:     3.2_p15-r1
dev-java/java-config: 1.3.7, 2.0.32
dev-lang/python:     2.3.5-r2, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.12-r4
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/X11/xkb /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.inode.at/ http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="PEAR X acl apache apache2 bacula-console bacula-split-init bcmath berkdb cgi chroot cli cracklib crypt cups curl dri dvd exif fortran gd gdbm gpm iconv isdnlog ldap mailwrapper management midi mudflap mysql ncurses nls nptl nptlonly odbc openmp pam pcre perl php postgres pppd python readline reflection samba session snmp spl ssl tcpd threads truetype ttf unicode x86 xfs xml xmlreader xmlrpc xmlwriter xorg xpm yaz zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt intel mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
purak
Apprentice
Apprentice


Joined: 21 Jun 2008
Posts: 160
Location: /dev/urandom

PostPosted: Fri Mar 20, 2009 9:22 am    Post subject: Reply with quote

Portage tells everything to you

Code:
!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:
        default/linux/x86/2008.0/server

I think, you must chance your system profile.
Code:
eselect profile list

it looks like the following..
Code:
Available profile symlink targets:
  [1]   default/linux/x86/2008.0 *
  [2]   default/linux/x86/2008.0/desktop
  [3]   default/linux/x86/2008.0/developer
  [4]   default/linux/x86/2008.0/server
  [5]   hardened/x86/2.6
  [6]   selinux/2007.0/x86
  [7]   selinux/2007.0/x86/hardened
  [8]   hardened/linux/x86

You select one of them. For example
Code:
eselect profile set 1

After that, you had better use this command for system upgrade
Code:
emerge -DNvA world

maybe works :)

sorry for english
_________________
:)
Back to top
View user's profile Send private message
TheCykor
n00b
n00b


Joined: 16 Feb 2004
Posts: 8

PostPosted: Fri Mar 20, 2009 9:29 am    Post subject: Reply with quote

Thanks for the answer, profile thing could be solved, but still have the same problems.

Also I am no native speaker so I reckognized nothing *g*

Any other Ideas?

Code:
roxor ~ # emerge -DNvA world
usage: emerge [options]

emerge: error: no such option: -A
roxor ~ # emerge -DNv world

These are the packages that would be merged, in order:

Calculating world dependencies \
!!! All ebuilds that could satisfy ">=dev-lang/python-2.5" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/python-2.5.4-r2 (masked by: required EAPI 1, supported EAPI 0)
- dev-lang/python-2.5.2-r7 (masked by: required EAPI 1, supported EAPI 0)
- dev-lang/python-2.5.2-r8 (masked by: required EAPI 1, supported EAPI 0)
- dev-lang/python-2.6-r5 (masked by: required EAPI 2, supported EAPI 0)
# Ali Polatel <hawking@gentoo.org> (05 Oct 2008)
# Masked until packages that don't work with it are fixed.
# see bug #230205 for more info

- dev-lang/python-2.6.1 (masked by: required EAPI 2, supported EAPI 0)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "dev-python/pycrypto-2.0.1-r8" [ebuild])



!!! Problem resolving dependencies for mail-client/pine
!!! Depgraph creation failed.
Back to top
View user's profile Send private message
sera
Developer
Developer


Joined: 29 Feb 2008
Posts: 1012
Location: CET

PostPosted: Fri Mar 20, 2009 9:54 am    Post subject: Reply with quote

You have python 2.4.3-r1 installed witch is enough for the current stable portage. As you have also a 2.3 version installed you might have forgotten to run python-updater.
As portage is EAPI="0" you should fulfill the requirements.

Always update portage first.

And -A should be -a and add an -u for --update to the list of options.
Back to top
View user's profile Send private message
FizzyWidget
Veteran
Veteran


Joined: 21 Nov 2008
Posts: 1127
Location: 127.0.0.1

PostPosted: Fri Mar 20, 2009 10:33 am    Post subject: Reply with quote

emerge portage
emerge -auDNv system
emerge -auDNv world
_________________
I know 43 ways to kill with a SKITTLE, so taste my rainbow bitch.
Back to top
View user's profile Send private message
AllenJB
Veteran
Veteran


Joined: 02 Sep 2005
Posts: 1283
Location: Ashford, Kent

PostPosted: Fri Mar 20, 2009 11:30 am    Post subject: Reply with quote

purak wrote:
Portage tells everything to you

Code:
!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:
        default/linux/x86/2008.0/server

I think, you must chance your system profile.


Changing the profile will not fix the problem. In fact it could well leave you in a worse situation. Fix the EAPI problem first, since that's what's blocking the portage upgrade.

I would recommend you update your base system at least once every 6 months (a year at the most).

I would suggest that your only chance is to upgrade to an intermediate version of portage, then upgrade python, then upgrade portage to the latest stable version. You may also want to search the forums as there have been a number of people trying to upgrade insanely old setups like yours recently and one of them may have posted a solution.

I would heavily recommend you backup first, in case you completely hose your install (instructions given on the forums are often incorrect, as illustrated already by those above).

You may well find that the simplest and quickest solution is to reinstall from scratch.

Related thread: http://forums.gentoo.org/viewtopic-t-747824.html
_________________
http://gentoo-wiki.com :: http://lug.org.uk :: http://www.linux.org/groups/ :: User Blogs


Last edited by AllenJB on Fri Mar 20, 2009 11:50 am; edited 1 time in total
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Fri Mar 20, 2009 11:41 am    Post subject: Reply with quote

Maybe the best for you is to run this :

Upgrade your profile to 2008.0 and then run this :

Code:

# emerge -aev system
# emerge -aev world


This will recompile your box from A to Z.

Don't forget to recompile your kernel when you finish your recompilation.
_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
AllenJB
Veteran
Veteran


Joined: 02 Sep 2005
Posts: 1283
Location: Ashford, Kent

PostPosted: Fri Mar 20, 2009 11:51 am    Post subject: Reply with quote

d2_racing wrote:
Maybe the best for you is to run this :

Upgrade your profile to 2008.0 and then run this :

Code:

# emerge -aev system
# emerge -aev world


This will recompile your box from A to Z.

Don't forget to recompile your kernel when you finish your recompilation.


Ignoring the fact that upgrading the profile could easily do more harm than good and that the emerge will bail out on exactly the same message when it considers upgrading portage, this will fail miserably because virtually the entire tree is now EAPI=1 or EAPI=2.
_________________
http://gentoo-wiki.com :: http://lug.org.uk :: http://www.linux.org/groups/ :: User Blogs
Back to top
View user's profile Send private message
TheCykor
n00b
n00b


Joined: 16 Feb 2004
Posts: 8

PostPosted: Fri Mar 20, 2009 12:01 pm    Post subject: Reply with quote

Hi all!

I found http://forums.gentoo.org/viewtopic-t-747824-highlight-eapi.html now
Following thing seemed to work:
emerge --nodep portage
emerge --nodep python
emerge portage
emerge python


Portage and Python are up to date now and i am start checking all other things now and hope that this issue could be solved

Best regards

Gabriel
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum