Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HOWTO] ATI Radeon Binary Drivers on Gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Wedge_
Advocate
Advocate


Joined: 08 Aug 2002
Posts: 3614
Location: Scotland

PostPosted: Fri Sep 05, 2003 12:27 pm    Post subject: Reply with quote

Check the Radeon sticky thread for an ebuild. If you emerge rpm2targz and run it on the rpm, it'll give you a tarball that you can move to /usr/portage/distfiles so the ebuild can pick it up.
_________________
Per Ardua Ad Astra
The Earth is the cradle of the mind, but we cannot live forever in a cradle - Konstantin E. Tsiolkovsky
Gentoo Radeon FAQ
Back to top
View user's profile Send private message
gentooalex
Tux's lil' helper
Tux's lil' helper


Joined: 02 May 2003
Posts: 123
Location: Charlottesville, Virginia

PostPosted: Fri Sep 05, 2003 1:40 pm    Post subject: Reply with quote

so i would put the tar in the distfiles dir and then emerge 3.2.5 with

Code:

ACCEPT_KEYWORDS="x86" emerge ati-drivers-3.2.5


is that right?
Back to top
View user's profile Send private message
Wedge_
Advocate
Advocate


Joined: 08 Aug 2002
Posts: 3614
Location: Scotland

PostPosted: Fri Sep 05, 2003 3:18 pm    Post subject: Reply with quote

If you want to specify a particular version, you should add an equals sign:
Code:
ACCEPT_KEYWORDS="~x86" emerge =ati-drivers-3.2.5
but you don't need that here as 3.2.5 is the latest version, just use
Code:
ACCEPT_KEYWORDS="~x86" emerge ati-drivers

There isn't a ebuild in portage yet (AFAIK), so you'll have to get the one in the Radeon sticky if you haven't already and use that.
_________________
Per Ardua Ad Astra
The Earth is the cradle of the mind, but we cannot live forever in a cradle - Konstantin E. Tsiolkovsky
Gentoo Radeon FAQ
Back to top
View user's profile Send private message
xlyz
Veteran
Veteran


Joined: 27 Oct 2002
Posts: 1470
Location: Italy

PostPosted: Fri Sep 05, 2003 3:27 pm    Post subject: Reply with quote

Wedge_ wrote:
If you want to specify a particular version, you should add an equals sign:
Code:
ACCEPT_KEYWORDS="~x86" emerge =ati-drivers-3.2.5
but you don't need that here as 3.2.5 is the latest version, just use
Code:
ACCEPT_KEYWORDS="~x86" emerge ati-drivers

There isn't a ebuild in portage yet (AFAIK), so you'll have to get the one in the Radeon sticky if you haven't already and use that.

the ebuild has just been spotted in the wild 8)
still needs some refinement thus
_________________
wanna change how bootsplash or qingy look like? try here
Back to top
View user's profile Send private message
gentooalex
Tux's lil' helper
Tux's lil' helper


Joined: 02 May 2003
Posts: 123
Location: Charlottesville, Virginia

PostPosted: Sun Sep 07, 2003 2:16 pm    Post subject: Reply with quote

The ati drivers are not as optimized for linux as they are for windows. I know that ati is continually working on making better drivers but the drivers aren't fast enough for me yet. Does anyone have any idea as to when the linux drivers will be optimized enough to play et without getting as low as 20 fps with the radeon 9500 pro. I get an average of 40 but when there are a lot of polygons, my fps goes extremely low. If anyone has any idea about the new driver release timeframe it would be helpful.
Back to top
View user's profile Send private message
sputnik1969
Guru
Guru


Joined: 08 Aug 2002
Posts: 401
Location: Berlin / Germany

PostPosted: Mon Sep 08, 2003 1:37 am    Post subject: Reply with quote

gentooalex wrote:
The ati drivers are not as optimized for linux as they are for windows. I know that ati is continually working on making better drivers but the drivers aren't fast enough for me yet. Does anyone have any idea as to when the linux drivers will be optimized enough to play et without getting as low as 20 fps with the radeon 9500 pro.

Actual ati-drivers are firegl-drivers (so they are more comparable to FireGL-Windows drivers then to Catalyst-Windows drivers), which are more optimized for non-game-apps (e.g. CAD and similar) but ati is working on Catalyst-drivers for Linux (i've read an announce that they are searching for beta-testers for the new linux-catalyst-driver-series) so i think it won't be long until Linux-drivers are also optimized like the Windows-Versions.
_________________
'Cynic' is a word invented by optimists to criticize realists. - Nigel. In the ocean of Night by Gregory Benford
"Zyniker" ist ein Wort das Optimisten erfunden haben um Realisten zu kritisieren. - Nigel. Im Meer der Nacht von Gregory Benford
Back to top
View user's profile Send private message
Wedge_
Advocate
Advocate


Joined: 08 Aug 2002
Posts: 3614
Location: Scotland

PostPosted: Mon Sep 08, 2003 7:44 am    Post subject: Reply with quote

sputnik1969 wrote:
but ati is working on Catalyst-drivers for Linux (i've read an announce that they are searching for beta-testers for the new linux-catalyst-driver-series) so i think it won't be long until Linux-drivers are also optimized like the Windows-Versions.

I don't think that's actually correct. I applied to be a beta tester when I saw the recent announcements, and the drivers we were given to test were the same 3.2.5 drivers as were released officially a few days ago...
_________________
Per Ardua Ad Astra
The Earth is the cradle of the mind, but we cannot live forever in a cradle - Konstantin E. Tsiolkovsky
Gentoo Radeon FAQ
Back to top
View user's profile Send private message
gentooalex
Tux's lil' helper
Tux's lil' helper


Joined: 02 May 2003
Posts: 123
Location: Charlottesville, Virginia

PostPosted: Mon Sep 08, 2003 2:27 pm    Post subject: Reply with quote

I saw a post on a message board http://www.rage3d.com/board/showthread.php?s=f54c5aae5a088427cab4a04a7b15195a&threadid=33703965 in which an ATI guy said he needed linux testers for catylyst drivers. I dont know if he meant firgl because one of his sig links is for "catalist drivers" but is just a link to the ati drivers site.


Im not going to be able to do any more testing for the drivers for a while.
My radeon 9500 pro was recently fried by flashing the ROM so i am getting it reparied under warranty. ATI better not consider a 9600pro an "equivilent" if they replace my card! Im sure they have a supply of 9500pros in storage for replacing faulty cards.
Back to top
View user's profile Send private message
gentooalex
Tux's lil' helper
Tux's lil' helper


Joined: 02 May 2003
Posts: 123
Location: Charlottesville, Virginia

PostPosted: Mon Sep 08, 2003 2:38 pm    Post subject: Re: 9500 Reply with quote

gentooalex wrote:
I found that the 3.2.4 drivers are A LOT faster than 2.9 in ut2k3 when using the fasttls"1" fix. also, i rarely get under 20 fps with enemy territory(actually i think et was running without the fix so i might get higher when i try again). average of 30-40. I have a 9500 pro and pentium4 1.6ghz processor. I am using one of the fixes but If i restart my computer, i have to reinstall et or i will get a black screen without the game when i try to start et. Is anyone getting better frame rates with similar hardware,? What are you doing to improve performance?


oops must have hit the quote instead of the edit button... sorry
Back to top
View user's profile Send private message
Wedge_
Advocate
Advocate


Joined: 08 Aug 2002
Posts: 3614
Location: Scotland

PostPosted: Mon Sep 08, 2003 3:35 pm    Post subject: Reply with quote

gentooalex wrote:
I saw a post on a message board http://www.rage3d.com/board/showthread.php?s=f54c5aae5a088427cab4a04a7b15195a&threadid=33703965 in which an ATI guy said he needed linux testers for catylyst drivers. I dont know if he meant firgl because one of his sig links is for "catalist drivers" but is just a link to the ati drivers site.

Yep, he posted that in a couple of different forums there. That's what I applied for.
_________________
Per Ardua Ad Astra
The Earth is the cradle of the mind, but we cannot live forever in a cradle - Konstantin E. Tsiolkovsky
Gentoo Radeon FAQ
Back to top
View user's profile Send private message
cuban
Guru
Guru


Joined: 23 Aug 2003
Posts: 448
Location: Houston, TX

PostPosted: Sun Sep 14, 2003 10:07 pm    Post subject: Reply with quote

I just did emerge sync and do not see 3.2.5 in portage.
Back to top
View user's profile Send private message
Wedge_
Advocate
Advocate


Joined: 08 Aug 2002
Posts: 3614
Location: Scotland

PostPosted: Mon Sep 15, 2003 6:57 am    Post subject: Reply with quote

Are you using ACCEPT_KEYWORDS="~x86"?
_________________
Per Ardua Ad Astra
The Earth is the cradle of the mind, but we cannot live forever in a cradle - Konstantin E. Tsiolkovsky
Gentoo Radeon FAQ
Back to top
View user's profile Send private message
cuban
Guru
Guru


Joined: 23 Aug 2003
Posts: 448
Location: Houston, TX

PostPosted: Mon Sep 15, 2003 1:16 pm    Post subject: Reply with quote

Oops, forgot to delete that post. I found it right after posting that. It was a long day :).
Back to top
View user's profile Send private message
Beem
n00b
n00b


Joined: 12 Sep 2003
Posts: 13
Location: New Brunswick, Canada

PostPosted: Tue Sep 16, 2003 8:54 pm    Post subject: Reply with quote

Is DGA working in the 3.2.5 drivers? I'd really like to play some Quake 1 and be able to use the mouse :)
Back to top
View user's profile Send private message
Wedge_
Advocate
Advocate


Joined: 08 Aug 2002
Posts: 3614
Location: Scotland

PostPosted: Tue Sep 16, 2003 8:59 pm    Post subject: Reply with quote

Yes, I think DGA does work.
_________________
Per Ardua Ad Astra
The Earth is the cradle of the mind, but we cannot live forever in a cradle - Konstantin E. Tsiolkovsky
Gentoo Radeon FAQ
Back to top
View user's profile Send private message
Beem
n00b
n00b


Joined: 12 Sep 2003
Posts: 13
Location: New Brunswick, Canada

PostPosted: Tue Sep 16, 2003 10:23 pm    Post subject: Reply with quote

Well it works in that X will start, but games run really poorly and unplayable.
Back to top
View user's profile Send private message
DarkVillage
n00b
n00b


Joined: 12 Sep 2003
Posts: 52
Location: SWEDEN

PostPosted: Mon Sep 29, 2003 4:41 pm    Post subject: Reply with quote

er

Last edited by DarkVillage on Mon Sep 29, 2003 4:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
DarkVillage
n00b
n00b


Joined: 12 Sep 2003
Posts: 52
Location: SWEDEN

PostPosted: Mon Sep 29, 2003 4:43 pm    Post subject: Reply with quote

er

Last edited by DarkVillage on Mon Sep 29, 2003 4:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
DarkVillage
n00b
n00b


Joined: 12 Sep 2003
Posts: 52
Location: SWEDEN

PostPosted: Mon Sep 29, 2003 4:44 pm    Post subject: Reply with quote

er

Last edited by DarkVillage on Mon Sep 29, 2003 4:58 pm; edited 1 time in total
Back to top
View user's profile Send private message
DarkVillage
n00b
n00b


Joined: 12 Sep 2003
Posts: 52
Location: SWEDEN

PostPosted: Mon Sep 29, 2003 4:50 pm    Post subject: Reply with quote

er

Last edited by DarkVillage on Mon Sep 29, 2003 6:04 pm; edited 2 times in total
Back to top
View user's profile Send private message
DarkVillage
n00b
n00b


Joined: 12 Sep 2003
Posts: 52
Location: SWEDEN

PostPosted: Mon Sep 29, 2003 4:50 pm    Post subject: Reply with quote

I followed the first guide and everything went wrong...

when I typed ACCEPT_KEYWORDS="~x86" emerge ati-drivers

I got these errors
!!! ERROR: media-video/ati-drivers-2.3.5
!!! Function src_compile, Line66, exitcode

I used the 2.3.4 version...

When I tried with just emerge ati-drivers this happened

!!! ERROR: media-video/ati-drivers-2.9.12
!!! Function src_compile, Line66, exitcode

strange version I think
Back to top
View user's profile Send private message
Wedge_
Advocate
Advocate


Joined: 08 Aug 2002
Posts: 3614
Location: Scotland

PostPosted: Mon Sep 29, 2003 5:12 pm    Post subject: Reply with quote

You'll need to post more of the output from the ebuild, the last couple of lines aren't very helpful by themselves.
_________________
Per Ardua Ad Astra
The Earth is the cradle of the mind, but we cannot live forever in a cradle - Konstantin E. Tsiolkovsky
Gentoo Radeon FAQ
Back to top
View user's profile Send private message
DarkVillage
n00b
n00b


Joined: 12 Sep 2003
Posts: 52
Location: SWEDEN

PostPosted: Mon Sep 29, 2003 6:09 pm    Post subject: Reply with quote

Wedge_ wrote:
You'll need to post more of the output from the ebuild, the last couple of lines aren't very helpful by themselves.


is there a log file for this??? I mean I have to start xp to write to this forum and it takes long time if I has to first write down all text then send it to this post.

I tried with the version 3.2.5 but I got the same problem.

It sad, realy it is
Back to top
View user's profile Send private message
Wedge_
Advocate
Advocate


Joined: 08 Aug 2002
Posts: 3614
Location: Scotland

PostPosted: Mon Sep 29, 2003 6:58 pm    Post subject: Reply with quote

There are logfiles for each emerge you run under /var/log/portage.
_________________
Per Ardua Ad Astra
The Earth is the cradle of the mind, but we cannot live forever in a cradle - Konstantin E. Tsiolkovsky
Gentoo Radeon FAQ
Back to top
View user's profile Send private message
NuclearFusi0n
Apprentice
Apprentice


Joined: 20 Jun 2003
Posts: 297

PostPosted: Mon Sep 29, 2003 7:52 pm    Post subject: Reply with quote

make: Entering directory `/usr/src/linux-2.6.0-test6-mm1'
*** Warning: Overriding SUBDIRS on the command line can cause
*** inconsistencies
make[1]: `arch/i386/kernel/asm-offsets.s' is up to date.
CC [M] /var/tmp/portage/ati-drivers-3.2.5/work/lib/modules/fglrx/build_mod/agpgart_be.o
CC [M] /var/tmp/portage/ati-drivers-3.2.5/work/lib/modules/fglrx/build_mod/agp3.o
CC [M] /var/tmp/portage/ati-drivers-3.2.5/work/lib/modules/fglrx/build_mod/i7505-agp.o
CC [M] /var/tmp/portage/ati-drivers-3.2.5/work/lib/modules/fglrx/build_mod/nvidia-agp.o
CC [M] /var/tmp/portage/ati-drivers-3.2.5/work/lib/modules/fglrx/build_mod/firegl_public.o
/var/tmp/portage/ati-drivers-3.2.5/work/lib/modules/fglrx/build_mod/firegl_public.c:422:27: warning: extra tokens at end of #ifdef directive
/var/tmp/portage/ati-drivers-3.2.5/work/lib/modules/fglrx/build_mod/firegl_public.c:850:27: warning: extra tokens at end of #ifdef directive
/var/tmp/portage/ati-drivers-3.2.5/work/lib/modules/fglrx/build_mod/firegl_public.c: In function `__ke_geteuid':
/var/tmp/portage/ati-drivers-3.2.5/work/lib/modules/fglrx/build_mod/firegl_public.c:899: structure has no member named `euid'
/var/tmp/portage/ati-drivers-3.2.5/work/lib/modules/fglrx/build_mod/firegl_public.c: At top level:
/var/tmp/portage/ati-drivers-3.2.5/work/lib/modules/fglrx/build_mod/firegl_public.c:3103: warning: `have_cpuid_p' defined but not used
make[1]: *** [/var/tmp/portage/ati-drivers-3.2.5/work/lib/modules/fglrx/build_mod/firegl_public.o] Error 1
make: *** [/var/tmp/portage/ati-drivers-3.2.5/work/lib/modules/fglrx/build_mod] Error 2
make: Leaving directory `/usr/src/linux-2.6.0-test6-mm1'
* glx module not built



I dont think it likes test6-mm1
_________________
I will keel yoo grub
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6  Next
Page 3 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum