Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[qt overlay] Qt beta and live ebuilds & Qt4 apps
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, ... 14, 15, 16  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Riklaunim
Apprentice
Apprentice


Joined: 16 Dec 2004
Posts: 286
Location: Poland

PostPosted: Fri Feb 06, 2009 10:34 am    Post subject: Reply with quote

Ok, here are my ebuilds that "work": http://www.rk.edu.pl/ebuilds-qt.tar.gz
Code:

qt/qfmacnavbar
qt/qtermwidget
pyqt/pyqt-qtermwidget
pyqt/pyqt-pypoppler


missing:
Code:

qt/pictureflow-svn (qt and pyqt bindings)
pyqt/pyqt-qfmacnavbar

_________________
Biblioteka CMS i PHP | Biblioteka Linuksa | Biblioteka cRPG | Biblioteka Pythona
Back to top
View user's profile Send private message
Hwoarang
Developer
Developer


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Fri Feb 06, 2009 1:07 pm    Post subject: Reply with quote

Thank you . I ll take a look as soon as possible
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 364
Location: Ekaterinburg, Russia

PostPosted: Fri Feb 06, 2009 2:34 pm    Post subject: Reply with quote

@Hwoarang, apply my src_install changes at least..
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
Hwoarang
Developer
Developer


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Fri Feb 06, 2009 3:05 pm    Post subject: Reply with quote

Rion wrote:
just tried to remove all qt staff from my system and install qt-4.9999
got next error while compiling qt-core
Code:
/var/tmp/portage/x11-libs/qt-core-4.9999/work/qt-x11-opensource-src-4.9999/tools/qdoc3/qdoc3: error while loading shared libraries: libQtXml.so.4: cannot open shared object file: No such file or directory

USE="doc glib pch qt3support ssl -custom-cxxflags -debug"


Ok , today i run into the same problem. Seems to me that this is a very rare situation. It is an issue with LD_LIBRARY_PATH export. Usually , this can be "automatically" fixed if you try to compile this package on another terminal ( or open an new tab etc ). There is nothing wrong with the ebuild though :)

@Rion

Yes , as long as Im done with qt-X packages I will apply your solution
Back to top
View user's profile Send private message
Hwoarang
Developer
Developer


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Fri Feb 06, 2009 3:24 pm    Post subject: Reply with quote

Ok, qt-creator fixed :)
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 364
Location: Ekaterinburg, Russia

PostPosted: Fri Feb 06, 2009 4:12 pm    Post subject: Reply with quote

Hwoarang wrote:
Ok, qt-creator fixed :)

and icon too! :) please :-)
and this is not "GUIDesigner". this is "IDE"
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
Hwoarang
Developer
Developer


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Fri Feb 06, 2009 4:33 pm    Post subject: Reply with quote

Oh now upstream provides an icon? Heh nice :D

I will do it a bit later

Thanks for reporting :)
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 2734
Location: Gainesville, Florida

PostPosted: Fri Feb 06, 2009 4:33 pm    Post subject: Reply with quote

Just got this on qt-xmlpatterns:
Code:
Stdint enabled.
QtXmlPatterns was requested, but it can't be built due to exceptions being disabled.
 *
 * ERROR: x11-libs/qt-xmlpatterns-4.5.0_rc1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_configure
 *             environment, line 2983:  Called qt4-build-edge_src_configure
 *             environment, line 2714:  Called die
 * The specific snippet of code:
 *       ./configure ${myconf} || die "configure failed"
 *  The die message:
 *   configure failed
I've never seen this before. :o :? I do recall about a year ago when I was using the qt-snapshot method by Rion on his old thread I did something with "exceptions" or "no-exceptions", but either one didn't cause a compiling problem. Any ideas- I looked at the ebuild, but saw nothing.

BTW- I had been using qt-9999, but today I couldn't get tit to even begin compiling on the first package, so i switched to 4.5-rc1 (had used beta1 before 9999).

For now, i just did an emerge --resume -skipfirst and that seems to be going OK so far (now on package 2 of 7 more).

EDIT: Here's some of the discussion on the "exceptions" issue, on the qt-snapshot thread. Maybe it is related to this latest problem with 4.5-rc1?? http://forums.gentoo.org/viewtopic-t-677156-start-0.html

UPDATE: Adding -exceptions to the ebuild, and re-digesting it allowed qt-xmlpatterns to compile/install. :D
Code:
src_configure() {
   myconf="${myconf} -xmlpatterns -exceptions"
   qt4-build-edge_src_configure
}

_________________
Main box- Gigabyte GIGABYTE GA-990FXA-UD3 AM3+ rev.-4.0
Amd FX 8320, 3.5 GHz, 16GB GSkill DDR3 1866mhz
Samsung SATA 1000GB, Radeon HD 6570 2GB DDR3
Gentoo ~x86, ~amd64, glibc-2.19, gcc-4.8.2, kernel 3.14.0-gentoo (USE=experimental)


Last edited by wrc1944 on Fri Feb 06, 2009 5:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
Hwoarang
Developer
Developer


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Fri Feb 06, 2009 4:51 pm    Post subject: Reply with quote

@Rion
Fixed. Nice icon :P

@wrc1944

Thanks :). We are on it. We changed something on eclass and break it 8) . Please re-sync a bit later and try again . Thank you
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 364
Location: Ekaterinburg, Russia

PostPosted: Fri Feb 06, 2009 5:03 pm    Post subject: Reply with quote

Hwoarang wrote:
@Rion
Fixed. Nice icon :P

great! thanks:)
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Fri Feb 06, 2009 5:15 pm    Post subject: Reply with quote

wrc1944 wrote:
Just got this on qt-xmlpatterns:
Code:
QtXmlPatterns was requested, but it can't be built due to exceptions being disabled.

I was being misled by a message from the Qt configure script. It is fixed now, exceptions are enabled for qt-xmlpatterns only, and disabled for other qt-* packages (which should mean smaller binaries and lower memory usage).
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF


Last edited by yngwin on Fri Feb 06, 2009 5:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Fri Feb 06, 2009 5:27 pm    Post subject: Reply with quote

gaelic_cargal wrote:
i`ve got several problems with qt 4.5 and kde 4.2

Did you remerge at least kdelibs after upgrading Qt (as suggested by elog message)?
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF


Last edited by yngwin on Fri Feb 06, 2009 5:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 2734
Location: Gainesville, Florida

PostPosted: Fri Feb 06, 2009 5:34 pm    Post subject: Reply with quote

Thanks much. 8)
So my ebuild edit that I Updated above adding the "-exceptions" is no longer needed?
_________________
Main box- Gigabyte GIGABYTE GA-990FXA-UD3 AM3+ rev.-4.0
Amd FX 8320, 3.5 GHz, 16GB GSkill DDR3 1866mhz
Samsung SATA 1000GB, Radeon HD 6570 2GB DDR3
Gentoo ~x86, ~amd64, glibc-2.19, gcc-4.8.2, kernel 3.14.0-gentoo (USE=experimental)
Back to top
View user's profile Send private message
Hwoarang
Developer
Developer


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Fri Feb 06, 2009 5:40 pm    Post subject: Reply with quote

Nope. Re-syng and go ahead 8)
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5610
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Feb 06, 2009 6:49 pm    Post subject: Reply with quote

*subscribes*

thanks Hwoarang, yngwin and everyone involved in this overlay

hopefully this will fix all of those crashes with kio-stuff (e.g. kio_http_cache_)

does qt-copy work with 4.5.0_rc1 ?
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
Hwoarang
Developer
Developer


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Fri Feb 06, 2009 6:57 pm    Post subject: Reply with quote

kernelOfTruth wrote:

does qt-copy work with 4.5.0_rc1 ?


What do you mean exactly? :)

Qt-4.5.0_rc1 is from Nokia. We didnt bump qt-copy to 4.5.9999 yet since it is highly broken upstream.

I hope I answered your question
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2350
Location: Austria

PostPosted: Fri Feb 06, 2009 7:25 pm    Post subject: Reply with quote

I currently can't build qt-*-4.4.9999, it fails at
Code:
[snip]
    -no-xinput.......... Do not compile Xinput support.
 *  -xinput ............ Compile Xinput support. This also enabled tablet support
                         which requires IRIX with wacom.h and libXi or           
                         XFree86 with X11/extensions/XInput.h and libXi.         

 *  -no-xkb ............ Do not compile XKB (X KeyBoard extension) support.
    -xkb ............... Compile XKB support.                             

    -no-glib ........... Do not compile Glib support.
 +  -glib .............. Compile Glib support.       

 *
 * ERROR: x11-libs/qt-core-4.4.9999 failed.
 * Call stack:                             
 *               ebuild.sh, line   49:  Called src_configure
 *             environment, line 3167:  Called qt4-build-edge_src_configure
 *             environment, line 2872:  Called die                         
 * The specific snippet of code:                                           
 *       ./configure ${myconf} || die "configure failed"                   
 *  The die message:                                                       
 *   configure failed
[/snip]

Any idea what's wrong with it? Worked before...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Fri Feb 06, 2009 7:31 pm    Post subject: Reply with quote

Hwoarang wrote:
kernelOfTruth wrote:

does qt-copy work with 4.5.0_rc1 ?


What do you mean exactly? :)

Qt-4.5.0_rc1 is from Nokia. We didnt bump qt-copy to 4.5.9999 yet since it is highly broken upstream.

I hope I answered your question

If with qt-copy you're talking of qt-copy patches in KDE's SVN, then well, that got updated to 4.5.0-rc1 recently.

But I do not see the slightest point in using that. 4.5.0-rc1 works fine here with KDE 4.2.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
Hwoarang
Developer
Developer


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Fri Feb 06, 2009 7:37 pm    Post subject: Reply with quote

genstorm wrote:
I currently can't build qt-*-4.4.9999, it fails at
Code:
[snip]
    -no-xinput.......... Do not compile Xinput support.
 *  -xinput ............ Compile Xinput support. This also enabled tablet support
                         which requires IRIX with wacom.h and libXi or           
                         XFree86 with X11/extensions/XInput.h and libXi.         

 *  -no-xkb ............ Do not compile XKB (X KeyBoard extension) support.
    -xkb ............... Compile XKB support.                             

    -no-glib ........... Do not compile Glib support.
 +  -glib .............. Compile Glib support.       

 *
 * ERROR: x11-libs/qt-core-4.4.9999 failed.
 * Call stack:                             
 *               ebuild.sh, line   49:  Called src_configure
 *             environment, line 3167:  Called qt4-build-edge_src_configure
 *             environment, line 2872:  Called die                         
 * The specific snippet of code:                                           
 *       ./configure ${myconf} || die "configure failed"                   
 *  The die message:                                                       
 *   configure failed
[/snip]

Any idea what's wrong with it? Worked before...


Qt-4.4.9999 build system is now obsolete since qt-copy has been moved to qt-4.5. I ll remove those ebuilds soon and bring the shiny new qt-4.5.9999 :)

@gimpel

Yes I know, we want to offer to our users more choices. Hence we will have qt-4.5.0_rc1 from Nokia and qt-copy-4.5.9999 :).

Use whatever you like 8)
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2350
Location: Austria

PostPosted: Fri Feb 06, 2009 7:40 pm    Post subject: Reply with quote

Ah, thank you very much. I was yet hesitant to move on to 4.5 since the beta didn't quite match well with kde-4.2 back then. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 2734
Location: Gainesville, Florida

PostPosted: Fri Feb 06, 2009 8:03 pm    Post subject: Reply with quote

genstorm,
For what it's worth, I just completed my usual basic kde-live packages rebuild (admittedly pruned way down from the entire kde-live package list), using qt-4.5-rc1, and these all worked fine.
Code:
emerge -1  @qt-all-4.5 @kdedeps-live @kdebase-live @kdeadmin-live kde-base/gwenview ark kdf okular marble dragonplayer kdemultimedia-kioslaves kde-misc/konq-plugins libkcddb  libkcompactdisc libksieve libkpgp kaddressbook knode mimelib kmailcvt knode kode kontact kontactinterfaces libkleo kleopatra kmail

_________________
Main box- Gigabyte GIGABYTE GA-990FXA-UD3 AM3+ rev.-4.0
Amd FX 8320, 3.5 GHz, 16GB GSkill DDR3 1866mhz
Samsung SATA 1000GB, Radeon HD 6570 2GB DDR3
Gentoo ~x86, ~amd64, glibc-2.19, gcc-4.8.2, kernel 3.14.0-gentoo (USE=experimental)


Last edited by wrc1944 on Sat Feb 07, 2009 11:11 am; edited 1 time in total
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Fri Feb 06, 2009 8:09 pm    Post subject: Reply with quote

Hwoarang wrote:
@gimpel

Yes I know, we want to offer to our users more choices. Hence we will have qt-4.5.0_rc1 from Nokia and qt-copy-4.5.9999 :).

Use whatever you like 8)

Ah, I totally got it wrong then :)

Cool 8)
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2350
Location: Austria

PostPosted: Fri Feb 06, 2009 8:15 pm    Post subject: Reply with quote

thx wrc1944, building was never the problem, watch kde programs in everyday life for glitches and crashes with 4.5. ;)

I'll try it out myself anyway, now emerging! :)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Hwoarang
Developer
Developer


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Fri Feb 06, 2009 11:55 pm    Post subject: Reply with quote

* Removed qt-copy-4.4.9999 packages
* Bump to qt-copy-4.5.9999 packages
* Qt-creator-0.9.2_rc1 added

Please report here if you enounter any issues :)

Many thanks
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Sat Feb 07, 2009 2:38 am    Post subject: Reply with quote

gimpel wrote:
But I do not see the slightest point in using that. 4.5.0-rc1 works fine here with KDE 4.2.


For me kdm 4.2.0 does not work with qt 4.5.0-rc1. :?
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, ... 14, 15, 16  Next
Page 2 of 16

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum