Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HOWTO]New freetype subpixel font rendering for lcd monitors
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 28, 29, 30  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Sun Dec 21, 2008 9:07 pm    Post subject: Reply with quote

Phlogiston wrote:
You need that tarball as an overlay and then set the new useflags: ubuntu and newspr.
I need little help here. Which tarball are you referring to? So, does this mean that not all the stuff is in the portage as yet? Is there a link for a howto?
Back to top
View user's profile Send private message
bi3l
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 268
Location: France

PostPosted: Sun Dec 21, 2008 9:20 pm    Post subject: Reply with quote

layman -a devnull
echo "media-libs/fontconfig ~x86" >> /etc/portage/package.keywords
echo "media-libs/freetype ~x86" >> /etc/portage/package.keywords
echo "x11-libs/cairo ~x86" >> /etc/portage/package.keywords
echo "x11-libs/libXft ~x86" >> /etc/portage/package.keywords
echo "media-libs/fontconfig ubuntu" >> /etc/portage/package.use
echo "media-libs/freetype ubuntu" >> /etc/portage/package.use
echo "x11-libs/cairo newspr" >> /etc/portage/package.use
echo "x11-libs/libXft newspr" >> /etc/portage/package.use
emerge -uDN world
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sun Dec 21, 2008 9:20 pm    Post subject: Reply with quote

devsk wrote:
Phlogiston wrote:
You need that tarball as an overlay and then set the new useflags: ubuntu and newspr.
I need little help here. Which tarball are you referring to? So, does this mean that not all the stuff is in the portage as yet? Is there a link for a howto?


http://ogmrip.sourceforge.net/misc/gentoo-lcd-filtering.tar.bz2 <- this one... dunno where you could find the howto though.
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Sun Dec 21, 2008 9:26 pm    Post subject: Reply with quote

bi3l wrote:
layman -a devnull
echo "media-libs/fontconfig ~x86" >> /etc/portage/package.keywords
echo "media-libs/freetype ~x86" >> /etc/portage/package.keywords
echo "x11-libs/cairo ~x86" >> /etc/portage/package.keywords
echo "x11-libs/libXft ~x86" >> /etc/portage/package.keywords
echo "media-libs/fontconfig ubuntu" >> /etc/portage/package.use
echo "media-libs/freetype ubuntu" >> /etc/portage/package.use
echo "x11-libs/cairo newspr" >> /etc/portage/package.use
echo "x11-libs/libXft newspr" >> /etc/portage/package.use
emerge -uDN world
THANK YOU!

Can someone please put this stuff right at the first page?
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Sun Dec 21, 2008 10:12 pm    Post subject: Reply with quote

I knew I was missing something...:-) Fonts look better now.

Now question: How do I improve 32-apps?
Back to top
View user's profile Send private message
Evilguru
Guru
Guru


Joined: 16 Aug 2005
Posts: 380
Location: England

PostPosted: Sun Dec 21, 2008 10:42 pm    Post subject: Reply with quote

I have tried the exact same thing on a KDE system and fonts are looking fantastic. But not GNOME.

I think GNOMEs silly font configuration dialogue is overriding whatever eselect fontconfig does. How can I disable this?

Regards, Freddie.
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Sun Dec 21, 2008 11:27 pm    Post subject: Reply with quote

Evilguru wrote:
GNOMEs silly font configuration dialogue is overriding

I suggest you add cairo-respect-fontconfig.patch ;)
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Sun Dec 21, 2008 11:42 pm    Post subject: Reply with quote

I have some color fringe around some letters like 'l', 'n', 'f' and 'i'. How do I get rid of this? What is the fix for gnome not following eselect stuff?
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Sun Dec 21, 2008 11:50 pm    Post subject: Reply with quote

devsk wrote:
around some letters

Add a rule in ~/.fonts.conf to change the rendering for that particular font and/or fontsize.
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Mon Dec 22, 2008 2:26 am    Post subject: Reply with quote

This applies to all fonts. Its weird behavior. 'i' and 'y' are thicker. But thunderbird-2.0.0.18 has fonts come out better. KDE and tk+ apps except thunderbird-2.0.0.18 seems to having the problem. I have no idea. Do I need to recompile kdelibs/pango etc.?

Also, thunderbird seems to follow eselect selections of font rules while other gnome/kde use/modify ~/.fonts.conf and Xft.* rules in xrdb. So many sources of truth, and utter confusion.

Any more suggestions?
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Mon Dec 22, 2008 2:47 am    Post subject: Reply with quote

So, far the only fonts that I have liked are in thunderbird-2.0.0.18. I don't know what it compiled with or what options it uses or where it gets its options from, but it has no fringe, no coloring, no thicker 'i' or 'y', just smooth good looking fonts. How do I make the rest of the system behave that way?
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Mon Dec 22, 2008 5:23 am    Post subject: Reply with quote

Seems to be happening with Segoe UI and Consolas fonts I copied from my Vista machine. Hmmm...some conspiracy here...:)

These had become my favorite fonts...:-( Tahoma and Lucia seem to be work fine.
Back to top
View user's profile Send private message
Evilguru
Guru
Guru


Joined: 16 Aug 2005
Posts: 380
Location: England

PostPosted: Mon Dec 22, 2008 10:57 am    Post subject: Reply with quote

PaulBredbury wrote:
Evilguru wrote:
GNOMEs silly font configuration dialogue is overriding

I suggest you add cairo-respect-fontconfig.patch ;)

What would be the easiest way to add this? I do not really want to have to add my own custom overlay (and by extension, my own ebuild). Is there an easier way?

Regards, Freddie.
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Mon Dec 22, 2008 12:07 pm    Post subject: Reply with quote

Evilguru wrote:
PaulBredbury wrote:
Evilguru wrote:
GNOMEs silly font configuration dialogue is overriding

I suggest you add cairo-respect-fontconfig.patch ;)

What would be the easiest way to add this? I do not really want to have to add my own custom overlay (and by extension, my own ebuild). Is there an easier way?

Regards, Freddie.


Yes this should be added to the ebuild as use flag.
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
ocin
Guru
Guru


Joined: 01 Jan 2006
Posts: 500

PostPosted: Mon Dec 22, 2008 4:16 pm    Post subject: Reply with quote

I can add the patch to cairo in devnull overlay, however I need the link (can't find it in the fedoraforums) and it has to apply against cairo-1.8.4.

Also you don't need to add "newspr" and "ubuntu" useflags, they are enabled by default (+prefixed).

If you have problems with kde+fonts and you are using nvidia-drivers, update them or disable glyph cache.
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Mon Dec 22, 2008 7:29 pm    Post subject: Reply with quote

ocin wrote:
If you have problems with kde+fonts and you are using nvidia-drivers, update them or disable glyph cache.
I am using the latest nvidia drivers: 180.16. What do I need to do? How do I disable glyph cache? Does it even exist on 6600GT?
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Mon Dec 22, 2008 7:41 pm    Post subject: Reply with quote

ocin wrote:
however I need the link (can't find it in the fedoraforums) and it has to apply against cairo-1.8.4.

Gotta be kidding me. Read the thread and look at the cairo src.rpm. It's not a magical file. It contains the patch (and the patch is available on my FTP site as a file in its own right anyway), and full build instructions in the .spec file, plus a ton of useful URLs.

$ rpm -q cairo
cairo-1.8.4.20081118-1.fc9.i386
cairo-1.8.4.20081118-2.fc9.x86_64

So yes, it works with 1.8.4
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Mon Dec 22, 2008 8:59 pm    Post subject: Reply with quote

PaulBredbury wrote:
and the patch is available on my FTP site as a file in its own right anyway
I think he (and me) just want that link. Where is the link to your FTP site?
Back to top
View user's profile Send private message
ocin
Guru
Guru


Joined: 01 Jan 2006
Posts: 500

PostPosted: Tue Dec 23, 2008 4:02 pm    Post subject: Reply with quote

devsk wrote:
ocin wrote:
If you have problems with kde+fonts and you are using nvidia-drivers, update them or disable glyph cache.
I am using the latest nvidia drivers: 180.16. What do I need to do? How do I disable glyph cache? Does it even exist on 6600GT?

It should work with 180.16, but try "nvidia-settings -a GlyphCache=0" but before update the devnull overlay and recompile cairo

I have added all patches to cairo in devnull overlay, please update the overlay and rebuild cairo
Back to top
View user's profile Send private message
justinkb
Apprentice
Apprentice


Joined: 23 Dec 2008
Posts: 160

PostPosted: Tue Dec 23, 2008 10:45 pm    Post subject: Reply with quote

I've been watching this thread for a while, and decided to try this out. Added all keywords and use flags to /etc/paludis, yet I can't seem to lose this error:

Code:
paul@yoga ~ $ winecfg
Fontconfig warning: "/etc/fonts/conf.d/11-lcd-filter-lcddefault.conf", line 9: invalid constant used : lcddefault
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdlegacy
Fontconfig warning: "/etc/fonts/conf.d/11-lcd-filter-lcddefault.conf", line 9: invalid constant used : lcddefault
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdlegacy


Now, I assume this means that the lcdfilter-ing is broken, and fonts - I think - don't look quite right. I have recompiled fontconfig, libXft, freetype and cairo numerous times without effect... Also tried changing the constants in the .conf files to lcdfilter{default,legacy} but that didn't work either. Any idea what I could do to fix this guys?
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Tue Dec 23, 2008 11:09 pm    Post subject: Reply with quote

justinkb wrote:
$ winecfg

Wine is 32-bit. I bet you're on 64-bit ;)

So wine uses your 32-bit libs and doesn't know/care about the 64-bit libs. Recompiling the 64-bit libs makes no difference whatsoever to wine.

Recompile your 32-bit libs - if Gentoo lets you, I forget its multilib foibles. Otherwise, just ignore the warning message.
Back to top
View user's profile Send private message
mwhitlock
Tux's lil' helper
Tux's lil' helper


Joined: 07 Aug 2006
Posts: 75
Location: Weare, NH

PostPosted: Tue Dec 23, 2008 11:21 pm    Post subject: Reply with quote

PaulBredbury wrote:
Wine is 32-bit. I bet you're on 64-bit ;)

You'd have to compile these four libs on a 32-bit Gentoo system (do you have a 32-bit chroot system?) and copy them over the ones that come with the emul-linux packages. I have the same problem with Wine, but I don't use it enough to care that its fonts aren't spectacular like the rest of my Gentoo system. :-)
Back to top
View user's profile Send private message
justinkb
Apprentice
Apprentice


Joined: 23 Dec 2008
Posts: 160

PostPosted: Wed Dec 24, 2008 12:42 am    Post subject: Reply with quote

Thanks PaulBredbury and mwhitlock, that put my mind at ease. I second your not-caring-enough to fix this :) I hardly ever use wine anyway.
Back to top
View user's profile Send private message
justinkb
Apprentice
Apprentice


Joined: 23 Dec 2008
Posts: 160

PostPosted: Wed Dec 24, 2008 4:11 pm    Post subject: Reply with quote

Sorry for the double post, but I have one last issue. Please refer to the following image...

[IMG]http://img355.imageshack.us/img355/6706/fontrendernz1.png[/IMG]

I am loving the fonts how they are rendering on the web site, and in my menu. However, the fonts near buttons and for example all the fonts in my aMule aren't quite as pretty and I've got no idea why. Hope you guys can help me out again :)

edit: It's *not* because they are bold... because they are not. Furthermore, my window title font is bold and looks great.
Back to top
View user's profile Send private message
ocin
Guru
Guru


Joined: 01 Jan 2006
Posts: 500

PostPosted: Thu Dec 25, 2008 11:59 am    Post subject: Reply with quote

the image looks good to me, post an image of amule so we can see what you mean
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... , 28, 29, 30  Next
Page 29 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum